First Hop Redundancy Protocols Configuration Guide, Cisco IOS Release 15M&T
HSRP Version 2
Downloads: This chapterpdf (PDF - 1.3MB) The complete bookPDF (PDF - 3.3MB) | The complete bookePub (ePub - 495.0KB) | Feedback

HSRP Version 2

HSRP Version 2

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Information About HSRP Version 2

HSRP Version 2 Design

HSRP version 2 is designed to address the following restrictions in HSRP version 1:

  • In HSRP version 1, millisecond timer values are not advertised or learned. HSRP version 2 advertises and learns millisecond timer values. This change ensures stability of the HSRP groups in all cases.

  • In HSRP version 1, group numbers are restricted to the range from 0 to 255. HSRP version 2 expands the group number range from 0 to 4095.

  • HSRP version 2 provides improved management and troubleshooting. With HSRP version 1, you cannot use HSRP active hello messages to identify which physical device sent the message because the source MAC address is the HSRP virtual MAC address. The HSRP version 2 packet format includes a 6-byte identifier field that is used to uniquely identify the sender of the message. Typically, this field is populated with the interface MAC address.

  • The multicast address 224.0.0.2 is used to send HSRP hello messages. This address can conflict with Cisco Group Management Protocol (CGMP) leave processing.

Version 1 is the default version of HSRP.

HSRP version 2 uses the new IP multicast address 224.0.0.102 to send hello packets instead of the multicast address of 224.0.0.2, used by HSRP version 1. This new multicast address allows CGMP leave processing to be enabled at the same time as HSRP.

HSRP version 2 permits an expanded group number range, 0 to 4095, and consequently uses a new MAC address range 0000.0C9F.F000 to 0000.0C9F.FFFF. The increased group number range does not imply that an interface can, or should, support that many HSRP groups. The expanded group number range was changed to allow the group number to match the VLAN number on subinterfaces.

When the HSRP version is changed, each group will reinitialize because it now has a new virtual MAC address.

HSRP version 2 has a different packet format than HSRP version 1. The packet format uses a type-length-value (TLV) format. HSRP version 2 packets received by an HSRP version 1 device will have the type field mapped to the version field by HSRP version 1 and subsequently ignored.

The Gateway Load Balancing Protocol (GLBP) also addresses the same restrictions relative to HSRP version 1 that HSRP version 2 does. See the Configuring GLBP document for more information on GLBP.

How to Configure HSRP Version 2

Changing to HSRP Version 2

HSRP version 2 was introduced to prepare for further enhancements and to expand the capabilities beyond what is possible with HSRP version 1. HSRP version 2 has a different packet format than HSRP version 1.


Note


  • HSRP version 2 is not available for ATM interfaces running LAN emulation.
  • HSRP version 2 will not interoperate with HSRP version 1. An interface cannot operate both version 1 and version 2 because both versions are mutually exclusive. However, the different versions can be run on different physical interfaces of the same device. You cannot change from version 2 to version 1 if you have configured groups above the group number range allowed for version 1 (0 to 255).

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    ip address ip-address mask

    5.    standby version {1 | 2}

    6.    standby [group-number] ip [ip-address [secondary]]

    7.    end

    8.    show standby


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Device(config)# interface vlan 400
     

    Configures an interface type and enters interface configuration mode.

     
    Step 4 ip address ip-address mask


    Example:
    Device(config-if)# ip address 10.10.28.1 255.255.255.0
     

    Sets an IP address for an interface.

     
    Step 5 standby version {1 | 2}


    Example:
    Device(config-if)# standby version 2 
     

    Changes the HSRP version.

     
    Step 6 standby [group-number] ip [ip-address [secondary]]


    Example:
    Device(config-if)# standby 400 ip 10.10.28.5
     

    Activates HSRP.

    • The group number range for HSRP version 2 is 0 through 4095. The group number range for HSRP version 1 is 0 through 255.

     
    Step 7 end


    Example:
    Device(config-if)# end
     

    Ends the current configuration session and returns to privileged EXEC mode.

     
    Step 8 show standby


    Example:
    Device# show standby
     

    (Optional) Displays HSRP information.

    • HSRP version 2 information will be displayed if configured.

     

    Configuration Examples for HSRP Version 2

    Example: Configuring HSRP Version 2

    The following example shows how to configure HSRP version 2 on an interface with a group number of 350:

    Device(config)# interface vlan 350
    Device(config-if)# standby version 2
    Device(config-if)# standby 350 priority 110 
    Device(config-if)# standby 350 preempt 
    Device(config-if)# standby 350 timers 5 15
    Device(config-if)# standby 350 ip 172.20.100.10 
    

    Additional References

    Related Documents

    Related Topic

    Document Title

    Cisco IOS commands

    Cisco IOS Master Commands List, All Releases

    HSRP commands: complete command syntax, command mode, command history, defaults, usage guidelines, and examples

    Cisco IOS First Hop redundancy Protocols Command Reference

    HSRP for IPv6

    “HSRP for IPv6” module

    Troubleshooting HSRP

    Hot Standby Router Protocol: Frequently Asked Questions

    Standards

    Standards

    Title

    No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

    --

    MIBs

    MIBs

    MIBs Link

    CISCO-HSRP-MIB CISCO-HSRP-EXT-MIB

    To locate and download MIBs for selected platforms, Cisco software releases, and feature sets, use Cisco MIB Locator found at the following URL:

    http:/​/​www.cisco.com/​go/​mibs

    RFCs

    RFCs

    Title

    RFC 792

    Internet Control Message Protocol

    RFC 1828

    IP Authentication Using Keyed MD5

    RFC 2281

    Cisco Hot Standby Router Protocol

    Technical Assistance

    Description

    Link

    The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

    Feature Information for HSRP Version 2

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for HSRP Version 2

    Feature Name

    Releases

    Feature Information

    HSRP Version 2

    12.3(4)T

    HSRP Version 2 feature was introduced to prepare for further enhancements and to expand the capabilities beyond what is possible with HSRP version 1. HSRP version 2 has a different packet format than HSRP version 1.

    In Cisco IOS XE Release 3.5S, support was added for the Cisco ASR 903 Router.

    The following commands were introduced or modified by this feature: show standby, standby ip, standby version.