First Hop Redundancy Protocols Configuration Guide, Cisco IOS Release 15M&T
FHRP—HSRP BFD Peering
Downloads: This chapterpdf (PDF - 1.35MB) The complete bookPDF (PDF - 3.31MB) | The complete bookePub (ePub - 499.0KB) | Feedback

FHRP—HSRP BFD Peering

FHRP—HSRP BFD Peering

The FHRP—HSRP BFD Peering feature introduces Bidirectional Forwarding Detection (BFD) in the Hot Standby Router Protocol (HSRP) group member health monitoring system. Before the introduction of this feature, group member monitoring relied exclusively on HSRP multicast messages, which are relatively large and consume CPU memory. In architectures where a single interface hosts a large number of groups, there is a need for a protocol with low CPU memory consumption and processing overhead. BFD addresses this issue and offers second health monitoring (failure detection in milliseconds) at a relatively low CPU impact.

IPv6 and IPv4 HSRP groups support BFD. If BFD is configured on an interface, all IPv4 and IPv6 HSRP groups will automatically support BFD.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Restrictions for FHRP—HSRP BFD Peering

Hot Standby Router Protocol (HSRP) support for Bidirectional Forwarding Detection (BFD) is not available for all platforms and interfaces.

Information About FHRP—HSRP BFD Peering

HSRP BFD Peering

The HSRP BFD Peering feature introduces Bidirectional Forwarding Detection (BFD) in the Hot Standby Router Protocol (HSRP) group member health monitoring system. HSRP supports BFD as a part of the HSRP group member health monitoring system. Without BFD, HSRP runs as a process in a multiprocess system and cannot be guaranteed to be scheduled in time to service large numbers of groups with hello and hold timers, in milliseconds. BFD runs as a pseudopreemptive process and can therefore be guaranteed to run when required. Only one BFD session between two devices can provide early failover notification for multiple HSRP groups.

This feature is enabled by default. The HSRP standby device learns the real IP address of the HSRP active device from the HSRP hello messages. The standby device registers as a BFD client and asks to be notified if the active device becomes unavailable. When BFD determines that the connections between standby and active devices has failed, it will notify HSRP on the standby device which will immediately take over as the active device.

BFD provides a low-overhead, short-duration method of detecting failures in the forwarding path between two adjacent devices, including the interfaces, data links, and forwarding planes. BFD is a detection protocol that you enable at the interface and routing protocol levels. Cisco supports the BFD asynchronous mode, which depends on the sending of BFD control packets between two systems to activate and maintain BFD neighbor sessions between devices. Therefore, to create a BFD session, you must configure BFD on both systems (or BFD peers). When BFD is enabled on the interfaces and at the device level for HSRP, a BFD session is created, BFD timers are negotiated, and the BFD peers will begin to send BFD control packets to each other at the negotiated interval.

BFD provides fast BFD peer failure detection times independently of all media types, encapsulations, topologies, and routing protocols such as, Border Gateway Protocol (BGP), Enhanced Interior Gateway Routing Protocol (EIGRP), Hot Standby Router Protocol (HSRP), Intermediate System To Intermediate System (IS-IS), and Open Shortest Path First (OSPF). By sending rapid failure detection notices to the routing protocols in the local device to initiate the routing table recalculation process, BFD contributes to greatly reduce overall network convergence time. The figure below shows a simple network with two devices running HSRP and BFD.

Figure 1. HSRP BFD Peering

For more information about BFD, see the IP Routing: BFD Configuration Guide.

How to Configure FHRP—HSRP BFD Peering

Configuring BFD Session Parameters on an Interface

Perform this task to configure Bidirectional Forwarding Detection (BFD) on an interface by setting the baseline BFD session parameters on the interface. Repeat the steps in this task for each interface on which you want to run BFD sessions to BFD neighbors.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    interface type number

    4.    bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier

    5.    end


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.

     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 interface type number


    Example:
    Device(config)# interface FastEthernet 6/0
     

    Enters interface configuration mode.

     
    Step 4 bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier


    Example:
    Device(config-if)# bfd interval 50 min_rx 50 multiplier 5
     

    Enables BFD on the interface.

     
    Step 5 end


    Example:
    Device(config-if)# end
     

    Exits interface configuration mode.

     

    Configuring HSRP BFD Peering

    Perform this task to enable Hot Standby Router Protocol (HSRP) Bidirectional Forwarding Detection (BFD) peering. Repeat the steps in this task for each interface over which you want to run BFD sessions to HSRP peers.

    HSRP supports BFD peering by default. If HSRP BFD peering is disabled, you can reenable it at the device level to enable BFD support globally for all interfaces or you can reenable it on a per-interface basis at the interface level.

    Before You Begin

    Before you proceed with this task:

    • HSRP must be running on all participating devices.

    • Cisco Express Forwarding must be enabled.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    ip cef [distributed]

      4.    interface type number

      5.    ip address ip-address mask

      6.    standby [group-number] ip [ip-address [secondary]]

      7.    standby bfd

      8.    exit

      9.    standby bfd all-interfaces

      10.    exit

      11.    show standby [neighbors]


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.

       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 ip cef [distributed]


      Example:
      Device(config)# ip cef
       

      Enables Cisco Express Forwarding or distributed Cisco Express Forwarding.

       
      Step 4 interface type number


      Example:
      Device(config)# interface FastEthernet 6/0
       

      Enters interface configuration mode.

       
      Step 5 ip address ip-address mask


      Example:
      Device(config-if)# ip address 10.0.0.11 255.255.255.0
       

      Configures an IP address for the interface.

       
      Step 6 standby [group-number] ip [ip-address [secondary]]


      Example:
      Device(config-if)# standby 1 ip 10.0.0.11
       

      Activates HSRP.

       
      Step 7 standby bfd


      Example:
      Device(config-if)# standby bfd
       

      (Optional) Enables HSRP support for BFD on the interface.

       
      Step 8 exit


      Example:
      Device(config-if)# exit
       

      Exits interface configuration mode.

       
      Step 9 standby bfd all-interfaces


      Example:
      Device(config)# standby bfd all-interfaces
       

      (Optional) Enables HSRP support for BFD on all interfaces.

       
      Step 10 exit


      Example:
      Device(config)# exit
       

      Exits global configuration mode.

       
      Step 11 show standby [neighbors]


      Example:
      Device# show standby neighbors
       

      (Optional) Displays information about HSRP support for BFD.

       

      Verifying HSRP BFD Peering

      To verify Hot Standby Router Protocol (HSRP) Bidirectional Forwarding Detection (BFD) peering, use any of the following optional commands.

      SUMMARY STEPS

        1.    show standby

        2.    show standby brief

        3.    show standby neighbors [type number]

        4.    show bfd neighbors

        5.    show bfd neighbors details


      DETAILED STEPS
        Step 1   show standby

        Use the show standby command to display HSRP information.



        Example:
        Device# show standby
        
        FastEthernet2/0 - Group 1
          State is Active
            2 state changes, last state change 00:08:06
          Virtual IP address is 10.0.0.11
          Active virtual MAC address is 0000.0c07.ac01
            Local virtual MAC address is 0000.0c07.ac01 (v1 default)
          Hello time 3 sec, hold time 10 sec
            Next hello sent in 2.772 secs
          Preemption enabled
          Active router is local
          Standby router is 10.0.0.2, priority 90 (expires in 8.268 sec)
            BFD enabled ! 
          Priority 110 (configured 110)
            Group name is "hsrp-Fa2/0-1" (default)
        
        Step 2   show standby brief

        Use the show standby brief command to display HSRP standby device information in brief.



        Example:
        Device# show standby brief
        
        Interface   Grp  Pri P State   Active  Standby                     Virtual IP
        
        Et0/0       4    120 P Active  local   172.24.1.2                  172.24.1.254
        Et1/0       6    120 P Active  local   FE80::A8BB:CCFF:FE00:3401   FE80::5:73FF:FEA0:6 
        
        
        Step 3   show standby neighbors [type number]

        Use the show standby neighbors command to display information about HSRP peer devices on an interface.



        Example:
        Device1# show standby neighbors
        
        HSRP neighbors on FastEthernet2/0
            10.1.0.22
            No active groups
            Standby groups: 1
            BFD enabled !
        
        Device2# show standby neighbors
        
        HSRP neighbors on FastEthernet2/0
            10.0.0.2
            Active groups: 1
            No standby groups
            BFD enabled !
        
        Step 4   show bfd neighbors

        Use the show bfd neighbors command to display a line-by-line listing of existing Bidirectional Forwarding Detection (BFD) adjacencies.



        Example:
        Device# show bfd neighbors
        
        IPv6 Sessions
        
        NeighAddr                              LD/RD         RH/RS     State     Int
        
        FE80::A8BB:CCFF:FE00:3401               4/3          Up        Up        Et1/0
        FE80::A8BB:CCFF:FE00:3401               4/3          Up        Up        Et1/0
        
        
        Step 5   show bfd neighbors details

        Use the details keyword to display BFD protocol parameters and timers for each neighbor.



        Example:
        Device# show bfd neighbors details
        
        OurAddr       NeighAddr     LD/RD  RH/RS   Holdown(mult)  State     Int
        10.0.0.2      10.0.0.1       5/0    Down      0    (0 )   Down      Fa2/0
        Local Diag: 0, Demand mode: 0, Poll bit: 0
        MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
        Received MinRxInt: 0, Received Multiplier: 0
        Holdown (hits): 0(0), Hello (hits): 1000(55)
        Rx Count: 0, Rx Interval (ms) min/max/avg: 0/0/0 last: 3314120 ms ago
        Tx Count: 55, Tx Interval (ms) min/max/avg: 760/1000/872 last: 412 ms ago
        Registered protocols: HSRP !
        Last packet: Version: 1            - Diagnostic: 0
                     State bit: AdminDown  - Demand bit: 0
                     Poll bit: 0           - Final bit: 0
                     Multiplier: 0         - Length: 0
                     My Discr.: 0          - Your Discr.: 0
                     Min tx interval: 0    - Min rx interval: 0
                     Min Echo interval: 0

        Configuration Examples for FHRP—HSRP BFD Peering

        Example: HSRP BFD Peering

        Hot Standby Router Protocol (HSRP) supports Bidirectional Forwarding Detection (BFD) as a part of the HSRP group member health monitoring system. Without BFD, HSRP runs as a process in a multiprocess system and cannot be guaranteed to be scheduled in time to service large numbers of groups with millisecond hello and hold timers. BFD runs as a pseudo-preemptive process and can therefore, be guaranteed to run when required. Only one BFD session between two devices can provide early failover notification for multiple HSRP groups.

        In the following example, the standby bfd and the standby bfd all-interfaces commands are not displayed. HSRP support for BFD is enabled by default when BFD is configured on a device or an interface by using the bfd interval command. The standby bfd and standby bfd all-interfaces commands are needed only if BFD has been manually disabled on a device or an interface.

        Device A

        DeviceA(config)# ip cef
        DeviceA(config)# interface FastEthernet2/0
        DeviceA(config-if)#  no shutdown
        DeviceA(config-if)# ip address 10.0.0.2 255.0.0.0
        DeviceA(config-if)# ip router-cache cef
        DeviceA(config-if)# bfd interval 200 min_rx 200 multiplier 3
        DeviceA(config-if)# standby 1 ip 10.0.0.11
        DeviceA(config-if)# standby 1 preempt
        DeviceA(config-if)# standby 1 priority 110
        DeviceA(config-if)# standby 2 ip 10.0.0.12
        DeviceA(config-if)# standby 2 preempt
        DeviceA(config-if)# standby 2 priority 110
        

        Device B

        DeviceB(config)# interface FastEthernet2/0
        DeviceB(config-if)# ip address 10.1.0.22 255.255.0.0
        DeviceB(config-if)# no shutdown
        DeviceB(config-if)# bfd interval 200 min_rx 200 multiplier 3
        DeviceB(config-if)# standby 1 ip 10.0.0.11
        DeviceB(config-if)# standby 1 preempt
        DeviceB(config-if)# standby 1 priority 90
        DeviceB(config-if)# standby 2 ip 10.0.0.12
        DeviceB(config-if)# standby 2 preempt
        DeviceB(config-if)# standby 2 priority 80
        

        Additional References for FHRP—HSRP BFD Peering

        Related Documents

        Related Topic

        Document Title

        Cisco IOS commands

        Cisco IOS Master Command List, All Releases

        BFD

        “Bidirectional Forwarding Detection” module in the IP Routing: BFD Configuration Guide

        HSRP commands

        Cisco IOS IP Application Services Command Reference

        Troubleshooting HSRP

        Hot Standby Router Protocol: Frequently Asked Questions

        RFCs

        RFCs

        Title

        RFC 2281

        Cisco Hot Standby Router Protocol

        Technical Assistance

        Description

        Link

        The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

        http:/​/​www.cisco.com/​cisco/​web/​support/​index.html

        Feature Information for FHRP—HSRP BFD Peering

        The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

        Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

        Table 1 Feature Information for FHRP—HSRP BFD Peering

        Feature Name

        Releases

        Feature Information

        FHRP—HSRP BFD Peering

        12.4(11)T

        The FHRP-HSRP BFD Peering feature introduces Bidirectional Forwarding Detection (BFD) in the Hot Standby Router Protocol (HSRP) group member health monitoring system. Before the introduction of this feature, group member monitoring relied exclusively on HSRP multicast messages, which are relatively large and consume CPU memory. In architectures where a single interface hosts a large number of groups, there is a need for a protocol with low CPU memory consumption and processing overhead. BFD addresses this issue and offers second health monitoring (failure detection in milliseconds) at a relatively low CPU impact.

        The following commands were introduced or modified by this feature: debug standby events neighbor, show standby, show standby neighbors, standby bfd, standby bfd all-interfaces.

        FHRP—HSRP IPv6 BFD Peering

        The FHRP—HSRP IPv6 BFD Peering feature implements BFD support for IPv6 and IPv4 HSRP groups.