Guest

Asymmetric Digital Subscriber Line (ADSL)

Cisco DSL Router Configuration and Troubleshooting Guide - Cisco DSL Router Acting as a PPPoE Client with a Static IP Address

Document ID: 71122

Updated: Oct 05, 2006

   Print

Introduction

Your Internet Service Provider (ISP) has assigned a single static public IP address to your Cisco Digital Subscriber Line (DSL) Router.

Tip: If you are not familiar with how to configure Cisco devices and would like to follow a step-by-step configuration, refer to Step-by-Step Configuration of PPPoE with a Static IP Address.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Tasks to Perform

  • Design an IP addressing scheme for your private LAN.

  • Configure an IP address, subnet mask, and TCP maximum segment size (MSS) adjustment on the Cisco DSL Router Ethernet interface.

  • Configure the ATM interface (Asymmetric Digital Subscriber Line (ADSL) interface) of the Cisco DSL Router with an ATM permanent virtual circuit (PVC) and encapsulation.

  • Configure a Point-to-Point Protocol over Ethernet (PPPoE) virtual private data network (VPDN) group for Cisco IOS® Software later than 12.2(13)T.

  • Create and configure the Dialer interface of the Cisco DSL Router for PPPoE with a static IP address.

  • For Network Address Translation (NAT): Configure NAT on the Cisco DSL Router to allow sharing of the dynamic public IP address of the Dialer interface.

    • Optional: NAT Pool, if additional IP addresses have been provided by your ISP.

    • Optional: Static NAT, if Internet users require access to internal servers.

  • Configure each PC client with an IP address, subnet mask, default gateway, and Domain Name System (DNS) server(s).

    For Dynamic Host Configuration Protocol (DHCP): Alternatively, if you want the Cisco DSL Router to assign your PC clients dynamic IP addresses, configure each PC to obtain an IP address and DNS server(s) automatically via DHCP.

Possible Required Configuration Steps on the PC

If your Cisco DSL Router software supports the ip tcp adjust-mss 1452 or ip adjust-mss 1452 configuration commands, no further action is needed and you can continue with the Configure section.

If your Cisco DSL Router software does not support the ip tcp adjust-mss 1452 or ip adjust-mss 1452 configuration commands, you must change the maximum transmission unit (MTU) size on each PC in your LAN that has access to the Internet through the Cisco DSL Router. Complete these steps in order to change the MTU size.

  1. Download the latest version of the Dr. TCP utility from http://www.dslreports.com/front/drtcp.html leavingcisco.com.

  2. Refresh your browser page to ensure the page is current.

  3. Run the Dr. TCP utility.

  4. From the menu choose your Ethernet adapter.

  5. In the MTU field, type 1492.

  6. Click Apply to save the change, and then click Exit.

  7. Reboot the PPPoE PC client.

The registry change is saved when the procedure finishes. Therefore, you only need to run the utility once per PC.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Configurations

Tip: If you are not familiar with how to configure Cisco devices and would like to follow a step-by-step configuration, refer to Step-by-Step Configuration of PPPoE with a Static IP Address.

Cisco DSL Router with a Static IP Address

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
  vpdn-group pppoe
   request-dialin
    protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than than 12.2(13)T.

!
!
ip subnet-zero
!

!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported, try this
 !--- configuration statement: ip adjust-mss 1452. If this command is not
 !--- supported in your current Cisco DSL Router software release, upgrade to the 
 !--- latest Cisco DSL Router software or follow the procedure in the
 !--- "Possible Required Configuration Steps on the PC" section of this document. 


!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address <ip address> <subnet mask>
 mtu 1492

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer1

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

Refer to Troubleshooting the Cisco DSL Router PPPoE Client if your DSL service does not work properly.

Related Information

Updated: Oct 05, 2006
Document ID: 71122