Guest

Asymmetric Digital Subscriber Line (ADSL)

Sample Configurations for Cisco 7200 Broadband Aggregation

Cisco - Sample Configurations for Cisco 7200 Broadband Aggregation

Document ID: 12868

Updated: Aug 09, 2006

   Print

Introduction

This document provides a general description of digital subscriber line (DSL) components and how the components fit together in a basic DSL implementation. The sample configurations in this document show the most common DSL networks that are currently in use. You can use these configurations as a general reference to design a broadband aggregation implementation. However, do not view these configurations as a cookie-cutter solution. Every customer and every requirement are different, and there are many ways to accomplish the same design goals.

While the configurations in this document are as complete as possible, the document gives only the essential lines. The document assumes that the user has a basic understanding of Cisco device configuration and omits many of the basic command lines. Use these configurations only as a start point to design your own implementation.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

PPPoA Session Termination: xDSL to 7200

Network Diagram

This section uses this network setup:

7200_bdaggreg1.gif

Configurations

This example describes how to connect a Cisco 677, or other DSL customer premises equipment (CPE), to a Cisco 7200 via PPP over ATM (PPPoA). The configuration includes a Cisco Lightstream 1010 (LS1010) ATM switch, which is an optional component. The results are the same if you directly connect the DSL access multiplier (DSLAM) to the Cisco 7200.

In this example, you establish the PPP session on the Cisco 677 and terminate on the Cisco 7200. After the termination of the session, traditional IP passes traffic to the network service provider (NSP) or to the Internet.

The CPE has a configuration to perform Network Address Translation (NAT)/Port Address Translation (PAT). The CPE also implements a DHCP server to assign IP addresses to the Ethernet stations.

This section uses these configurations:

PC Configuration for PPPoA
  1. Set IP addressing to automatically obtain an IP address.
  2. Set WINS to use DHCP for WINS resolution.
  3. Ensure that no default gateway is set.

Note: If DHCP cannot pass this information, you need to set a domain name.

Cisco CPE Configuration for PPPoA
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Cisco DSLAM Configuration for PPPoA
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 atm pvc 1 32 interface atm0/1 1 35

Cisco LS1010 Configuration for PPPoA
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Cisco 7200 Configuration for PPPoA
aaa new-model
AAA authentication ppp default local
!
!
username password 
!
!
interface ATM 2/0.1 multipoint
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template 2
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template 2
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
!
ip local pool <pool name> 172.22.40.10 172.22.40.25

RFC 1483 Bridging: xDSL to 7200

Network Diagram

This section uses this network setup:

7200_bdaggreg2.gif

Configurations

This example describes how to connect a Cisco 677, or other DSL CPE, to a Cisco 7200 via RFC 1483 bridged encapsulation. This configuration includes a Cisco LS1010 ATM switch, which is an optional component. The results are the same if you directly connect the DSLAM to the Cisco 7200.

In this example, you establish the bridged session on the Cisco 677 and terminate on the Cisco 7200. After the session bridges to the Cisco 7200, traditional IP passes traffic to the NSP or to the Internet. A DHCP server with configuration in the 7200 assigns an IP address to the client workstation.

This configuration uses integrated routing and bridging (IRB). To alleviate scalability and security concerns with IRB, consider Routed Bridged Encapsulation (RBE).

This section uses these configurations:

PC Configuration for RFC 1483
  1. Set IP addressing to automatically obtain an IP address.
  2. Set WINS to use DHCP for WINS resolution.
  3. Ensure that no default gateway is set.

Note: If DHCP cannot pass this information, you need to set a domain name.

Cisco 677 CPE Configuration for RFC 1483
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Cisco DSLAM Configuration for RFC 1483
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Cisco LS1010 Configuration for RFC 1483
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Cisco 7200 Configuration for RFC 1483
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!         
!
bridge irb
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
 bridge-group 1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
 bridge-group 1!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface BVI 1
 ip address 172.22.40.9 255.255.255.0
 no ip directed-broadcast
!
!
bridge 1 protocol ieee
 bridge 1 route ip

RBE: xDSL to 7200

Network Diagram

This section uses this network setup:

7200_bdaggreg2.gif

Configurations

RBE is currently the configuration of choice for most new DSL installations. RBE addresses the security and scalability issues of bridging in the broadband subscriber environment.

A DHCP server with configuration in the 7200 assigns an IP address to the client workstation.

Important: DHCP cannot run on the router with unnumbered ATM except when you use Cisco IOS® Software Release 12.1(2)T or later.

This section uses these configurations:

PC Configuration for RBE
  1. Set IP addressing to automatically obtain an IP address.
  2. Set WINS to use DHCP for WINS resolution.
  3. Ensure that no default gateway is set.

Note: If DHCP cannot pass this information, you need to set a domain name.

Cisco CPE Configuration for RBE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Cisco DSLAM Configuration for RBE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Cisco LS1010 Configuration for RBE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Cisco 7200 Configuration for RBE
ip dhcp excluded-address 172.22.40.1 172.22.40.25
!
!
ip dhcp pool 0
   network 172.22.40.0 255.255.255.0
   default-router 172.22.40.9 
   dns-server  
   netbios-name-server 
!
!
interface Loopback0
 ip address 172.22.40.9 255.255.255.0
!
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/35 
  encapsulation aal5snap
!
!
interface ATM 2/0.2 point-to-point
 ip unnumbered Loopback0
 no ip directed-broadcast
 ATM route-bridged ip
 PVC 1/36 
  encapsulation aal5snap
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!

PPPoE: xDSL to 7200

Network Diagram

This section uses this network setup:

7200_bdaggreg3.gif

Configurations

PPP over Ethernet (PPPoE) extends the PPP session from the router to the end client. PPP and authentication software usually run on the client either within the operating system or in a standalone application. The CPE acts in bridging mode to bridge the PPP session over the DSL connection. But CPE cannot act as the DHCP server in this scenario.

Configurations for the CPE, DSLAM, and ATM switch are the same as the configurations for RFC 1483 bridging. You can configure the Cisco 7200 aggregation router for local authentication, as this example shows. Or you can configure the 7200 with authentication, authorization, and accounting (AAA) RADIUS authentication.

This section uses these configurations:

PC Configuration for PPPoE
  1. Set IP addressing to automatically obtain an IP address.
  2. Set WINS to use DHCP for WINS resolution.
  3. Ensure that no default gateway is set.

Note: If DHCP cannot pass this information, you need to set a domain name.

Note: The end station must be able to establish a PPP connection to the router. Special client software for authentication and access can be necessary.

Cisco 677 CPE Configuration for PPPoE
cbos# set bridging rfc1483 enabled

!--- Use write, then reboot for the changes to take effect.


cbos# set bridging management enable

cbos# set int eth0 address 172.22.40.25

!--- You use this IP address for management purposes only.


cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# write
NVRAM written.

cbos# reboot

Cisco DSLAM Configuration for PPPoE
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Cisco LS1010 Configuration for PPPoE
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Cisco 7200 Configuration for PPPoE
!
username <username> password <password>
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
  pppoe limit per-mac 100
  pppoe limit per-vc 100
!
ip cef
!
interface atm2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5snap
  protocol pppoe
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5snap
  protocol pppoe
!
interface Virtual-Template1
 ip unnumbered FastEthernet 4/0
 no ip directed-broadcast
 peer default ip address pool <pool name>
 ppp authentication pap
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
ip local pool <pool name> 172.22.32.20 172.22.32.100

L2TP: xDSL to 7200 via L2TP

Network Diagram

This section uses this network setup:

7200_bdaggreg4.gif

Configurations

Layer Two Tunneling Protocol (L2TP) provides a means to terminate the PPP connection from the end user at one location and transport the L2 data packets to another location. L2TP offloads much of the IP functionality from the aggregation device and allows more centralized network designs. A RADIUS server provides AAA.

The configurations for all devices except the Cisco 7200 are the same as the configurations for the RFC 1483 example.

This section uses these configurations:

PC Configuration for L2TP
  1. Set IP addressing to automatically obtain an IP address.
  2. Set WINS to use DHCP for WINS resolution.
  3. Ensure that no default gateway is set.

Note: If DHCP cannot pass this information, you need to set a domain name.

Cisco 677 CPE Configuration for L2TP
cbos> enable
Password:

cbos# set nat enable
NAT is now enabled
You must use "write" then reboot for changes to take effect.

cbos# set ppp wan0-0 login 
User name for wan0-0 has been set to testcpe.

cbos# set ppp wan0-0 password 
Password for wan0-0 has been set to cisco.

cbos# set ppp wan0-0 ipcp 0.0.0.0
PPP wan0-0 IPCP Address set to 0.0.0.0

cbos# set int wan0-0 close
cbos# set int wan0-0 vpi 1

cbos# set int wan0-0 vci 32

cbos# set int wan0-0 open

cbos# set int eth0 address 172.22.10.254
eth0 ip address changed from 10.0.0.1 to 172.22.10.254

cbos# set int eth0 netmask 255.255.255.0
eth0 netmask changed from 255.255.255.0 to 255.255.255.0

cbos# set dhcp server enable
DHCP Server enabled

cbos# set dhcp server pool 0 ip 172.22.10.0
Pool 0 IP parameter is now 172.22.10.0

cbos# set dhcp server pool 0 netmask 255.255.255.0
Pool 0 netmask parameter is now 255.255.255.0

cbos# set dhcp server pool 0 gateway 172.22.10.254
Pool 0 gateway parameter is now 172.22.10.254

cbos# set password exec 
Exec Password Change Successful! 

cbos# set password enable 
Enable Password Change Successful! 

cbos# write
NVRAM written.

Cisco DSLAM Configuration for L2TP
hostname 6260
! Subtending Port - Will set as shutdown
interface atm0/2
 shutdown
slot 1 atuc-1-4dmt
!
dsl-profile fast
 dmt codeword-size downstream 16 upstream 16
 dmt bitrate maximum interleaved downstream 8032 upstream 832
!
interface atm1/1
 dsl profile fast
 ATM PVC 1 32 interface atm0/1 1 35

Cisco LS1010 Configuration for L2TP
interface ATM 0/1/2
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
 ATM pvp 1 interface ATM 0/0/2 1

Cisco 7200 LAC Configuration for L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!  
vpdn-group 4
 request-dialin
  protocol l2tp
  domain cisco.com
 initiate-to ip 172.22.32.27 priority 1
 local name cisco-tunnel      
!
interface ATM 2/0
 no ip address
 no ip directed-broadcast
 no ATM ilmi-keepalive
!
!
interface ATM 2/0.1 point-to-point
 no ip directed-broadcast
 PVC 1/35 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface ATM 2/0.2 point-to-point
 no ip directed-broadcast
 PVC 1/36 
  encapsulation aal5mux ppp Virtual-Template1
!
!
interface FastEthernet 4/0
 ip address 172.22.32.1 255.255.255.0
 no ip directed-broadcast
!
!
interface Virtual-Template1
 ip unnumbered FastEthernet4/0
 no ip directed-broadcast
 ppp authentication pap
!
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Cisco 7200 LNS Configuration for L2TP
!
AAA new-model
AAA authentication login default none
AAA authentication ppp default local group radius
AAA authorization network default local group radius none
AAA accounting network default wait-start group radius
!
vpdn-group 1
 accept-dialin
  protocol any
  virtual-template 1
 terminate-from hostname cisco-tunnel
 local name tunnel-gate
!
radius-server host 172.22.32.20 auth-port 1645 acct-port 1646
radius-server key cisco

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 09, 2006
Document ID: 12868