Guest

IP Version 6 (IPv6)

Redistribute IPv6 BGP Default Route in EIGRPv6 Configuration Example

Document ID: 113598

Updated: Jun 25, 2012

   Print

Introduction

This document provides a sample configuration of how to redistribute a Border Gateway Protocol (IPv6 BGP) default route in to Enhanced Interior Gateway Routing Protocol (EIGRPv6) using mutual redistribution between EIGRPv6 and IPv6 BGP.

Prerequisites

Make sure that you meet these requirements before you attempt this configuration:

  • Have a basic knowledge of EIGRPv6

  • Have a basic knowledge of IPv6 BGP

  • Have a basic knowledge of IPv6 addressing

Hardware and Software Versions

The configurations in this document are based on the Cisco 7200 Series Router with Cisco IOS® Software Release 15.0(1).

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this example, routers R2 and R1 communicate with each other using IPv6 eBGP. Routers R1 and R3 use EIGRPv6. The default route is created in router R2 by issuing the neighbor default-originate command. In order to mutually redistribute the IPv6 eBGP routes in to EIGRPv6, use the redistribute bgp command with EIGRP metrics. Similarly, in order to redistribute EIGRPv6 routes in to IPv6BGP, use the redistribute eigrp AS number command under the address-family configuration mode.

Note: Use the Command Lookup Tool (registered customers only) in order to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

redis-ipv6-default-route-01.gif

Configurations

This document uses these configurations:

Router R1
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address BB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address BB20::20/128
!
interface Loopback30
 no ip address
 ipv6 address BB30::30/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 serial restart-delay 0
!
interface Serial1/1
 no ip address
 ipv6 address 4040:1:1:1::10/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
router bgp 505
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 500
 no auto-summary
 !
 address-family ipv6
  redistribute eigrp 1

!--- EIGRP is redistributed in to BGP.

  no synchronization
  network BB10::10/128
  network BB20::20/128
  neighbor 3030:1:1:1::10 activate
 exit-address-family
!
!
ipv6 router eigrp 1
 eigrp router-id 1.1.1.1
 redistribute bgp 505 metric 100 1 255 1 1500

!--- EIGRP for IPv6 has a shutdown feature.
!--- Make sure that the routing process is in "no shut" mode 
!--- in order to start running the protocol.


!--- BGP is redistributed with EIGRP default metrics.

!
end

Router R2
R2#show run
Building configuration...
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback10
 no ip address
 ipv6 address AB10::10/128
!
interface Loopback20
 no ip address
 ipv6 address AB20::20/128
!
interface Serial1/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 serial restart-delay 0
!
router bgp 500
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 505
 neighbor 3030:1:1:1::11 default-originate
 no auto-summary
!
 address-family ipv6
  no synchronization
  network AB10::10/128
  network AB20::20/128
  neighbor 3030:1:1:1::11 activate
  neighbor 3030:1:1:1::11 default-originate
 exit-address-family
!
end

!--- Originates default route to the 
!--- neighbor 3030:1:1:1::11.

Router R3
R3#show run
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback10
 no ip address
 ipv6 address CC10::10/128
 ipv6 eigrp 1
!
interface Loopback20
 no ip address
 ipv6 address CC20::20/128
 ipv6 eigrp 1
!
interface Serial1/0
 no ip address
 ipv6 address 4040:1:1:1::11/64
 ipv6 eigrp 1
 serial restart-delay 0
!
!
ipv6 router eigrp 1
 eigrp router-id 3.3.3.3
!
end

Verify

Use this section in order to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT in order to view an analysis of show command output.

Show Commands

In order to verify that router R3 is receiving the redistributed IPv6 BGP default route, use the show ipv6 route eigrp command in router R3.

show ipv6 route eigrp
In router R3
R3#show ipv6 route eigrp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
EX  ::/0 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB10::10/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
EX  AB20::20/128 [170/26112256]
     via FE80::C806:16FF:FE08:0, Serial1/0
D   BB30::30/128 [90/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the default route
!--- is redistributed in EIGRP. EX indicates EIGRP external routes.

In order to verify EIGRPv6 routes are redistributed in router R2 properly, use the show ipv6 route bgp command in router R2.

show ipv6 route bgp
In router R2
R2#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   BB10::10/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   BB20::20/128 [20/0]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC10::10/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0
B   CC20::20/128 [20/2297856]
     via FE80::C806:16FF:FE08:0, Serial1/0

!--- The above output shows that the eigrp routes
!--- are redistributed in to BGP.

Verify the reachability between routers R2 and R3 using the ping command.

ping
From router R2:
R2#ping  CC10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/40/96 ms

R2#ping CC20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to CC20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/44/100 ms
From router R3:
R3#ping AA10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

R3#ping AA20::20

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to AA20::20, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/33/92 ms

!--- The above ping responses shows that R1 and R3 are able
!--- to communicate with each other.

Related Information

Updated: Jun 25, 2012
Document ID: 113598