Guest

IP Routing

IPv6 BGP Prefix-Based Outbound Route Filtering Configuration Example

Document ID: 113504

Updated: Jun 14, 2012

   Print

Introduction

This document provides a sample configuration using IPv6 that helps you to configure BGP Prefix-Based Outbound Route Filtering. This feature uses BGP outbound route filter (ORF) send and receive capabilities that minimize the number of BGP updates sent between peer routers. The configuration of this feature can help in filtering out unwanted routing updates at the source.

Prerequisites

Requirements

Make sure that you meet these requirements before you attempt this configuration:

  • Have an understanding of BGP routing protocol and its operation

  • Have an understanding of the IPv6 Addressing scheme

Components Used

This document is not restricted to specific software and hardware versions.

The configurations in this document are based on the Cisco 7200 Series Router with Cisco IOS® Software Release 15.0(1).

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this example, router R1 is configured to advertise-prefix based ORF send capabilities to router R2. On the other end router R2 is configured to advertise the prefix-based ORF receive capabilities to router R1. Before the BGP Prefix-Based Outbound Route Filtering feature can be enabled to send or receive prefix-based ORF announcements, BGP peering sessions must be up and running and BGP ORF capabilities must be enabled on each participating router before a router.

This document uses the neighbor orf prefix-filter command in order to enable the ORF prefix list capability on the router. This command was introduced in Cisco IOS Software Release 12.0(11)ST.

Note: Use the Command Lookup Tool (registered customers only) in order to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

ipv6-bgp-outbound-prefixfilter-01.gif

Sample Configurations

This document uses these configurations:

Router R1
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Loopback1
 no ip address
 ipv6 address 1111::1/128
!
!
interface Loopback2
 no ip address
 ipv6 address 2222::1/128
! 
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::1/64
 serial restart-delay 0
!
!
router bgp 6501
 no synchronization
 no bgp default ipv4-unicast
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 capability orf prefix-list send
  neighbor 2011:11:11:11::2 prefix-list FILTER_IPv6 in
 exit-address-family
!
!
ipv6 prefix-list FILTER_IPv6 seq 10 permit 1111::1/128
ipv6 prefix-list FILTER_IPv6 seq 20 permit 2222::1/128
!
!
end

Router R2
!
hostname R2
!
!
no ip domain lookup
ipv6 unicast-routing
ipv6 cef
!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
 !
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::2/64
 serial restart-delay 0
!
!
router bgp 6502
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::1 remote-as 6501
 neighbor 2011:11:11:11::1 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6

  network 1010::1/128
  network 2020::1/128
  neighbor 2011:11:11:11::1 activate
  neighbor 2011:11:11:11::1 capability orf prefix-list receive
  neighbor 2011:11:11:11::1 prefix-list R2_list in
 exit-address-family
!
ipv6 prefix-list R2_list seq 10 permit 1010::1/128
ipv6 prefix-list R2_list seq 20 permit 2020::1/128
!
end

Scenario 1: Filter Routes Based on Prefix-list with Expressions

In this scenario, a loopback address 1000::1/45 is configured in R1 under interface loopback 0 . A prefix-list is created in order to allow any routes that are greater than prefix-length ::/64.

Note: The configuration of router R2 remains the same as previously given and R1 configuration changes as shown here. The IP addresses on these routers remains the same.

Router R1

!--- Output omitted.
 
!
interface Loopback0
 no ip address
 ipv6 address 1000::1/45
 !

!--- Output omitted.

  router bgp 6501
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  network 1000::1/45
  network 1111::1/128
  network 2222::1/128
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 prefix-list IPV6-LONG in

!--- Applies the prefix-list and filters 
!--- the incoming updates from the neighbor 2011:11:11:11::2.

 exit-address-family
!
ipv6 prefix-list IPV6-LONG description Match any prefix longer than /64
ipv6 prefix-list IPV6-LONG seq 1 permit ::/0 ge 64

!--- seq 1 permit ::/0 ge 64 permits anything
!--- that is ge /64 subnet mask.

!
end

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

These show commands are used to verify the configuration:

Verify IPv6 BGP Prefix-Based Outbound Route Filtering Configured in Send Mode

In Router R1:

show running-config | beg bgp
router bgp 6501
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::2 remote-as 6502
 neighbor 2011:11:11:11::2 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  neighbor 2011:11:11:11::2 activate
  neighbor 2011:11:11:11::2 capability orf prefix-list send

!--- Indicates that the neighbor 2011:11:11:11::2 
!--- is configured with the prefix-based 
!--- ORF feature in send mode.

show bgp ipv6 unicast neighbors
R1#show bgp ipv6 unicast neighbors 2011:11:11:11::2
BGP neighbor is 2011:11:11:11::2,  remote AS 6502, external link
  BGP version 4, remote router ID 2.2.2.2
  Session state = Established, up for 01:30:36
  Last read 00:00:44, last write 00:00:42, hold time is 180, keepalive interval is 60 seconds 
 BGP multisession with 2 sessions (2 established), first up for 01:31:26
  Neighbor sessions:
    2 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new) on session 1, 2
    Four-octets ASN Capability: advertised and received on session 1, 2
    Address family IPv4 Unicast: advertised and received
    Address family IPv6 Unicast: advertised and received

!--- Output omitted.

 For address family: IPv6 Unicast
  Session: 2011:11:11:11::2 session 2
  BGP table version 1, neighbor version 1/0
  Output queue size : 0
  Index 2
  session 2 member
  2 update-group member
  AF-dependant capabilities:
    Outbound Route Filter (ORF) type (128) Prefix-list:

!--- Shows that the neighbor 2011:11:11:11::2 
!--- is configured with the prefix-based 
!--- ORF feature in send mode.

      Send-mode: advertised
      Receive-mode: received
  Outbound Route Filter (ORF): sent;
  Incoming update prefix filter list is FILTER_IPv6
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          4
    Prefixes Total:                 0          0
    Implicit Withdraw:              1          0
    Explicit Withdraw:              1          0
    Used as bestpath:             n/a          0
    Used as multipath:            n/a          0

                                   Outbound    Inbound
  Local Policy Denied Prefixes:    --------    -------
    
  
!--- Output omitted.

Verify IPv6 BGP Prefix-Based Outbound Route Filtering Configured in Receive Mode

In Router R2:

show running-config | beg bgp
router bgp 6502
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::1 remote-as 6501
 neighbor 2011:11:11:11::1 ebgp-multihop 255
 no auto-summary
 !
 address-family ipv6
  network 1010::1/128
  network 2020::1/128
  neighbor 2011:11:11:11::1 activate
  neighbor 2011:11:11:11::1 capability orf prefix-list receive

!--- Indicates that the neighbor 2011:11:11:11::1 
!--- is configured with the prefix-based 
!--- ORF feature in receive mode.

show bgp ipv6 unicast neighbors
R2#show bgp ipv6 unicast nei 2011:11:11:11::1
BGP neighbor is 2011:11:11:11::1,  remote AS 6501, external link
  BGP version 4, remote router ID 1.1.1.1
  Session state = Established, up for 01:47:11
  Last read 00:00:44, last write 00:00:32, hold time is 180, keepalive interval is 60 seconds  
multisession with 2 sessions (2 established), first up for 01:48:02
  Neighbor sessions:
    2 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new) on session 1, 2
    Four-octets ASN Capability: advertised and received on session 1, 2
    Address family IPv4 Unicast: advertised and received
    Address family IPv6 Unicast: advertised and received
    Multisession Capability: advertised and received
 
!--- Output omitted.


 For address family: IPv6 Unicast
  Session: 2011:11:11:11::1 session 2
  BGP table version 3, neighbor version 3/0
  Output queue size : 0
  Index 3
  session 2 member
  3 update-group member
  AF-dependant capabilities:
    Outbound Route Filter (ORF) type (128) Prefix-list:

!--- Shows that the neighbor 2011:11:11:11::1 
!--- is configured with the prefix-based 
!--- ORF feature in receive mode.

      Send-mode: received
      Receive-mode: advertised
  Outbound Route Filter (ORF): received (2 entries)
Incoming update prefix filter list is R2_list
                                 Sent       Rcvd
  Prefix activity:               ----       ----
    Prefixes Current:               2          5
    Prefixes Total:                 0          0
    Implicit Withdraw:              0          0
    Explicit Withdraw:              2          0
    

!--- Output omitted.
 

Verify Scenario 1: Filter Routes Based on Prefix-list with Expressions

Issue the show ipv6 route bgp command in router R1 in order to display the current contents of the IPv6 BGP routing table.

show ipv6 route bgp
In router R1:
R1#show ipv6 route bgp
IPv6 Routing Table - default - 9 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       D - EIGRP, EX - EIGRP external, ND - Neighbor Discovery
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
B   1010::1/128 [20/0]
     via 2011:11:11:11::2
B   2020::1/128 [20/0]
     via 2011:11:11:11::2

!--- In this ouput, 1000::1/45 is not 
!--- displayed because the network is lesser 
!--- than ::/64 prefix and its filtered. 

Use the show ipv6 prefix-list command in order to display information about an IPv6 prefix list or IPv6 prefix list entries.

show ipv6 prefix-list
In router R1:
R1#show ipv6 prefix-list detail

Prefix-list with the last deletion/insertion: IPV6-LONG
ipv6 prefix-list IPV6-LONG:
   Description: Match any prefix longer than /64
   count: 1, range entries: 1, sequences: 1 - 1, refcount: 3
   seq 1 permit ::/0 ge 64 (hit count: 14, refcount: 1)

R1#show ipv6 prefix-list summary

Prefix-list with the last deletion/insertion: IPV6-LONG
ipv6 prefix-list IPV6-LONG:
   Description: Match any prefix longer than /64
   count: 1, range entries: 1, sequences: 1 - 1, refcount: 3

R1#show ipv6 prefix-list  IPV6-LONG

ipv6 prefix-list IPV6-LONG: 1 entries
   seq 1 permit ::/0 ge 64

Related Information

Updated: Jun 14, 2012
Document ID: 113504