Guest

IP Version 6 (IPv6)

Multiprotocol BGP for IPv6 Configuration Example

Cisco - Multiprotocol BGP for IPv6 Configuration Example

Document ID: 112135

Updated: Sep 21, 2010

   Print

Introduction

This document provides a sample configuration for multiprotocol Border Gateway Protocol (BGP) for IPv6. BGP is an Exterior Gateway Protocol (EGP) used mainly to connect separate routing domains that contain independent routing policies (autonomous systems). BGP is commonly used to connect to a service provider for access to the Internet. BGP can also be used within an autonomous system, and this variation is referred to as internal BGP (iBGP). Multiprotocol BGP is an enhanced BGP that carries routing information for multiple network layer protocol address families, such as, IPv6 address family and for IP multicast routes. All BGP commands and routing policy capabilities can be used with multiprotocol BGP.

Prerequisites

Requirements

Ensure that you meet these requirements before you attempt this configuration:

Components Used

This document is not restricted to specific software and hardware versions.

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

In this topology, routers R0 and R1 form an EBGP relationship: R0 is in Autonomous System Number 1 (AS1) and R1 is in AS2. Router R0 is advertising two IPv6 networks: 2010:AB8:2::/48 and 2010:AB8:3::/48.

Network Diagram

This document uses this network setup:

ipv6-bgp-01.gif

Configurations

This is the sample configuration of IPv6 multiprotocol BGP for the routers shown in the diagram:

Router R0

ipv6 unicast-routing

!--- Enables forwarding of IPv6 packets.

ipv6 cef

interface Loopback10
 no ip address
 ipv6 address 2010:AB8:2::/48
 ipv6 enable
!
interface Loopback20
 no ip address
 ipv6 address 2010:AB8:3::/48
 ipv6 enable
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 1
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring ""no bgp default ipv4-unicast"" only IPv4 will be 

!--- advertised

 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C601:10FF:FE58:0 remote-as 2
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C601:10FF:FE58:0 activate
  network 2010:AB8:2::/48
  network 2010:AB8:3::/48
 exit-address-family
!

Router R1
ipv6 unicast-routing
ipv6 cef

interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2010:AB8:0:2::/64 eui-64
 ipv6 enable
!

router bgp 2
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2010:AB8:0:2:C600:10FF:FE58:0 remote-as 1
 !
 address-family ipv6
  neighbor 2010:AB8:0:2:C600:10FF:FE58:0 activate
 exit-address-family
!

Verify

Use this section to confirm that your configuration works properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

show ipv6 route

This command displays the the IPv6 routing table.

R1#
show ipv6 route

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
C   2010:AB8:0:2::/64 [0/0]
     via ::, FastEthernet0/0
L   2010:AB8:0:2:C601:10FF:FE58:0/128 [0/0]
     via ::, FastEthernet0/0
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
L   FF00::/8 [0/0]
     via ::, Null0

show ipv6 route bgp

When you specify a protocol, only routes for that particular routing protocol are shown. This sample output is from the show ipv6 route command when entered with the BGP keyword:

R1#
show ipv6 route bgp

IPv6 Routing Table - 5 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2010:AB8:2::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0
B   2010:AB8:3::/48 [20/0]
     via FE80::C600:10FF:FE58:0, FastEthernet0/0

show bgp ipv6 unicast summary

This command provides output similar to the show ip bgp summary command, except it is IPv6-specific.

R1#
show bgp ipv6 unicast summary

BGP router identifier 2.2.2.2, local AS number 2
BGP table version is 3, main routing table version 3
2 network entries using 304 bytes of memory
2 path entries using 152 bytes of memory
2/1 BGP path/bestpath attribute entries using 248 bytes of memory
1 BGP AS-PATH entries using 24 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 728 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
2010:AB8:0:2:C600:10FF:FE58:0
                4     1      15      14        3    0    0 00:11:52        2

Related Information

Updated: Sep 21, 2010
Document ID: 112135