Cisco MDS 9000 Family Cookbook, Release 1.x
Logical Interfaces

Table Of Contents

Logical Interfaces

Creating a PortChannel

Adding a New Member to a PortChannel

Removing a Member from a PortChannel

Modifying the VSAN Allowed List


Logical Interfaces


PortChannels allow for the aggregation of multiple Fibre Channels or FCIP links into a single, high- speed, fault tolerant Fibre Channel or FCIP ISL (Inter-Switch Link). An ISL with multiple Fibre Channels or FCIP links has the same configuration options as a single-link Fibre Channel or FCIP ISL. This chapter focuses on the procedures associated with building, modifying, and reducing a PortChannel. It includes the following sections:

Creating a PortChannel

Adding a New Member to a PortChannel

Removing a Member from a PortChannel

Modifying the VSAN Allowed List

Creating a PortChannel

There are two basic methods to create a PortChannel: using the Fabric Manager wizard or entering commands through the CLI (command-line interface). This procedure shows how to create a PortChannel using the CLI.

This procedure uses the following resources:

Switch 1:

Channel Group 2

Interfaces: fc1/1 and fc2/1

Switch 2:

Channel Group 2

Interfaces: fc1/1 and fc2/1

Allowed VSANs: 1,10

Figure 4-1 Topology


TipA PortChannel should use interfaces on multiple line cards to protect the PortChannel against line card failure.

The same channel group number should be used on both ends of a PortChannel. Having the same number helps in troubleshooting and identifying the corresponding channel group on the other switch.

A PortChannel, like all other interfaces, can have a description. Use the description field to specify exactly where the PortChannel goes.

PortChannels can use any port on the switch and connect to any other port on a switch.

Set the initial VSAN allowed list prior to bringing up the PortChannel. This action prevents any VSANs from merging when you bring up the PortChannel the first time.


To create a PortChannel through the CLI, follow these steps:


Step 1 Create the PortChannel on switch 1.

switch1# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch1(config)# interface fc1/1, fc2/1
switch1(config-if)# channel-group 2
fc1/1 fc2/1 added to port-channel 2 and disabled
please do the same operation on the switch at the other end of the port-channel,
then do "no shutdown" at both ends to bring them up
switch1(config-if)# switchport description "To switch2 PortChannel2"

Step 2 Enable trunking (TE) and set the VSAN allowed list on switch 1.

switch1# config terminal
switch1(config)# int port-channel 2
switch1(config-if)# switchport trunk mode on
switch1(config-if)# switchport trunk allowed vsan 1
switch1(config-if)# switchport trunk allowed vsan add 10

Step 3 Create the PortChannel and set the description on switch 2.

switch2# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch2(config)# interface fc1/1, fc2/1
switch2(config-if)# channel-group 2
fc1/1 fc2/1 added to port-channel 2 and disabled
please do the same operation on the switch at the other end of the port-channel,
then do "no shutdown" at both ends to bring them up
switch2(config-if)# switchport description "To switch1 PortChannel2"

Step 4 Enable trunking (TE) and set the VSAN allowed list on switch 2.

switch2# config terminal
switch2(config)# int port-channel 2
switch2(config-if)# switchport trunk mode on
switch2(config-if)# switchport trunk allowed vsan 1
switch2(config-if)# switchport trunk allowed vsan add 10

Step 5 Enable the interfaces to bring up the PortChannel.

a. Switch 1

switch1# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch1(config)# interface fc1/1, fc2/1
switch1(config-if)# no shut

b. Switch 2

switch2# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch2(config)# interface fc1/1, fc2/1
switch2(config-if)# no shut

Step 6 Verify that the PortChannel came up.

switch1# show interface port-channel 2
port-channel 2 is trunking
    Port description is To switch2 PortChannel2
    Hardware is Fibre Channel
    Port WWN is 24:02:00:0c:85:e9:d2:c0
    Admin port mode is E, trunk mode is on
    Port mode is TE
    Port vsan is 1
    Speed is 4 Gbps
    Trunk vsans (admin allowed and active) (1,10)
    Trunk vsans (up)                       (1,10)
    Trunk vsans (isolated)                 ()
    Trunk vsans (initializing)             ()
    5 minutes input rate 64 bits/sec, 8 bytes/sec, 0 frames/sec
    5 minutes output rate 56 bits/sec, 7 bytes/sec, 0 frames/sec
      78296342 frames input, 72311141128 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      56299070 frames output, 26061293700 bytes
        0 discards, 0 errors
      0 input OLS, 2 LRR, 0 NOS, 0 loop inits
      4 output OLS, 2 LRR, 0 NOS, 0 loop inits
    Member[1] : fc1/1
    Member[2] : fc2/1
    iSCSI authentication: None


Adding a New Member to a PortChannel

This procedure uses the following resources:

Switch 1:

Channel Group 2

Existing Interfaces: fc1/1 and fc2/1

New Interfaces: fc3/1

Switch 2:

Channel Group 2

Existing Interfaces: fc1/1 and fc2/1

New Interface: fc3/1

To add a member to an existing PortChannel, follow these steps:


Step 1 To add the new member to switch 1, use the force keyword to have the new link inherit the parameters of the existing link.

switch1# conf t
switch1(config)# int fc3/1
switch1(config-if)# channel-group 2 force
fc3/1 added to port-channel 2 and disabled
please do the same operation on the switch at the other end of the port-channel,
then do "no shutdown" at both ends to bring them up
switch1(config-if)# no shut

Step 2 To add the new member to switch 2, use the force keyword to have the new link inherit the parameters of the existing link.

switch2# conf t
switch2(config)# int fc3/1
switch2(config-if)# channel-group 2 force
fc3/1 added to port-channel 2 and disabled
please do the same operation on the switch at the other end of the port-channel,
then do "no shutdown" at both ends to bring them up
switch3(config-if)# no shut

Step 3 Verify that the PortChannel now has all three members.

switch1# show interface port-channel 2
port-channel 2 is trunking
    Port description is To switch2 PortChannel2
    Hardware is Fibre Channel
    Port WWN is 24:02:00:0c:85:e9:d2:c0
    Admin port mode is E, trunk mode is on
    Port mode is TE
    Port vsan is 1
    Speed is 6 Gbps
    Trunk vsans (admin allowed and active) (1,10)
    Trunk vsans (up)                       (1,10)
    Trunk vsans (isolated)                 ()
    Trunk vsans (initializing)             ()
    5 minutes input rate 64 bits/sec, 8 bytes/sec, 0 frames/sec
    5 minutes output rate 56 bits/sec, 7 bytes/sec, 0 frames/sec
      78296342 frames input, 72311141128 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      56299070 frames output, 26061293700 bytes
        0 discards, 0 errors
      0 input OLS, 2 LRR, 0 NOS, 0 loop inits
      4 output OLS, 2 LRR, 0 NOS, 0 loop inits
    Member[1] : fc1/1
    Member[2] : fc2/1
    Member[3] : fc3/1
    iSCSI authentication: None


Removing a Member from a PortChannel

This procedure shows how to remove a member from a PortChannel.


Tip Using the quiesce command allows seamless reduction in the PortChannel, with no dropping of in-flight frames.


This procedure uses the following resources:

Switch 1:

Channel Group 2

Existing Interfaces: fc1/1, fc2/1, fc3/1

Remove Interface: fc3/1

Switch 2:

Channel Group 2

Existing Interfaces: fc1/1, fc2/1, fc3/1

Remove Interface: fc3/1

To remove a member of a PortChannel, follow these steps:


Step 1 On switch 1, quiesce the interfaces to be removed.

switch1# quiesce interface fc3/1
WARNING: this command will stop forwarding frames to the specified interfaces. I
t is intended to be used to gracefully shutdown interfaces in a port-channel. The
procedure is:
1. quiesce the interfaces on both switches.
2. shutdown the interfaces administratively.
Do you want to continue? (y/n)  [n] y
fc3/1: quiesced
Please quiesce the corresponding interfaces on the other switch and then shut down
them administratively.

Step 2 On switch 2, quiesce the interfaces to be removed.

switch2# quiesce interface fc3/1
WARNING: this command will stop forwarding frames to the specified interfaces. I
t is intended to be used to gracefully shutdown interfaces in a port-channel. The
procedure is:
1. quiesce the interfaces on both switches.
2. shutdown the interfaces administratively.
Do you want to continue? (y/n)  [n] y
fc3/1: quiesced
Please quiesce the corresponding interfaces on the other switch and then shut down
them administratively.

Step 3 Shut the physical interfaces on both switches.

a. On Switch 1:

switch1# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch1(config)# int fc3/1
switch1(config-if)# shut

b. On Switch 2:

switch2# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
switch2(config)# int fc3/1
switch2(config-if)# shut


Modifying the VSAN Allowed List

Modifying the VSAN allowed list for a PortChannel is the same as modifying it for a standard, single link TE port.

To add VSAN 17 to PortChannel 2, enter these commands:

switch2# config terminal
switch2(config)# int port-channel 2

switch2(config-if)# switchport trunk allowed vsan add 17

To remove VSAN 17 from PortChannel 2, enter these commands:

switch2# config terminal
switch2(config)# int port-channel 2
switch2(config-if)# no switchport trunk allowed vsan add 17