Cisco MDS 9000 Family Cookbook, Release 1.x
Physical Interfaces

Table Of Contents

Physical Interfaces

Configuring Fibre Channel Ports

Port Description

Port Speed

Port Mode (auto)

Port Mode (E)

Port Mode (F)

Port Mode (FL)

Port Mode (Fx)

Port Mode (SD)

Port Mode (ST)

Port Mode (TL)

Configuring Trunking E ports

Setting the Trunk Port Mode

Configuring Trunk Ports to Filter Specific VSANs

Enabling Port Beaconing

Configuring Gigabit Ethernet Ports

Configuring VRRP


Physical Interfaces


This chapter describes options you can use to configure Fibre Channel (FC) and Gigabit Ethernet ports on an MDS multi-protocol switch. It includes the following sections:

Configuring Fibre Channel Ports

Configuring Gigabit Ethernet Ports

Configuring Fibre Channel Ports

The recipes in this section show how to configure various parameters and modes for a physical port on a Cisco MDS 9000 switch.

Port Description

The port description allows you to provide a plain text name as a description for the interface. In the following example, the Fibre Channel interface fc 1/1 is given the description "storage array 17 port 1," which then becomes the port name on the switch.

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport description "storage array 17 port 1"
switch(config-if)# end
switch#

Port Speed

This example shows how to the set the port speed for fc 1/1 to 1 GB, 2 Gb or auto-negotiate speed.


Note A port can be set to one speed. The default is auto-negotiate.


switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport speed 1000 <- port speed set to 1 GB
switch(config-if)# switchport speed 2000 <- port speed set to 2 GB
switch(config-if)# switchport speed auto <- port speed set to auto negotiate
switch(config-if)# ^Z
switch#

Port Mode (auto)


Note A Fibre Channel port can be set to one port mode at any given time. The default is auto on the 16-port line cards and FX on the 32-port line cards.


Setting the port mode to auto allows the port to negotiate to either an F, FL, or E port. It cannot negotiate to either ST, SD, or TL port modes. Auto port setting is the default setting for all ports on a 16-port line card. The following example shows how to set the port fc 1/1 to auto port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode auto
switch(config-if)# end
switch#

Port Mode (E)

Setting the port mode to E restricts the port to coming up as an E port (either trunking or non-trunking, depending on the trunking port mode). E port mode is used when the port functions as one end of an Inter-Switch Link (ISL). The following example shows how to set the port fc 1/1 to E port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode E
switch(config-if)# end

Port Mode (F)

Setting the port mode to F restricts the port to coming up as an F port. F port mode is used for end devices which can only communicate in point-to-point mode or to a switch. The following example shows how to set the port fc 1/1 to F port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode F 
switch(config-if)# end
switch#

Port Mode (FL)

Setting the port mode to FL restricts the port to coming up as an FL port. FL port mode is used for end devices which can only communicate as a public loop device. The following example shows how to set the port fc 1/1 to FL port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode FL 
switch(config-if)# end
switch#

Port Mode (Fx)

Setting the port mode to Fx restricts the port to coming up as an F or FL port. Fx port mode is used exclusively for end devices and prevents a port from autonegotiating to an E port. The following example shows how to set the port fc 1/1 to Fx port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode Fx 
switch(config-if)# end
switch#

Port Mode (SD)

Setting the port mode to SD configures the port for usage with a span session as the span destination (SD) port. This setting is used in conjunction with the PAA to span a port and obtain Fibre Channel traces without a Fibre Channel analyzer. The following example shows how to set the port fc 1/1 to SD port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode SD 
switch(config-if)# end

Port Mode (ST)

Setting the port mode to ST configures the port for usage with a remote span session as the span tunnel (ST) port. This setting is used to set up a remote SPAN session to a remote switch in which a PAA or protocol analyzer is connected. The following example shows how to set the port fc 1/1 to ST port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode ST 
switch(config-if)# end
switch#

Port Mode (TL)

Setting the port mode to TL restricts the port to coming up as a TL port. TL port mode is used exclusively for end devices which can only communicate as a private loop device. The following example shows how to set the port fc 1/1 to TL port mode:

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport mode TL 
switch(config-if)# end
switch#

Configuring Trunking E ports

A trunking port carries VSAN enabled frames between switches. The section below shows the various configuration options for a trunking port.


Note These same principles apply to PortChannels. Just specify the PortChannel interface, int port-channel 1, rather than an individual link, interface fc 1/1.


Setting the Trunk Port Mode

This example shows how to the set the trunk port mode for fc 1/1 to auto, on and off. The default mode is auto. One end of an ISL should be set to on when connected between two MDS switches, while the other end can be either on or auto. The trunk port mode needs to be off when the ISL is talking to non-MDS switches.

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport trunk mode auto <- auto negotiates trunk port mode
switch(config-if)# switchport trunk mode on   <- sets trunk port mode to on
switch(config-if)# switchport trunk mode off  <- sets trunk port mode to off
switch(config-if)# ^Z
switch#

Configuring Trunk Ports to Filter Specific VSANs

This example shows how to configure the allowed VSAN traffic through the interface fc 1/1. The all keyword allows all VSAN traffic to go through the port. The add 2 keyword adds VSAN 2 to the list of allowed VSANs through the port. The add 2-4 keyword adds VSANs 2 to 4 to the list of allowed VSANs through the port. The default mode is to allow all the VSAN traffic to pass through the port.

switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport trunk allowed vsan all     <- all VSAN traffic
switch(config-if)# switchport trunk allowed vsan add 2   <- only VSAN 2 traffic
switch(config-if)# switchport trunk allowed vsan add 2-4 <- VSAN 2 to 4 traffic
switch(config-if)# ^Z
switch#

Enabling Port Beaconing

This example shows how to enable the LEDs below the port fc 1/1 to start flashing. The flashing is useful in identifying a port for physical cabling or troubleshooting.


switch# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
switch(config)# interface fc 1/1
switch(config-if)# switchport beacon
switch(config-if)# end

Configuring Gigabit Ethernet Ports

Configuring VRRP

Virtual Router Redundancy Protocol (VRRP) allows two Gigabit Ethernet interfaces to provide failover capability for an IP address. The two interfaces will form an active/passive or master/backup state in which one interface will service requests for the shared IP address while the other will remain in a backup or standby state. VRRP is ideal for providing port level redundancy in iSCSI configurations. A Gigabit Ethernet port can still have its own IP address while partaking in a VRRP configuration.

A VRRP session has an ID assigned to it. Using this ID, the two interfaces will communicate to identify its peer. The same ID must be used on both switches. The procedure for having both members of the VRRP pair on the same switch would be the same as if the two members were on different switches.


Note To have one interface become the master interface whenever it is online, which is known as preemption, set the Gigabit Ethernet interface to have the same IP address as the VRRP IP address.


In this example, the configuration is as follows:

VRRP ID: 1

VRRP IP address: 192.168.1.40

Switch 1:

Interface gige3/3 (192.168.1.20)

Switch 2:

Interface gige4/1 (192.168.1.30)

To configure VRRP, follow these steps:


Step 1 Configure the IP address on the two Gigabit Ethernet interfaces.

Switch1# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)# interface gigabitethernet 3/3
Switch1(config-if)# ip address 192.168.1.20 255.255.255.0
Switch1(config-if)# no shut

Switch2# config terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch2(config)# interface gigabitethernet 4/1
Switch2(config-if)# ip address 192.168.1.30 255.255.255.0
Switch2(config-if)# no shut

At this point, it is a good idea to verify that a host on the local subnet can ping both IP addresses (192.168.1.20 and 192.168.1.30). Alternatively, use the ips measure-rtt command to ping from one Gigabit Ethernet port to the other.

Switch1# ips measure-rtt 192.168.1.30 interface gigabitethernet 3/3
Round trip time is 172 micro seconds (0.17 milli seconds)

Step 2 Configure the VRRP session on both switches using the VRRP ID (1).

Switch1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch1(config)# interface gigabitethernet 3/3
Switch1(config-if)# vrrp 1
Switch1(config-if-vrrp)# address 192.168.1.40
Switch1(config-if-vrrp)# no shut
Switch1(config-if-vrrp)# end

Switch2# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Switch2(config)# interface gigabitethernet 4/1
Switch2(config-if)# vrrp 1
Switch2(config-if-vrrp)# address 192.168.1.40
Switch2(config-if-vrrp)# no shut
Switch2(config-if-vrrp)# end

Step 3 Verify that the VRRP session is up and which interface has become the master. Enter the following commands:

Switch2# show vrrp vr 1
                       Interface    VR     Status
-------------------------------------------------------
              GigabitEthernet3/3     1     backup

switch1# show vrrp vr 1 interface gig3/3 status
vr id 1 status
MAC address 00:00:5e:00:01:01
Operational state: master
Up time 8 sec

To view the configuration, enter the following command:

Switch1# show vrrp vr 1 interface gigabitethernet 3/3 configuration
vr id 1 configuration
admin state up
priority 100
associated ip: 192.168.1.40
no authentication
advertisement-interval 1
preempt no
protocol IP