テナント、VRF、およびブリッジ ドメインの作成
このトピックでは、新しいテナントの基本的なプロビジョニングにおける次の手順について説明します。
-
テナントを作成します
-
テナントをセキュリティ ドメインと関連付けます
-
テナントの VRF を作成します
-
テナント内のエンドポイント グループにブリッジ ドメインを作成します
手順
コマンドまたはアクション | 目的 | |
---|---|---|
ステップ 1 |
configure 例:
|
コンフィギュレーション モードに入ります。 |
ステップ 2 |
tenant tenant-name 例:
|
テナント (存在しない場合) を作成し、テナント コンフィギュレーション モードを開始します。 |
ステップ 3 |
security domain domain-name 例:
|
1 つ以上のセキュリティ ドメインとテナントを関連付けます。 |
ステップ 4 |
[no] vrf context vrf-name 例:
|
テナントのプライベート ネットワーク(VRF)を作成します。テナントには 1 つ以上の VRF を設定できます。 |
ステップ 5 |
[no] contract {provider | consumer } contract-name 例:
|
VRF 下ですべての EPG のコントラクトを提供または使用します。 |
ステップ 6 |
exit 例:
|
テナント コンフィギュレーション モードに戻ります。 |
ステップ 7 |
[no] bridge-domain bd-name 例:
|
テナント下でブリッジ ドメインを作成または削除します。ブリッジ ドメイン コンフィギュレーション モードを開始します。 |
ステップ 8 |
[no] vrf member vrf-name 例:
|
VRF にブリッジドメインを割り当てます。 |
ステップ 9 |
exit 例:
|
テナント コンフィギュレーション モードに戻ります。 |
ステップ 10 |
interface bridge-domain bd-name 例:
|
テナント インターフェイス コンフィギュレーション モードを開始して、ブリッジ ドメインにインターフェイスを適用します。 |
ステップ 11 |
[no] {ip |ipv6 } address アドレス/マスク長[scope {private |public }] [secondary ] 例:
|
ブリッジ ドメインのゲートウェイ IP アドレスを割り当てまたは削除し、IP アドレス モードを開始し、オプションの IP アドレス プロパティを設定します。 ゲートウェイ アドレスの範囲は、次のいずれかです。
The optional secondary keyword allows you to configure a secondary gateway address. |
例
次に、セキュリティ ドメインへの割り当て、コントラクトと VRF の作成、ブリッジ ドメインの作成を含むテナントの基本設定の例を示します。
apic1# configure
apic1(config)# tenant exampleCorp
apic1(config-tenant)# security domain exampleCorp_dom1
apic1(config-tenant)# vrf context exampleCorp_v1
apic1(config-tenant-vrf)# contract enforce
apic1(config-tenant-vrf)# contract provider web
apic1(config-tenant-vrf)# contract consumer db
apic1(config-tenant-vrf)# contract provider icmp
apic1(config-tenant-vrf)# contract consumer icmp
apic1(config-tenant-vrf)# exit
apic1(config-tenant)# bridge-domain exampleCorp_b1
apic1(config-tenant-bd)# vrf member exampleCorp_v1
apic1(config-tenant-bd)# exit
apic1(config-tenant)# interface bridge-domain exampleCorp_b1
apic1(config-tenant-interface)# ip address 172.1.1.1/24
apic1(config-tenant-interface)# ipv6 address 2001:1:1::1/64
apic1(config-tenant-interface)# exit
次に、リーフに特有の VRF 設定の例を示します。
apic1# configure
apic1(config)# leaf 101
apic1(config-leaf)# vrf context exampleCorp_v1 tenant exampleCorp
apic1(config-leaf-vrf)# ip route 1.2.3.4 5.6.7.8
次に、リーフ インターフェイスに特有の VRF 設定の例を示します。
apic1# configure
apic1(config)# leaf 101
apic1(config-leaf)# int eth 1/1
apic1(config-leaf-if)# vrf member exampleCorp_v1 tenant exampleCorp
次のタスク
アプリケーション プロファイルを追加し、アプリケーション エンドポイント グループ(EPG)を作成し、ブリッジ ドメインに EPG を関連付けます。