Cisco Crosswork Network Controller データシート

データ シート

ダウンロード オプション

  • PDF
    (815.6 KB)
    Adobe Reader を使ってさまざまなデバイスで表示
Updated: 2026 年 4 月 23 日

偏向のない言語

この製品のドキュメントセットは、偏向のない言語を使用するように配慮されています。このドキュメントセットでの偏向のない言語とは、年齢、障害、性別、人種的アイデンティティ、民族的アイデンティティ、性的指向、社会経済的地位、およびインターセクショナリティに基づく差別を意味しない言語として定義されています。製品ソフトウェアのユーザインターフェイスにハードコードされている言語、RFP のドキュメントに基づいて使用されている言語、または参照されているサードパーティ製品で使用されている言語によりドキュメントに例外が存在する場合があります。シスコのインクルーシブ ランゲージの取り組みの詳細は、こちらをご覧ください。

翻訳について

このドキュメントは、米国シスコ発行ドキュメントの参考和訳です。リンク情報につきましては、日本語版掲載時点で、英語版にアップデートがあり、リンク先のページが移動/変更されている場合がありますことをご了承ください。あくまでも参考和訳となりますので、正式な内容については米国サイトのドキュメントを参照ください。

ダウンロード オプション

  • PDF
    (815.6 KB)
    Adobe Reader を使ってさまざまなデバイスで表示
Updated: 2026 年 4 月 23 日
 

 

トランスポート SDN コントローラである Cisco Crosswork Network Controller(CNC)を使用すると、共通の GUI と API により、マルチベンダーネットワーク環境でのインテントベースのネットワークサービスのプロビジョニング、ヘルスモニタリング、最適化のプロセスを簡素化および自動化できます。Cisco CNC は、サービスライフサイクルとデバイス管理機能の両方を単一の統合ソリューションに統合することで、運用ワークフローを簡素化します。

製品の概要

ネットワークオペレータは、ネットワークトラフィックの急激な増加をサポートする一方で、ネットワーク運用を効率的に実行するというプレッシャーに対処するという課題に直面しています。オペレータは、ネットワークの統合と縮小、ソフトウェア定義型ネットワーキング(SDN)への移行、および日常業務の自動化により効率性と競争力を高めることで、管理の複雑さを軽減しています。サービスライフサイクル機能を自動化することは、収益化までの時間を短縮し、エンドユーザー体験を向上させ、運用の俊敏性を高めるのに役立つため、成功に不可欠です。

Cisco Crosswork Network Controller を使用すると、サービスをより迅速に展開することができ、ネットワークの輻輳問題を緩和しながらサービス提供を改善する、インテントベースのサービスヘルスモニタリングおよびネットワーク最適化が可能になります。Cisco Crosswork Network Controller は、複数の第 1 層サービスプロバイダーや企業のお客様が、シンプルなデバイスのターンアップから高度なライフサイクル全体のサービス管理まで、あらゆる作業を自動化できるように支援してきた経験に基づいて実現されました。サービスのオーケストレーションと実行、ネットワークの最適化、パス計算、サービスのヘルスモニタリング、要素管理を自動化するために不可欠な機能を提供します。基本的な目標は、サービスポリシーの意図と関連する SLA を維持することです。

統合ソリューションとして、Cisco Crosswork Network Controller は、高度なトラフィック エンジニアリング、セグメントルーティングパス計算要素(SR-PCE)、フレキシブルアルゴリズム、インテントベースのアシュアランスなど、業界をリードする複数の革新的な機能を共通の API と UI と組み合わせることで、単一のペインで可視性と制御を実現します。

Cisco Crosswork Network Controller を使用すると、次のような多くの成果がもたらされます。

●     サービスプロビジョニング(たとえば、関連付けられたセグメント ルーティング ポリシーを含む L2VPN、L3VPN サービス)。

●     明示的な目的(たとえば、帯域幅の制約、遅延の最小化など)のためのセグメントルーティング(SR)ポリシーのプロビジョニング。

●     実証的なデータプレーン検証とインフラストラクチャの正常性を組み合わせることで、L2VPN および L3VPN サービスの正常性をモニタリングおよびトラブルシュートし、サービスに正の影響を与える。
サービスの正常性ステータスの可視化は、インフラストラクチャアラームで強化できます。

●     リアルタイムのパフォーマンス情報を収集し、ネットワークを最適化して、関連のセグメントルーティングポリシーの意図に沿うようにする。

●     帯域幅最適化技術を使用して、輻輳時にネットワークを戦術的に最適化する。

●     Gain the most from migration to next-generation networks and technologies (for example, migration to SRv6 or Routed Optical Networks (RON), implementing multicast with SR Tree-SID, embracing 5G network slicing, etc).

Cisco Crosswork Network Controller には、次のようなさまざまな利点があります。

●     新しいサービス、基盤となるトランスポート、既存サービスの変更のプロビジョニングが迅速化する。

●     ネットワークリソースの最適な使用とともに、サービス提供とエンドユーザー体験が向上する。

●     サービスとデバイスのライフサイクル全体で機能を自動化することで、業務効率が向上する。

●     収益化までの時間を短縮し、OpEx の使用率を改善することで、収益性が向上し、コストが削減される。

SDN Transport Automation

図 1.   

SDN トランスポートの自動化

機能と利点

Cisco Crosswork Network Controller には、デバイスとサービスのライフサイクル管理全体で自動化のユースケースをサポートする包括的な機能セット(表 1)が含まれています。これらの機能はパッケージ(Essentials、Advantage、Premier、Add-on)で提供され、お客様のユースケースに合わせて効果的に使用できます。

表 1.                    CNC の主な特長と機能

機能

利点

一元管理

●  Crosswork Network Controller は、ネットワークトポロジ、サービスインベントリ、トランスポートポリシー、サービスの正常性、デバイスの正常性などの直感的なナビゲーションにより、サービスとデバイスのライフサイクル全体をリアルタイムで可視化し、共通の統合されたユーザー体験により幅広いユースケースをサポートします。

物理ネットワークトポロジの可視化

●  物理トポロジ、つまり、CDP/LLDP と 802.3ad LAG を含む L2 P2P 接続トポロジを可視化します

IP トポロジの自動検出

●  IETF 標準のボーダー ゲートウェイ プロトコル リンク ステート(BGP-LS )に基づく自動検出により、複数のベンダーの IP トポロジを自動的に検出します

要素管理

インベントリの可視化

●  シャーシ、ラインカード、プラガブル、ポートなど、詳細なインベントリを使用して、デバイスとインターフェイスの情報を強化します。
●  すべての FRU 部品番号とシリアル番号を可視化することで、インストールされているハードウェアを追跡します

障害の可視化

●  ネットワークトポロジとアシュアランスグラフのアラームオーバーレイで障害対応を迅速化します
●  すべての管理対象デバイスから収集されたアラームの統合ビューを使用して、ネットワークの正常性を追跡します

メトリックの可視化

●  デバイス、モジュール、ポート、環境パラメータなど、さまざまなインフラストラクチャ要素のコンテキストの正常性をモニタリングします
●  設定可能なマルチレベルのしきい値アラートでプロアクティブにモニタリングします

ソフトウェア イメージの管理

●  SMU を含むデバイスソフトウェアのオンデマンドアップグレードまたはスケジュー ルされたアップグレードを実行します
●  組み込みの標準チェックを備えたシームレスな UI/API を活用し、イメージのアップグレードを可能にします

ゼロタッチデバイスの導入準備

●  サポートされている XR デバイス用のクラシックモードとセキュアな RFC 8572 を使用して、大規模なネットワークデバイスの迅速なプロビジョニングと導入準備により、コストを削減します。And PnP for supported XE devices
●  Perform simplified device onboarding via Zero Touch profiles with day0 Image and day0 Configuration

設定のバックアップと復元

●  デバイス設定管理の簡素化: バックアップ、復元、ゴールデンコンフィギュレーション

アンダーレイ設定

●  テンプレートを使用したオンデマンドおよびスケジュール済みのデバイスレベルの設定
●  インターフェイス設定の可視化と変更

Fleet Upgrade

●  事前チェックと事後チェックを実行しながら、多数のデバイスを同時に簡単にアップグレードできます。XR および XE デバイス用のアウトオブボックス MOP が含まれている

インテントベースのプロビジョニングと可視化

サービス

●  サービスモデルで表現されたインテントに準拠した迅速な L2VPN および L3VPN サービスプロビジョニング
●  パッケージ化された L2VPN および L3VPN サービス定義の拡張とカスタマイズ

トランスポート(SR-MPLS、SRv6、RSVP-TE)

●  最適化目標(遅延/IGP/TE メトリック最小化)と制約(アフィニティ、分離パス、帯域幅など)を指定することによる、明示的な SLA を使用したサービス指向トランスポ ート ネットワーク ポリシーのプロビジョニング
●  PCC で開始された SRv6-TE ポリシーのプロビジョニング

SR 回線型

●  バックアップパスと保護パスを含む双方向の同一ルーティングパスの帯域幅を予約
●  セグメント ルーティング ネットワークを介したトランスポート回線のようなサービス(光回線、TDM 回線など)のサポートの有効化

SR ツリー SID

●  動的および静的 SR マルチキャストツリー SID の可視化
●  インテントベースの自動化されたワークフローで MVPN と静的 SR ツリー SID をプロビジョニング

クローズドループインテント最適化とダイナミック トラフィック エンジニアリング

クローズドループ最適化

●  Crosswork Network Controller は、 BGP-LS やパス計算要素通信プロトコル( PCEP )などのリアルタイムプロトコルを活用して、ネットワークトポロジの状態変化のクローズドループ トラッキングを可能にし、ネットワークの状態変化に迅速に対応してサービスインテントを維持します。 帯域幅と遅延の需要変動にリアルタイムで対応

トラフィック エンジニアリング ダッシュボード

●  ネットワーク全体の可視性により、最適なトラフィック エンジニアリングの決定を促進
●  LSP 使用率、パス変更イベント、および関連する詳細に関する履歴情報を取得

ローカル輻輳の緩和

●  戦術的な TE ポリシーを使用して、ローカライズされた方法でリンクの輻輳を効果的に処理します。
●  LCM 推奨ポリシーおよびアクションの自動展開のカスタマイズ
●  IGP ドメインごとに推奨事項をグループ化し、ネットワーク内の他のドメインに展開することなく、1 つのドメインに特定のアクションセットを展開します

SR フレキシブルアルゴリズム

●  特定のサービスニーズに応じた IGP 最短パス計算のカスタマイズを可能にする、フレキシブルアルゴリズムを利用したトラフィック エンジニアリングを強化
●  プレフィックス SID (SR-MPLS )、ロケータ(SRv6 )、およびフレキシブルアルゴリズムのアフィニティを検出して可視化

サービスのヘルスモニタリングと障害対応

●  サービスインテントを動的に関連付け、サービスベースでテレメトリと重要業績評価指標をキャプチャ。基盤となるリソースはサービスに動的に関連付けられ、個別にモニタリングされ、サービスの正常性を反映するようにデータが関連付けられます
●  エンドカスタマーの SLA を満たす能力を改善。平均特定時間(MTTI )または平均判明時間(MTTK )を短縮することで実現します
●  ヒューリスティック パッケージ内のナレッジにより、障害対応タスクを支援および自動化

トランスポートスライシングの自動化

●  自動化されたプロビジョニング、可視化、モニタリング、および最適化により、トランスポートスライスのライフサイクル管理を簡素化。
●  差別化されたサービス提供による新しい収益源の実現

ブラウンフィールド サービス サポート

●  Cisco Crosswork NSO で以前に開発された既存の L2VPN および L3VPN サービスモデルの導入準備
●  Crosswork Network Controller を使用して、ブラウンフィールドサービスをプロビジョニングおよび可視化

組み込み型ワークフローエンジン

●  包括的なプログラミング環境、すぐに使用できるアダプタ、およびライブラリ機能を提供することによって、カスタム ワークフローを作成する

ノースバウンド API

●  オープンでプログラム可能なフレームワークにより、ネットワークオペレータは API に基づいて独自のアプリケーションを開発し、既存のツールセットに統合することができます。
●  Cisco RON アーキテクチャをサポートする Crosswork Hierarchical Controller で事前テストされた API 統合

階層化されたサービスアーキテクチャ(LSA)のサポート

●  大規模で拡張性があるサービスプロビジョニング機能を実装するための設計アプローチとして LSA を利用

マルチベンダー

●  Crosswork Network Controller は、業界標準(BGP-LS 、SNMP 、gNMI 、PCEP 、セグメントルーティング、NETCONF/YANG )を活用したネットワークおよびサービスのプロビジョニング、データ収集、およびネットワーク制御を行う上でマルチベンダー対応となっています

拡張性と復元力

●  高可用性と拡張性を実現するマイクロサービスベースのアーキテクチャ基盤。
●  役割別の詳細なアクセス制御(デバイスまたはデバイスグループで定義)による、割り当てられた運用ドメインへのユーザーアクセス

地理的冗長性

●  アクティブロールとスタンバイロールを実装する並列クラスタ設計によりサポート

デュアルスタックのサポート

●  IPv4 プロトコルと IPv6 プロトコルの両方で実装されているネットワークを管理IPv4 および IPv6 を介したさまざまなシステム(NTP 、DNS 、Syslog など)およびデバイスとシームレスかつ同時に通信

高い拡張性

●  カスタム開発によるサービスおよびトランスポート ポリシー プロビジョニングの拡張性を実現する、事前構築済み関数パック

柔軟な展開選択肢

●  シングルノードとマルチノードのインストールによるシンプルな展開オプション。特定のお客様の展開ユースケースに対応する容易さと柔軟性を提供。

多様な消費と価格設定

●  1 、3 (デフォルト)、5 年のサブスクリプション ライセンス
●  消費モデルに合わせた価格設定

製品仕様

Cisco Crosswork Network Controller は、大規模な第 1 層サービスプロバイダーや企業のお客様が、シンプルなデバイスのターンアップからクローズドドメインの自動化、高度なライフサイクル全体のサービス管理まで、あらゆる作業を自動化できるように支援することで、実現しました。Cisco Crosswork Network Controller は、マルチベンダー準拠を可能にする業界標準に基づいて構築されています。Cisco Crosswork Network Controller には、ネットワークへのタッチポイントの 3 つの領域があります。

1.     プロビジョニング:モデルベースのプログラムインターフェイス(NETCONF/YANG)。これにより、単純なデバイスの起動や設定管理から、高度なライフサイクル全体のサービス管理まで制御することができます。

2.     データ収集:一般的なパフォーマンスデータ収集。gNMI(gRPC ネットワーク管理インターフェイス)、SNMP(簡易ネットワーク管理プロトコル)、MDT(モデル駆動型テレメトリ)、CLI(コマンドラインインターフェイス)などを使用してデータ収集を行います。

3.     ネットワーク制御:BGP-LS によるリアルタイムのネットワーク トポロジ ディスカバリ、および PCEP を使用したネットワーク最適化とトラフィック制御。

Cisco Crosswork Network Controller は、標準ベースのノースバウンド インターフェイスを提供し、外部エンティティ(たとえば OSS/BSS または上位レベルのオーケストレーション システム)との統合を可能にします。

表 2.                    標準プロトコルのサポート:SBI および NBI

トピック

プロトコルの詳細

デバイス、サービス、およびポリシーのプロビジョニング

NETCONF/YANG

リアルタイムのトポロジ検出

BGP-LS

ネットワークトラフィックの制御

PCEP

パスエンジニアリング

SR-TE、RSVP-TE、SRv6、SR FlexAlgo

ネットワークパフォーマンスのデータ収集

SNMP、gNMI/OpenConfig、MDT、CLI、Syslog

ノースバウンド API

RESTCONF、REST

サポートされるプロトコル

表 3.                    標準プロトコルのサポート:キープロトコル

プロトコル

タイトル

RFC 5440

パス計算要素(PCE)通信プロトコル(PCEP)

RFC 8231

ステートフル PCE 用パス計算要素通信プロトコル(PCEP)拡張機能

RFC 8281

ステートフル PCE モデルでの PCE 開始 LSP 設定のパス計算要素通信プロトコル(PCEP)拡張機能

RFC 3209

RSVP-TE: Extensions to RSVP for LSP Tunnels

RFC 3630

OSPF バージョン 2 へのトラフィック エンジニアリングの拡張

RFC 3784

IS-IS Extensions for Traffic Engineering(TE)

RFC 7752

リンクステートおよびトラフィック エンジニアリング(TE)のノースバウンド配信

draft-ietf-spring-sr-replication-segment

マルチポイントサービス提供のための SR レプリケーションセグメント

draft-ietf-pim-sr-p2mp-policy

セグメント ルーティング ポイントツーマルチポイント ポリシー

draft-ietf-pce-sr-p2mp-policy

p2mp sr ポリシー用のセグメント ルーティング ポイントツーマルチポイント ポリシーの PCEP 拡張

draft-ietf-bess-mvpn-evpn-sr-p2mp

セグメントルーティング P2MP および入力レプリケーションを使用したマルチ
キャストおよびイーサネット VPN

サポートされるすべての RFC と IETF ドラフトの詳細なリスト、およびその他の情報については、シスコのアカウント担当者にお問い合わせください。

導入

Cisco Crosswork Network Controller は、お客様のさまざまなユースケースに対応するための幅広い導入オプションを提供します。

●     On-Premise: Single node supported on VMWare vSphere and RHEL KVM

●     On-Premise: Multi node cluster supported on VMWare vSphere and RHEL KVM

●     クラウド:AWS/EC2 でサポートされるマルチノードクラスタ

これらの導入オプションの詳細については、シスコの営業担当者にお問い合わせください。また、対象となる
ユースケースに基づいて最適なオプションを決定してください。

システム要件

Cisco Crosswork Network Controller は、さまざまな規模の顧客ネットワーク向けに設計されています。こういった包括的な自動化アプローチを一元的に提供できるのは、シスコだけです。シスコのネットワークコント
ローラは、最も困難な現実世界の問題を対象とした、完全に統合されたソリューションを提供します。システム要件は、選択した機能パッケージと導入オプションによって異なります。ネットワーク規模に応じたシステム要件の詳細については、シスコの営業担当者にお問い合わせください。

発注情報

Cisco Crosswork Network Controller は、導入のユースケースに効果的に対応するモジュラパッケージを提供します。パッケージには、Essentials、Advantage として分類される機能と、オプションの Add-on コンポーネントが含まれています。Cisco Crosswork Network Controller の発注方法の詳細については、シスコのアカウント担当者にお問い合わせください。

保証情報

Cisco Crosswork Network Controller は、
https://www.cisco.com/c/en/us/products/warranties/warranty-doc-c99-740613.html の保証対象です。

シスコの環境維持への取り組み

シスコ製品、ソリューション、運用および拡張運用またはサプライチェーンに対する環境持続可用性ポリシーと取り組みに関する情報は、シスコの企業の社会的責任(CSR)レポートの「環境持続可用性」項を参照してください。

環境保全に関する主要なトピック(CSR レポートの「環境保全」セクションに記載)への参照リンクを次の表に示します。

持続性に関するトピック

参照先

製品の材料に関する法律および規制に関する情報

材料

製品、バッテリ、パッケージを含む電子廃棄物法規制に関する情報

WEEE 適合性

シスコでは、パッケージデータを情報共有目的でのみ提供しています。これらの情報は最新の法規制を反映していない可能性があります。シスコは、情報が完全、正確、または最新のものであることを表明、保証、または確約しません。これらの情報は予告なしに変更されることがあります。

導入サービスおよび最適化サービス

Cisco Solution Support により、シスコのネットワーク環境内の製品とプロバイダー全体で合理化されたサポートを体験できます。問題が発生した場合は、トリアージをスキップして、シスコにお問い合わせください。シスコの一次連絡窓口のエンジニアが 24 時間 365 日対応し、シスコおよびサードパーティのテクノロジーベンダーによるソフトウェアおよびハードウェアに対して、専門家による一元的なサポートを提供します。シスコが問題を解決するか、必要に応じて、シスコ内外のサポートチームと問題の調整を主導して、問題の解決にあたります。単一の製品に焦点を当てたサポートを使用する場合と比較して、複雑な問題の解決に要する時間を 44% 短縮[1]しました。また、IT ネットワーク インフラストラクチャ チームの効率が 49% 向上しました。計画外のダウンタイムによる生産性の低下が 51% 減少しました。イノベーションに費やすスタッフの時間が 2 倍以上に増加[2]しました。

ソリューションサポート

Cisco Solution Support により、Cisco Crosswork Network Controller のパフォーマンス、信頼性、および ROI を最大化します。主要な連絡窓口であるシスコのソリューションエキスパートチームは、24 時間 365 日体制で導入全体を一元的にサポートします。シスコ製品に問題がある場合、別のベンダーの製品に問題がある場合、または新しいソリューションに関するガイダンスや保証を確認したい場合など、お気軽にお問い合わせください。最初のお問い合わせから問題の解決まで、責任を持って対応いたします。

注:          問題がサードパーティベンダーのデバイスによるものであると特定された場合は、サードパーティベンダーにお問い合わせください。シスコは、お客様と連携して、トリアージ情報を第三者に提供します。

Solution Support により、スタッフの効率性を 32% 改善し、インシデント発生を 21% 抑え、3,700 万ドルのダウンタイムを削減し、企業の収益を平均で 350 万ドル増加させることができます。複雑な問題については、製品サポートよりも平均 43% 迅速に解決した実績があり、Cisco Crosswork Network Controller ソリュー
ション環境に適したテクニカルサービスとなっています。

Cisco Capital

目的達成に役立つ柔軟な支払いソリューション

Cisco Capital により、目標を達成するための適切なテクノロジーを簡単に取得し、ビジネス変革を実現し、競争力を維持できます。総所有コスト(TCO)の削減、資金の節約、成長の促進に役立ちます。シスコの柔軟な支払いソリューションは 100 か国以上で利用可能であり、ハードウェア、ソフトウェア、サービス、およびサードパーティ製の補完的な機器を、利用しやすい計画的な支払方法で購入できます。詳細はこちらをご覧ください。

詳細はこちら

For more information on Cisco's network automation portfolio for service providers,
please visit https://www.cisco.com/go/crosswork.

Cisco Crosswork Network Controller の詳細やデモのスケジュールについては、シスコの営業担当者にお問い合わせください。

文書の変更履歴

新規トピックまたは改訂されたトピック

説明

日付

CNC の主な特長と機能を更新

表 1

October 21, 2024

CNC の主な特長と機能を更新

表 1

2024 年 9 月 16 日

データシートバージョン 3 に更新

データシート

2021 年 11 月 2 日

データシートバージョン 2 に更新

データシート

2020 年 2 月 22 日

データシートバージョン 1 を作成(ドラフト)

データシート

2020 年 2 月 5 日

 



[1] 2020 年 7 月 300,000 件のサポートケースに関するシスコ社内調査

[2] 2021 IDC: The Business Value of Cisco Customer Experience Services; based on the experience of study participants using Solution Support

専門家からのおすすめ

Learn more