S Commands

self-isolation

To enable virtual port-channel (vPC) self-isolation for the specified vPC domain, use the self-isolation command. To disable vPC self-isolation, use the no form of the command.

self-isolation

no self-isolation

Syntax Description

This command has no arguments or keywords.

Command Default

vPC self-isolation is disabled.

Command Modes

vpc-domain command mode

Command History

Release

Modification

7.1(1)D1(0)

This command was introduced.

Usage Guidelines

Use the self-isolation command in vpc-domain command mode to enable the vPC self-isolation feature for the vPC domain.

The vPC self-isolation feature enables a vPC peer to self-isolate itself when a significant error is detected on the switch, thereby preventing the entire vPC complex being brought down.

This command does not require a license.

Examples

This example shows how to enable vPC self-isolation:

switch(config)# vpc domain 1
switch(config-vpc-domain)# self-isolation

session-down

To configure what action is taken on an interface when an Ethernet OAM session goes down, use the session-down command in Ethernet OAM action configuration mode or interface Ethernet OAM action configuration mode. To remove the configuration, use the no form of this command.

session-down {disable | efd | error-disable-interface | log}

nosession-down {disable | efd | error-disable-interface | log}

Syntax Description

disable

Performs no action on the interface when an Ethernet OAM session goes down.

efd

Puts the line protocol into the down state for an interface when an Ethernet OAM session goes down.

error-disable-interface

Puts the interface into the error-disable state when a n Ethernet OAM session goes down.

log

(Interface Ethernet OAM action configuration only) Creates a syslog entry when an Ethernet OAM session goes down. This action is available in Interface Ethernet OAM action configuration mode to override the profile setting and log the event for the interface when it occurs.

Command Default

The default action is to create a syslog entry.

Command Modes

Ethernet OAM action configuration (config-eoam-action)

Interface Ethernet OAM action configuration (config-if-eoam-action)

Command History

Release Modification
7.3(0)D1(1)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

The following example shows how to configure that no action is performed on the interface when an Ethernet OAM session goes down:

switch# configure terminal
switch(config)# ethernet oam profile Profile_1
switch(config-eoam)# action
switch(config-eoam-action)# session-down disable

The following example shows how to configure putting the interface into the line-protocol-down state when an Ethernet OAM session goes down:

switch# configure terminal
switch(config)# ethernet oam profile Profile_1
switch(config-eoam)# action
switch(config-eoam-action)# session-down efd

The following example shows how to configure that the interface is put into the error-disable state when an Ethernet OAM session goes down:

switch# configure terminal
switch(config)# ethernet oam profile Profile_1
switch(config-eoam)# action
switch(config-eoam-action)# session-down error-disable-interface

The following example shows how to configure that a syslog is created when an Ethernet OAM session goes down:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# ethernet oam
switch(config-if-eoam)# action
switch(config-if-eoam-action)# session-down log

session-up

To perform no action on an interface when an Ethernet OAM session is established, use the session-up disable command in Ethernet OAM action configuration mode or interface Ethernet OAM action configuration mode. To remove the configuration, use the no form of this command.

session-up {disable | log}

nosession-up {disable | log}

Syntax Description

disable

Performs no action on the interface when an Ethernet OAM session is established.

log

(Interface Ethernet OAM action configuration only) Creates a syslog entry when an Ethernet OAM session is established. This action is available in Interface Ethernet OAM action configuration mode to override the profile setting and log the event for the interface when it occurs.

Command Default

The default action is to create a syslog entry.

Command Modes

Ethernet OAM action configuration (config-eoam-action)

Interface Ethernet OAM action configuration (config-if-eoam-action)

Command History

Release Modification
7.3(0)D1(1)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

The following example shows how to configure that no action is performed on the interface when an Ethernet OAM session is established:

switch# configure terminal
switch(config)# ethernet oam profile Profile_1
switch(config-eoam)# action
switch(config-eoam-action)# session-up disable

The following example shows how to configure that a syslog is created when an Ethernet OAM session is established:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# ethernet oam
switch(config-if-eoam)# action
switch(config-if-eoam-action)# session-up log

shutdown

To bring the port administratively down, use the shutdown command. To bring the port administratively up, use the no shutdown command.

shutdown [force]

no shutdown [force]

Syntax Description

force

(Optional) Forces the interface state to change. When you shut down a management interface, a warning question is displayed regarding active Telnet sessions. You can bypass the question with the force option. The force option is also useful when you run an automated configuration playback.

The force option is only available for Ethernet interfaces or the management port.

Command Default

None

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

Use the shutdown command to bring the port administratively down. Use the no shutdown command to bring the port administratively up.

This command does not require a license.

Examples

This example shows how to bring the port administratively down:

switch(config-if)# shutdown 

This example shows how to bring the port administratively up:

switch(config-if)# no shutdown

shutdown lan

To shut down LAN VLANs on a shared Ethernet interface, use the shutdown lan command. To bring up the LAN VLAN on a shared Ethernet interface. use the no shutdown lan command.

shutdown lan

no shutdown lan

Syntax Description

This command has no keywords or arguments.

Command Default

Disabled

Command Modes

Interface configuration mode

Command History

Release

Modification

6.2(6)

This command was introduced.

Usage Guidelines

Use the shutdown lan command to enable you to shut down the LAN VLANs on a shared Ethernet interface.

The no form of this command brings up the LAN VLAN on a shared Ethernet interface.


Note

The shutdown lan command is supported on shared interfaces only.

The Link Layer Discovery Protocol (LLDP) must be enabled in the Ethernet VDC for shutdown LAN.

This command does not require a license.

Examples

This example shows how to shut down Ethernet traffic on the interface:

switch# configure terminal 
switch(config)# interface ethernet 3/1
switch(config-if)# shutdown lan

speed

To set the speed for Ethernet ports or management interfaces or set the port to autonegotiate its speed with other ports on the link, use the speed command.

speed {10 | 100 | 1000 | 10000 | auto [10 [100 [1000]]]}

Syntax Description

10

Sets the speed at 10 Mbps.

100

Sets the speed at 100 Mbps.

1000

Sets the speed at 1 Gbps.

10000

Sets the speed at 10 Gbps.

auto

Sets the interface to autonegotiation.

Command Default

None

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

Before you begin, make sure that the remote port has a speed setting that supports your changes for the local port. If you want to set the local port to use a specific speed, you must set the remote port for the same speed or set the local port to autonegotiate the speed.

The interface speed and duplex mode are interrelated, so you should configure both of their parameters at the same time.

The interface speed that you specify can affect the duplex mode used for an interface, so you should set the speed before setting the duplex mode. If you set the speed for autonegotiation, the duplex mode is automatically set to be autonegotiated. If you specify 10- or 100-Mbps speed, the port is automatically configured to use half-duplex mode, but you can specify full-duplex mode instead. If you specify a speed of 1000 Mbps (1 Gbps) or faster, full duplex is automatically used. For more details about configuring this command, see the Cisco NX-OS Interfaces Configuration Guide .

This command does not require a license.

Examples

This example shows how to set the speed of Ethernet port 1 on the 48-port 10/100/1000 module in slot 3 to 1000 Mbps and full-duplex mode:

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# speed 1000
switch(config-if)# duplex full

state enabled

To enable the specified port profile, use the state enabled command. To return to the default value, use the no form of this command.

state enabled

no state enabled

Syntax Description

This command has no keywords or arguments.

Command Default

Disabled

Command Modes

Port-profile configuration mode

Command History

Release

Modification

4.2(1)

This command was introduced.

Usage Guidelines

Use the state enabled command to enable the specified port profile. See the port-profile command for information about the port-profile feature.

To apply the port-profile configurations to the interfaces, you must enable the specific port profile. You can configure and inherit a port profile onto a range of interfaces prior to enabling the port profile; you would then enable that port profile for the configurations to take effect on the specified interfaces. The maximum number of interfaces that can inherit a single profile is 512.

If you inherit one or more port profiles onto an original port profile, only the last inherited port profile must be enabled; the system assumes that the underlying port profiles are enabled.

This command does not require a license.

Examples

This example shows how to enable the port-profile feature:

switch(config)# port-profile type ethernet test
switch(config-ppm)# state enabled

switchport

To set the interface as a Layer 2 switching port, use the switchport command. To return the interface to the default Layer 3 routed interface status and cause all Layer 2 configuration to be erased, use the no form of this command.

switchport

no switchport

Syntax Description

This command has no keywords or arguments.

Command Default

Interfaces are Layer 3 by default.

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the LAN interface as a Layer 2 interface before you can enter additional switchport commands with keywords. This action is required only if you have not entered the switchport command for the interface.

The default switchport mode is the access mode. Use the switchport mode command to do the following:

  • Set the interface to the Layer 2 access mode

  • Return the interface to the Layer 2 trunk mode

  • Use the interface with private VLANs

Enter the no switchport command to shut down the port and then reenable it. This action may generate messages on the device to which the port is connected.

When you use the no switchport command, all the Layer 2 configuration is deleted from that interface, and the interface has the default VLAN configuration.

The port goes down and reinitializes when you change the interface mode.

This command does not require a license.

Examples

This example shows how to cause a port interface to stop operating as a Cisco routed port and convert to a Layer 2 switched interface:

switch(config-if)# switchport

switchport access vlan

To set the access VLAN when the interface is in access mode, use the switchport access vlan command. To reset the access-mode VLAN to the appropriate default VLAN for the device, use the no form of this command.

switchport access vlan vlan-id

no switchport access vlan

Syntax Description

vlan-id

VLAN to set when the interface is in access mode; valid values are from 1 to 4094, except for the VLANs reserved for internal switch use.

Command Default

VLAN1

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the LAN interface as a Layer 2 interface before you can enter the switchport access vlan command. This action is required only if you have not entered the switchport command for the interface.

Enter the no switchport access vlan command to shut down the port and then reenable it. This action may generate messages on the device to which the port is connected.

Use the no form of the switchport access vlan com mand to reset the access-mode VLAN to the appropriate default VLAN for the device.

This command does not require a license.

Examples

This example shows how to cause a port interface that has already been configured as a switched interface to operate as an access port in VLAN 2 instead of the platform’s default VLAN in the interface-configuration mode:

switch(config-if)# switchport access vlan 2

switchport autostate exclude

To exclude an access port or trunk from the VLAN interface link-up calculation on the Cisco NX-OS device, use the switchport autostate exclude command. To revert to the default settings, use the no form of this command.

switchport autostate exclude

no switchport autostate exclude

Syntax Description

This command has no keywords or arguments.

Command Default

All ports are included in the VLAN interface link-up calculation.

Command Modes

Interface configuration

Command History

Release

Modification

5.0

This command was introduced.

Usage Guidelines

The switchport autostate exclude command marks the port to be excluded from the interface VLAN up calculation when there are multiple ports in the VLAN.

The show interface interface switchport command displays the autostate mode if the mode has been set. If the mode has not been set, the autostate mode is not displayed.

This command does not require a license.

Examples

This example shows how to exclude a port from the VLAN interface link-up calculation on the Cisco NX-OS device:

switch# configure terminal
switch(config)# interface ethernet 1/1
switch(config-if)# switchport
switch(config-if)# switchport autostate exclude

This example shows how to include all ports in the VLAN interface link-up calculation on the Cisco NX-OS device:

switch(config-if)# no switchport autostate exclude

switchport dot1q ethertype

To set the EtherType used for Q-in-Q encapsulation on an interface, use the switchport dot1q ethertype command. To reset the EtherType to its default value, Use the no form of this command.

switchport dot1q ethertype ethertype

no switchport dot1q ethertype [ethertype]

Syntax Description

ethertype

Value to set for the EtherType. The range is from 0x600 to 0xffff.

  • 0x8100 is the default EtherType for 802.1q frames

  • 0x88A8 is the EtherType for 802.1ad double tagged frames

  • 0x9100 is the EtherType for QinQ frames

Command Default

0x8100 is the default EtherType for 802.1q frames

Command Modes

Interface configuration mode

Command History

Release

Modification

5.0(2)

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the Ethernet interface as a Layer 2 interface before you can enter the switchport mode command. This action is required only if you have not entered the switchport command for the interface.

You must set the EtherType only on the egress trunk interface that carries double tagged frames (the trunk interface that connects the service providers). If you change the EtherType on one side of the trunk, you must set the same value on the other end of the trunk (symmetrical configuration).


Caution

The EtherType value you set affects all the tagged packets going out on the interface (not just Q-in-Q packets).


This command does not require a license.

Examples

This example shows how to create a 802.1Q tunnel on an interface:

switch(config-if)# switchport dot1q ethertype 0x9100 

switchport host

To configure a port that is not connected to any other devices as a Layer 2 access port with optimized packet forwarding, use the switchport host command. To disable a port that is not connected to any other devices as a Layer 2 access, use the no form of this command.

switchport host

no switchport host

Syntax Description

This command has no keywords or arguments.

Command Default

Interfaces are Layer 3 by default.

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the LAN interface as a Layer 2 interface before you can enter the switchport host command. This action is required only if you have not entered the switchport command for the interface.

Entering the switchport host command on an interface:

  • Makes the Layer 2 interface an access port.

  • Makes the Layer 2 interface an STP edge port, which decreases the time that it takes to start up packet forwarding.

  • Disables port channeling on this interface.

You should enter the switchport host command only on ports that are connected to a single host. When you use this command with an interface connected to other than a single host, the device returns an error message.

To optimize the port configuration, entering the switchport host command sets the switch port mode to access and disables channel grouping. Only an end station can accept this configuration.

This command toggles the port if it is in the UP state.

This command does not require a license.

Examples

This example shows how to optimize an access port configuration for a host connection:

switch(config-if)# switchport host

switchport mode

To set the Layer 2 interface type, use the switchport mode command. To return the interface to the Layer 2 access mode, use the no form of this command.

switchport mode {access | dot1q-tunnel | fabricpath | fex-fabric | private-vlan {host | promiscuous | trunk [promiscuous | secondary]} | trunk}

no switchport mode

Syntax Description

access

Specifies the interface as a nontrunking, nontagged single-VLAN Layer 2 interface. An access port carries traffic in one VLAN only.

dot1q-tunnel

Creates a 802.1Q tunnel on the interface.

fabricpath

Specifies the port mode as FabricPath.

fex-fabric

Sets the interface type to be an uplink port for a Fabric Extender.

private-vlan

Sets the port mode as a private-VLAN (PVLAN) host.

host

Sets the port mode as the PVLAN host.

promiscuous

(Optional) Sets the port mode as PVLAN promiscuous.

secondary

(Optional) Sets the port mode trunk as isolated.

trunk

Specifies the trunking VLAN interface in Layer 2. A trunk port can carry traffic in one or more VLANs (based on the trunk allowed VLAN list configuration) on the same physical link.

Command Default

access ports

Command Modes

Interface configuration mode

Command History

Release

Modification

5.2(1)

Added the dot1q-tunnel, fabricpath, fex-fabric, private-vlan, host, promiscuous, and secondary keywords.

4.0

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the LAN interface as a Layer 2 interface before you can enter the switchport mode command. This action is required only if you have not entered the switchport command for the interface.

If you enter access mode, the interface goes into nontrunking mode; if you enter trunk mode, the interface goes into trunking mode.

To correctly deliver the traffic on a trunk port with several VLANs, the switch uses the IEEE 802.1Q encapsulation, or tagging, method. If an access port receives a packet with an 802.1Q tag in the header, that port drops the packet without learning its MAC source address.


Note

A port can function as either an access port, a trunk port, or a private VLAN port; a port cannot function as all three simultaneously.

The port goes down and reinitializes when you change the interface mode.

This command does not require a license.

Examples

This example shows how to set the interface to trunking mode:

switch(config-if)# switchport mode trunk

switchport mode dot1q-tunnel

To creates an 802.1Q tunnel on an interface, use the switchport mode dot1q-tunnel command. To disable the 802.1Q tunnel on the interface, use the no form of this command.

switchport mode dot1q-tunnel

no switchport mode dot1q-tunnel

Syntax Description

This command has no arguments or keywords.

Command Default

No 802.1Q tunnel

Command Modes

Interface configuration mode

Command History

Release

Modification

5.0(2)

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the Ethernet interface as a Layer 2 interface before you can enter the switchport mode command. This action is required only if you have not entered the switchport command for the interface.

The port goes down and reinitializes (port flap) when the interface mode is changed. BPDU filtering is enabled and the Cisco Discovery Protocol (CDP) is disabled on tunnel interfaces.

This command does not require a license.

Examples

This example shows how to create a 802.1Q tunnel on an interface:

switch(config-if)# switchport mode dot1q-tunnel

switchport trunk allowed vlan

To set the list of allowed VLANs on the trunking interface, use the switchport trunk allowed vlan command. To allow all VLANs on the trunking interface, use the no form of this command.

switchport trunk allowed vlan {vlan-list | add vlan-list | all | except vlan-list | none | remove vlan-list}

no switchport trunk allowed vlan

Syntax Description

vlan-list

Allowed VLANs that transmit through this interface in tagged format when in trunking mode; the range of valid values is from 1 to 4094.

add

Adds the defined list of VLANs to those currently set instead of replacing the list.

all

Allows all appropriate VLANs to transmit through this interface in tagged format when in trunking mode.

except

Allows all VLANs to transmit through this interface in tagged format when in trunking mode except the specified values.

none

Blocks all VLANs transmitting through this interface in tagged format when in trunking mode.

remove

Removes the defined list of VLANs from those currently set instead of replacing the list.

Command Default

All VLANs

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the LAN interface as a Layer 2 interface before you can enter the switchport trunk allowed vlan command. This action is required only if you have not entered the switchport command for the interface.

You can enter the switchport trunk allowed vlan command on interfaces where the Switched Port Analyzer (SPAN) destination port is either a trunk or an access port.

If you remove VLAN 1 from a trunk, the trunk interface continues to send and receive management traffic in VLAN 1.


Note

The switchport trunk allowed vlan command is not supported on FEX fabric interfaces.

This command does not require a license.

Examples

This example shows how to add a series of consecutive VLANs to the list of allowed VLANs on a trunking port:

switch(config-if)# switchport trunk allowed vlan add 40-50

switchport trunk native vlan

To change the native VLAN ID when the interface is in trunking mode, use the switchport trunk native vlan command. To return the native VLAN ID to VLAN 1, use the no form of this command.

switchport trunk native vlan vlan-id

no switchport trunk native vlan

Syntax Description

vlan-id

Native VLAN for the trunk in 802.1Q trunking mode. The range is from 1 to 4094, except the internally reserved VLANs are 3968 to 4047 and 4094.

Command Default

VLAN1

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

You must enter the switchport command without any keywords to configure the LAN interface as a Layer 2 interface before you can enter the switchport trunk native vlan command. This action is required only if you have not entered the switchport command for the interface.

Changing the native VLAN on an access port or trunk port will flap the interface. This behavior is expected.


Note

See the vlandot1q tag native command for more information about configuring the native VLAN for 802,1Q trunk ports.

Use the no form of the native vlan command to res et the native mode VLAN to the default VLAN1 for the device.

This command does not require a license.

Examples

This example shows how to configure the native VLAN for an interface in trunk mode:

switch(config-if)# switchport trunk native vlan 5

switchport trunk native vlan tag

To enable native VLAN tagging on a trunk port, use the switchport trunk native vlan tag command. To remove native VLAN tagging on a trunk port, use the no form of this command.

switchport trunk native vlan tag [exclude control]

no switchport trunk native vlan tag [exclude control]

Syntax Description

exclude control

(Optional) Excludes untagged control packets on the native VLAN.

Command Default

Packets (both control and data) are untagged on the native VLAN.

Command Modes

Interface configuration mode

Command History

Release

Modification

6.2(10)

This command was introduced.

Usage Guidelines

The switchport trunk native vlan tag command is applicable only for trunk ports.

For trunk ports, the default behavior is that packets (both control and data) are untagged. The switchport trunk native vlan tag command allows you to tag or untag control and data packets of the native VLAN. The tagging states are:

  • switchport trunk native vlan tag —Both control and data packets of the native VLAN are tagged.

  • switchport trunk native vlan tag exclude control —Data packets are tagged and control packets are untagged.

  • no switchport trunk native vlan tag and no switchport trunk native vlan tag exclude control —Both control and data packets are untagged

When a port-level configuration is applied, the global configuration for native VLAN tagging will no longer take effect on that port. Port-level configurations take priority over global configurations.

This command does not require a license.

Examples

This example shows how to configure the native VLAN for an interface in trunk mode:

switch(config)# interface ethernet7/1
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk native vlan tag

symbol-period threshold

To configure the thresholds that trigger an Ethernet OAM symbol-period error event, use the symbol-period threshold command in Ethernet OAM link monitor configuration mode. To remove the configuration, use the no form of this command.

symbol-period threshold low threshold [high threshold]

no symbol-period threshold [low threshold [high threshold]]

Syntax Description

lowthreshold

Low threshold value, in symbols, that triggers a symbol-period error event. The range is 1 to 60000000.

highthreshold

(Optional) High threshold value, in symbols, that triggers a symbol-period error event. The range is 1 to 60000000. The high threshold value can be configured only in conjunction with the low threshold value.

Command Default

The default low threshold value is 1. There is no default high threshold value.

Command Modes

Ethernet OAM link monitor configuration (config-eoam-lm)

Interface Ethernet OAM link monitor configuration (config-if-eoam-lm)

Command History

Release Modification

7.3(0)D1(1)

This command was introduced.

Usage Guidelines

When the low threshold is passed, a symbol-period error event notification is generated and transmitted to the OAM peer. Additionally, any registered higher level OAM protocols, such as Connectivity Fault Management (CFM), are also notified. When the high threshold is passed, the configured high threshold action is performed in addition to the low threshold actions. The high threshold is optional and is configurable only in conjunction with the low threshold.

This command does not require a license.

Examples

The following example shows how to configure the symbol-period low and high thresholds that trigger a symbol-period error event:

switch(config)# ethernet oam profile Profile_1
switch(config-eoam)# link-monitor
switch(config-eoam-lm)# symbol-period threshold low 100 high 6000

symbol-period window

To configure the window size for an Ethernet OAM symbol-period error event, use the symbol-period window command in Ethernet OAM link monitor or interface Ethernet OAM link monitor configuration mode. To remove the configuration, use the no form of this command.

symbol-period window window

nosymbol-period window window

Syntax Description

window

Size of the window for symbol-period error in milliseconds. The range is 1000 to 60000.

Command Default

The default window size value is 1000.

Command Modes

Ethernet OAM link monitor configuration (config-eoam-lm)

Interface Ethernet OAM link monitor configuration (config-if-eoam-lm)

Command History

Release Modification

7.3(0)D1(1)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

The following example shows how to configure the window size for a symbol-period error.

switch(config)# ethernet oam profile Profile_1
switch(config-eoam)# link-monitor
switch(config-eoam-lm)# symbol-period window 60000

system-mac

To overwrite the MAC address that the device creates for the virtual port-channel (vPC) domain when you create a vPC domain, use the system-mac command. To return to the default vPC system MAC address, use the no form of this command.

system-mac mac-address

no system-mac

Syntax Description

mac-address

MAC address that you want for the vPC domain using the format xxxx.xxxx.xxxx.

Command Default

None

Command Default

vpc-domain command mode

Command History

Release

Modification

4.1(3)

This command was introduced.

Usage Guidelines

You must enable the vPC feature before you can create a vPC system MAC address.

Use the system-mac command to overwrite the MAC address created by the system once you create a vPC domain. By default, the system creates a MAC address for the vPC when you create a vPC domain based on the domain ID. Cisco reserved a range of MAC addresses from the IEEE for this purpose and these addresses are used to complete the last 10 bits of the vPC domain MAC address. The range of default MAC addresses is as follows:

  • Number of reserved MAC addresses—1024

  • Starting—002304eebe00

  • Ending—002304eec1ff

This command does not require a license.

Examples

This example shows how to create a vPC system MAC address:

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# system-mac 22cd.34ab.ca32

system-priority

To overwrite the system priority that the device creates for the virtual port-channel (vPC) domain when you create a vPC domain, use the system-priority command. To return to the default vPC system priority, use the no form of this command.

system-priority priority

no system-priority priority

Syntax Description

priority

System priority. The range is from 1 to 65535.

Command Default

32667

Command Modes

vpc-domain command mode

Command History

Release

Modification

4.1(3)

This command was introduced.

Usage Guidelines

You must enable the vPC feature before you can create a vPC system priority.


Note

We recommend that you manually configure the vPC system priority when you are running LACP to ensure that the vPC peer devices are the primary devices on LACP.

This command does not require a license.

Examples

This example shows how to create a vPC system priority:

switch# configure terminal
switch(config)# vpc domain 5
switch(config-vpc-domain)# system-priority 4000

system default interface congestion mode

To configure the default interface congestion mode, use the system default interface congestion mode command. To disable this feature, use the no form of this command.

system default interface congestion mode {core | edge}

no system default interface congestion mode {core | edge}

Syntax Description

core

Specifies the core port type.

edge

Specifies the edge port type.

Command Default

None

Command Modes

Global configuration mode

Command History

Release

Modification

6.1(1)

This command was introduced.

Usage Guidelines

None

Examples

This example shows how to configure the default interface congestion mode for the core port type:

switch# configure terminal
switch(config)# system default interface congestion mode core
switch(config)#

This example shows how to disable the default interface congestion mode for the edge port type:

switch# configure terminal
switch(config)# no system default interface congestion mode edge
switch(config)#

system default interface congestion timeout

To configure the default value for a congestion timeout, use the system default interface congestion timeout command. To disable this feature, use the no form of this command.


Note

Beginning from Cisco NX-OS Release 8.2(1), use the system timeout fcoe congestion-drop {milliseconds |default} mode {core | edge} command to configure congestion timeout for slow drain.


system default interface congestion timeout milliseconds mode {core | edge}

no system default interface congestion timeout milliseconds mode {core | edge}

Syntax Description

milliseconds

Number of milliseconds. The range is from 100 to 1000 milliseconds.

mode

Specifies the mode.

core

Specifies the core port type.

edge

Specifies the edge port type.

Command Default

500 milliseconds

Command Modes

Global configuration mode

Command History

Release

Modification

6.1(1)

This command was introduced.

Usage Guidelines

Setting a smaller timeout on the edge ports such as 100 or 200 milliseconds helps to reduce the congestion on the edge port by making the packets on that port timeout sooner when they see the pause condition.


Note

You should use the default configuration for core ports and a value that does not exceed 500 ms (100 to 200 ms preferable) for fabric edge ports.

Examples

This example shows how to configure the default value for a congestion timeout for the core type:

switch# configure terminal
switch(config)# system default interface congestion timeout 100 mode core
switch(config)#

This example shows how to disable the default value for a congestion timeout for the edge type:

switch# configure terminal
switch(config)# no system default interface congestion timeout 100 mode edge
switch(config)#

system default interface pause mode

To configure the default timeout value for a pause frame, use the system default interface pause mode command. To disable this feature, use the no form of this command.

system default interface pause mode {core | edge}

no system default interface pause mode {core | edge}

Syntax Description

core

Specifies the core port type.

edge

Specifies the edge port type.

Command Default

None

Command Modes

Global configuration mode

Command History

Release

Modification

6.1(1)

This command was introduced.

Usage Guidelines

None

Examples

This example shows how to configure the default timeout value for a pause frame for the core port type:

switch# configure terminal
switch(config)# system default interface pause mode core
switch(config)#

This example shows how to disable the timeout default value for a pause frame for the edge port type:

switch# configure terminal
switch(config)# no system default interface pause mode edge
switch(config)#

system default interface pause timeout

To configure the default timeout value for a pause frame, use the system default interface pause timeout command. To disable this feature, use the no form of this command.

system default interface pause timeout milliseconds mode {core | edge}

no system default interface pause timeout milliseconds mode {core | edge}

Syntax Description

milliseconds

Number of milliseconds. The range is from 100 to 500 milliseconds.

mode

Specifies the mode.

core

Specifies the port type.

edge

Specifies the edge port type.

Command Default

500 milliseconds

Command Modes

Global configuration mode

Command History

Release

Modification

6.1(1)

This command was introduced.

Usage Guidelines

When the port is in the PAUSE state for the configured period, pause frame timeout can be enabled on that port, which results in all frames that come to that port getting dropped in the egress. This action frees up the buffer space in the ISL link (which carries traffic for this port) and helps to reduce congestion on other unrelated flows, use the same link.

Examples

This example shows how to configure the timeout value pause frame for the core port type:

switch# config terminal
switch(config)# system default interface pause timeout 100 mode core
switch(config)#

This example shows how to disable the timeout value pause for the edge port type:

switch# config terminal
switch(config)# no system default interface pause timeout 100 mode edge
switch(config)#

system default link-fail laser-on

To prevent the laser from turning off when a link failure occurs, use the system default link-fail laser-on command. To return to the default setting, use the no form of this command.

system default link-fail laser-on

no system default link-fail laser-on

Command Default

See the Usage Guidelines section.

Command Modes

Global configuration mode

Command History

Release

Modification

6.2(12)

This command was introduced.

Usage Guidelines

When a link failure is detected, the default behavior is for the laser to turn off for a few microseconds. This command overrides the default behavior and prevents the laser from turning off when there is a link failure.


Note

Only F3 line cards support this feature.

Examples

This example shows how to prevent the laser from turning off when a link failure occurs:

switch# configure terminal
switch(config)# system default link-fail laser-on

This example shows how to return to the default behavior (where the laser turns off when a link failure occurs):

switch# configure terminal
switch(config)# no system default link-fail laser-on

system default switchport

To change the default interface mode for the system from Layer 3 routing to Layer 2 switching, use the system default switchport command. To return the system to Layer 3 routing default interface mode, use the no form of this command.

system default switchport [fabricpath | shutdown]

no system default switchport [fabricpath | shutdown]

Syntax Description

fabricpath

(Optional) Configures the default port mode as FabricPath.

shutdown

(Optional) Configures the administrative state as down.

Command Default

None

Command Modes

Global configuration mode

Command History

Release

Modification

5.2(1)

Added the fabricpath keyword.

4.0

This command was introduced.

Usage Guidelines

The system default switchport command makes all the interfaces Layer 2 access ports.

This command does not require a license.

Examples

This example shows how to configure the system so that all the interfaces are in Layer 2 access mode:

switch(config-if)#
 system default switchport

system jumbomtu

To configure the system jumbo maximum transmission unit (MTU) size for Layer 2 interfaces, use the system jumbomtu command.

system jumbomtu size

Syntax Description

size

Even number between 1500 and 9216.

Command Default

The system jumbo MTU default size is 9216 bytes and the interface default MTU is 1500 bytes.

Command Modes

Global configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

Use the system jumbomtu command to specify the MTU size for Layer 2 interfaces. The range is from 1500 to 9216.

The physical level uses an unchangeable bandwidth of 1 GB.

This command does not require a license.

Examples

This example shows how to configure the system jumbo MTU as 8000 bytes and how to change the MTU specification for an interface that was configured with the previous jumbo MTU size:

switch# configure terminal
switch(config)# system jumbomtu 8000
switch(config)# show running-config
switch(config)# interface ethernet 2/2
switch(config-if)# switchport
switch(config-if)# mtu 4608

system module-type

To control which type of modules are allowed in this chassis, use the system module-type command. To return to the default settings, use the no form of this command.

system module-type module-type

no system module-type module-type

Syntax Description

module-type

f1 — Enables f1 type modules in the chassis.

f2—Enables f2 type modules in the chassis.

m1—Enables m1 type modules in the chassis.

m1x1—Enables m1x1 type modules in the chassis.

m2x1—Enables m2x2 type modules in the chassis.

Command Default

None

Command Modes

Global configuration mode.

Command History

Release

Modification

6.1(3)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

This example shows how to control the type of modules that are allowed in this chassis:

switch# configure terminal
switch(config)# system module-type f1 m1xl f2 m2xl fc f2e
Modules of unsupported types will not be allowed to power on after this. Continue(y/n)? [yes]
switch(config)#