B Commands

bandwidth (interface)

To set the inherited and received bandwidth values for an interface, use the bandwidth command. To restore the default values, use the no form of this command.

bandwidth {kbps | inherit [kbps]}

no bandwidth {kbps | inherit [kbps]}

Syntax Description

kbps

Intended bandwidth, in kilobits per second. The range is from 1 to 10000000.

inherit

(Optional) Specifies the inherited bandwidth such as how a subinterface inherits the bandwidth of its main interface.

Command Default

1000000 kbps

Command Modes

Interface configuration mode

Command History

Release

Modification

4.0

This command was introduced.

Usage Guidelines

The bandwidth command sets an informational parameter to communicate only the current bandwidth to the higher-level protocols; you cannot adjust the actual bandwidth of an interface using this command.


Note

This is a routing parameter only. It does not affect the physical interface.

The bandwidth inherit command controls how a subinterface inherits the bandwidth of its main interface.

The no bandwidth inherit command enables all subinterfaces to inherit the default bandwidth of the main interface, regardless of the configured bandwidth. If a bandwidth is not configured on a subinterface, and you use the bandwidth inherit command, all subinterfaces inherit the current bandwidth of the main interface. If you configure a new bandwidth on the main interface, all subinterfaces use this new value.

If you do not configure a bandwidth on the subinterface and you configure the bandwidth inherit command on the main interface, the subinterfaces inherit the specified bandwidth.

In all cases, if an interface has an explicit bandwidth setting configured, that interface uses that setting, regardless of whether the bandwidth inheritance setting is in effect.

This command does not require a license.

Examples

This example shows how to configure all subinterfaces off this main interface to inherit the configured bandwidth:

switch(config-if)# bandwidth inherit 30000

bfd

To enable Bidirectional Forwarding Detection (BFD) for a protocol, use the bfd command. To disable BFD for a protocol, use the no form of this command.

bfd

no bfd

Syntax Description

This command has no arguments or keywords.

Command Default

BFD is not enabled on the protocol.

Command Modes


Router configuration mode Neighbor configuration mode

Command History

Release

Modification

5.0(2)

This command was introduced.

Usage Guidelines

There are two methods to configure protocols to use BFD for failure detection. To enable BFD for all neighbors or interfaces of a protocol, enter the bfd command in router configuration mode for the Enhanced Interior Gateway Routing Protocol (EIGRP), Open Shortest Path First (OSPFv2), Open Shortest Path First (OSPFv3) and Intermediate-System-to-Intermediate-System (IS-IS) or in neighbor configuration mode for the Border Gateway Protocol (BGP). If you do not want to enable BFD on all interfaces, see the interface-level BFD enable commands in the Related Commands section.

Examples

This example shows how to enable BFD for all EIGRP neighbors:


switch# configure terminal
switch(config)# router eigrp Test1
switch(config-router)# bfd 
         

This example shows how to enable BFD for all BGP neighbors:


switch# configure terminal
switch(config)# router bgp 1.1
switch(config-router)# neighbor 192.0.2.1 remote-as 1.0
switch(config-router-neighbor)# bfd
         

bfd authentication

To configure SHA-1 authentication for all Bidirectional Forwarding Detection (BFD) sessions on the interface, use the bfd authentication command. To remove the SHA-1 authentication configuration, use the no form of this command.

bfd [ipv4 | ipv6] authentication keyed-SHA1 key-id id hex-key key ascii-key

no bfd [ipv4 | ipv6] authentication keyed-SHA1 key-id id hex-key key ascii-key

Syntax Description

ipv4

(Optional) Enables BFD authentication for the IPv4 address.

ipv6

(Optional) Enables BFD authentication for the IPv6 IP address.

key-id

Specifies the key ID to use in BFD frames.

id

Key ID value. The range is from 1 to 255.

hex-key

HEX binary SHA1 secret. A hex-key can be any case-sensitive, alphanumeric string up to 40 characters.

key

Specifies the ASCII SHA1 secret.

ascii-key

SHA1 secret value. An ASCII key can be any case-sensitive, alphanumeric string up to 20 characters.

Command Default

None

Command Modes

Interface configuration mode (config-if)

Command History

Release

Modification

6.2(2)

Added ipv4, ipv6 keywords to the syntax description.

5.2(1)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

This example shows how to configure SHA-1 authentication for all BFD sessions on the interface:

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# bfd authentication keyed-SHA1 key-id 23 key cisco123
switch(config-if)#

This example shows how to disable SHA-1 authentication on the interface:

switch(config-if)# no bfd authentication keyed-SHA1 key-id 23 key cisco123
switch(config-if)#

bfd c-bit

To configure the control plane independent bit setting in outgoing BFD packets, use the bfdc-bit command. To remove the control plane independent bit setting configuration, use the no form of this command.

bfd c-bit

no bfd c-bit

Syntax Description

This command has no keywords or arguments.

Command Default

The control plane independent bit setting in outgoing BFD packets is enabled by default.

Command Modes

Global configuration mode (config)

Command History

Release Modification

8.(0)1

This command was introduced.

Usage Guidelines

Enable the BFD feature before using the bfd c-bit command.

Examples

This example shows how to configure the control plane independent bit setting in outgoing BFD packets:

switch# configure terminal
switch(config)# feature bfd
switch(config)# bfd c-bit
switch(config)#

This example shows how to disable the control plane independent bit setting in outgoing BFD packets:

switch(config)# no bfd c-bit
switch(config)#

bfd echo

To enable Bidirectional Forwarding Detection (BFD) echo mode, use the bfd echo command. To disable BFD echo mode, use the no form of this command.

bfd [ipv4 | ipv6] echo

no bfd [ipv4 | ipv6] echo

Syntax Description

ipv4

(Optional) Enables BFD echo mode for the IPv4 address.

ipv6

(Optional) Enables BFD echo mode for the IPv6 address.

Command Default

BFD echo mode is enabled by default.

Command Modes


Interface configuration mode (config-if)

Command History

Release

Modification

6.2(2)

Added ipv4 , ipv6 keywords to the syntax description.

5.0(2)

This command was introduced.

Usage Guidelines

When echo mode is enabled, the required minimum receive interval value is taken from the BFD slow-timer setting.


Note

Before using BFD echo mode, you must disable the IP packet verification check for identical IP source and destination addresses by entering the no hardware ip verify address identical command in the default virtual device context (VDC).

Note

Before using BFD echo mode, you must disable the sending of Internet Control Message Protocol (ICMP) redirect messages by entering the no ip redirects command.

Use the no bfd echo command to stop sending echo packets and signify that the device is unwilling to forward echo packets that are received from BFD neighbors. The RequiredMinEchoRx BFD session parameter is set to zero when echo mode is disabled.

This command does not require a license.

Examples

This example shows how to configure BFD echo mode:


switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# bfd ipv4 echo

This example shows that the BFD session neighbor is up and using BFD echo mode. The relevant command output is shown in bold in the output:


switch# show bfd neighbors details
OurAddr       NeighAddr      LD/RD  RH/RS    Holdown(mult)State    Int
172.16.1.2    172.16.1.1     1/6    Up       0    (3 )    Up       Fa0/1
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
Received MinRxInt: 1000000, Received Multiplier: 3
Holdown (hits): 3000(0), Hello (hits): 1000(337)
Rx Count: 341, Rx Interval (ms) min/max/avg: 1/1008/882 last: 364 ms ago
Tx Count: 339, Tx Interval (ms) min/max/avg: 1/1016/886 last: 632 ms ago
Registered protocols: EIGRP
Uptime: 00:05:00
Last packet: Version: 1            - Diagnostic: 0
             State bit: Up         - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 6          - Your Discr.: 1
             Min tx interval: 1000000    - Min rx interval: 1000000
             Min Echo interval: 50000

bfd interval

To configure the Bidirectional Forwarding Detection (BFD) session parameters, use the bfd interval command. To return to the default setting, use the no form of this command.

bfd [ipv4 | ipv6] interval mintx min_rx msec multiplier value

no bfd [ipv4 | ipv6] interval mintx min_rx msec multiplier value

Syntax Description

ipv4

(Optional) Configures BFD session parameters for the IPv4 address.

ipv6

(Optional) Configures BFD session parameters for the IPv6 address.

mintx

Rate at which BFD control packets are sent to BFD neighbors. The configurable range is from 50 to 999.

min_rx msec

Specifies the rate at which BFD control packets are expected to be received from BFD neighbors. The range is from 50 to 999.

multiplier value

Specifies the number of consecutive BFD control packets that must be missed from a BFD neighbor before BFD declares that the neighbor is unavailable and the BFD neighbor is informed of the failure. The range is from 1 to 50.

Command Default

BFD interval: 50 milliseconds

min_rx: 50 milliseconds

multiplier: 3

Command Modes

Global configuration mode

Interface configuration mode

Command History

Release

Modification

6.2(2)

Added ipv4, ipv6 keywords to the syntax description.

5.0(2)

This command was introduced.

Usage Guidelines

BFD session parameters configured at the interface level take precedence over the globally configured BFD session parameters.

This command does not require a license.

Examples

This example shows how to set the BFD session parameters for Ethernet interface 3/1:

switch# configure terminal
switch(config)# interface ethernet 3/1
switch(config-if)# bfd ipv6 interval 50 min_rx 20 multiplier 3

bfd multihop authentication

To configure SHA-1 authentication for all Bidirectional Forwarding Detection (BFD) multihop sessions for the BGP neighbor, use the bfd multihop authentication command. To remove the SHA-1 authentication configuration, use the no form of this command.

bfd multihop authentication keyed-SHA1 key-id id {hex-key | key ascii-key}

no bfd multihop authentication keyed-SHA1 key-id id {hex-key | key ascii-key}

Syntax Description

key-id

Specifies the key ID to use in BFD frames.

id

Key ID value. The range is from 1 to 255.

hex-key

HEX binary SHA1 secret. A hex-key can be any case-sensitive, alphanumeric string up to 40 characters.

key

Specifies the ASCII SHA1 secret.

ascii-key

SHA1 secret value. An ASCII key can be any case-sensitive, alphanumeric string up to 20 characters.

Command Default

None

Command Modes

Neighbor configuration mode (config-router-neighbor)

Command History

Release

Modification

8.1(1)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

This example shows how to configure BFD multihop session on BGP:

switch# configure terminal
switch(config)#router bgp 200
switch(config-if)# neighbor 10.1.1.2 remote-as 200
switch(config-router)# bfd
switch(config-router-neighbor)# bfd multihop interval 250 min_rx 250 multiplier 10
switch(config-router-neighbor)# bfd multihop authentication keyed-SHA1 keyid 20 key sha

bfd multihop hosting-linecard

To configure the hosting linecard for the Bidirectional Forwarding Detection (BFD) multihop sessions, use the bfd multihop hosting-linecard command.

bfd multihop hosting-linecard add module module-number

Syntax Description

module-number

Specifies the module number.

Command Default

None

Command Modes


Global configuration mode

Command History

Release

Modification

8.1(1)

This command was introduced.

Usage Guidelines

This command does not require a license.

Examples

This example shows how to add a hosting linecard for the BFD multihop sessions:


switch# configure terminal
switch(config)# bfd multihop hosting-linecard add module 10
switch(config)# end

bfd multihop interval

To configure the Bidirectional Forwarding Detection (BFD) multihop session parameters, use the bfd multihop interval command. To return to the default setting, use the no form of this command.

bfd mutlihop interval milliseconds min_rx milliseconds multiplier interval-multiplier

no bfd mutlihop interval milliseconds min_rx milliseconds multiplier interval-multiplier

Syntax Description

milliseconds

Rate at which BFD control packets are sent to BFD neighbors. The configurable range is from 250 to 999 milliseconds.

min_rx

Specifies the rate at which BFD control packets are expected to be received from BFD neighbors.

interval-multiplier

Specifies the number of consecutive BFD control packets that must be missed from a BFD neighbor before BFD declares that the neighbor is unavailable and the BFD neighbor is informed of the failure. The range is from 3 to 250.

Command Default

BFD interval: 250 milliseconds

min_rx: 250 milliseconds

multiplier: 3

Command Modes

Global configuration mode

Neighbor configuration mode

Command History

Release

Modification

8.1(1)

This command was introduced.

Usage Guidelines

The interval value configured for the BGP neighbor is used for the BFD multihop session. If the interval value is not configured for the BGP neighbor, the value configured by using the bfd multihop interval command is considered. If the interval values are not configured in any case, then the default values are used.

This command does not require a license.

Examples

This example shows how to set the BFD multihop session parameters:


switch# configure terminal
switch(config)# bfd multihop interval 250 min_rx 250 multiplier 10
switch(config)# end

This example shows how to set the BFD multihop session parameters for BFD neighbor:


switch# configure terminal
switch(config)# neighbor 10.1.1.2 remote-as 200
switch(config-router)# bfd
switch(config-router-neighbor)# bfd multihop interval 250 min_rx 250 multiplier 10

bfd optimize subinterfaces

To optimize subinterfaces on a physical interface for Bidirectional Forwarding Detection (BFD), use the bfd optimize subinterfaces command. To return to the default setting, use the no form of this command.

bfd optimize subinterfaces

no bfd optimize subinterfaces

Syntax Description

This command has no arguments or keywords.

Command Default

Disabled

Command Modes


Interface configuration mode

Command History

Release

Modification

5.0(2)

This command was introduced.

Usage Guidelines

You can optimize subinterfaces, because BFD creates sessions for all configured subinterfaces. BFD sets the subinterface with the lowest configured VLAN ID as the master subinterface and that subinterface uses the BFD session parameters of the parent interface. The remaining subinterfaces use the slow timer. If the master subinterface session detects an error, BFD marks all subinterfaces on that physical interface as down.

When the lowest configured VLAN has both an IPv4 and an IPv6 BFD session, there is no deterministic way to say which of the two sessions is always chosen as the master session.

This command does not require a license.

Examples

This example shows how to enable subinterface optimization:


switch(config)# interface Ethernet 1/1
switch(config-if)# bfd
 optimize subinterfaces

bfd per-link

To enable Bidirectional Forwarding Detection (BFD) for all links in a port channel, use the bfd per-link command. To disable BFD for a port channel, use the no form of this command.

bfd per-link

no bfd per-link

Syntax Description

This command has no arguments or keywords.

Command Default

BFD is not enabled on the port channel.

Command Modes


Port channel configuration mode

Command History

Release

Modification

5.0(2)

This command was introduced.

Usage Guidelines

Use the bfd per-link command to enable BFD on each link in a port channel. BFD creates a session for each link in the port channel and provides an aggregate result to client protocols. For example, if the BFD session for one link on a port channel is up, BFD informs client protocols such as Open Shortest Path First (OSPF) that the port channel is up. The BFD session parameters are negotiated between the BFD peers in a three-way handshake.

bfd Per-link is not allowed with echo mode, or when there are BFD sessions on the port-channel. The port-channel must be shutdown before configuring per-link.

This command does not require a license.

Examples

This example shows how to enable BFD for port channel 3:


switch# configure terminal
switch(config)# interface port-channel 3
switch(config)# shutdown
switch(config-if)# bfd per-link

This example shows how to configure the BFD session parameters for a port channel:


switch# configure terminal
switch(config)# interface port-channel 3
switch(config-if)# bfd interval 50 min_rx 50 multiplier 3 

bfd slow-timer

To configure the Bidirectional Forwarding Detection (BFD) slow timer value, use the bfd slow-timer command. To return to the default setting, use the no form of this command.

bfd [ipv4 | ipv6] slow-timer milliseconds

no [ipv4 | ipv6] bfd slow-timer milliseconds

Syntax Description

ipv4

Configures the slow timer in milliseconds, used in the echo function for the IPv4 address.

ipv6

Configures the slow timer in milliseconds, used in the echo function for the IPv6 address.

milliseconds

BFD slow timer value, in milliseconds. The range is from 1000 to 30000.

Command Default

The default BFD slow timer value is 2000 milliseconds.

Command Modes


Global configuration modeInterface configuration mode

Command History

Release

Modification

6.2(2)

Added ipv4, ipv6 keywords to the syntax description.

5.0(2)

This command was introduced.

Usage Guidelines

Use the bfd slow-timer command to configure how fast a BFD session comes up. This value also sets the RequiredMinRx (or min_rx) value when echo mode is enabled.

This command does not require a license.

Examples

This example shows that the BFD slow timer value is configured to 14,000 milliseconds for IPv6:


switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# bfd ipv6 slow-timer 14000
switch(config-if)#

This example shows that the BFD slow timer value of 14,000 milliseconds has been implemented. The values for the MinTxInt and MinRxInt correspond to the configured value for the BFD slow timer. The relevant command output is shown in bold.


switch# show bfd neighbors details
OurAddr       NeighAddr     LD/RD  RH/RS   Holdown(mult)  State     Int
172.16.10.1   172.16.10.2   1/1    Up      0    (3 )      Up        Et2/0
Session state is UP and using echo function with 50 ms interval.
Local Diag: 0, Demand mode: 0, Poll bit: 0
MinTxInt: 14000, MinRxInt: 14000
, Multiplier: 3
Received MinRxInt: 10000, Received Multiplier: 3
Holdown (hits): 3600(0), Hello (hits): 1200(418)
Rx Count: 422, Rx Interval (ms) min/max/avg: 1/1480/1087 last: 112 ms ago
Tx Count: 420, Tx Interval (ms) min/max/avg: 1/2088/1090 last: 872 ms ago
Registered protocols: OSPF
Uptime: 00:07:37
Last packet: Version: 1            - Diagnostic: 0
             State bit: Up         - Demand bit: 0
             Poll bit: 0           - Final bit: 0
             Multiplier: 3         - Length: 24
             My Discr.: 1          - Your Discr.: 1
             Min tx interval: 14000 - Min rx interval: 14000
             Min Echo interval: 4000