The show interface command displays interface configurations. If no arguments are provided, this command displays the information for all the configured interfaces in the switch.
You can also specify arguments (a range of interfaces or multiple, specified interfaces) to display interface information. You can specify a range of interfaces by entering a command with the following example format: interface fc2/1 - 4 , fc3/2 - 3
The following example shows how to display all interfaces:
switch# show interface
fc3/1 is up
...
fc3/3 is up
...
Ethernet1/3 is up
...
mgmt0 is up
...
vethernet1/1 is up
...
vfc 1 is up
The following example shows how to display multiple specified interfaces:
switch# show interface fc3/1 , fc3/3
fc3/1 is up
...
fc3/3 is up
...
The following example shows how to display a specific interface:
switch# show interface vfc 1
vfc 1 is up
...
The following example shows how to display interface descriptions:
switch# show interface description
-------------------------------------------------
Interface Description
-------------------------------------------------
fc3/1 test intest
Ethernet1/1 --
vfc 1 --
...
The following example shows how to display all interfaces in brief:
switch# show interface brief
The following example shows how to display interface counters:
switch# show interface counters
The following example shows how to display transceiver information for a specific interface:
switch# show interface fc3/1 transceiver
 Note |
The show interface transceiver command is only valid if the SFP is present.
|
The show running-configuration command displays the entire running configuration with information for all interfaces. The interfaces have multiple entries in the configuration files to ensure that the interface configuration commands execute in the correct order when the switch reloads. If you display the running configuration for a specific interface, all the configuration commands for that interface are grouped together.
The following example shows the interface display when showing the running configuration for all interfaces:
switch# show running configuration
...
interface fc3/5
switchport speed 2000
...
interface fc3/5
switchport mode E
...
interface fc3/5
channel-group 11 force
no shutdown
The following example shows the interface display when showing the running configuration for a specific interface:
switch# show running configuration fc3/5
interface fc3/5
switchport speed 2000
switchport mode E
channel-group 11 force
no shutdown