Introduction
This document describes how to clean up license assignments from CSSM portal when there is a mismatch in real assignment count from vManage.
Problem
You can encounter a licensing mismatch between the vManage instance and the Cisco Smart Software Manager (CSSM) portal. This can manifest as incorrect license counts, licenses not being released after device deletion.
Symptoms
- License counts in vManage and the CSSM portal show different values.
- Deleted devices in vManage do not release their assigned licenses in CSSM, leading to a shortage of available licenses.
- Duplicated license reports in CSSM (old and new reports summing up).
- Suspect hitting some of these bugs: Cisco bug ID CSCwj27435 or Cisco bug ID CSCwm39910
- Error messages in vManage admin-tech file var/log/nms/vmanage-server.log similar to:
[vmanage-0] [SmartLicensingManager || SmartLicense: Failed to report license usage for tenant default : Exception: {"product_instance_identifier":["The identity for the instance <instance_ID> is not valid.Please re-register the instance."]}
Example:
You can see in vManage that the number of licensed devices is 298 and total licenses is 300.

However, in the Licensing portal it showed that 598 licenses are in use. It is reporting a duplicate number of licenses usage (300+298 = 598), 300 licenses reported before unassigning 2 licenses and 298 licenses reported after unassigning the two licenses.

Root Cause
The primary cause identified was stale license entries within the vManage database and potentially incorrect Smart Agent Tenant Component information. This prevented accurate reporting and synchronization with the CSSM portal.
Solution
In order to reactivate vManage synchronization to CSSM portal, you need to open a TAC case to request help to perform workaround documented in the BUGs.
However, if there is only a problem with the mismatch in usage and available licenses in the CSSM portal, you can delete current licensing assignments and wait until vManage generates the new report.
Clean Up Balance from Cisco Central Portal (CSSM)
This step typically requires engagement with the Cisco Licensing team if you do not have the correct privilege to remove any duplicated or incorrect reports.
- In Cisco Software Portal navigate to Smart Software Manager > Manage licenses > Select your Smart and Virtual Account >Inventory > Licenses tab and click the license.

- Navigate to Product Instances and click the Instance.


- Then, remove the license usage.

- Now, you see the counter Licenses in Use 0 and all the licenses available.
Sync Licenses in vManage
After cleaning up the portal, initiate a license synchronization from vManage.
Wait at least 24 hours for vManage to sync again to CSSM portal.