Guest

Cisco Catalyst 2950 LRE Series Switches

Delivering Video on Demand over Long-Reach Ethernet

White Paper

Delivering Video on Demand
over Long-Reach Ethernet


Overview

Cisco Systems® developed Long-Reach Ethernet (LRE) technology to deliver Ethernet service over existing single-pair wires. Cisco® LRE technology dramatically extends Ethernet over existing Category 1-3 wiring at speeds from 5 to 15 Mbps (full duplex) and distances of up to 5000 feet (1524 meters). It delivers broadband service on the same lines as basic telephone service and ISDN traffic. The LRE downlink (from the LRE switch to the customer-premises equipment [CPE]) and uplink frequency ranges from 1 to 3.5 MHz and from 4 to 8 MHz, respectively. Table 1 summarizes the performance of the Cisco Catalyst® 2924 LRE XL Switch and the Cisco Catalyst 2950 LRE Series Switch.

Table 1   Performance of Cisco Catalyst 2924 LRE XL and Cisco Catalyst 2950 LRE Series Switches

Performance Cisco Catalyst 2924 LRE XL Cisco Catalyst 2950 LRE Series
Switching fabric

5 Gbps

8.8 Gbps

Forwarding bandwidth

4.2 Gbps

4.7 Gbps

Forwarding rate

3.0 Mpps

3.5 Mpps

MAC address

8192

8192

As Table 1 indicates, both LRE switches are capable of supporting voice, video, and data on a single box over existing telephone wire. The video delivery method over LRE can be unicast or multicast. Both switches also support Multicast VLAN Registration (MVR). This feature offers bandwidth optimization and can be used for video delivery over LRE in a ring network architecture.

This white paper examines a typical network setup for a unicast video-on-demand (VOD) solution over LRE, explains the configurations, and discuss some implementation issues.

Network Architecture for VOD

Figure 1 is a network diagram for a VOD solution. Each LRE switch can support up to 24 CPE devices. A typical solution will probably use either the Cisco Catalyst 2924 LRE XL Switch or the Cisco Catalyst 2950 LRE Series Switch. Both switches are shown in Figure 1 to highlight the uplink difference between the two.


Figure 1
Network Architecture for VOD over Cisco Catalyst 2924 LRE XL and Cisco Catalyst 2950 LRE Series Switches

Physical and Logical Architecture

Figure 1 shows the network setup for unicast video delivery over LRE. The network can be split into three distinct domains; room, intermediate distribution frame (IDF), and main distribution frame (MDF). The CPE, microfilters, set-top box, and TV are installed in the room. The LRE switch and the telephone splitter are installed in the IDF (large installation) or MDF (small installation). A Cisco Catalyst 3500 Series core switch, video server, application servers, and Cisco Building Broadband Service Manager (BBSM) are typically installed in the MDF. A Cisco BBSM is not required for a VOD solution over LRE. It is used when the solution calls for VOD and concurrent Internet access. In some VOD solutions, a boot or Dynamic Host Configuration Protocol (DHCP) server can also be used.

Microfilter and CPE

The CPE is directly connected to the phone jack in the room. No microfilter is required on the jack because the CPE already has a built-in microfilter for connecting a telephone. A low-pass microfilter should be installed on all other active jacks in the room to prevent line loading by the telephone at higher frequencies and to eliminate disturbance to telephone service by LRE transmission.

The Cisco 575 LRE CPE Device provides one RJ-45 port and two RJ-11 connectors for the LRE link and analog phone. The Cisco 585 LRE CPE Device provides four RJ-45 switched ports along with two RJ-11 connectors. The 4-port Cisco 585 LRE CPE should be used to deliver video and Internet access concurrently. The Cisco 575 LRE CPE, which has only one Ethernet port, cannot support video and Internet access at the same time. The Cisco 585 LRE CPE also supports 802.1p quality of service (QoS) and can prioritize voice or video over data traffic.

Telephone Splitter

A basic telephone service splitter is required for building deployments in which the private branch exchange (PBX) is onsite and basic telephone traffic must coexist with LRE traffic over the same line. The splitter is designed to block LRE frequencies from reaching the telco switch and to allow a subscriber's telephone to have a normal DC current path to the telco switch. The physical connections from the CPEs will terminate on the telephone splitter over the Category 3 wire, and the telephone splitter will direct the telephone traffic to the PBX and other traffic (data and video) to the LRE switch.

LRE Switch

The logical connection from the CPEs will terminate on the Cisco Catalyst 2900 Series LRE switch on interfaces
longReachEthernet 0/1 thru 0/24. These LRE interfaces need to be configured for proper virtual LAN (VLAN) assignments and other port-specific features, which are discussed later in detail. The connection between the Cisco Catalyst 2900 Series LRE and Cisco Catalyst 3500 Series core switch varies depending on the specific switch types. If the Cisco Catalyst 2924 LRE XL Switch is used, Fast Ethernet ports between the two switches can be bundled together as an EtherChannel® connection for greater bandwidth. If a Cisco Catalyst 2950 LRE Series Switch is used, an EtherChannel connection is not necessary because the uplink port on that switch can support Gigabit Ethernet.

Core Switch

A Cisco Catalyst 3500 Series XL Switch or a Cisco Catalyst 3550 Series Switch can be used as a core switch for delivering VOD. A Cisco Catalyst 4000 Series or 6000 Series switch is recommended for large installations. The specific switch type will depend on the following factors:

  • Physical connection to the LRE switch (number of links and bandwidth requirement)
  • Layer 2 or Layer 3 network architecture
  • Room density
  • Security and QoS requirements

The Cisco Catalyst 3500 Series XL Switch or the Cisco Catalyst 3550 Series Switch can be used for a flat Layer 2 network design. With the Cisco Catalyst 3550 Series or any Layer-3-capable switch, each LRE switch and server can reside on its own subnetwork (VLAN), and the Cisco Catalyst 3550 Series Switch will route between the subnetworks. The core switch examines incoming packets to distinguish between a video request and control traffic and between video traffic and Internet data traffic, and directs the traffic accordingly to a video server, set-top box, or Cisco BBSM.

Video Server and Application Server

The video, boot, and application servers all connect to the core switch using Fast Ethernet or Gigabit Ethernet link. These servers can have internal and external network connections depending on the design and vendor requirements.

The video server can use gigabit link or load balance between two Fast Ethernet links for greater bandwidth utilization. This will depend on the model of the core switch and the specific video server and its capabilities. The video sever is where all the movies are stored. It has to be configured properly according to the requirement of the property. Careful planning of the storage capacity, hard drives, memory, and power requirements of the video server is necessary. In general, the video server should be designed and configured for a 25 percent concurrent take rate.

The application server is used to create a vendor-specific user interface on the set-top box (the welcome page, the menu, and so on.). It also directs different requests to the video server.

Cisco BBSM

A Cisco BBSM is used for delivering Internet access. It is also used for billing, accounting, authentication, and port control. The Cisco BBSM uses two Network Interface Cards (NICs) for the external and internal sides of the network. Private IP addresses can be used on the internal side; address translation needs to occur on the outgoing router. As previously mentioned, Cisco BBSM is not required for VOD-only deployments.

Internet Router

Typically a Cisco 2600 Series Multiservice Platform with enough memory can be used for Internet connection and remote network management. Appropriate access control lists needs to be configured in the router to block unwanted traffic and unauthorized access.

Configuration Steps

The first configuration step is to configure the uplink ports of the Cisco Catalyst 2900 Series LRE connecting to the core switch. In case of the Cisco Catalyst 2924 LRE XL Switch, two to four Fast Ethernets can be grouped together to form an EtherChannel connection. Cisco Catalyst 2950 LRE Series Switch has gigabit uplink ports, and so an EtherChannel connection is not necessary. The second step is to configure the LRE ports connecting to each room. LRE ports are configured with specific VLANs, features for security, and QoS as required. Figure 2 shows the configuration commands for a Cisco Catalyst 2924 LRE XL Switch, a Cisco Catalyst 2950 LRE Series Switch, and a Cisco Catalyst 3550 Series Switch for a VOD application based on Figure 1. The command-line interface (CLI) is a little different on the Cisco Catalyst 2924 LRE XL Switch and the Cisco Catalyst 2950 LRE Series Switch. Full configurations of both switches are included in the appendix at the end of this document.


Figure 2
Configuration Commands
Cisco Catalyst 2924 LRE XL Switch Configuration:
interface FastEthernet0/1 - To 3550 Core switch, EtherChannel
 switchport access vlan 2
 port group 1
!
interface LongReachEthernet0/1
 Ire profile <>
 port block unicast
 port block multicast
 port protected
 switchport access vlan 2
 spanning-tree portfast
 spanning-tree rootguard
 
Cisco Catalyst 2950 LRE Series Switch Configuration:
interface GigabitEthernet0/1 - To 3550 Core switch, Trunk
!
interface LongReachEthernet0/1
 switchport access vlan 3
 switchport protected
 profile <>
 spanning-tree portfast
 spanning-tree rootguard
 
Cisco Catalyst 3550 Series Switch Configuration:
interface FastEthernet0/1 - 2924 LRE, EtherChannel
 port group 1 distribution destination
 switchport access vlan 2
!
interface FastEthernet0/5 - Video Server
 switchport access vlan 4
 spanning-tree portfast
!similar configs for fa0/7 connected to Application server
!
interface FastEthernet0/9 - BBSM Internal Int.
 switchport access vlan 5
 spanning-tree portfast
!
interface FastEthernet0/10 - BBSM External Int.
 switchport access vlan 6
 spanning-tree portfast
!similar config for fa0/11 connected to 2600 router
!
interface GigabitEthernet0/1 - connects to 2950 LRE, Trunk

Command Explanations

  • port group <>—This command creates a Fast EtherChannel connection between the LRE and the aggregation switch for high bandwidth connection. The interfaces that are members of this channel group act as a single logical port. The port group <> distribution destination command is configured only on the core switch to make sure that it performs load balancing on the EtherChannel based on the destination (specific set-top boxes). The default is source-based load balancing, which in this case will cause the video traffic to use only one of the Fast Ethernet ports.
  • lre profile <profile name> / profile <profile name>—This command configures a specific LRE profile to the interface. The default profile is LRE-10, which provides 10-Mbps symmetrical upstream and downstream bandwidth. Available LRE profiles can be viewed by issuing the command show controller LRE profile names. The profiles can be different for the LRE interfaces on the same switch.
  • port block unicast—By default, a switch floods packets with unknown destination MAC addresses to all ports. This command blocks unknown unicast flooding that results from link failures on other LRE ports. Without this feature LRE ports with lower profiles can get inundated with unknown flooded traffic, causing the video stream to freeze.
  • port block multicast—This command blocks unknown multicast forwarding to the port. These two commands are only available on the Cisco Catalyst 2924 LRE XL Switch. The Cisco Catalyst 2950 LRE Series Switch will support these in a future release.
  • port protected / switchport protected—In an LRE deployment at hotels, multitenant units, or multiple-dwelling units, no direct forwarding of traffic between the rooms or tenants should occur. This command disables the Layer 2 forwarding of traffic between the ports on an LRE switch. The forwarding can happen at a Layer 3 device where access control lists can be applied for security. Individual ports of the Cisco 585 LRE CPE Device can be configured for this feature by the cpe protected port <> command under the main LRE interface.
  • switchport access VLAN <>—This command assigns interfaces to specific VLANs. The port must be configured as an access port with the switchport mode access command before any VLAN assignment.
  • spanning-tree portfast—This Port Fast feature brings a port directly from a blocking state into a forwarding state. Without this feature, it will take 20 to 30 seconds for a port to come up, compared with 5 seconds or less with this feature enabled. A port with Port Fast enabled goes through the normal cycle of shielded twisted-pair (STP) status changes only when the switch is restarted.
  • spanning-tree rootguard—This feature blocks a switch or any other device outside the network to become the root switch. If a switch or other device outside the network becomes a root switch because of STP calculations, the interface is blocked (root-inconsistent state), and the STP selects a new root switch.

Optional Features

The following optional features can be applied with the VOD solution to make it more robust, dynamic, and secure. Some of these features are available only on the new Cisco Catalyst 2950 LRE Series Switch and the Cisco 585 LRE CPE Device.

  • RSTP and MSTP—IEEE 802.1w Rapid Spanning Tree Protocol (RSTP) and IEEE 802.1s Multiple Spanning Tree Protocol (MSTP) provide rapid convergence of spanning tree (less than 2 seconds, compared with 15-30 seconds with 802.1d) in case of link failure and Layer 2 load sharing on redundant links. Configuration of 802.1w and 802.1s is recommended for a Layer 2 network design. This feature is supported only on the Cisco Catalyst 2950 LRE Series Switch.
  • Access control list—An access control list can be applied on an individual LRE port to filter traffic based on Layer 2-4 classifications to prevent unauthorized data flows. In hotels, multitenant units, and multiple-dwelling units, this tool is useful in preventing unauthorized access between rooms.
  • Port Aggregation Protocol—This technology allows dynamic bandwidth aggregation between the switches and is available only on the Cisco Catalyst 2950 LRE Series Switch.
  • 802.1p—The Cisco 585 LRE CPE Device supports 802.1p QoS with priority queues. This feature can be used to prioritize voice and video traffic over data traffic.
  • Port security—This feature secures the access to a port based on the MAC address of a user's device. The MAC address is stored statically and removed only when the security aging timer expires. This can be useful in an environment in which set-top boxes don't send out periodic packets or keepalives to the video or application server.
  • Link persistence—The LRE link persistence feature allows configuration of delay duration before dynamic MAC addresses are removed from the MAC address table because of LRE link drops. This is useful in a noisy environment in which an LRE link flap causes MAC address deletion, which in turn causes video freeze.
  • 802.1x—This feature allows users to be authenticated before getting access to the network and is particularly useful in a wireless environment. This feature is supported only on the Cisco 575 LRE CPE Device.

Implementation Notes

LRE Profile Selection

Configuration of an LRE switch is straightforward; however, the configuration will vary based on different VOD systems' requirements. Special attention needs to be paid while configuring LRE profiles. Based on a typical digital movie encoding rate of 3.75 Mbps to 6 Mbps default, an LRE-10 profile will do. When any other profile is used in a room because of noise and poor line quality, that profile has to support both the downstream and upstream requirement of the VOD system. Selection of LRE profiles largely depends on the noise level and quality of the phone line. So the better the phone line the better the chances of running VOD over LRE smoothly. Some VOD systems might require low-latency LRE profiles for a faster booting process when the set-top box is powered up. Table 2 lists all the available LRE profiles for the VOD application. The LRE-5 profile is not recommended for a movie encoding rate of more than 4 Mbps. Concurrent Internet access and downloading of large files can affect the video quality in a room with a lower rate profile. The use of the 802.1p QoS feature can alleviate this problem by prioritizing video traffic over data.

Table 2   LRE Profiles for VOD

Profile Name Downstream Upstream Notes
LRE-15

15

15

LRE-15LL for low latency

LRE-15_5

15

5

 

LRE-15_3

15

3

 

LRE-10

10

10

LRE-10LL for low latency

LRE-10_5

10

5

 

LRE-10_3

10

3

 

LRE-8

8

8

 

LRE-7

7

7

 

LRE-5

5

5

LRE-5LL for low latency

Cisco 575 and 585 LRE CPE Devices

Important: Read the following usage notes regarding the Cisco LRE CPE devices:

  • The Cisco 585 LRE CPE should be used for concurrent VOD and Internet access. The Cisco 575 LRE CPE can be used for either VOD or Internet access but not both.
  • The four Ethernet ports of the Cisco 585 LRE CPE cannot be configured into separate VLANs.
  • The Cisco 575 and 585 LRE CPE devices are interchangeable without any software configuration changes on the LRE switches. However, the power supply of the Cisco 575 LRE CPE cannot be used with the Cisco 585 LRE CPE.
  • Both the Cisco 575 and 585 LRE CPE devices are unable to tag packets, but they will transport tagged packets transparently.

Microfilters

A low-pass microfilter must be installed on all the active phone jacks in the room except the one that connects to the CPE. Microfilters reduce the effects of bridge taps, which cause impedance mismatch and LRE signal attenuation. Fax machines and other basic telephone service devices connected to the phone jack require microfilters, too. Cisco recommends the use of Excelsus Z-Blocker In-Line filter.

Cisco BBSM

Cisco BBSM is designed for "plug and play" and runs a DHCP server. When a client sends an Address Resolution Protocol request for the IP address, Cisco BBSM will provide an IP address with its own address for the default gateway. If the set-top box uses DHCP, then the Cisco BBSM might respond before the designated DHCP server, preventing the set-top box from booting and directing traffic to the appropriate video or application server. The use of Bootstrap Protocol can resolve this issue because Cisco BBSM ignores Bootstrap Protocol requests.

STP Issues

Connecting or disconnecting any router or switch in a Layer 2 VOD network might trigger an STP topology change and cause the LRE switches to flush out the MAC address table. MAC address flushing causes the video stream to freeze. Special attention also needs to be paid when connecting any end device like a PC to an unused port of the core switch. The unused port needs to have the spanning-tree portfast command configured to guard against any STP change.

Appendix

Case Study: NXTV VOD Solution

This case study examines a VOD solution over LRE designed and deployed by NXTV, Inc. The $125 million Harrah's Rincon Hotel and Casino in San Diego, California opened in August 2002. Harrah's Rincon is a 200-room luxury resort offering 45,000 square feet of gaming space with more than 1500 slot machines, 30 gaming tables, and 6 restaurants. Managed by Harrah's Entertainment, Inc., Harrah's Rincon is now considered the premier hotel-casino in Southern California.

The entire hotel, including every guest room, is wired with telephone grade (Category 3) cable, which is aggregated at a single main distribution frame (MDF). A single cable pair is dedicated in each room for providing NXTV over LRE. Features delivered by NXTV at Harrah's Rincon include:

  • Digital video on demand with trick-play functionality such as pause, rewind, fast forward, and bookmark
  • High-speed Internet access on televisions and laptops, with multiple virtual private network (VPN) support
  • Television e-mail service
  • Video games
  • Hotel portal with cross-marketing and promotional capabilities

Another integral part of the system at Harrah's Rincon is NXTVue, a browser-based real-time system monitoring and backend management tool that provides a comprehensive "view" of the entire system. NXTVue features include real-time viewing of system buy rates, revenue information, sales analysis, room status, system status, and network status. NXTVue efficiently empowers the following capabilities: dynamically adjust product and pricing information, remotely manage and distribute content, centrally rollout system updates and enhancements.

NXTV has successfully installed its system at some of the most prestigious hotels in the world. Based on its success in the hospitality industry, NXTV has adapted its LRE solution to be deployed in health-care, financial, education, and distance-learning environments.

The NXTV VOD solution (Figure 3) at Harrah's Rincon is deployed on a dedicated Category 3 cable pair. The video and basic telephone service are delivered on different lines, so a telephone service splitter is not required. The solution also includes a boot server installed at the MDF. The server provides IP address assignment, gateway information, and other set-top-box-specific services. The NXTVue system is used for billing and accounting instead of a Cisco BBSM. Each NXTV Set Top Box has two Ethernet ports: one connects to the CPE, and the other can be used for Internet access. Thus, the NXTV solution provides VOD and Internet access with one Ethernet-port Cisco 575 LRE CPE. Each LRE switch resides on its own VLAN. The video, application, and boot servers reside on another VLAN. The Cisco Catalyst 3550 Series Switch routes between these VLANs.


Figure 3
VOD Architecture in NXTV Solution

Table 3 lists all the equipment and model numbers for the NXTV VOD solution. This is not a bill of materials.

Table 3   Equipment List for NXTV VOD Solution

Description Model Number
Cisco Catalyst 2924 LRE XL

WS-C2924-LRE-XL

Cisco 575 LRE CPE Device

CISCO575-LRE

Low-pass microfilter

EXCELSUS: Z-D251CW

24-port Cisco Catalyst 3550 Series core switch

WS-C3550-24-SMI

Cisco 2600 Internet Router

CISCO2610XM

Video server

NXTV software running on Compaq Proliant DL 380

Application server

NXTV software running on Compaq Proliant DL 380

Boot server

NXTV software running on Compaq Proliant DL 380

Set-top box

NXTV Set-top box

LRE and Core Switch Configuration Outputs

The following configuration outputs of the Cisco Catalyst 2924 LRE XL Switch, the Cisco Catalyst 2950 LRE Series Switch, and the Cisco Catalyst 3550 Series Switch are for reference only. Actual configurations may vary depending on the Layer 2 or Layer 3 network design.

Configuration of Cisco Catalyst 2924 LRE XL Switch

All LRE interfaces are configured with the default LRE-10 profile. The default profile does not show up in the configuration.

hostname 2924-LRE
!
interface FastEthernet0/1
  description EtherChannel to 3550 Core switch
  switchport access vlan 2
  port group 1
!
interface FastEthernet0/2
  description EtherChannel to 3550 Core switch
  switchport access vlan 2
  port group 1
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface LongReachEthernet0/1
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/2
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/3
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/4
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/5
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/6
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/7
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/8
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/9
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/10
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/11
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/12
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/13
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/14
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/15
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/16
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/17
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/18
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/19
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/20
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/21
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/22
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/23
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/24
  port block unicast
  port block multicast
  port protected
  switchport access vlan 2
  spanning-tree portfast
  spanning-tree rootguard
!
interface VLAN2
  ip address 10.1.2.2 255.255.255.0
!
snmp-server community cisco RW
snmp-server community cisco RO
!
line con 0
line vty 0 4
  password ..
  login
!
end

Configuration of Cisco Catalyst 2950 LRE Series Switch

hostname 2950-LRE
!
interface GigabitEthernet0/1
  description Trunk port to 3550 Core switch
  switchport mode trunk
!
interface GigabitEthernet0/2
!
interface LongReachEthernet0/1
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/2
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/3
  switchport access vlan 3
  switchport protected
  profile LRE-10
vspanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/4
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/5
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/6
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/7
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/8
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/9
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/10
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/11
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/12
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/13
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/14
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/15
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/16
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/17
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/18
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/19
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/20
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/21
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/22
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/23
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface LongReachEthernet0/24
  switchport access vlan 3
  switchport protected
  profile LRE-10
  spanning-tree portfast
  spanning-tree rootguard
!
interface Vlan1
  ip address 10.1.1.3 255.255.255.0
  no ip route-cache
!
line con 0
line vty 0 4
  login
  password .
!
end

Configuration of Cisco Catalyst 3550 Series Switch

hostname 3550-Core
!
ip routing
!
interface FastEthernet0/1
  description EtherChannel to 2924 LRE
  port group 1 distribution destination
  switchport access vlan 2
  spanning-tree portfast
!
interface FastEthernet0/2
  description EtherChannel to 2924 LRE
  port group 1 distribution destination
  switchport access vlan 2
  spanning-tree portfast
!
interface FastEthernet0/3
  spanning-tree portfast
!
interface FastEthernet0/4
  spanning-tree portfast
!
interface FastEthernet0/5
  description connection to video server
  switchport access vlan 4
  spanning-tree portfast
!
interface FastEthernet0/6
  description connection to video server
  switchport access vlan 4
  spanning-tree portfast
!
interface FastEthernet0/7
  description connection to Boot/NFS server
  switchport access vlan 4
  spanning-tree portfast
!
interface FastEthernet0/8
  description connection to Application server
  switchport access vlan 4
  spanning-tree portfast
!
interface FastEthernet0/9
  description connection to internal BBSM interface
  switchport access vlan 5
  spanning-tree portfast
!
interface FastEthernet0/10
  description connection to external BBSM interface
  switchport access vlan 6
  spanning-tree portfast
!
interface FastEthernet0/11
  description connection to Internet Router
  switchport access vlan 6
  spanning-tree portfast
!
interface FastEthernet0/12
spanning-tree portfast
!
interface FastEthernet0/13
  spanning-tree portfast
!
interface FastEthernet0/14
  spanning-tree portfast
!
interface FastEthernet0/15
  spanning-tree portfast
!
interface FastEthernet0/16
  spanning-tree portfast
!
interface FastEthernet0/17
  spanning-tree portfast
!
interface FastEthernet0/18
  spanning-tree portfast
!
interface FastEthernet0/19
  spanning-tree portfast
!
interface FastEthernet0/20
  spanning-tree portfast
!
interface FastEthernet0/21
  spanning-tree portfast
!
interface FastEthernet0/22
  spanning-tree portfast
!
interface FastEthernet0/23
  spanning-tree portfast
!
interface FastEthernet0/24
  spanning-tree portfast
!
interface GigabitEthernet0/1
  description Trunk port to 2950 LRE
  switchport mode trunk
!
interface GigabitEthernet0/2
!
interface VLAN1
  ip address 10.1.1.1 255.255.255.0
!
interface VLAN2
  ip address 10.1.2.1 255.255.255.0
!
interface VLAN3
  ip address 10.1.3.1 255.255.255.0
!
interface VLAN4
  ip address 10.1.4.1 255.255.255.0
!
interface VLAN5
  ip address 10.1.5.1 255.255.255.0
!
interface VLAN6
  ip address 10.1.6.1 255.255.255.0
!
snmp-server community cisco RW
snmp-server community cisco RO
!
line con 0
line vty 0 4
  password .
  login
!
end