
 

Upgrading Cisco ONS 15600 to Release 6.0

Note The terms "Unidirectional Path Switched Ring" and "UPSR" may appear in Cisco literature. These terms 
do not refer to using Cisco ONS 15xxx products in a unidirectional path switched ring configuration. 
Rather, these terms, as well as "Path Protected Mesh Network" and "PPMN," refer generally to Cisco's 
path protection feature, which may be used in any topological network configuration. Cisco does not 
recommend using its path protection feature in any particular topological network configuration.

This document explains how to upgrade the Cisco ONS 15600 Cisco Transport Controller (CTC) 
software from Software Release 5.x to Software R6.0 using the Timing and Shelf Controller (TSC) card. 
The ONS 15600 supports errorless upgrades.
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  Before You Begin
Before You Begin
Before beginning, write down the following information about your site: date, street address, site phone 
number, and dial-up number. This data will be useful during and after the upgrade.

Caution Before beginning an upgrade of an ONS 15600 to Release 6.0 contact the Cisco TAC for system 
verification.

Caution Read each procedure before you begin the upgrade.

Caution This document supports upgrades from Release 5.x to 6.0. You cannot upgrade from Releases 1.1.x, 
1.3.x, or 1.4 to 6.0.

Note Perform the procedures in this document in consecutive order unless otherwise noted. In general, you 
are not done with a procedure until you have completed it for each node that you are upgrading, and you 
are not done with the upgrade until you have completed each procedure that applies to your network. If 
you are new to upgrading the ONS 15600, you might want to check off each procedure on your printed 
copy of this document as you complete it.

This section lists the document procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

Each non-trouble procedure (NTP) is a list of steps designed to accomplish a specific task. Follow the 
steps until the task is complete. For a crafts person requiring more detailed instructions, refer to the 
Detailed Level Procedure (DLP) specified in the procedure steps. 

The detailed level procedure (DLP) supplies additional task details to support the NTP. The DLP lists 
numbered steps that lead the crafts person through completion of a task. Some steps require that 
equipment indications be checked for verification. When the proper response is not obtained, a trouble 
clearing reference is provided. 

The following NTPs are in this document:

1. NTP-U141 Prepare for the Release 6.0 Upgrade, page 3—This procedure contains critical 
information and tasks that you must read and complete before beginning the upgrade process. 

2. NTP-U142 Back Up the Software Database, page 4—Complete the database backup to ensure that 
you have preserved your node and network provisioning in the event that you need to restore them.

3. NTP-U143 Upgrade to Release 6.0, page 6—You must complete this entire procedure to complete 
the upgrade.

4. NTP-U144 Restore the Previous Software Load and Database, page 16—Complete this procedure if 
you need to return to Software R5.x.
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DLP-  U217 Verify CTC Workstation Requirements
NTP-U141 Prepare for the Release 6.0 Upgrade

Step 1 Read the Release Notes for Cisco ONS 15600 Release 6.0.

Step 2 Log into the node that you will upgrade. For detailed instructions, refer to the Cisco ONS 15600 
Procedure Guide. 

Step 3 Complete the “DLP-U217 Verify CTC Workstation Requirements” task on page 3.

Step 4 Disable all other Ethernet devices (such as a dial-up adapter) on the workstation that runs CTC. For 
instructions, contact the Cisco Technical Assistance Center (TAC).

If you have multiple IP addresses on your workstation, you should remove them; you cannot run 
Software R6.0 if multiple IP addresses are configured. 

Step 5 If you have multiple ONS 15600 nodes configured in the same IP subnet, ensure that only one is 
connected to a router. Otherwise, the remaining nodes might be unreachable. Refer to the 
Cisco ONS 15600 Reference Manual for LAN-connection suggestions.

Step 6 Verify that TSC cards are installed in Slots 5 and 10 and that the TSC in Slot 10 is active.

Step 7 Complete the “NTP-U142 Back Up the Software Database” task on page 4.

Stop. You have completed this procedure.

DLP-U217 Verify CTC Workstation Requirements

Purpose This procedure steps you through the critical information checks and tasks 
you must complete before beginning an upgrade.

Tools/Equipment PC or UNIX workstation; Cisco ONS 15600 Software Release 6.0 (CD or 
soft copy)

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level Superuser

Purpose This task verifies that all PC or UNIX workstation hardware and software 
requirements are met.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U217 Verify CTC Workstation Requirements
Step 1 Ensure that your workstation is either one of the following:

• IBM-compatible PC with a Pentium III/700 or faster processor, CD-ROM drive, a minimum of 384 
MB RAM and 190 MB of available hard drive space, running Windows 98, Windows NT 4.0 (with 
Service Pack 6a), Windows 2000 Professional (with Service Pack 3), or Windows XP Professional 
(with Service Pack 1)

• UNIX workstation with Solaris Versions 8 or 9, on an UltraSPARC or faster processor, with a 
minimum of 384 MB RAM and a minimum of 190 MB of available hard drive space

Step 2 Ensure that your web browser software is one of the following:

• Netscape Navigator 7.x or higher

• Internet Explorer 6.x or higher 

Step 3 Verify that the Java Version installed on your computer is Java Runtime Environment (JRE) Release 
1.4.2.

Tip You can check the JRE version in your browser window after entering the node IP address in the 
URL window under Java Version.

Step 4 Verify that the Java Policy file is installed on your computer. 

Note For important information on CTC backward compatibility affected by your choice of JRE 
versions, see the Readme.txt or Readme.html file on the software CD.

Step 5 Return to your originating procedure (NTP).

NTP-U142 Back Up the Software Database

Note To restore a software database, a backup file of that database must be available. 

Step 1 Log into CTC. For detailed instructions, refer to the Cisco ONS 15600 Procedure Guide. If you are 
already logged in, continue with Step 2.

Step 2 In node view, click the Maintenance > Database tabs.

Step 3 Click Backup.

Purpose This procedure preserves all configuration data for your network before 
performing the upgrade.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U141 Prepare for the Release 6.0 Upgrade, page 3

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U217 Verify CTC Workstation Requirements
Step 4 In the Database backup dialog box, click Browse. 

Step 5 In the Save dialog box, navigate to a local PC directory or network directory and type a database name 
(such as database.db) in the File name field. 

Step 6 Click Save.

Step 7 If you are overwriting an existing file, click Yes in the confirmation dialog box.

Step 8 In the Database backup dialog box, check the Alarms, Performance, and/or Audit check boxes to 
choose these database items in addition to provisioning information. 

Note Provisioning is a default component of the backup file.

Step 9 Click OK.

Step 10 Repeat Steps 1 through 9 for each node in the network.

Step 11 (Optional) Cisco recommends that you manually log critical information by either writing it down or 
printing screens where applicable. Use Table 1 to determine the information you should log; complete 
the table (or your own version) for every node in the network. 

Stop. You have completed this procedure.

Table 1 Manually Logged Data

Item Record Data Here (If Applicable)

IP address of the node

Node name 

Timing settings

DCC connections; list all optical ports that have DCCs activated

User IDs (List all, including at least one super user)

Inventory; do a print screen from the inventory window

Active TSC

Note The TSC card in Slot 10 must be the active TSC card for 
an upgrade.

Slot 5 or Slot 10 (circle one)

SSXC preferred copy Slot 6/7 or Slot 8/9 (circle one)

Network information; do a print screen from the Provisioning tab 
in the network view.

Current configuration: path protection, linear, etc. Do print 
screens as needed.

List all protection groups in the system; do a print screen from 
the Protection Group window.

List alarms; do a print screen from the Alarm window.

List circuits; do a print screen from the Circuit window.
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DLP-  U217 Verify CTC Workstation Requirements
NTP-U143 Upgrade to Release 6.0

Caution Executing an upgrade with a single TSC card is traffic affecting. Do not start an upgrade unless both 
TSC cards are present and alarm free.

Note To upgrade the software successfully, read and perform each task that applies to your network in the 
proper order. 

Note The UPGRADE, SFTWDOWN, and SW-VER alarms are raised during the upgrade process. These 
alarms are normal and will clear when the download is complete.

Step 1 Insert the Software R6.0 CD into the workstation CD-ROM (or otherwise acquire access to the software) 
to begin the upgrade process.

Note Inserting the software CD activates the CTC Setup Wizard. You can use the setup wizard to 
install components or click Cancel to continue with the upgrade.

Step 2 Log into the node that you want to upgrade. For detailed instructions, refer to the Cisco ONS 15600 
Procedure Guide. If you are already logged in, continue with Step 3.

Step 3 (BLSR nodes only) Complete the “DLP-U218 Perform a BLSR Lockout” task on page 7.

Note The bidirectional line switched ring (BLSR) lockout must be completed for all nodes in all rings 
for which the ONS 15600 is provisioned.

Step 4 Complete the “DLP-U219 Download the Software” task on page 8.

Step 5 Complete the “DLP-U220 Activate the New Load” task on page 10.

Step 6 (As needed) Complete the “DLP-U91 Delete Cached JAR Files” task on page 12.

Note The “DLP-U91 Delete Cached JAR Files” task on page 12 is provided in case you have trouble 
logging back into a node after the activation. This task is not generally necessary.

Step 7 Reconnect to the node using CTC. The new CTC applet for Software R6.0 uploads. 

Purpose This procedure upgrades your software to Software R6.0.

Tools/Equipment PC or UNIX workstation; Cisco ONS 15600 Software Release 6.0 (CD or 
soft copy)

Prerequisite Procedures NTP-U142 Back Up the Software Database, page 4

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U218 Perform a BLSR Lockout
Step 8 During the CTC login, complete the “DLP-U92 Install the Public-Key Security Certificate” task on 
page 13.

Step 9 Complete the “DLP-U221 Accept the New Load” task on page 14.

Note After you have accepted the Software R6.0 build, you cannot revert to Software R5.x without 
downloading Software R5.x again and restoring the R5.x database. 

Step 10 Repeat Steps 5 through 9 for all nodes in the network that need to be upgraded. Allow each node to finish. 
All alarms should be cleared for 10 minutes before activating the next node.

Note You can only activate one node at a time; however, you can begin activation of the next node as 
soon as the controller cards for the current node have rebooted successfully.

Step 11 Complete the “DLP-U222 Remove the BLSR Lockout” task on page 15 for all BLSR nodes in the 
network.

Step 12 Complete the “DLP-U94 Set the Date and Time” task on page 16 for any nodes that are not using Simple 
Network Time Protocol (SNTP).

Step 13 As needed, upgrade any spare TSC cards by installing the spare in the standby slot of a Software R6.0 
node.

Note When you insert a spare TSC card in the standby slot, a software mismatch is raised. The 
working software on the active TSC card is then copied to the standby TSC, causing the standby 
TSC card to reset. When the standby TSC card reset completes, the standby TSC is running the 
same software version as the active TSC card.

Step 14 To back up the Release 6.0 database for the Working software load, see “NTP-U142 Back Up the 
Software Database” procedure on page 4 in order to preserve the database for the Release 6.0 software

Stop. You have completed this procedure.

DLP-U218 Perform a BLSR Lockout

Note During activation, BLSR spans are not protected. You must leave the BLSR in the lockout state until you 
have finished activating all nodes in the ring, but you must be sure to remove the lockout after you have 
finished activating.

Purpose If you have a BLSR provisioned, before beginning the upgrade you must 
perform a span lockout at each node in the ring.

Tools/Equipment PC or UNIX workstation, Software R6.0 files

Prerequisite Procedures NTP-U142 Back Up the Software Database, page 4

Required/As Needed Required for BLSR only

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U219 Download the Software
Note To prevent ring or span switching, perform the lockout on both the east and west spans of each node.

Step 1 In node view, click the Maintenance > BLSR tabs.

Step 2 For each of the BLSR trunk (span) cards (OC-48, OC-192), perform the following steps:

a. Next to the trunk card row, click the East Switch column to show the drop-down list.

b. From the menu options, choose Lockout Span.

c. Click Apply.

d. In the same row, click the West Switch column to show the drop-down list.

e. From the menu options, choose Lockout Span.

f. Click Apply. 

Note Ignore any Default K alarms that occur on the protect STS time slots during this lockout period.

Note Certain BLSR or Multiservice Switching Platform (MSSP)-related alarms might be raised following 
activation of the first node in the ring. The following alarms, if raised, are normal and should not cause 
concern. They clear upon completion of the upgrade, after all nodes have been activated.

• BLSROSYNC (MN)

• RING-MISMATCH (MJ)

• APSCDFLTK (MN)

• BLSR-RESYNC (NA)

Step 3 Return to your originating procedure (NTP).

DLP-U219 Download the Software

Note The download task does not affect traffic because the active software continues to run at the primary 
RAM location; therefore, you can download the software at any time.

Step 1 From the View menu, choose Go To Network View.

Purpose This task downloads the software to the ONS 15600 nodes.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U142 Back Up the Software Database, page 4

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U219 Download the Software
Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is selected and disabled if the tool is raised (not selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding. If necessary, refer to the Cisco ONS 15600 Troubleshooting Guide.

Step 4 From the View menu, choose Go to Home View.

Step 5 Verify that the TSC card in Slot 10 is the active card. If it is not, complete the following:

a. Right-click the TSC in Slot 5 and choose Soft-reset Card.

b. Click Yes in the confirmation dialog box.

c. Click OK in the Connection Lost dialog box.

Note The TSC card takes several minutes to reboot. 

Step 6 Double-click the node icon to return to node view.

Step 7 Click the Maintenance > Software tabs.

Step 8 Click Download. The Download Selection dialog box appears.

Step 9 Click Browse.

Step 10 In the Open dialog box, navigate to the software package files on the ONS 15600 software CD or on your 
hard drive, if you are working from a local copy. 

Step 11 Select the file with the .pkg extension and click Open. 

Step 12 In the Download Selection dialog box, verify that the node is checked. 

Step 13 Click OK. The software begins downloading to the active TSC card. The Download Status column on 
the Maintenance > Software tab shows the percentages complete:

1. Downloading (approximately 7 to 10 minutes) 

2. Qualifying (approximately 1 to 2 minutes)

3. Copying to stby TSC (approximately 2 to 5 minutes)

When the Download Status column is empty, the software has finished loading. 

Step 14 Verify the version:

a. Click Info. 

b. In the Current Software Info dialog box, verify that the TSC B Working field shows 5.x and the TSC 
B Protect field shows 6.0. 

c. Click OK. 

Note You can also verify the load information on the Maintenance > Software tab. The Working 
Version column shows the original software load and the Protect Version column shows the 
software load that you just downloaded.

Step 15 Repeat Steps 1 through 14 for each node.
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DLP-  U220 Activate the New Load
Note The software download process can take 15 minutes or more per node.

Step 16 Return to your originating procedure (NTP).

DLP-U220 Activate the New Load

Note Although the activate task is not service affecting, Cisco recommends that you activate the new load 
during a maintenance window. 

Caution Do not perform maintenance or provisioning activities during the activation task.

Note For BLSRs only, a non-service affecting APS-CHAN-FAILURE alarm is raised on each of the nodes 
joined to an activating node in the ring during activation. Once the activation completes for that node, 
the alarms will clear. 

Note Cisco recommends that the first node you activate be a LAN-connected node. This ensures that the new 
CTC JAR files will download to your workstation as quickly as possible.

Step 1 In node view, click the Maintenance > Software tabs.

Step 2 Verify the version:

a. Click Info. 

b. In the Current Software Info dialog box, verify that the TSC B Working shows R5.x and the TSC B 
Protect shows R6.0. 

c. Click OK. 

Step 3 Click Activate. The Activate dialog box appears with a warning message indicating that you should 
perform a database backup.

Step 4 Complete one of the following:

Purpose This task activates Software R6.0 in each node in the network. Activating 
the software load downloads the software to the standby TSC.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U142 Back Up the Software Database, page 4

DLP-U219 Download the Software, page 8

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U220 Activate the New Load
• If you have not backed up the Software R5.x database, click No. Complete the “NTP-U142 Back Up 
the Software Database” procedure on page 4. When you have completed the procedure, return to 
Step 3 in this task.

• If you have backed up the Software R5.x database, click Yes to proceed with the activation. The 
Download Status column shows: 

– The Qualifying percentage completed (approximately 1 to 2 minutes).

– The status “Wait” while the standby TSC reboots (approximately 2 to 5 minutes). When the 
standby TSC completes the reboot, it is still in standby but is now running Software R6.0. The 
active TSC in Slot 10 is still active and is running Software R5.x.

– The Acquiring percentage completed as the standby TSC acquires the active timing reference 
(approximately 10 to 15 minutes).

Step 5 Click OK when the Rebooting message appears indicating that the software is successfully activated. 
The node reboot could take up to four minutes.

Step 6 Click OK in the Connection Lost dialog box. 

Note CTC loses connection to the node while the node reboots and displays the network view. 

Step 7 After activating the node, the software upgrade reboot occurs as follows.( The node will remain gray for 
the remainder of this task.) 

• When the active TSC card in Slot 10 reboots, the TSC card in Slot 5 becomes active, using 
Software R6.0 as the working copy. When the TSC card in Slot 10 resets, it is in standby mode and 
is still running Software R5.x. All remaining cards in the shelf reset simultaneously. 

• A system reboot (SYSBOOT) alarm is raised briefly while activation is in progress. When all cards 
have reset, this alarm clears. 

After the common control cards finish resetting and all associated alarms clear, you can safely proceed 
to the next step. (If you are upgrading remotely and cannot see the nodes, wait for 5 minutes for the 
process to complete, then check to ensure that related alarms have cleared before proceeding.) 

Step 8 In CTC, choose File > Exit.

Step 9 In your browser window, click the Delete CTC Cache button.

Note You must ensure that CTC is closed before clicking the Delete CTC Cache button. CTC behavior 
is unreliable if the button is clicked while the software is still running.

Note It might also be necessary to delete cached files from your browser’s directory, or from the temp 
directory on your MS Windows workstation. If you have trouble reconnecting to CTC, complete 
the “DLP-U91 Delete Cached JAR Files” task on page 12.

Step 10 Close your browser.

Step 11 Install the new JRE version and (optionally) run the Cache Loader pre-caching utility:
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DLP-  U91 Delete Cached JAR Files
Note Cisco recommends you run the optional Cache Loader pre-caching utility during this step, prior 
to activating the node. This ensures that the new CTC JAR files download to your workstation 
as quickly as possible.

a. In your Windows environment, choose Start > Settings > Control Panel, and click Add/Remove 
Programs.

b. Scroll the list of programs until you see the Java 2 Runtime Environment, then click 
Change/Remove.

c. Click Yes in the dialog box to proceed with removing the old JRE version.

a. Load the Release 6.0 CD into your CD-ROM drive. If the directory of the CD does not open 
automatically, open it.

b. Double-click the setup.exe file to run the Installation Wizard. The CTC installation wizard dialog 
box opens.

c. Click Next. The setup options dialog box opens.

d. Choose Custom, and click Next. The custom options dialog box appears.

e. Select Cisco Transport Controller, Java Runtime Environment 1.4.2, and (optionally) CTC JAR 
files. Deselect any other preselected options. 

f. Click Next. A confirmation box appears.

g. Click Next again. The (optional) CTC Cache Loader pre-caches the JAR files to your workstation, 
displaying a progress status box, and installs the JRE.

h. When the installation finishes, click OK, and then in the wizard, click Finish.

Step 12 Reopen your browser.

Step 13 Return to your originating procedure (NTP).

DLP-U91 Delete Cached JAR Files

Step 1 Delete cache files from your browser directory.

In Netscape:

a. Choose Edit > Preferences > Advanced > Cache.

b. Click Clear Memory Cache.

c. Click OK.

Purpose This task deletes previously cached files from your browser and hard 
drive. 

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U220 Activate the New Load, page 10

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level None
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DLP-  U92 Install the Public-Key Security Certificate
d. Click Clear Disk Cache.

e. Click OK twice.

In Microsoft Internet Explorer:

a. Choose Tools > Internet Options > General.

b. Choose Delete Files.

c. Select the Delete all offline content check box.

d. Click OK twice.

Step 2 Close your browser.

You will not be able to delete cached JAR files from your hard drive until you have closed your browser. 
If you have other applications open that use JAR files, you must also close them.

Step 3 (Windows systems only) Delete cached files from your workstation.

a. In your Windows start menu, choose Settings > Control Panel > System > Advanced.

b. Click Environment Variables. This shows you a list of user variables and a list of system variables.

c. In the list of user variables, look for the TEMP variable. The value associated with this variable is 
the path to your temporary directory where JAR files are stored.

d. Open the TEMP directory located in the path you just looked up.

e. Select View > Details.

f. Select and delete all files with “jar” in the Name or Type field.

Step 4 Reopen your browser. You should now be able to connect to CTC.

Step 5 Return to your originating procedure (NTP).

DLP-U92 Install the Public-Key Security Certificate

Caution If you delete the Java policy file, you cannot log into nodes running Software R5.x and earlier. If you 
delete the file and want to log into an ONS 15600 running an earlier release, insert the software CD for 
the release into your PC CD-ROM and run the CTC setup wizard to reinstall the Java policy file.

Step 1 If the Java Plug-in Security Warning dialog box appears, choose one of the following options. 

Purpose This task installs the ITU Recommendation X.509 public-key security 
certificate. The public-key certificate is required to run Software R5.0 or 
later.

Tools/Equipment None

Prerequisite Procedures DLP-U91 Delete Cached JAR Files, page 12

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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DLP-  U221 Accept the New Load
• Grant This Session—Installs the public-key certificate to your PC only for the current session. After 
the session is ended, the certificate is deleted. This dialog box will appear the next time you log into 
the ONS 15600.

• Deny—Denies permission to install the certificate. If you choose this option, you cannot log into the 
ONS 15600. 

• Grant always—Installs the public-key certificate and does not delete it after the session is over. 
Cisco recommends this option.

• View Certificate—Allows you to view the public-key security certificate.

Step 2 If the Login dialog box appears, continue with Step 3. If the Change Java Policy File dialog box appears, 
complete this step. The Change Java Policy File dialog box appears if CTC finds a modified Java policy 
file (.java.policy) on your PC. In Software R1.5.x, the Java policy file was modified to allow CTC 
software files to be downloaded to your PC. The modified Java policy file is not needed in Software R6.0, 
so you can remove it unless you will log into ONS 15600s running Software R1.5.x. Choose one of the 
following options: 

• Yes—Removes the modified Java policy file from your PC. Choose this option only if you will log 
into ONS 15600s running Software R5.0 or later.

• No—Does not remove the modified Java policy file from your PC. Choose this option if you will 
log into ONS 15600s running Software R1.5.x. If you choose No, this dialog box will appear every 
time you log into the ONS 15600. If you do not want it to appear, check the Do not show the 
message again check box.

Step 3 Return to your originating procedure (NTP).

DLP-U221 Accept the New Load

Step 1 In node view, click the Maintenance > Software tabs.

Step 2 Click Accept. This process takes approximately 2 to 5 minutes.

Note You can reject the new software load by clicking Cancel. The Cancel button resets the active 
TSC card in Slot 5. The TSC card in Slot 10 then becomes the active TSC using Software R5.x 
as the working copy. After the TSC card in Slot 5 resets, it becomes the standby TSC and begins 
using Software R5.x. 

Purpose This task upgrades the standby TSC.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U220 Activate the New Load, page 10

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U222 Remove the BLSR Lockout
Note If the Cancel button is not active, the standby TSC has not finished acquiring the active timing 
reference. The acquire process can take approximately 10 to 15 minutes. When the acquire 
process completes, the Cancel button becomes active.

Step 3 Verify the version:

a. Click Info.

b. In the Current Software Info dialog box, verify that the TSC B Working field shows the correct 
version. The TSC B Protect field should show the previous version. 

c. If the TSC B Working and TSC B Protect fields show “none,” click OK and click the Info button 
again after several minutes. Repeat until the TSC B software versions appear.

d. Click OK.

Step 4 Return to your originating procedure (NTP).

DLP-U222 Remove the BLSR Lockout

Step 1 In CTC node view, click the Maintenance > BLSR tabs.

Step 2 For each of the BLSR trunk (span) cards (OC-48, or OC-192), perform the following steps: 

a. Next to the trunk card row, click the West Switch column to show the drop-down list.

b. Choose Clear from the list

c. Click Apply to activate the command. 

Note When removing a lockout, be sure to apply your changes each time you choose the Clear option. 
If you try to select Clear for more than one lockout at a time, you risk traffic loss on the first ring 
switch.

d. In the same row, click the East Switch column to show the drop-down list.

e. Choose Clear from the list.

f. Click Apply to activate the command. 

Step 3 Repeat this task as many times as necessary to remove all BLSR span lockouts on the upgrade nodes.

Purpose Release the span lockouts on all BLSR nodes. Complete this task after the 
new software load is activated on all nodes.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U220 Activate the New Load, page 10

Required/As Needed Required for BLSR

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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Step 4 Return to your originating procedure (NTP).

DLP-U94 Set the Date and Time

Note If you are not using SNTP, the upgrade procedure can cause the date and time setting to change. If you 
are using SNTP, you do not need to perform this task.

Step 1 In node view, click the Provisioning > General tabs.

Step 2 Set the correct date and time, then click Apply. 

Step 3 Repeat Steps 1 and 2 for each remaining node.

Step 4 Return to your originating procedure (NTP).

NTP-U144 Restore the Previous Software Load and Database

Note The tasks to downgrade to a previous load are not a part of the upgrade. They are provided here as a 
convenience to those wishing to restore an earlier software load after an upgrade. If you have performed 
all necessary procedures up to this point, you have finished the software upgrade.

Purpose This task resets the date and time at each node.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser

Purpose This procedure returns the node to the software and database provisioning 
you had before you activated Software R6.0.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U141 Prepare for the Release 6.0 Upgrade, page 3

NTP-U142 Back Up the Software Database, page 4

NTP-U143 Upgrade to Release 6.0, page 6

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
16
Upgrading Cisco ONS 15600 to Release 6.0

OL-7108-01



 

DLP-  U94 Set the Date and Time
Note Before you upgraded to Release 6.0 software, you should have backed up the existing database at all 
nodes in the network (using the “NTP-U142 Back Up the Software Database” procedure on page 4). 
Cisco recommends that you record or export all critical information to your hard drive. 

Caution Downgrades are service affecting.

Note A system-wide soft reset occurs after the database is restored. All line (I/O) and matrix (SSXC) cards 
automatically soft reset. Existing traffic can be affected, depending on the circuit provisioning map. 

Step 1 Log into the node. For detailed instructions, refer to the Cisco ONS 15600 Procedure Guide. If you are 
already logged in, continue with Step 2.

Note To perform a downgrade from Software R6.0, Software R5.x must have been working at the time 
you activated to Software R6.0 on that node. Also, a supported revert restores the node 
configuration at the time of the previous activation. Thus, any configuration changes made after 
activation will be lost when you revert the software.

Step 2 (BLSR nodes only) Complete the “DLP-U218 Perform a BLSR Lockout” task on page 7.

Note The BLSR lockout must be completed for all nodes in all rings for which the ONS 15600 is 
provisioned.

Step 3 Complete the “DLP-U219 Download the Software” task on page 8.

Step 4 Click Revert. The Database Restore dialog box appears.

Step 5 Click Browse.

Step 6 In the Open dialog box, navigate to a local PC directory or network directory where the database file is 
stored and click Open.

Step 7 If alarms and performance were backed up, check the Alarms and Performance check boxes in the 
Database Restore dialog box.

Step 8 Click OK.

Step 9 Click Yes in the confirmation dialog box. 

Step 10 Wait until the software download finishes. The Download Status column shows:

• The Qualifying percentage completed (approximately 1 to 2 minutes)

• The status “Wait” while the standby TSC reboots (approximately 2 to 5 minutes)

• The Acquiring percentage completed as the standby TSC acquires the active timing reference 
(approximately 10 to 15 minutes)

The ONS 15600 then reboots.

Step 11 Complete the “DLP-U222 Remove the BLSR Lockout” task on page 15 for all BLSR nodes in the 
network.

Step 12 Complete the “DLP-U221 Accept the New Load” task on page 14.
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  Related Documentation
Step 13 Repeat Steps 1 through 12 for any other nodes you want to downgrade.

Stop. You have completed this procedure.

Related Documentation
Use this Upgrading Cisco ONS 15600 to Release 6.0 document in conjunction with the following 
publications:

• Cisco ONS 15600 Procedure Guide
Provides installation, turn up, test, and maintenance procedures

• Cisco ONS 15600 Reference Manual
Provides technical reference information for SONET/SDH cards, nodes, and networks

• Cisco ONS 15600 Troubleshooting Guide
Provides a list of alarms and troubleshooting procedures, general troubleshooting information, and 
hardware replacement procedures

• Cisco ONS SONET TL1 Command Guide
Provides a comprehensive list of TL1 commands

• Release Notes for Cisco ONS 15600 Release 6.0
Provides caveats, closed issues, and new feature and functionality information

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What's New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation. 

Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) 
feedand set content to be delivered directly to your desktop using a reader application. The RSS feeds 
are a free service and Cisco currently supports RSS version 2.0.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of 
Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The 
use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Copyright © 2007 Cisco Systems, Inc. All rights reserved.
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