
 

Upgrading Cisco ONS 15310-CL to Release 6.0

This document explains how to upgrade Cisco ONS 15310-CL Cisco Transport Controller (CTC) 
software from Release 5.0 to Release 6.0.
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  Before You Begin
Before You Begin
Before beginning, write down the following information about your site; the data will be useful during 
and after the upgrade: Date, Street Address, Site Phone Number, and Dial Up Number.

Caution Read all procedures before you begin the upgrade.

Caution This upgrade is supported only for Software Releases 5.x upgrading to Release 6.0. 

Document Procedures 
Procedures in this document are to be performed in consecutive order unless otherwise noted. In general, 
you are not done with a procedure until you have completed it for each node you are upgrading, and you 
are not done with the upgrade until you have completed each procedure that applies to your network. If 
you are new to upgrading the ONS 15310-CL, you might want to check off each procedure on your 
printed copy of this document as you complete it.

Each non-trouble procedure (NTP) is a list of steps designed to accomplish a specific procedure. Follow 
the steps until the procedure is complete. If you need more detailed instructions, refer to the detail-level 
procedure (DLP) specified in the procedure steps. Throughout this guide, NTPs are referred to as 
“procedures” and DLPs are termed “tasks.” Every reference to a procedure includes its NTP number, and 
every reference to a task includes its DLP number.

The DLP (task) supplies additional task details to support the NTP. The DLP lists numbered steps that 
lead you through completion of a task. Some steps require that equipment indications be checked for 
verification. When the proper response is not obtained, a trouble clearing reference is provided. This 
section lists the document procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

This section lists the document procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

1. NTP-U137 Prepare for Upgrade to Release 6.0, page 3—This section contains critical information 
and tasks that you must read and complete before beginning the upgrade process.

2. NTP-U138 Back Up the Software Database, page 4—Complete the database backup to ensure that 
you have preserved your node and network provisioning in the event that you need to restore them.

3. NTP-U139 Upgrade to Software R6.0, page 5—You must complete this entire procedure before the 
upgrade is finished.

4. NTP-116 Install Public-Key Security Certificate, page 11—You must complete this procedure to be 
able to run ONS 15310-CL Software R6.0.

5. NTP-U140 Revert to Previous Software Load and Database, page 12—Complete this procedure 
only if you need to return to the software load you were running before activating the Release 6.0 
software.
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DLP-  U213 Verify CTC Workstation Requirements
NTP-U137 Prepare for Upgrade to Release 6.0

Step 1 Read the Release Notes for Cisco ONS 15310-CL Release 6.0.

Step 2 Log into the node that you will upgrade. For detailed instructions, refer to the Cisco ONS 15310-CL 
Procedure Guide.

Step 3 Complete the “DLP-U213 Verify CTC Workstation Requirements” task on page 3.

Step 4 If you have multiple ONS 15310-CL nodes configured in the same IP subnet, ensure that only one is 
connected to a router. Otherwise, the remaining nodes might be unreachable. Refer to the 
Cisco ONS 15310-CL Reference Manual for LAN-connection suggestions.

Step 5 When you have completed the tasks for this section, proceed with the “NTP-U138 Back Up the Software 
Database” procedure on page 4.

Stop. You have completed this procedure.

DLP-U213 Verify CTC Workstation Requirements

Step 1 Ensure that your workstation is either one of the following:

• IBM-compatible PC with a Pentium III/700 or faster processor, CD-ROM drive, a minimum of 384 
MB RAM and 190 MB of available hard drive space, running Windows 98, Windows NT 4.0 (with 
Service Pack 6a), Windows 2000 Professional (with Service Pack 3), or Windows XP Professional 
(with Service Pack 1)

• UNIX workstation with Solaris Versions 8 or 9, on an UltraSPARC or faster processor, with a 
minimum of 384 MB RAM and a minimum of 190 MB of available hard drive space

Purpose This procedure provides the critical information checks and tasks you 
must complete before beginning an upgrade.

Tools/Equipment ONS 15310-CL nodes to upgrade
PC or UNIX workstation
Cisco ONS 15310-CL Release 6.0 software

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level Superuser

Purpose This task verifies all PC or UNIX workstation hardware and software 
requirements. Before upgrading the workstation to run CTC Software 
R6.0, complete this task.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U213 Verify CTC Workstation Requirements
Step 2 Ensure that your web browser software is one of the following:

• Netscape Navigator 7.x or higher 

• Internet Explorer 6.x or higher 

Step 3 Verify that the Java Version installed on your computer is:

– Java Runtime Environment (JRE) 1.4.2, and Java Plug-in 1.4.2

Tip You can check the JRE version in your browser window after entering the node IP address in the 
URL window under Java Version.

• The Java Policy file is installed on your computer. 

Note For important information on CTC backward compatibility affected by your choice of JRE 
versions, see the Readme.txt or Readme.html file on the software CD.

Note To install JRE 1.4.2, the Java Policy file, or the Release 6.0 online help, refer to the installation 
instructions in the Cisco ONS 15310-CL Procedure Guide.

Step 4 Return to your originating procedure (NTP).

NTP-U138 Back Up the Software Database

Step 1 Log into CTC. For detailed instructions, refer to the Cisco ONS 15310-CL Procedure Guide. If you are 
already logged in, continue with Step 2.

Step 2 In the node (default) view, click the Maintenance > Database tabs.

Step 3 Click Backup.

Step 4 Save the database on the workstation's hard drive or on network storage. Use an appropriate file name 
with the file extension .db. (Cisco recommends that you use the IP address of the node and the date, for 
example 1010120192061103.db.)

Step 5 Click Save. A message appears indicating that the backup is complete.

Step 6 Click OK.

Step 7 Repeat Steps 1 through 6 for each node in the network.

Purpose This procedure preserves all configuration data for your network before 
performing the upgrade.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U137 Prepare for Upgrade to Release 6.0, page 3

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Maintenance or higher
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DLP-  U213 Verify CTC Workstation Requirements
Step 8 (Optional) Cisco recommends that you manually log critical information by either writing it down or 
printing screens where applicable. Use the following table to determine the information you should log; 
complete the table (or your own version) for every node in the network.

Stop. You have completed this procedure.

NTP-U139 Upgrade to Software R6.0

Step 1 Insert the Release 6.0 software CD into the workstation CD-ROM (or otherwise acquire access to the 
software) to begin the upgrade process.

Note Inserting the software CD activates the CTC Setup Wizard. You can use the setup wizard to 
install components or click Cancel to continue with the upgrade.

Table 1 Manually Recorded Data

Item Record Data Here (If Applicable)

IP address of the node.

Node name.

Timing settings.

DCC connections; list all optical ports that have DCCs activated.

User IDs; list all, including at least one superuser.

Inventory; do a print screen from the inventory window.

Network information; do a print screen from the Provisioning tab in 
the network view.

Current configuration (linear, etc.); do print screens as needed.

List all protection groups in the system; do a print screen from the 
protection group window.

List alarms; do a print screen from the alarm window.

List circuits; do a print screen from the circuit window.

Purpose This procedure upgrades your CTC software to Software R6.0.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U138 Back Up the Software Database, page 4

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U214 Download Release 6.0 Software
Caution A traffic interruption of less than 50 ms on each circuit is possible during the activation task, with 
Ethernet traffic disruption possibly lasting up to several minutes on each circuit.

Caution Do not perform maintenance or provisioning activities during the activation task.

Step 2 Complete the “DLP-U214 Download Release 6.0 Software” task on page 6 for all nodes (or groups of 8 
or less nodes) you are upgrading.

Step 3 Complete the “DLP-U215 Activate the New Load” task on page 7 for all nodes you are upgrading.

Note You can only activate one node at a time; however, you can begin activation of the next node as 
soon as the controller cards for the current node have rebooted successfully.

Step 4 (Optional) If you wish to ensure that a software revert to the previous software release will no longer be 
possible, complete the “DLP-U214 Download Release 6.0 Software” task on page 6 for all nodes, or 
groups of nodes you are upgrading a second time.

Caution If you download the Release 6.0 software a second time following activation you will never be able to 
revert to the previous software version.

Step 5 Complete the “DLP-U52 Set the Date and Time” task on page 11 (any nodes not using SNTP).

Step 6 If you need to return to the software and database you had before activating Software R6.0, proceed with 
the “NTP-U140 Revert to Previous Software Load and Database” procedure on page 12.

Stop. You have completed this procedure.

DLP-U214 Download Release 6.0 Software

Note The CTX-CL card has two flash RAMs. An upgrade downloads the software to the backup RAM on the 
CTX-CL card. The download task does not affect traffic because the active software continues to run at 
the primary RAM location; therefore, you can download the software at any time.

Step 1 From the View menu, choose Go to Network View.

Purpose This task downloads Software R6.0 to the ONS 15310-CL nodes prior to 
activation.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U138 Back Up the Software Database, page 4

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser or Maintenance
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DLP-  U215 Activate the New Load
Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar. Alarm filtering is enabled if the 
tool is depressed (selected) and disabled if the tool is raised (not selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Note During the software download process, the SWFTDWN alarm indicates that the software 
download is taking place. The alarm is normal and clears when the download is complete.

Step 4 Return to node view and click the Maintenance > Software tabs.

Step 5 Click Download. The Download Selection dialog box opens.

Step 6 Browse to locate the software files on the ONS 15310-CL software CD or on your hard drive, if you are 
working from a local copy.

Step 7 Open the “Cisco15310-CL” folder. 

Step 8 Choose the file with the “.pkg” extension and click Open. 

Step 9 In the list of compatible nodes, select the check boxes for all nodes you are downloading the software to. 

Note Cisco advises that you limit concurrent software downloads on an SDCC to 8 nodes at once, 
using the central node to complete the download.

Note If you attempt more than eight concurrent software downloads at once, the downloads in excess 
of eight will be placed in a queue.

Step 10 Click OK. The Download Status column monitors the progress of the download. 

Note The software download process can take up to 30 minutes per node, though typically under ten 
minutes.

Step 11 Return to your originating procedure (NTP).

DLP-U215 Activate the New Load

Purpose This task activates Software R6.0 in each node in the network.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U214 Download Release 6.0 Software, page 6

Required/As Needed Required

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U215 Activate the New Load
Note Cisco recommends you run the optional Cache Loader pre-caching utility in Step 13 or the activation 
task. If you do not plan to run the pre-caching utility, Cisco recommends that the first node you activate 
be a LAN-connected node. This ensures that the new CTC JAR files download to your workstation as 
quickly as possible.

Step 1 Record the IP address of the node. The IP address is on the upper left corner of the CTC window.

Step 2 Verify that the alarm filter is not on:

a. Click the Alarms tab.

b. Click the Filter tool at the lower-right side of the bottom toolbar.

Alarm filtering is enabled if the tool is depressed (selected) and disabled if the tool is raised (not 
selected). 

Step 3 On the Alarms tab, check all nodes for existing alarms. Resolve any outstanding alarms before 
proceeding.

Step 4 Click the Maintenance > Software tabs.

Step 5 Verify that the protect version is 6.0 (the release you are upgrading to).

Step 6 Click Activate. The Activate dialog box appears with a warning message.

Step 7 Click Yes to proceed with the activation. The “Activation Successful” message appears when the 
software is successfully activated. Click OK in the message box.

Note When you click Yes, CTC will lose connection to the node and will display the network view.

Step 8 After activating the node, the software upgrade reboot occurs as follows:

• Each card in the node resets, beginning with the expansion card. The CTX-CL card will then reset 
and come back up. When the CTX-CL is finished, the Ethernet card comes back up, followed by 
reset of the Electrical and optical ports. The whole process can take up to 8 minutes, This process 
is service affecting, so Cisco recommends that you activate the new load during a maintenance 
window. Time-division multiplexing (TDM) traffic can endure a hit of up to 50 ms. Expect Ethernet 
traffic to remain down from the time the expansion card resets, until all cards have finished resetting 
and come back up (this will take 3 to 8 minutes). 

After the common control cards finish resetting and all associated alarms clear, you can safely proceed 
to the next step. (If you are upgrading remotely and cannot see the nodes, wait for 5 minutes for the 
process to complete, then check to ensure that related alarms have cleared before proceeding.)

Caution The upgrade process is service affecting, so Cisco recommends that you activate the new load during a 
maintenance window. Time-division multiplexing (TDM) traffic can endure a hit of up to 50 ms. 
Ethernet traffic may remain down from the time the 15310-CL-CTX cards switch to the time all Ethernet 
cards have finished resetting. 

Step 9 In CTC, choose File > Exit.

Step 10 In your browser window, click “Delete CTC Cache.” A confirmation dialog box is displayed.

Step 11 Click Yes to confirm.
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DLP-  U215 Activate the New Load
Note You must ensure that CTC is closed before clicking the “Delete CTC Cache” button. CTC 
behavior will be unreliable if the button is clicked while the software is still running.

Note It might also be necessary to delete cached files from your browser’s directory, or from the 
“temp” directory on your MS Windows workstation. If you have trouble reconnecting to CTC, 
complete the “DLP-U216 Delete Cached JAR Files” task on page 10.

Step 12 Close your browser and then reopen it.

Step 13 (Optional) Run the Cache Loader pre-caching utility, which can improve your speed logging back into 
CTC after an upgrade. Perform the following steps to run the Cache Loader.

a. Load the Release 6.0 CD into your CD-ROM drive. If the directory of the CD does not open 
automatically, open it.

b. Double-click the setup.exe file to run the Installation Wizard. The CTC installation wizard dialog 
box opens.

c. Click Next. The setup options dialog box opens.

d. Choose Custom, and click Next. The custom options dialog box opens.

e. Select Cisco Transport Controller, and CTC JAR files (deselect any other preselected options), then 
click Next. A confirmation box opens.

f. Click Next again. The CTC Cache Loader pre-caches the JAR files to your workstation, displaying 
a progress status box.

g. When the utility finishes, click OK, and then in the wizard, click Finish.

Step 14 Reconnect to CTC using the IP address from Step 1. The new CTC applet for Software R6.0 uploads. 
During this logon, type the user name CISCO15. A password is not required.

Note Steps 9 through 14 are only necessary after upgrading the first node in a network because cached 
files only need to be removed from your workstation once. For the remaining nodes, you will 
still be disconnected and removed to the network view during the node reboot, but after the 
reboot is complete, CTC will restore connectivity to the node.

Step 15 Return to your originating procedure (NTP).
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DLP-  U216 Delete Cached JAR Files
DLP-U216 Delete Cached JAR Files

Step 1 Delete cache files from your browser directory.

In Netscape:

a. Choose Edit > Preferences > Advanced > Cache.

b. Click Clear Memory Cache.

c. Click OK.

d. Click Clear Disk Cache.

e. Click OK twice.

In Microsoft Internet Explorer:

a. Choose Tools > Internet Options > General.

b. Choose Delete Files.

c. Select the Delete all offline content check box.

d. Click OK twice.

Step 2 Close your browser.

Note You will not be able to delete cached JAR files from your hard drive until you have closed your 
browser. If you have other applications open that use JAR files, you must also close them.

Step 3 Delete cached files from your workstation (Windows systems only).

a. In your Windows start menu, choose Settings > Control Panel > System > Advanced.

b. Click Environment Variables. This will show you a list of user variables and a list of system 
variables.

c. In the list of user variables, look for the TEMP variable. The value associated with this variable is 
the path to your temporary directory where JAR files are stored.

d. Open the TEMP directory located in the path you just looked up.

e. Select View > Details.

f. Select and delete all files with “jar” in the Name or Type field.

Step 4 Reopen your browser. You should now be able to connect to CTC.

Purpose This task manually deletes cached JAR files from your browser and hard 
drive. When you upgrade or revert to a different CTC software load, you 
must reload CTC to your browser. Before you can reload CTC, you must 
ensure that previously cached files are cleared from your browser and hard 
drive.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U215 Activate the New Load, page 7

Required/As Needed As needed.

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Maintenance or higher
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DLP-  U52 Set the Date and Time
Step 5 Return to your originating procedure (NTP).

DLP-U52 Set the Date and Time

Note If you are using SNTP, you do not need this task.

Step 1 In CTC node view, click the Provisioning > General tabs.

Step 2 Set the correct date and time, then click Apply. 

Step 3 Repeat Steps 1 and 2 for each remaining node.

Step 4 Return to your originating procedure (NTP).

NTP-116 Install Public-Key Security Certificate

Step 1 Log into CTC.

Step 2 If the Java Plug-in Security Warning dialog box appears, choose one of the following options:

• Grant This Session—Installs the public-key certificate to your PC only for the current session. After 
the session is ended, the certificate is deleted. This dialog box will appear the next time you log into 
the ONS 15310-CL.

• Deny—Denies permission to install the certificate. If you choose this option, you cannot log into the 
ONS 15310-CL. 

Purpose If you are not using SNTP, the upgrade procedure can cause the Date/Time 
setting to change. Perform this task to reset the date and time at each node.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures None

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser

Purpose This procedure installs the ITU Recommendation X.509 public-key 
security certificate. The public-key certificate is required to run Software 
R4.1 or later.

Tools/Equipment None

Prerequisite Procedures This procedure is performed when logging into CTC. You cannot perform 
it at any other time.

Required/As Needed This procedure is required to run ONS 15310-CL software.

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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DLP-  U52 Set the Date and Time
• Grant always—Installs the public-key certificate and does not delete it after the session is over. 
Cisco recommends this option.

• View Certificate—Allows you to view the public-key security certificate.

After you complete the security certificate dialog boxes, the web browser displays information about 
your Java and system environments. If this is the first login, a CTC downloading message appears while 
CTC files are downloaded to your computer. The first time you connect to an ONS ONS 15310-CL, this 
process can take several minutes. After the download, the CTC Login dialog box appears.

Step 3 If you need to return to the software and database you had before activating Software R6.0, proceed with 
the “NTP-U140 Revert to Previous Software Load and Database” procedure on page 12.

Stop. You have completed this procedure.

NTP-U140 Revert to Previous Software Load and Database

Note The tasks to revert to a previous load are not a part of the upgrade. They are provided here as a 
convenience to those wishing to perform a revert after an upgrade. If you have performed all necessary 
procedures up to this point, you have finished the software upgrade.

Note Before you upgraded to Software R6.0, you should have backed up the existing database at all nodes in 
the network (this is part of the “NTP-U138 Back Up the Software Database” procedure on page 4). Cisco 
recommends that you record or export all critical information to your hard drive. If you need to revert to 
the backup database, use the following tasks, in order. 

Step 1 Log into the node. For detailed instructions, refer to the Cisco ONS 15310-CL Procedure Guide. If you 
are already logged in, continue with Step 2.

Step 2 Complete the “DLP-U183 Revert to Protect Load” task on page 13.

Step 3 If the software revert to your previous release failed, complete the “DLP-U184 Manually Restore the 
Database” task on page 14.

Stop. You have completed this procedure.

Purpose This procedure restores the software and database provisioning you had 
before you activated Software R6.0.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U137 Prepare for Upgrade to Release 6.0, page 3
NTP-U138 Back Up the Software Database, page 4
NTP-U139 Upgrade to Software R6.0, page 5

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U183 Revert to Protect Load
DLP-U183 Revert to Protect Load

Note To perform a supported (non-service-affecting) revert from Software R6.0, the release you want to revert 
to must have been working at the time you activated to Software R6.0 on that node. Also, a supported 
revert automatically restores the node configuration at the time of the previous activation. Thus, any 
configuration changes made after activation will be lost when you revert the software. The exception to 
this is when you have downloaded Release 6.0 a second time, to ensure that no actual revert to a previous 
load can take place. In this latter case, the revert will occur, but will not be traffic affecting and will not 
change you database.

Step 1 From the node view, click the Maintenance > Software tabs.

Step 2 Verify that the protect software displays the release you upgraded from.

Step 3 Click Revert. Revert activates the protect software and restores the database from the previous load. A 
dialog box asks you to confirm the choice.

Step 4 Click Yes. This begins the revert. CTC drops the connection to the node and takes you to the network 
view, displaying a confirmation dialog box.

Step 5 Click OK and wait until the software revert finishes before continuing.

Note The system reboot might take up to 4 minutes to complete.

Step 6 Wait one minute before reverting another node.

Step 7 After reverting all of the nodes in the network, close and restart your Netscape or Internet Explorer 
browser and log back into the last node that was reverted. This uploads the appropriate CTC applet to 
your workstation.

Note It might also be necessary to delete cached files from your browser’s directory or from the TEMP 
directory on your MS Windows workstation. If you have trouble reconnecting to CTC, see the 
“DLP-U216 Delete Cached JAR Files” task on page 10.

Step 8 Return to your originating procedure (NTP).

Purpose This task reverts to the software you were running prior to the last 
activation and to restore your database to the provisioning you had prior to 
the activation.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures NTP-U137 Prepare for Upgrade to Release 6.0, page 3
NTP-U138 Back Up the Software Database, page 4
NTP-U139 Upgrade to Software R6.0, page 5 

Required/As Needed Required for revert

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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DLP-  U184 Manually Restore the Database
DLP-U184 Manually Restore the Database

Caution Do not perform these steps unless the software revert failed.

Caution This process is service affecting and should be performed during a maintenance window.

Step 1 In the CTC node view, click the Maintenance > Database tabs.

Step 2 Click Restore. The Open dialog box appears.

Step 3 Select the previously saved file and choose Open.

The database will be restored and the 15310-CL-CTX card will reboot.

Step 4 When the 15310-CL-CTX card has rebooted, log back into CTC and verify that the database is restored.

Wait one minute before restoring the next node.

Step 5 You have now completed the manual database backup.

Step 6 Return to your originating procedure (NTP).

Related Documentation

Release-Specific Documents
• Release Notes for Cisco ONS 15310-CL, Release 6.0

• Release Notes for Cisco ONS 15454 SDH, Release 6.0

• Release Notes for Cisco ONS 15454, Release 6.0

• Release Notes for Cisco ONS 15600, Release 6.0

• Release Notes for Cisco ONS 15327, Release 6.0

Platform-Specific Documents
• Cisco ONS 15310-CL Procedure Guide, Release 5.0

Purpose This task manually restores the database. If you were unable to perform a 
revert successfully and need to restore the database, perform this task.

Tools/Equipment PC or UNIX workstation

Prerequisite Procedures DLP-U183 Revert to Protect Load, page 13

Required/As Needed As needed

Onsite/Remote Onsite or remote (but in the presence of the workstation)

Security Level Superuser
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  Obtaining Optical Networking Information
• Cisco ONS 15310-CL Reference Manual, Release 5.0

• Cisco ONS 15310-CL Troubleshooting Guide, Release 5.0

• Cisco ONS 15310-CL Ethernet Card Software Feature and Configuration Guide, Release 5.0

• Cisco ONS SONET TL1 Command Guide

Obtaining Optical Networking Information
This section contains information that is specific to optical networking products. For information that 
pertains to all of Cisco, refer to the Obtaining Documentation and Submitting a Service Request section.

Where to Find Safety and Warning Information
For safety and warning information, refer to the Cisco Optical Transport Products Safety and 
Compliance Information document that accompanied the product. This publication describes the 
international agency compliance and safety information for the Cisco ONS 15454 system. It also 
includes translations of the safety warnings that appear in the ONS 15454 system documentation.

Cisco Optical Networking Product Documentation CD-ROM
Optical networking-related documentation, including Cisco ONS 15xxx product documentation, is 
available in a CD-ROM package that ships with your product. The Optical Networking Product 
Documentation CD-ROM is updated periodically and may be more current than printed documentation.

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What's New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation, at: 

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What's New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a 
free service and Cisco currently supports RSS version 2.0.
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  Obtaining Documentation and Submitting a Service Request
This document is to be used in conjunction with the documents listed in the “Related Documentation” section.
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