Cisco 3900 Series, 2900 Series, and 1900 Series Software Configuration Guide
Configuring Backup Data Lines and Remote Management
Downloads: This chapterpdf (PDF - 430.0KB) The complete bookPDF (PDF - 3.29MB) | Feedback

Table Of Contents

Configuring Backup Data Lines and Remote Management

Configuring Backup Interfaces

Configuring the Backup Interface

Configuring Gigabit Ethernet Failover Media

Assigning Primary and Secondary Failover Media

Enabling Auto-Detect

Configuring Cellular Dial-on-Demand Routing Backup

Configuring DDR Backup Using Dialer Watch

Configuring DDR Backup Using Floating Static Route

Cellular Wireless Modem as Backup with NAT and IPSec Configuration

Configuring Dial Backup and Remote Management Through the Console Port or Auxiliary Port

Configuring Data Line Backup and Remote Management Through the ISDN S/T Port

Configuring ISDN Settings

Example

Configuring Third-Party SFPs

Examples


Configuring Backup Data Lines and Remote Management


Cisco 3900 series, Cisco 2900 series, and Cisco 1900 series integrated services routers (ISRs) support remote management and backup data connectivity by means of ISDN.

The following sections describe how to configure backup data lines and remote management:

Configuring Backup Interfaces

Configuring Dial Backup and Remote Management Through the Console Port or Auxiliary Port

Configuring Data Line Backup and Remote Management Through the ISDN S/T Port

Configuring Third-Party SFPs

Configuring Backup Interfaces

This section contains the following topics:

Configuring the Backup Interface

Configuring Gigabit Ethernet Failover Media

Configuring Cellular Dial-on-Demand Routing Backup

Configuring the Backup Interface

When the router receives an indication that the primary interface is down, the backup interface is enabled. After the primary connection is restored for a specified period, the backup interface is disabled.


Note For dial-on-demand routing (DDR) backup, even if the backup interface comes out of standby mode, the router does not enable the backup interface unless the router receives the traffic specified for that backup interface.


To configure the router with a backup interface, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. interface type number

2. backup interface interface-type interface-number

3. backup delay enable-delay disable-delay

4. exit

DETAILED STEPS

 
Command
Purpose

Step 1 

interface type number

Example:

Router(config)# interface atm 0/0/0

Router(config-if)#

Enters interface configuration mode for the interface for which you want to configure backup.

The example shows configuration of a backup interface for an ATM WAN connection.

Step 2 

backup interface interface-type interface-number

Example:

Router(config-if)# backup interface bri 0/0/1

Router(config-if)#

Assigns an interface as the secondary or backup interface.

This can be a serial interface or an asynchronous interface. For example, a serial 1 interface could be configured to back up a serial 0/2/1 interface.

The example shows a BRI interface configured as the backup interface for the ATM 0/0/0 interface.

Step 3 

backup delay enable-delay disable-delay

Example:

Router(config-if)# backup delay enable delay

Specifies the delay between the physical interface going down and the backup interface being enabled, and the delay between the physical interface coming back up and the backup interface being disabled.

Step 4 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits configuration interface mode.

Configuring Gigabit Ethernet Failover Media

Cisco 2921, Cisco 2951, and Cisco 3900 Series routers provide a Gigabit Ethernet (GE) small-form-factor pluggable (SFP) port that supports copper and fiber concurrent connections. Media can be configured for failover redundancy when the network goes down.


Note Do not connect back-to-back Cisco 2921, Cisco 2951, or Cisco 3900 Series routers with failover or as auto-detect configured. This is not a supported configuration and the behavior is unpredictable.


Assigning Primary and Secondary Failover Media

To assign primary and secondary failover media on the GE-SFP port, follow these steps, beginning in EXEC mode.

SUMMARY STEPS

1. configure terminal

2. interface gigabitethernet slot/port

3. media-type sfp

4. media-type sfp auto-failover

5. end

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

Router> enable

Router# configure terminal

Router(config)#

Enters global configuration mode, when using the console port.

Use the following commands to connect to the router with a remote terminal:

telnet router name or address

Login: login id

Password: *********

Router> enable

Step 2 

interface gigabitethernet slot/port

Example:

Router(config)# interface gigabitethernet 0/1

Router(config-if)#

Enters interface configuration mode.

Step 3 

media-type sfp

Example:

Router(config-if)# media-type sfp

Router(config-if)#

Example:

Router(config-if)# media-type rj45

Router(config-if)#

Designates SFP port as the primary media.

OR

Designates RJ-45 as the primary media.

Step 4 

media-type sfp auto-failover

Example:

Router(config-if)# media-type sfp auto-failover

Router(config-if)#

Example:

Router(config-if)# media-type rj45 auto-failover

Router(config-if)#

Configures the port with SFP as the primary media for automatic failover from SFP to RJ-45.

OR

Configures the port with RJ-45 as the primary media for automatic failover from RJ-45 to SFP.

Step 5 

end

Exits to global configuration mode.

Enabling Auto-Detect

The Auto-Detect feature is enabled if media-type is not configured. This feature automatically detects which media is connected and links up. If both media are connected, whichever media comes up first is linked up.


Note The Auto-Detect feature only works with 1 GigE SFPs. This feature does not detect 100M SFPs.


Use the no media-type command in interface configuration mode to enable the Auto-Detect feature.

To configure the Auto-Detect feature, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. configure terminal

2. interface gigabitethernet slot/port

3. no media-type

DETAILED STEPS

 
Command
Purpose

Step 1 

configure terminal

Example:

Router# configure terminal

Router(config)#

Enters global configuration mode.

Step 2 

interface gigabitethernet slot/port

Example:

Router(config)# interface gigabitethernet 0/1

Router(config-if)#

Enters interface configuration mode.

Step 3 

no media-type

Example:

Router(config-if)# no media-type

GigabitEthernet0/1: Changing media to UNKNOWN.

You may need to update the speed and duplex settings for this interface.

Enables Auto-Detect. If a 1 GigE SFP is plugged in, set the speed as 1000 and duplex as full. An RJ45 connection only works with speed as 1000 and duplex as full. If a SFP is not plugged in, all speeds and duplexes are available for the RJ45 media.

Note Do not set speed as 100 or 10 and duplex as half if a 1 GigE SFP is plugged in. SFP behavior is unpredictable at these settings.

Configuring Cellular Dial-on-Demand Routing Backup

To monitor the primary connection and initiate the backup connection over the cellular interface when needed, the router can use one of the following methods:

Backup Interface—Backup interface stays in standby mode until the primary interface line protocol is detected as down; then the backup interface is brought up. See the "Configuring Backup Interfaces" section.

Dialer Watch—Dialer watch is a backup feature that integrates dial backup with routing capabilities. See the "Configuring DDR Backup Using Dialer Watch" section.

Floating Static Route—Route through the backup interface has an administrative distance that is greater than the administrative distance of the primary connection route and therefore is not in the routing table until the primary interface goes down. When the primary interface goes down, the floating static route is used. See the "Configuring DDR Backup Using Floating Static Route" section.

Cellular Wireless Modem—To configure the 3G wireless modem as backup with Network Address Translation (NAT) and IPSec on either Global System for Mobile Communications (GSM) or code division multiple access (CDMA) networks, see "Cellular Wireless Modem as Backup with NAT and IPSec Configuration" section.


Note You cannot configure a backup interface for the cellular interface or any other asynchronous serial interface.


Configuring DDR Backup Using Dialer Watch

To initiate dialer watch, you must configure the interface to perform dial-on-demand routing (DDR) and backup. Use traditional DDR configuration commands, such as dialer map, for DDR capabilities. To enable dialer watch on the backup interface and create a dialer list, use the following commands in interface configuration mode.

SUMMARY STEPS

1. configure terminal

2. interface type number

3. dialer watch group group-number

4. dialer watch-list group-number ip ip-address address-mask

5. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

6. ip access-list access list number permit ip source address

7. interface cellular 0

8. dialer string string

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode.

Step 2 

interface type number

Example:

Router (config)# interface ATM 0

Specifies the interface.

Step 3 

dialer watch-group group-number

Example:

Router(config-if)# dialer watch-group 2

Enables dialer watch on the backup interface.

Step 4 

dialer watch-list group-number ip ip-address address-mask

Example:

Router(config-if)# dialer watch-list 2 ip 10.4.0.254 255.255.0.0

Defines a list of all IP addresses to be watched.

Step 5 

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}>

Example:

Router(config)# dialer-list 2 protocol ip permit

Creates a dialer list for traffic of interest and permits access to an entire protocol.

Step 6 

ip access-list access-list-number permit ip-source-address

Example:

Router(config)# access list 2 permit 10.4.0.0

Defines traffic of interest.

Do not use the access list permit all command to avoid sending traffic to the IP network. This may result in call termination.

Step 7 

interface cellular 0

Example:

Router (config)# interface cellular 0

Specifies the cellular interface.

Step 8 

dialer string string

or

dialer group dialer-group-number

Example:

Router (config-if)# dialer string cdma *** cdma ***

Example:

Router (config-if)# dialer group 2 *** gsm ***

CDMA only—dialer string string specifies the dialer script. (The dialer script is defined by using the chat script command).

GSM only—dialer group dialer-group-number maps a dialer list to the dialer interface.

Configuring DDR Backup Using Floating Static Route

To configure a floating static default route on the secondary interface, use the following commands, beginning in global configuration mode.


Note Make sure you have IP classless enabled on your router.


SUMMARY STEPS

1. configure terminal

2. ip route network-number network-mask {ip address | interface} [administrative-distance] [name name]

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

configure terminal

Example:

Router# configure terminal

Enters global configuration mode from the terminal.

Step 2 

ip route network-number network-mask {ip-address | interface} [administrative-distance] [name name]

Example:

Router (config)# ip route 0.0.0.0 Dialer 2 track 234

Establishes a floating static route with the configured administrative distance through the specified interface.

A higher administrative distance should be configured for the route through the backup interface, so that the backup interface is used only when the primary interface is down.

Cellular Wireless Modem as Backup with NAT and IPSec Configuration

The following example shows how to configure the 3G wireless modem as backup with NAT and IPsec on either GSM or CDMA networks.


Note The receive and transmit speeds cannot be configured. The actual throughput depends on the cellular network service.


Router# sh run
Building configuration...
 
 
Current configuration : 5833 bytes
!
! Last configuration change at 18:26:15 UTC Wed Sep 30 2009
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
service-module wlan-ap 0 bootimage autonomous
!
no ipv6 cef
ip source-route
ip cef
!
!
ip multicast-routing 
!
ip dhcp pool miercom
   network 10.1.0.0 255.255.0.0
   default-router 10.1.0.254 
   dns-server 10.1.0.254 
!
ip dhcp pool wlan-clients
   network 10.9.0.0 255.255.0.0
   default-router 10.9.0.254 
   dns-server 10.9.0.254 
!
!
!
multilink bundle-name authenticated
!
chat-script gsm ""  "atdt*99#" TIMEOUT 180 "CONNECT"
chat-script cdma "" "atdt#777" TIMEOUT 180 "CONNECT"
!
!
license udi pid CISCO1941W-A/K9 sn FHH1249P016
!
!
archive
 log config
  hidekeys
!
redundancy
!
!
!
track 234 ip sla 1 reachability
! 
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface Wlan-GigabitEthernet0/0
 description Internal switch interface connecting to the embedded AP
 !
!
interface GigabitEthernet0/0
 ip address dhcp
 ip virtual-reassembly
 load-interval 30
 shutdown
 duplex auto
 speed auto
 !
!
interface wlan-ap0
 description Service module interface to manage the embedded AP
 ip address 192.168.1.1 255.255.255.0
 arp timeout 0
 no mop enabled
 no mop sysid
 !
!
interface GigabitEthernet0/1
 ip address 10.1.0.254 255.255.0.0
 ip nat inside
 ip virtual-reassembly
 shutdown
 duplex auto
 speed auto
 crypto ipsec client ezvpn hw-client-pri inside
 crypto ipsec client ezvpn hw-client inside
 !
!
interface Cellular0/0/0
 no ip address
 ip access-group 131 out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer in-band
 dialer pool-member 1
 dialer idle-timeout 0
 dialer-group 1
 no peer default ip address
 async mode interactive
 no ppp lcp fast-start
 ppp ipcp dns request
 ppp timeout retry 120
 ppp timeout ncp 30
 fair-queue 64 16 0
 !
 routing dynamic
!
interface ATM0/1/0
 no ip address
 no atm ilmi-keepalive
 no dsl bitswap
 !
!
interface ATM0/1/0.1 point-to-point
 ip virtual-reassembly
 pvc 0/35 
  pppoe-client dial-pool-number 2
 !
!
interface Vlan1
 ip address 10.9.0.254 255.255.0.0
 ip nat inside
 ip virtual-reassembly
 !
!
interface Dialer1
 ip address negotiated
 ip access-group 131 out
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer idle-timeout 0
 dialer string cdma
 dialer persistent
 dialer-group 1
 no peer default ip address
 no ppp lcp fast-start
 ppp chap hostname nousername
 ppp chap password 0 nopassword
 ppp ipcp dns request
 ppp timeout retry 120
 ppp timeout ncp 30
 fair-queue
 crypto ipsec client ezvpn hw-client
 !
!
interface Dialer2
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 load-interval 30
 dialer pool 2
 dialer idle-timeout 0
 dialer persistent
 dialer-group 2
 ppp authentication chap callin
 ppp chap hostname ciscoenzo2@sbcglobal.net
 ppp chap password 0 Enzo221
 ppp pap sent-username ciscoenzo2@sbcglobal.net password 0 Enzo221
 ppp ipcp dns request
 no cdp enable
 crypto ipsec client ezvpn hw-client-pri
 !
!
ip local policy route-map track-primary-if
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source route-map nat2cell interface Dialer1 overload
ip nat inside source route-map nat2dsl interface Dialer2 overload
ip route 0.0.0.0 0.0.0.0 Dialer2 track 234
ip route 0.0.0.0 0.0.0.0 Dialer1 253
!         
ip sla 1
 icmp-echo 128.107.248.247 source-interface Dialer2
 frequency 5
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 2 permit 10.1.0.0 0.0.255.255
access-list 100 deny   ip 10.1.0.0 0.0.0.255 10.4.0.0 0.0.0.255
access-list 100 permit ip any any
access-list 101 permit ip 10.0.0.0 0.255.255.255 any
access-list 101 permit ip host 1.1.1.1 any
access-list 102 permit icmp any host 128.107.248.247
access-list 131 deny   ip 10.0.0.0 0.255.255.255 any log-input
access-list 131 permit ip any any
dialer-list 1 protocol ip permit
dialer-list 2 protocol ip permit
!
no cdp run
 
 
!
!
!
route-map track-primary-if permit 10
 match ip address 102
 set interface Dialer2 Null0
!
route-map nat2dsl permit 10
 match ip address 101
 match interface Dialer2
!
route-map nat2cell permit 10
 match ip address 101
 match interface Dialer1
!
!
!
control-plane
 !
!
!
line con 0
 exec-timeout 0 0
line aux 0
line 0/0/0
 exec-timeout 0 0
 script dialer cdma
 login    
 modem InOut
 no exec
 transport input all
 transport output all
 autoselect ppp
 rxspeed 3100000
 txspeed 1800000
line 67
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 login
!
exception data-corruption buffer truncate
scheduler allocate 20000 1000
event manager applet pri_back 
 event track 234 state any
 action 2.0 cli command "clear ip nat trans forced"
!
end       
 
 
Router#

Configuring Dial Backup and Remote Management Through the Console Port or Auxiliary Port

When customer premises equipment, such as a Cisco 3900 series ISR, is connected to an ISP, an IP address is dynamically assigned to the router, or the IP address is assigned by the router peer through the centrally managed function. The dial backup feature can be added to provide a failover route in case the primary line fails. Cisco 3900 series ISRs can use the auxiliary port for dial backup and remote management.

Figure 1 shows the network configuration used for remote management access and for providing backup to the primary WAN line.

Figure 1 Dial Backup and Remote Management Through the Auxiliary Port

1

Cisco 3900 series router

A

Main WAN link; primary connection to Internet service provider

2

Modem

B

Dial backup; serves as a failover link for Cisco 3900 routers when primary line goes down

3

PC

C

Remote management; serves as dial-in access to allow changes or updates to Cisco IOS configurations


To configure dial backup and remote management on Cisco 3900 series, Cisco 2900 series, and Cisco 1900 series ISRs, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. ip name-server server-address

2. ip dhcp pool name

3. exit

4. chat-script script-name expect-send

5. interface type number

6. exit

7. interface type number

8. dialer watch-group group-number

9. exit

10. ip nat inside source {list access-list-number} {interface type number | pool name} [overload]

11. ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

12. access-list access-list-number {deny | permit} source [source-wildcard]

13. dialerwatch-list group-number {ip ip-address address-mask | delay route-check initial seconds}

14. line [aux | console | tty | vty] line-number [ending-line-number]

15. modem enable

16. exit

17. line [aux | console | tty | vty] line-number [ending-line-number]

18. flowcontrol {none | software [lock] [in | out] | hardware [in | out]}

DETAILED STEPS

 
Command
Purpose

Step 1 

ip name-server server-address

Example:

Router(config)# ip name-server 192.168.28.12

Router(config)#

Enters your ISP DNS IP address.

Tip You may add multiple server addresses if available.

Step 2 

ip dhcp pool name

Example:

Router(config)# ip dhcp pool 1

Router(config-dhcp)#

Creates a DHCP address pool on the router and enters DHCP pool configuration mode. The name argument can be a string or an integer.

Configure the DHCP address pool. For sample commands that you can use in DHCP pool configuration mode, see the "Example" section.

Step 3 

exit

Example:

Router(config-dhcp)# exit

Router(config)#

Exits DHCP pool configuration mode and enters global configuration mode.

Step 4 

chat-script script-name expect-send

Example:

Router(config)# chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT 5555102 T" TIMEOUT 45 CONNECT \c

Router(config)#

Configures a chat script for use in DDR to give commands for dialing a modem and for logging in to remote systems. The defined script is used to place a call over a modem connected to the PSTN.

Step 5 

interface type number

Example:

Router(config)# interface Async 1

Router(config-if)#

Creates asynchronous interface and enters configuration mode for the asynchronous interface.

Configure the asynchronous interface. For sample commands that you can use in asynchronous interface configuration mode, see the "Example" section.

Step 6 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits interface configuration mode and enters global configuration mode.

Step 7 

interface type number

Example:

Router(config)# interface Dialer 3

Router(config-if)#

Creates dialer interface and enters configuration mode for the dialer interface.

Step 8 

dialer watch-group group-number

Example:

Router(config-if)# dialer watch-group 1

Router(config-if)#

Specifies the group number for the dialer watch list.

Step 9 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits interface configuration mode and enters global configuration mode.

Step 10 

ip nat inside source {list access-list-number} {interface type number | pool name} [overload]

Example:

Router(config)# ip nat inside source list 101 interface Dialer 3 overload

Enables dynamic translation of addresses on the inside interface.

Step 11 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]}

Example:

Router(config)# ip route 0.0.0.0 0.0.0.0 22.0.0.2

Router(config)#

Sets the IP route to point to the dialer interface as a default gateway.

Step 12 

access-list access-list-number {deny | permit} source [source-wildcard]

Example:

Router(config)# access-list 1 permit 192.168.0.0 0.0.255.255 any

Defines an extended access list that indicates which addresses need translation.

Step 13 

dialerwatch-list group-number {ip ip-address address-mask | delay route-check initial seconds}

Example:

Router(config)# dialer watch-list 1 ip 22.0.0.2 255.255.255.255

Router(config)#

Evaluates the status of the primary link, based on the existence of routes to the peer. The address 22.0.0.2 is the peer IP address of the ISP.

Step 14 

line [aux | console | tty | vty] line-number [ending-line-number]

Example:

Router(config)# line console 0

Router(config-line)#

Enters configuration mode for the line interface.

Step 15 

modem enable

Example:

Router(config-line)# modem enable

Router(config-line)#

Switches the port from console port to auxiliary port function.

Step 16 

exit

Example:

Router(config-line)# exit

Router(config)#

Exits interface configuration mode.

Step 17 

line [aux | console | tty | vty] line-number [ending-line-number]

Example:

Router(config)# line aux 0

Router(config)#

Enters configuration mode for the auxiliary interface.

Step 18 

flowcontrol {none | software [lock] [in | out] | hardware [in | out]}

Example:

Router(config)# flowcontrol hardware

Router(config)#

Enables hardware signal flow control.

Example

The following configuration example specifies an IP address for the ATM interface through PPP and IP Control Protocol (IPCP) address negotiation and specifies dial backup over the console port.

!
ip name-server 192.168.28.12
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool 1
 import all
 network 192.168.1.0 255.255.255.0
 default-router 192.168.1.1
!
! Need to use your own correct ISP phone number.
modemcap entry MY-USER_MODEM:MSC=&F1S0=1
chat-script Dialout ABORT ERROR ABORT BUSY "" "AT" OK "ATDT 5555102\T"
TIMEOUT 45 CONNECT \c
!
!
!
!
interface vlan 1
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip tcp adjust-mss 1452
 hold-queue 100 out
!
! Dial backup and remote management physical interface.
interface Async1
 no ip address
 encapsulation ppp
 dialer in-band
 dialer pool-member 3
 async default routing
 async dynamic routing
 async mode dedicated
 ppp authentication pap callin
!
interface ATM0
 mtu 1492
 no ip address
 no atm ilmi-keepalive
 pvc 0/35
 pppoe-client dial-pool-number 1
!
dsl operating-mode auto
!
! Primary WAN link.
interface Dialer1
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp authentication pap callin
 ppp pap sent-username account password 7 pass
 ppp ipcp dns request
 ppp ipcp wins request
 ppp ipcp mask request
!
! Dialer backup logical interface.
interface Dialer3
 ip address negotiated
 ip nat outside
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 dialer pool 3
 dialer idle-timeout 60
 dialer string 5555102 modem-script Dialout
 dialer watch-group 1
!
! Remote management PC IP address.
peer default ip address 192.168.2.2
no cdp enable
!
! Need to use your own ISP account and password.
ppp pap sent-username account password 7 pass
ppp ipcp dns request
ppp ipcp wins request
ppp ipcp mask request
!
! IP NAT over Dialer interface using route-map.
ip nat inside source route-map main interface Dialer1 overload
ip nat inside source route-map secondary interface Dialer3 overload
ip classless
!
! When primary link is up again, distance 50 will override 80 if dial backup 
! has not timed out. Use multiple routes because peer IP addresses are alternated 
! among them when the CPE is connected.
ip route 0.0.0.0 0.0.0.0 64.161.31.254 50
ip route 0.0.0.0 0.0.0.0 66.125.91.254 50
ip route 0.0.0.0 0.0.0.0 64.174.91.254 50
ip route 0.0.0.0 0.0.0.0 63.203.35.136 80
ip route 0.0.0.0 0.0.0.0 63.203.35.137 80
ip route 0.0.0.0 0.0.0.0 63.203.35.138 80
ip route 0.0.0.0 0.0.0.0 63.203.35.139 80
ip route 0.0.0.0 0.0.0.0 63.203.35.140 80
ip route 0.0.0.0 0.0.0.0 63.203.35.141 80
ip route 0.0.0.0 0.0.0.0 Dialer1 150
no ip http server
ip pim bidir-enable
!
! PC IP address behind CPE.
access-list 101 permit ip 192.168.0.0 0.0.255.255 any
access-list 103 permit ip 192.168.0.0 0.0.255.255 any
!
! Watch multiple IP addresses because peers are alternated 
! among them when the CPE is connected.
dialer watch-list 1 ip 64.161.31.254 255.255.255.255
dialer watch-list 1 ip 64.174.91.254 255.255.255.255
dialer watch-list 1 ip 64.125.91.254 255.255.255.255
!
! Dial backup will kick in if primary link is not available 
! 5 minutes after CPE starts up.
dialer watch-list 1 delay route-check initial 300
dialer-list 1 protocol ip permit
!
! Direct traffic to an interface only if the dialer is assigned an IP address.
route-map main permit 10
 match ip address 101
 match interface Dialer1
!
route-map secondary permit 10
 match ip address 103
 match interface Dialer3
!
! Change console to aux function.
line con 0
 exec-timedout 0 0
 modem enable
 stopbits 1
line aux 0
 exec-timeout 0 0
 ! To enable and communicate with the external modem properly.
 script dialer Dialout
 modem InOut
 modem autoconfigure discovery
 transport input all 
 stopbits 1
 speed 115200
 flowcontrol hardware
line vty 0 4
 exec-timeout 0 0
 password cisco
 login
!
scheduler max-task-time 5000
end
 
 

Configuring Data Line Backup and Remote Management Through the ISDN S/T Port

This section contains the following topics:

Configuring ISDN Settings

Example

Cisco 3900 series routers can use the ISDN S/T port for remote management. Figure 2 and Figure 3 show two typical network configurations that provide remote management access and backup for the primary WAN line.

Figure 2 shows a dial backup link that goes through a customer premises equipment (CPE) splitter, a digital subscriber line access multiplexer (DSLAM), and a central office (CO) splitter before connecting to the ISDN switch.

Figure 2 Data Line Backup Through CPE Splitter, DSLAM, and CO Splitter

1

Cisco 3900 series router

A

Primary DSL interface, FE interface (Cisco 3900 series router)

2

DSLAM

B

Dial backup and remote management through the ISDN interface (ISDN S/T port); serves as a failover link when the primary line goes down

3

ATM aggregator

4

ISDN switch

5

ISDN

C

Provides administrator with remote management capability through the ISDN interface when the primary DSL link is down; serves as dial-in access to allow changes or updates to Cisco IOS configuration

6

ISDN peer router

7

Web server

8

Administrator

   

Figure 3 shows a dial backup link that goes directly from the router to the ISDN switch.

Figure 3 Data Line Backup Directly from Router to ISDN Switch

1

PC

A

Primary DSL interface

2

Cisco 3900 series ISR

B

Dial backup and remote management through the ISDN interface (ISDN S/T port); serves as a failover link when the primary line goes down

3

DSLAM

4

Aggregator

5

ISDN switch

C

Provides administrator with remote management capability through the ISDN interface when the primary DSL link is down; serves as dial-in access to allow changes or updates to Cisco IOS configuration

6

Web server

7

Administrator


Configuring ISDN Settings


Note Traffic of interest must be present in order to activate the backup ISDN line by means of the backup interface and floating static routes methods. Traffic of interest is not needed in order for the dialer watch to activate the backup ISDN line.


To configure your router ISDN interface for use as a backup interface, follow these steps, beginning in global configuration mode.

SUMMARY STEPS

1. isdn switch-type switch-type

2. interface type number

3. encapsulation encapsulation-type

4. dialer pool-member number

5. isdn switch-type switch-type

6. exit

7. interface dialer dialer-rotary-group-number

8. ip address negotiated

9. encapsulation encapsulation-type

10. dialer pool number

11. dialer string dial-string# [:isdn-subaddress]

12. dialer-group group-number

13. exit

14. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

DETAILED STEPS

 
Command
Purpose

Step 1 

isdn switch-type switch-type

Example:
Router(config)# isdn switch-type basic-net3
Router(config)#

Specifies the ISDN switch type.

The example specifies a switch type used in Australia, Europe, and the United Kingdom. For details on other supported switch types, see Cisco IOS Dial Technologies Command Reference.

Step 2 

interface type number

Example:
Router(config)# interface bri 0
Router(config-if)#

Enters configuration mode for the ISDN BRI.

Step 3 

encapsulation encapsulation-type

Example:
Router(config-if)# encapsulation ppp
Router(config-if)#

Sets the BRI0 interface encapsulation type.

Step 4 

dialer pool-member number

Example:
Router(config-if)# dialer pool-member 1
Router(config-if)#

Specifies the dialer pool membership.

Step 5 

isdn switch-type switch-type

Example:
Router(config-if)# isdn switch-type 
basic-net3
Router(config-if)#

Specifies the ISDN switch type.

Step 6 

exit

Example:
Router(config-if)# exit
Router(config)#

Exits interface configuration mode and enters global configuration mode.

Step 7 

interface dialer dialer-rotary-group-number

Example:
Router(config)# interface dialer 0
Router(config-if)#

Creates a dialer interface (numbered 0 to 255) and enters interface configuration mode.

Step 8 

ip address negotiated

Example:
Router(config-if)# ip address negotiated
Router(config-if)#

Specifies that the IP address for the interface is obtained through PPP/IPCP (IP Control Protocol) address negotiation. The IP address is obtained from the peer.

Step 9 

encapsulation encapsulation-type

Example:

Router(config-if)# encapsulation ppp

Router(config-if)#

Sets the encapsulation type for the interface.

Step 10 

dialer pool number

Example:

Router(config-if)# dialer pool 1

Router(config-if)#

Specifies the dialer pool to be used.

In the example, the dialer pool 1 setting associates the dialer 0 interface with the BRI0 interface because the BRI0 dialer pool-member value is 1.

Step 11 

dialer string dial-string# [:isdn-subaddress]

Example:

Router(config-if)# dialer string 384040

Router(config-if)#

Specifies the telephone number to be dialed.

Step 12 

dialer-group group-number

Example:

Router(config-if)# dialer group 1

Router(config-if)#

Assigns the dialer interface to a dialer group (1-10).

Step 13 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits dialer interface configuration mode and enters global configuration mode.

Step 14 

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

Example:

Router(config)# dialer-list 1 protocol ip permit

Router(config)#

Creates a dialer list for packets of interest to be forwarded through the specified interface dialer group.

In the example, dialer-list 1 corresponds to dialer-group 1.

For details about this command and additional parameters that can be set, see Cisco IOS Dial Technologies Command Reference.

Example

The following configuration example configures an aggregated and ISDN peer router.

The aggregator is typically a concentrator router where your Cisco router Asynchronous Transfer Mode (ATM) permanent virtual connection (PVC) terminates. In the following configuration example, the aggregator is configured as a PPP over Ethernet (PPPoE) server.

The ISDN peer router is any router that has an ISDN interface and can communicate through a public ISDN network to reach your Cisco router ISDN interface. The ISDN peer router provides Internet access for your Cisco router during the ATM network downtime.

 
 
! This portion of the example configures the aggregator.
vpdn enable
no vpdn logging
!
vpdn-group 1
 accept-dialin
 protocol pppoe
 virtual-template 1
!
interface Ethernet3
 description "4700ref-1"
 ip address 40.1.1.1 255.255.255.0
 media-type 10BaseT
!
interface Ethernet4
 ip address 30.1.1.1 255.255.255.0
 media-type 10BaseT
!
interface Virtual-Template1
 ip address 22.0.0.2 255.255.255.0
 ip mtu 1492
 peer default ip address pool adsl
!
interface ATM0
 no ip address
 pvc 1/40
 encapsulation aal5snap
 protocol pppoe
!
no atm limi-keepalive
!
ip local pool adsl 22.0.0.1
ip classless
ip route 0.0.0.0 0.0.0.0 22.0.0.1 50
ip route 0.0.0.0 0.0.0.0 30.1.1.2.80
 
 
! This portion of the example configures the ISDN peer.
isdn switch-type basic-net3
!
interface Ethernet0
 ip address 30.1.1.2 255.0.0.0 
!
interface BRI0
 description "to 836-dialbackup"
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-net3
!
interface Dialer0
 ip address 192.168.2.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer string 384020
 dialer-group 1
 peer default ip address pool isdn
!
ip local pool isdn 192.168.2.1
ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.2.1
ip route 40.0.0.0 255.0.0.0 30.1.1.1
dialer-list 1 protocol ip permit

Configuring Third-Party SFPs

Small Form-Factor Pluggables (SFPs) that are not Cisco certified are called third-party SFPs. Cisco approved means the SFPs have undergone rigorous testing with Cisco products and the SFPs are guaranteed to have 100% compatibility.

Third-party SFPs are manufactured by companies that are not on the Cisco-approved Vendor List (AVL). Currently, Cisco ISR G2 routers support only Cisco-approved SFPs. From Release 15.3(2)T, Cisco ISR G2 routers recognize third-party SFPs.


Note Cisco does not provide any kind of support for the third-party SFPs because they are not validated by Cisco.


Restrictions

Supports only 100BASE SFPs and 1000BASE SFPs under two speed configurations:

100 Mbps speed for 100BASE SFPs

1000 Mbps speed for 1000BASE SFPs

Only the following routers and modules support third-party SFPs:

Cisco 2921 Integrated Services Router

Cisco 2951 Integrated Services Router

Cisco 3900 Integrated Services Router

Cisco 3900E Series Integrated Services Routers

Cisco 892-F Gigabit Ethernet Security Router

Cisco 898-EA Gigabit Ethernet Security Router

EHWIC-1GE-SFP

SUMMARY STEPS

1. enable

2. configure terminal

3. service unsupported-transceiver

4. interface type slot/subslot/port number

5. media-type sfp

6. speed value

7. shutdown

8. no shutdown

9. exit

DETAILED STEPS

 
Command or Action
Purpose

Step 1 

enable

Example:

Router> enable

Enables the privileged EXEC mode.

Enter your password if prompted.

Step 2 

configure terminal

Example:

Router# configure terminal

Enters the global configuration mode.

Step 3 

service unsupported-transceiver

Example:

Router(config)# service unsupported-transceiver

Enables third-party SFP support.

Step 4 

interface type slot/subslot/port number

Example:

Router(config)# interface ethernet 0/3/0

Selects an interface to configure.

Step 5 

media-type sfp

Example:

Router(config-if)# media-type sfp

Changes media type to SFP.

Step 6 

speed value

Example:

Router(config-if)# speed 100

Configures the speed of the interface.

Note For 100BASE SFPs, configure the speed to 100 Mbps only. Similarly, for 1000BASE SFPs, configure the speed to 1000 Mbps only.

Step 7 

shutdown

Example:

Router(config-if)# shutdown

Disables the interface, changing its state from administratively UP to administratively DOWN.

Step 8 

no shutdown

Example:

Router(config-if)# no shutdown

Enables the interface, changing its state from administratively DOWN to administratively UP.

Step 9 

exit

Example:

Router(config-if)# exit

Router(config)#

Exits the configuration mode and returns the global configuration mode.


Examples

This example shows how to configure a third-party SFP on a Cisco ISR G2 Series Router:

Router# configure terminal 
Router(config-if)# service unsupported-transceiver
Router(config)# interface ethernet 0/3/0
Router(config-if)# media-type sfp
Router(config-if)# speed 100
Router(config-if)# shutdown 
Router(config-if)# no shutdown
Router(config-if)# exit
Router(config)# exit