Guest

Cisco IOS Software Releases 12.4 T

Multiple PPPoE Client

  • Viewing Options

  • PDF (125.1 KB)
  • Feedback
Multiple PPPoE Client

Table Of Contents

Multiple PPPoE Client

Configuration Information

Command Reference Information

Master Commands Lists

pppoe-client dial-pool-number


Multiple PPPoE Client


Prior to Cisco IOS Release 12.4(15)T, one ATM PVC supported one PPPoE client. With the introduction of the Multiple PPPoE Client feature in Cisco IOS Release 12.4(15)T, one ATM PVC supports multiple PPPoE clients, allowing second line connection and redundancy. Multiple PPPoE clients can run concurrently on different PVCs, but each PPPoE client must use a separate dialer interface and a separate dialer pool.

Configuration Information

Configuration information is included in the "PPP Over Ethernet Client" module of the Cisco IOS Broadband and DSL Configuration Guide, Release 12.4T.

The following sections provide information about this feature:

Restrictions for PPPoE Client

PPPoE Client Support on ATM PVCs and Ethernet Interfaces

Configuring a PPPoE Client on an ATM PVC

PPPoE Client in Cisco IOS Release 12.2(13)T and Later Releases: Examples

For a complete list of features included in the "PPPover Ethernet Client" module, see the Feature Information table located toward the end of the module.

Command Reference Information

Release 12.4(15)T

The following commands are new or modified for this feature:

pppoe-client dial-pool-number

Detailed information about these commands is included in the Cisco IOS Broadband Access Aggregation and DSL and Command Reference.

Master Commands Lists

Cisco IOS master commands lists provide an alphabetical list of all Cisco IOS commands in a Cisco IOS release.

Cisco IOS new, modified, removed, and replaced commands lists provide an alphabetized list of all new, modified, removed, and replaced commands in a Cisco IOS release.

Release 12.4T

Cisco IOS Master Commands List, Release 12.4T, at the following URL:

http://www.cisco.com/en/US/docs/ios/mcl/124tmcl/124t_book.html

Cisco IOS New, Modified, Removed, and Replaced Commands List, Release 12.4T, at the following URL:

http://www.cisco.com/univercd/cc/td/doc/product/software/ios124/124mindx/124htnml.htm

pppoe-client dial-pool-number

To configure a PPP over Ethernet (PPPoE) client and to specify dial-on-demand routing (DDR) functionality, use the pppoe-client dial-pool-number command in either interface configuration mode or ATM virtual circuit configuration mode. To disable any configured functionality, use the no form of this command.

pppoe-client dial-pool-number number [dial-on-demand]

no pppoe-client dial-pool-number number [dial-on-demand]

Syntax Description

number

Unique number of a dialer pool configured with the dialer-group dialer interface command.

dial-on-demand

(Optional) Enables DDR functionality for the PPPoE connection.


Defaults

A PPPoE client is not configured, and DDR functionality is disabled.

Command Modes

Interface configuration
ATM virtual circuit configuration

Command History

Release
Modification

12.1(3)XG

This command was introduced.

12.2(2)T

This command was integrated into Cisco IOS Release 12.2(2)T.

12.2(13)T

The dial-on-demand keyword was added to allow the configuration of DDR interesting traffic control list functionality.

12.2(28)SB

This command was integrated into Cisco IOS Release 12.2(28)SB.

12.4(15)T

This command was integrated into Cisco IOS Release 12.4(15)T and PPPoE client functionality was modified to support multiple clients on a single ATM PVC.


Usage Guidelines

One permanent virtual circuit (PVC) support s multiple PPPoE clients, enabling second line connection and redundancy. Use this command to configure one or more concurrent client PPPoE sessions on a single ATM PVC.

Use this command to configure dial-on-demand routing (DDR) interesting traffic control list functionality of the dialer interface with a PPP over Ethernet (PPPoE) client. When the DDR functionality is configured for this command, the following DDR commands must also be configured: dialer-group, dialer hold-queue, dialer idle-timeout, and dialer-list.

Tips for Configuring the Dialer Interface

If you are configuring a hard-coded IP address under the dialer interface, you can configure a default IP route using the ip route command as follows:

ip route 0.0.0.0 0.0.0.0 dialer1

But if you are configuring a negotiated IP address using the ip address negotiated command under the dialer interface, you must configure a default IP route using the ip route command as follows:

ip route 0.0.0.0 0.0.0.0 dialer1 permanent

The reason is that the dialer interface will lose its IP address when a PPPoE session is brought down (even if the dialer does not go down), and hence the route removal routine will take effect and remove all IP routes pointed at the dialer interface, even the default IP route. Although the default IP route will be added back about one minute later by IP background processes, you may risk losing incoming packets during the interval.

Examples

Multiple PPPoE Clients on an ATM PVC

The following example shows how to configure multiple PPPoE clients on a single ATM PVC:

interface ATM0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 4/20
  pppoe-client dial-pool-number 1
  pppoe-client dial-pool-number 2

PPPoE Client DDR Idle-Timer on an Ethernet Interface

The following example shows how to configure the PPPoE client DDR idle-timer on an Ethernet interface and includes the required DDR commands:

!
vpdn enable
no vpdn logging
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
interface Ethernet1
 pppoe enable
 pppoe-client dial-pool-number 1 dial-on-demand
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 180 either
 dialer hold-queue 100
 dialer-group 1
!
dialer-list 1 protocol ip permit
!         
ip route 0.0.0.0 0.0.0.0 Dialer1

PPPoE Client DDR Idle-Timer on an ATM PVC

The following example shows how to configure the PPPoE client DDR idle-timer on an ATM PVC interface and includes the required DDR commands:

!
vpdn enable
no vpdn logging
!
vpdn-group 1
 request-dialin
  protocol pppoe
!
interface ATM2/0
 pvc 2/100 
  pppoe-client dial-pool-number 1 dial-on-demand
!
interface Dialer1
 ip address negotiated
 ip mtu 1492
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 180 either
 dialer hold-queue 100
 dialer-group 1
!
dialer-list 1 protocol ip permit
!         
ip route 0.0.0.0 0.0.0.0 Dialer1

Related Commands

Command
Description

debug ppp negotiation

Displays LCP and NCP session neotiations.

debug vpdn pppoe-data

Displays PPPoE session data packets.

debug vpdn pppoe-errors

Displays PPPoE protocol errors that prevent a session from being established or errors that cause an established session to be terminated.

debug vpdn pppoe-events

Displays PPPoE protocol messages about events that are part of normal session establishment or shutdown.

debug vpdn pppoe-packets

Displays each PPPoE protocol packet exchanged.

dialer-group

Controls access by configuring a virtual access interface to belong to a specific dialing group.

dialer hold-queue

Allows interesting outgoing packets to be queued until a modem connection is established.

dialer idle-timeout

Specifies the idle time before the line is disconnected.

dialer-list

Defines a DDR dialer list to control dialing by protocol or by a combination of protocol and an access list.

show pppoe session

Displays information about currently active PPPoE sessions.



Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses in illustrative content is unintentional and coincidental.

© 2007 Cisco Systems, Inc. All rights reserved.