ISDN Voice Configuration Guide, Cisco IOS Release 15M&T
Integrated Data and Voice Services for ISDN PRI Interfaces on Multiservice Access Routers
Downloads: This chapterpdf (PDF - 1.51MB) The complete bookPDF (PDF - 4.43MB) | The complete bookePub (ePub - 1.38MB) | Feedback

Integrated Data and Voice Services for ISDN PRI Interfaces on Multiservice Access Routers

Contents

Integrated Data and Voice Services for ISDN PRI Interfaces on Multiservice Access Routers

This chapter describes how to configure ISDN PRI interfaces to support the integration of data and voice calls on multiservice access routers. This feature enables data (dial-in, dial-on-demand routing [DDR], and DDR backup) and voice call traffic to occur simultaneously from the supported ISDN PRI interfaces. You can also enable multilevel precedence and preemption (MLPP) for DDR calls over the active voice call when no idle channel is available during the DDR call setup.

Feature History for Integrated Data and Voice Services for ISDN PRI Interfaces

Release

Modification

12.4(4)XC

This feature was introduced.

12.4(9)T

This feature was integrated into Cisco IOS Release 12.4(9)T.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for Integrated Data and Voice Services for ISDN PRI Interfaces

  • Establish a working H.323 or SIP network for voice calls.
  • Ensure that you have a Cisco IOS image that supports this feature. Access Cisco Feature Navigator at http:/​/​www.cisco.com/​go/​cfn .
  • Perform basic ISDN PRI voice configuration, including dial-on demand routing (DDR) configuration for data calls. For more information, see Configuring ISDN PRI Voice-Interface Support.
  • To support PRI data calls, a VWIC-1MFT-E1 voice cards must have a packet voice data module (PVDM).

Supported Modules

  • This feature supports the following modules:
    • NM-HD
    • NM-HDV2
    • Onboard DSPs
  • This feature supports the following voice cards:
    • VWIC-XMFT-X interface modules
    • VWIC2-XMFT-X interface modules

Note


Data calls are supported only on the NM-HDV2-2T1/E1 and NM-HD-2V-E network modules, and the VWIC-2MFT-E1, VWIC-2MFT-T1 and VWIC2-T1/E1 voice cards.


Use the isdn switch-type ? command in interface configuration mode or global configuration mode to view the list of supported ISDN switch types. See the following example:

Router(config)# isdn switch-type ?
  primary-4ess    Lucent 4ESS switch type for the U.S.
  primary-5ess    Lucent 5ESS switch type for the U.S.
  primary-dms100  Northern Telecom DMS-100 switch type for the U.S.
  primary-dpnss   DPNSS switch type for Europe
  primary-net5    NET5 switch type for UK, Europe, Asia and Australia
  primary-ni      National ISDN Switch type for the U.S.
  primary-ntt     NTT switch type for Japan
  primary-qsig    QSIG switch type
  primary-ts014   TS014 switch type for Australia (obsolete)

Restrictions for Integrated Data and Voice Services for ISDN PRI Interfaces

  • This feature is supported only on C5510 DSP-based platforms.
  • ISDN backhaul is not supported.
  • This feature does not support modem calls.
  • For platforms that support HDLC resources on the motherboard, the available on board HDLC resources are limited to 31 if all resources are not enabled.
  • The Cisco 2801 platform does not support full channelized data or full integrated data and voice over T1/E1 PRI interfaces. However, data back up through one PRI channel, or one group of PRI channels for data backup, is supported on this platform.
  • Only PPP with multilink is supported for multiple channels. HDLC is not supported for multiple channels.
  • You can either configure ds0-groups or pri-groups on one controller, but not both. You receive a message, as in the following example:
Router(config-controller)#ds0-group 19 timeslots 20 type e&m-imme$9 timeslots 20 type e&m-immediate-start 
%A pri-group was configured already. Please remove it to configure a ds0-group
  • The following calls are not preempted by a DDR call:
    • Calls from a T.37 store-and-forward off-ramp gateway
    • Incoming ISDN calls
  • This feature is not supported from a BRI interface.
  • The following dialer commands are not supported with the integrated data and voice feature:
    • dialer aaa
    • dialer callback-secure
    • dialer callback-server
    • dialer dns
    • dialer order
    • dialer persistent
    • dialer redial
    • dialer vpdn
    • dialer watch-disable
    • dialer watch-group
    • dialer watch-list
    • dialer watch-list delay

Information About Integrated Data and Voice Services for ISDN PRI Interfaces

An ISDN serial interface configured for integrated mode supports data and voice calls using incoming call type checking to accept incoming voice and data calls when an inbound voice dial peer is matched.

The call type of an incoming call is determined using the incoming dial-peer. For data dial peer matching, the called number of an incoming call is used to match the incoming called-number of POTS dial peers.

Enabling integrated services allows data and voice call traffic to occur from ISDN PRI interfaces simultaneously.

When an interface is in integrated service mode:

  • ISDN performs calltype checking for the incoming call. The call is rejected by ISDN if no voice or data dial peer is matched for an incoming call.
  • The voice option for the isdn incoming-voice command, which treats incoming calls as voice calls, is not available.

By default, the integrated service option is disabled from the supported interfaces.

After an ISDN interface is assigned to a trunk group, you can configure maximum incoming and outgoing calls based on the call type (voice or data) or direction (inbound or outbound) through the trunk group.

When the isdn integrate calltype allcommand is removed from the interface, the isdn incoming-voice voicesetting is restored and the interface returns to voice mode.

This feature adds support for multilevel precedence and preemption (MLPP) for dial-on-demand routing (DDR) backup calls over outgoing voice calls.

Precedence designates the priority level that is associated with a call. Preemption designates the process of terminating lower-precedence calls so that a call of higher precedence can be extended. DDR backup is used to provide backup to a WAN link using any DDR or a dial-capable interface, like ISDN PRI interfaces.

From the gateway, voice and DDR backup calls are controlled by different entities.

  • The preemption level of an outgoing voice call is determined using the selected outbound POTS dial peer.
  • The preemption level of a DDR backup call is determined using the dialer map class.

A DDR backup call with higher precedence preempts the active outgoing voice call with a lower precedence if the idle B channel is not available from a trunk group during the DDR backup call setup. If MLPP is not configured, data calls wait for a free channel.

A trunk group is used as a common channel resource pool for idle channel allocation for outgoing voice calls and DDR backup calls. Multiple ISDN PRI interfaces that have been configured for integrated services are assigned to this trunk group to build up a channel resource pool for both voice and data calls. Enabling preemption on the trunk group allows DDR call preemption over a voice call per trunk group.

The tone timer defines the expiry timer for the preemption tone for the outgoing voice call, which is being preempted by a DDR backup call. When the tone timer expires, the call is disconnected.

During dial-on-demand routing (DDR) call setup, an idle B channel is selected from the trunk group. The trunk group and preemption level are configured as part of a map class, which can be attached to a dialer map or dialer string. By default, the preemption level of dialer calls is set to the lowest level (routine) to disable the MLPP service for a DDR call.

The trunk group preemption level is configured as part of a map class, which can be attached to a dialer map or dialer string.

  • For legacy DDR, configure the dialer interface to associate the class parameter with the dialer in-band and dialer map commands.
  • For dialer profiles, configure the dialer interface to associate the class parameter with the dialer pool and dialer string commands.

For TDM-only calls, or for calls that are hairpinned, the preemption tone is not heard as the DSPs are dropped. For this reason, you must disable TDM hairpinning on the voice card to use the MLPP DDR backup call preemption feature.

The preemption level of an outgoing voice call is defined from the outbound POTS dial peer. The preemption level defines the preemption priority level of an outgoing voice call.

ISDN call failures are most commonly attributed to dial-on-demand routing (DDR), ISDN layers 1, 2, and 3, and Point-to-Point Protocol (PPP), including link control protocol (LCP), Authentication, or IP Control Protocol (IPCP)-related issues.

Integrated Services for Multiple Call Types

ISDN interfaces can support both data calls and voice calls. Typically, this is done using one interface for data and another for voice. This feature enables data (dial-in, dial-on-demand routing [DDR], and DDR backup) and voice call traffic to occur simultaneously from the supported ISDN PRI interfaces. To enable integrated services, the interface used for incoming voice calls is configured to accept multiple voice call types.

The figure below shows an ISDN network configured for integrated data and voice services.

Figure 1. Integrated Voice with DDR Interface for WAN Failure Backup

Resource Allocation for Voice and Data Calls

Voice calls use DSP resources and data calls use HDLC resources for transmission. When an interface is configured for integrated services, the gateway allocates the HDLC resources dynamically during call setup and frees them back to the HDLC resource pools when the call terminates. This allows spare HDLC resources to support ISDN PRI data calls and DSP resources to support voice calls.

MLPP Call Preemption over Voice Calls

Multilevel precedence and preemption (MLPP) is the placement of priority calls through the network. Precedence designates the priority level that is associated with a call. Preemption designates the process of terminating lower-priority calls so that a call of higher precedence can be extended.

Preemption levels are assigned to outgoing voice calls and DDR backup calls. DDR backup is used to provide backup to a WAN link.

From the gateway, voice and DDR backup calls are controlled by different entities:

  • The preemption level of an outgoing voice call is determined using the selected outbound POTS dial peer.
  • The preemption level of a DDR backup call is determined using the dialer map class.

A trunk group is used as the common channel resource pool for outgoing voice call and DDR backup calls. Calls with a higher precedence preempt an active outgoing voice call, of a lower precedence, if an idle B channel is not available. An ISDN interface that is configured for integrated mode is assigned to this trunk group to allow dialer resources and voice resources to request an idle B channel from the same resource pool.

Preemption of Outgoing Voice Calls

The trunk group and preemption level are configured as part of a map class, which can be attached to a dialer map. The dialer map class supplies configuration parameters to dialer interfaces and can be referenced from multiple dialer interfaces.

During dial-on-demand routing (DDR) backup call setup, an idle B channel is selected from the trunk group. When no idle channel is found, the trunk group resource manager (TGRM) selects a B channel on the basis of the following:

  • The B channel currently active with a connected outgoing voice call
  • The preemption level of the connected voice call being lower than the preemption level of a DDR call

A guard timer, configured for the trunk group, is used to delay the idle channel notification and defer the DDR setup to allow the remote channel time to become ready and accept the incoming call with the higher precedence.

By default, the preemption level of dialer calls is set to the lowest level (routine) to disable the MLPP service for a DDR call.

The preemption level of an outgoing voice call is defined from the selected outbound POTS dial peer. During the voice call setup, the trunk group resource manager (TGRM) selects an idle B channel from a trunk group on the basis of the following:

  • The call ID of an outgoing voice call
  • The preemption level of an outgoing call as defined by the POTS dial peer
  • The voice interface B channel information of an outgoing voice call

When the preemption call notification is received, the TGRM saves the outgoing voice call to the preemption level link list based on FIFO.

Preemption Tones

When an outgoing voice call is preempted by a DDR backup call, the preemption call treatment starts by providing a preemption tone and starting the tone timer.

An MLPP preemption tone is a special tone played to the voice call announcing that the line is about to be seized by a call with a higher precedence. A steady tone, 1060 ms in duration, is played on all legs of the call until the user hangs up or the preemption tone times out.

  • For the telephony leg of the call, the preemption tone is played using the DSP.
  • For the IP leg (across the VoIP network) of the call, the preemption tone is played as media.
  • For the ephone leg on Cisco CME, a reorder tone is played for the local user and a preemption tone is played for the remote user.
Preemption Cause Codes

When the preemption tone timer is expired and the call is still in a connected state, both call legs are disconnected by the gateway with the following cause code:

Preemption - Circuit Reserved 0x8

If you release the call before the preemption tone timer expires, the following cause code is used:

Normal Call Clear 0x10

In both cases, the following internal cause code is used for the release calls:

Preemption Circuit Reserved 0x8

How to Configure Integrated Data and Voice Services for ISDN PRI Interfaces

Configuring the ISDN PRI Interface for Multiple Call Types

Perform the following tasks to configure integrated services:

Prerequisites

Unlike voice calls, which use DSP resources, data calls use HDLC resources for transmission. To use the integrated services feature, the gateway must allocate HDLC resources dynamically during call setup and free them back to the HDLC resource pools when the call terminates.

Use the following show commands to view the availability of HDLC resources:

  • show tdm connections

The following example shows HDLC resources on the TDM side.

Router# show tdm connections slot 0
              Active TDM connections for slot 0
              =================================
(Key: GT=FLEX TDM, V0=VWIC0, V1=VWIC1, V2=VWIC2, V3=VWIC3
      IC=EXPANSION, P0=PVDM0, P1=PVDM1, P2=PVDM2, P3=PVDM3
      HD=HDLC, BP=Backplane(AIM/NM))
V0:04/04-->HD:31/18, V0:04/06-->HD:31/06, V0:04/08-->HD:31/12
V0:04/10-->HD:31/36, V0:04/12-->HD:31/16, V0:04/14-->HD:31/10
V0:04/16-->HD:31/04, V0:04/18-->HD:31/14, V0:04/20-->HD:31/22
V0:04/22-->HD:31/20, V0:04/24-->HD:31/24, V0:04/26-->HD:31/30
V0:04/28-->HD:31/26, V0:04/30-->HD:31/32, V0:04/32-->HD:31/08
V0:04/34-->HD:31/34, V0:04/36-->HD:31/28, V0:04/38-->HD:31/38
V0:04/64-->HD:31/00, V0:04/66-->HD:31/02, HD:31/00-->V0:04/64
HD:31/02-->V0:04/66, HD:31/04-->V0:04/16, HD:31/06-->V0:04/06
HD:31/08-->V0:04/32, HD:31/10-->V0:04/14, HD:31/12-->V0:04/08
HD:31/14-->V0:04/18, HD:31/16-->V0:04/12, HD:31/18-->V0:04/04
HD:31/20-->V0:04/22, HD:31/22-->V0:04/20, HD:31/24-->V0:04/24
HD:31/26-->V0:04/28, HD:31/28-->V0:04/36, HD:31/30-->V0:04/26
HD:31/32-->V0:04/30, HD:31/34-->V0:04/34, HD:31/36-->V0:04/10
HD:31/38-->V0:04/38,
  • show controllers serial [slot/port

In the following example, the -1 listings under the hdlc_chan column show the free HDLC channels.

Router# show controllers Serial 1/1:0
Interface Serial1/1:0
Hardware is HDLC32
HDLC32 resource allocated to this interface:
Slot 1, Vic_slot 1, Port 1
CRC on 1, idle flags 1, frame inverted 0, clocking 0
Channel-group number 0, hdlc32 channel number 2
Channel-group bitfield 0x80000000, hdlc32 quad used 0x4
Channel HW state: 2
TX Ring:
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x0, descriptor: 0x102
data_ptr: 0x2DD1918C, descriptor: 0xB8830102
data_ptr: 0x0, descriptor: 0x102
RX Ring:
data_ptr: 0x2EE83E04, descriptor: 0x88800102
data_ptr: 0x2EE84064, descriptor: 0x88800102
data_ptr: 0x2EE842C4, descriptor: 0x88800102
data_ptr: 0x2EE84524, descriptor: 0x88800102
hdlc_chan hdlc_quad owner_idb chan chan_bitfield vic_slot port
========= ========= ========= ==== ============= ======== ====
0         1         65C03D5C  15   10000         1        0
1         2         65CB80F8  15   10000         1        1
2         4         67B862B0  0    80000000      1        1
3         8         65C7B1E4  1    40000000      1        1
4         10        67B8EDFC  2    20000000      1        1
5         20        65C83D30  3    10000000      1        1
6         40        67B97948  4    8000000       1        1
7         80        65C8C87C  5    4000000       1        1
8         100       67BA0494  6    2000000       1        1
9         200       65C953C8  7    1000000       1        1
-1        0         0         8    800000        1        1
-1        0         0         28   8             1        1
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0
-1        0         0         0    0             0        0

Configuring the POTS Dial-Peer Incoming Called Number

Use the following procedure to configure the POTS dial peer and incoming called number.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    dial-peer data tag pots

    4.    incoming called number string


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Router> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Router# configure terminal
     

    Enters global configuration mode.

     
    Step 3 dial-peer data tag pots


    Example:
    Router(config)# dial-peer data 100 pots
     

    Creates a data dial peer and enters data dial-peer configuration mode.

     
    Step 4 incoming called number string


    Example:
    Router(config-dial-peer)# incoming called number 4085550110
     

    For data dial-peer matching, only the called number of an incoming call is used to match the incoming called number of POTS dial peers. Wild cards are accepted.

    Note   

    The string must match the dialer string on the remote gateway.

     

    Configuring the Data Dial Peer Lookup Preference

    To optimize data or voice dial-peer searches for incoming ISDN calls, configure the preference of dial-peer lookup during the call type checking. Use the following procedure to configure a search for dial peers by type.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    dial-peer search type {data| none| voice} {data | voice}


    DETAILED STEPS
       Command or ActionPurpose
      Step 1 enable


      Example:
      Router> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Router# configure terminal
       

      Enters global configuration mode.

       
      Step 3 dial-peer search type {data| none| voice} {data | voice}


      Example:
      Router(config)# dial-peer search type data voice
       

      Configures the preference of voice or data dial-peer lookup during the calltype checking for incoming ISDN calls.

      • data --Search dial peers with type data first.
      • none --Search dial peers with any type at the same preference.
      • voice --Search dial peers with type voice first.

      By default, the data dial peer is searched first before voice dial peers.

       

      Enabling Integrated Services

      Use the following procedure to enable integrated mode on a serial interface.

      SUMMARY STEPS

        1.    enable

        2.    configure terminal

        3.    interface serial slot/port : timeslot

        4.    shutdown

        5.    isdn integrate calltype all

        6.    no shutdown


      DETAILED STEPS
         Command or ActionPurpose
        Step 1 enable


        Example:
        Router> enable
         

        Enables privileged EXEC mode.

        • Enter your password if prompted.
         
        Step 2 configure terminal


        Example:
        Router# configure terminal
         

        Enters global configuration mode.

         
        Step 3 interface serial slot/port : timeslot


        Example:
        Router(config)# interface serial 0/1:15
         

        Specifies a serial interface for ISDN PRI channel-associated signaling and enters interface configuration mode.

         
        Step 4 shutdown


        Example:
        Router(config-if)# shutdown
         

        Shuts down the interface.

         
        Step 5 isdn integrate calltype all


        Example:
        Router(config-if)# isdn integrate calltype all
         

        Enables the serial interface for integrated mode, which allows data and voice call traffic to occur simultaneously.

        Note   

        This configuration disables the voice option for the isdn incoming-voicecommand on the interface.

         
        Step 6 no shutdown


        Example:
        Router(config-if)# no shutdown
         

        Returns the interface to the active state.

         

        Creating a Trunkgroup and Configuring Maximum Calls Based on Call Type

        Use the following procedure to create a trunk group and configure maximum calls based on call type.


        Note


        If trunk groups are not configured, data and voice calls are treated as first-come first-served.


        SUMMARY STEPS

          1.    enable

          2.    configure terminal

          3.    trunk group name

          4.    max-calls {any | d at a| voice} number [direction [in | out]]


        DETAILED STEPS
           Command or ActionPurpose
          Step 1 enable


          Example:
          Router> enable
           

          Enables privileged EXEC mode.

          • Enter your password if prompted.
           
          Step 2 configure terminal


          Example:
          Router# configure terminal
           

          Enters global configuration mode.

           
          Step 3 trunk group name


          Example:
          Router(config)# trunk group 20
           

          Defines a trunk group and enters trunk group configuration mode.

          • name --Name of the trunk group. Valid names contain a maximum of 63 alphanumeric characters.
           
          Step 4 max-calls {any | d at a| voice} number [direction [in | out]]


          Example:
          Router(config-trunk-group)# max-calls data 100 direction out
           

          Defines the maximum number of dial-in or DDR data calls, or voice calls (incoming or outgoing) that can be accepted.

          • any --Assigns the maximum number of calls that the trunk group can handle, regardless of the call type.
          • data --Assigns the maximum number of data calls to the trunk group.
          • voice --Assigns the maximum number of voice calls to the trunk group.
          • number --Specifies number of allowed calls. Range is from 0 to 1000.
          • direction --(Optional) Specifies direction of calls.
          • in --(Optional) Allows only incoming calls.
          • out --(Optional) Allows only outgoing calls.
           
          Examples

          See the following sample configurations for the max-calls command:

          • This example configuration for trunk group 1 accepts up to a maximum of 7 dial-in data or DDR calls and places no restriction on voice calls:
          trunk group 1
           max-calls data 7
          
          • This sample configuration for trunk group 2 accepts up to a maximum of 2 data dial-in, 3 DDR calls, and 16 voice calls in any direction:
          trunk group 2
           max-calls data 2 direction in
           max-calls data 3 direction out
           max-calls voice 16
          
          • This sample configuration for trunk group 3 accepts up to a maximum of 10 incoming voice and dial-in data calls.
          trunk group 3
           max-calls any 10 direction in
          

          Disabling Integrated Services

          Use the following procedure to remove the integrated services option from the interface.

          1. enable
          2. configure terminal
          3. interface serial slot/port : timeslot
          4. shutdown
          5. no isdn integrate calltype all
          6. no shutdown
          SUMMARY STEPS

            1.    enable

            2.    configure terminal

            3.    interface serial slot/port : timeslot

            4.    shutdown

            5.    no isdn integrate calltype all

            6.    no shutdown


          DETAILED STEPS
             Command or ActionPurpose
            Step 1 enable


            Example:
            Router> enable
             

            Enables privileged EXEC mode.

            • Enter your password if prompted.
             
            Step 2 configure terminal


            Example:
            Router# configure terminal
             

            Enters global configuration mode.

             
            Step 3 interface serial slot/port : timeslot


            Example:
            Router(config)# interface serial 0/1:15
             

            Specifies a serial interface for ISDN PRI channel-associated signalling and enters interface configuration mode.

             
            Step 4 shutdown


            Example:
            Router(config-if)# shutdown
             

            Shuts down the interface.

             
            Step 5 no isdn integrate calltype all


            Example:
            Router(config-if)# no isdn integrate calltype all
             

            Disables the serial interface from being in integrated mode. You are prompted to confirm this command.

            Note   

            This configuration restores the voice option for the isdn incoming-voicecommand on the interface.

             
            Step 6 no shutdown


            Example:
            Router(config-if)# no shutdown
             

            Returns the interface to the active state.

             

            Configuring MLPP Call Preemption over Outgoing Voice Calls

            Perform the following tasks to configure call preemption:

            Enabling Preemption on the Trunk Group

            Use the following procedure to create a trunk group resource pool and enable preemption on the trunk group.


            Note


            If the trunk group channel resource pool is not shared between voice and DDR calls, you should not enable preemption on the trunk group.


            SUMMARY STEPS

              1.    enable

              2.    configure terminal

              3.    trunk group name

              4.    preemption enable

              5.    preemption tone timer seconds

              6.    preemption guard timer value


            DETAILED STEPS
               Command or ActionPurpose
              Step 1 enable


              Example:
              Router> enable
               

              Enables privileged EXEC mode.

              • Enter your password if prompted.
               
              Step 2 configure terminal


              Example:
              Router# configure terminal
               

              Enters global configuration mode.

               
              Step 3 trunk group name


              Example:
              Router(config)# trunk group 20
               

              Defines a trunk group and enters trunk group configuration mode.

              • name --Name of the trunk group. Valid names contain a maximum of 63 alphanumeric characters.
               
              Step 4 preemption enable


              Example:
              Router(config-trunk-group)# preemption enable
               

              Enables preemption capabilities on a trunk group.

               
              Step 5 preemption tone timer seconds


              Example:
              Router(config-trunk-group)# preemption tone timer 20
               

              Defines the expiry time for the preemption tone for the outgoing call being preempted by a DDR backup call.

              • seconds --Expiry time, in seconds. The range is 4 to 30. The default value is 10.
              Note   

              Use the default preemption tone timer command to change back to the default value and no preemption tone timer to disable the tone timer.

               
              Step 6 preemption guard timer value


              Example:
              Router(config-trunk-group)# preemption guard timer 60
               

              Defines the guard timer for the DDR call to allow time to clear the last call from the channel.

              • value --Guard timer, in milliseconds. The range is 60 to 500. When preemption is enabled on the trunk group, the default value is 60.
               

              Defining a Dialer Map Class and Setting the Preemption Level

              Use the following procedure to define a map class for the dialer interface.

              SUMMARY STEPS

                1.    enable

                2.    configure terminal

                3.    map-class dialer class-name

                4.    dialer trunkgroup label

                5.    dialer preemption level {flash-override | flash | immediate | priority | routine}


              DETAILED STEPS
                 Command or ActionPurpose
                Step 1 enable


                Example:
                Router> enable
                 

                Enables privileged EXEC mode.

                • Enter your password if prompted.
                 
                Step 2 configure terminal


                Example:
                Router# configure terminal
                 

                Enters global configuration mode.

                 
                Step 3 map-class dialer class-name


                Example:
                Router(config)# map-class dialer dial1
                 

                Defines a class of shared configuration parameters associated with the dialer map command for outgoing calls from an ISDN interface. The class name is a unique class identifier.

                • class-name --Unique class identifier.
                 
                Step 4 dialer trunkgroup label


                Example:
                Router(config-map-class)# dialer trunkgroup 20
                 

                Defines the dial-on-demand trunk group label.

                • label --Unique name for the dialer interface trunk group. Valid names contain a maximum of 63 alphanumeric characters.
                 
                Step 5 dialer preemption level {flash-override | flash | immediate | priority | routine}


                Example:
                Router(config-map-class)# dialer preemption level flash
                 

                Defines the preemption level of the DDR call on the dialer interface. The default is routine.

                • flash-override --Level 0 (highest)
                • flash --Level 1
                • immediate --Level 2
                • priority --Level 3
                • routine --Level 4 (lowest)
                 

                Associating the Class Parameter on the Dialer Interface

                Use the following procedure to associate the class parameter on the dialer interface.

                or

                dialer string dial-string class class-name

                SUMMARY STEPS

                  1.    enable

                  2.    configure terminal

                  3.    interface dialer dialer-rotary-group-number

                  4.    Do one of the following:

                  • dialer in-band [no-parity| odd-parity]
                  • dialer pool number

                  5.    Do one of the following:

                  • dialer map protocol-keyword protocol-next-hop-address [name host-name] [speed 56| speed 64] [broadcast] class dialer-map-class-name [dial-string[: isdn-subaddress]]
                  • dialer string dial-string [ class class name]


                DETAILED STEPS
                   Command or ActionPurpose
                  Step 1 enable


                  Example:
                  Router> enable
                   

                  Enables privileged EXEC mode.

                  • Enter your password if prompted.
                   
                  Step 2 configure terminal


                  Example:
                  Router# configure terminal
                   

                  Enters global configuration mode.

                   
                  Step 3 interface dialer dialer-rotary-group-number


                  Example:
                  Router(config)# interface dialer 10
                   

                  Defines a dialer rotary group.

                  • dialer-rotary-group-number-- Number of the dialer rotary group. The range is 0 to 255.
                   
                  Step 4Do one of the following:
                  • dialer in-band [no-parity| odd-parity]
                  • dialer pool number


                  Example:
                  Router(config-if)# dialer in-band


                  Example:
                  Router(config-if)# dialer pool 1
                   

                  Specifies that dial-on-demand routing (DDR) is to be supported on this interface.

                  • no-parity --(Optional) No parity is to be applied to the dialer string that is sent out to the modem on synchronous interfaces.
                  • odd-parity --(Optional) Dialed number has odd parity (7-bit ASCII characters with the eighth bit as the parity bit) on synchronous interfaces.

                  or

                  Specifies, for a dialer interface, which dialing pool to use to connect to a specific destination subnetwork.

                  • number --The dialing pool number. The range is 1 to 255.
                   
                  Step 5Do one of the following:
                  • dialer map protocol-keyword protocol-next-hop-address [name host-name] [speed 56| speed 64] [broadcast] class dialer-map-class-name [dial-string[: isdn-subaddress]]
                  • dialer string dial-string [ class class name]


                  Example:
                  Router(config-if)# dialer map ip 172.22.82.2 name gw3845 class dial1 20009


                  Example:
                  Router(config-if)# dialer string 4081234 class test
                   

                  Configures an ISDN interface to place a call to multiple sites and to authenticate calls from multiple sites.

                  • protocol-keyword protocol-next-hop-address --For ISDN services, you must use ip for the protocol-keyword.
                  • name host-name --(Optional) The remote system with which the local router or access server communicates. Used for authenticating the remote system on incoming calls. The host-name argument is a case-sensitive name or ID of the remote device. For routers with ISDN interfaces, if calling line identification--sometimes called CLID, but also known as caller ID and automatic number identification (ANI)--is provided, the host-name argument can contain the number that the calling line ID provides.
                  • speed 56 | speed 64--(Optional) Keyword and value indicating the line speed in kbps to use. Used for ISDN only. The default speed is 64 kbps.
                  • broadcast --(Optional) Forwards broadcasts to the address specified with the protocol-next-hop-address argument.
                  • class dialer-map-class-name--Dialer map class name.
                  • dial-string : isdn-subaddress ] --(Optional) Dial string (telephone number) sent to the dialing device when it recognizes packets with the specified address that matches the configured access lists, and the optional subaddress number used for ISDN multipoint connections. The colon is required for separating numbers. The dial string and ISDN subaddress, when used, must be the last item in the command line.

                  or

                  Specifies the string (telephone number) to be used when placing a call from an interface.

                  • dial-string --Telephone number to be sent to a DCE device.
                  • class class name --(Optional) Dialer map class associated with this telephone number.
                   
                  Examples
                  interface Dialer11
                   ip address 172.22.82.1 255.255.255.0
                   encapsulation ppp
                   dialer in-band
                   dialer map ip 172.22.82.2 name gw3845 class dial1 20009
                   dialer load-threshold 1 outbound
                   dialer-group 1
                   ppp callback accept
                   ppp authentication chap
                   ppp multilink
                   map-class dialer dial1
                   dialer trunkgroup 1
                   dialer preemption level flash-override
                  
                  interface Dialer10
                   ip address 192.168.254.1 255.255.255.0
                   dialer pool 1
                   dialer remote-name is2811
                   dialer string 4081234 class test
                   dialer-group 1
                  map-class dialer test
                   dialer trunkgroup 1
                   dialer preemption level flash-override
                  

                  Disabling TDM Hairpinning on the Voice Card

                  Use the following procedure to disable TDM hairpinning on the voice card.

                  SUMMARY STEPS

                    1.    enable

                    2.    configure terminal

                    3.    voice-card slot

                    4.    no local-bypass


                  DETAILED STEPS
                     Command or ActionPurpose
                    Step 1 enable


                    Example:
                    Router> enable
                     

                    Enables privileged EXEC mode.

                    • Enter your password if prompted.
                     
                    Step 2 configure terminal


                    Example:
                    Router# configure terminal
                     

                    Enters global configuration mode.

                     
                    Step 3 voice-card slot


                    Example:
                    Router(config)# voice-card 1
                     

                    Enters voice-card configuration mode to configure a voice card.

                    • slot --Slot number for the card to be configured.
                    Note   

                    Valid entries vary by router platform; enter the show voice port summary command for available values.

                     
                    Step 4 no local-bypass


                    Example:
                    Router(config-voicecard)# no local-bypass
                     

                    Disables TDM hairpinning.

                     

                    Configuring the POTS Dial Peer for Outgoing Voice Calls

                    Use the following procedure to set the preemption level for outgoing voice calls on a POTS dial peer.

                    SUMMARY STEPS

                      1.    enable

                      2.    configure terminal

                      3.    dial-peer voice tag pots

                      4.    trunkgroup name [preference-number]

                      5.    preemption level {flash-override | fla s h| immediate| priority| routine}


                    DETAILED STEPS
                       Command or ActionPurpose
                      Step 1 enable


                      Example:
                      Router> enable
                       

                      Enables privileged EXEC mode.

                      • Enter your password if prompted.
                       
                      Step 2 configure terminal


                      Example:
                      Router# configure terminal
                       

                      Enters global configuration mode.

                       
                      Step 3 dial-peer voice tag pots


                      Example:
                      Router(config)# dial-peer voice 25 pots
                       

                      Defines a particular dial peer, specifies the method of voice encapsulation, and enters dial-peer configuration mode.

                      • tag --Digits that define a particular dial peer. The range is from 1 to 2147483647.
                      • pots --Indicates that this is a POTS peer that uses VoIP encapsulation on the IP backbone.
                       
                      Step 4 trunkgroup name [preference-number]


                      Example:
                      Router(config-dial-peer)# trunkgroup 1
                       

                      Defines the trunk group associated with this dial peer.

                      • name --Label of the trunk group to use for the call. Valid trunk group names contain a maximum of 63 alphanumeric characters.
                      • preference-number --Preference or priority of the trunk group. Range is from 1 (highest priority) to 64 (lowest priority).
                       
                      Step 5 preemption level {flash-override | fla s h| immediate| priority| routine}


                      Example:
                      Router(config-dial-peer)# preemption level flash
                       

                      Sets the preemption level of the selected outbound dial peer. Voice calls can be preempted by a DDR call with a higher preemption level. The default is routine.

                      • flash-override --Level 0 (highest)
                      • flash --Level 1
                      • immediate --Level 2
                      • priority --Level 3
                      • routine --Level 4 (lowest)
                      Note   

                      The preemption level flash-override setting can prevent the call to be preempted by a DDR call.

                       

                      Troubleshooting Tips for Integrated Data and Voice Services

                      Use the following commands to troubleshoot integrated data and voice for ISDN interfaces:

                      • debug dialer events --Used to display debugging information about the packets received on a dialer interface.
                      • debug isdn q931 --Used to check outgoing dial-peer matching for an ISDN incoming call. Enable this command on both sides of the call. The output indicates whether the messages are generated by the calling party router (indicated by TX ->) or by the called party router (indicated by RX <-).
                      • debug tgrm inout --Used to check voice or DDR channel selection request and return status. From the output, you can determine what type of call enabled the preemption and which timeslot is selected from which trunkgroup.
                      • debug voip ccapi individual 146 --Used to troubleshoot the call control application programming interface (CCAPI) contents. The individual 146 command option is used to log call preemption indication information.
                      • debug voip ccapi inout --Used to show how a call flows through the system. From the output, you can see the call setup and teardown operations performed on both the telephony and network call legs.
                      • show call history voice | i Cause --Used to gather DisconnectCause information from the show call history voice command line display.
                      • show isdn active and show isdn status--Used to show the active data and voice calls.
                      • show trunk group --Used to check the preemption active or pending calls counter for MLPP preemption calls. The output shows the number of active channels from the trunkgroup and the current preemption levels. If a data call with a higher priority initiates the preemption of voice call, it is shown as pending against the higher priority preemption level.

                      Configuration Examples for Integrated Data and Voice Services for ISDN PRI Interfaces

                      MLPP DDR Backup Call Preemption over Voice Call Example

                      The following example shows that preemption is enabled on the trunk group, the trunk group is associated with a map class, and the preemption level is set on the dialer interface.

                      Router# show running-config
                      Building configuration...
                      Current configuration : 5984 bytes
                      !
                      version 12.3
                      service timestamps debug datetime msec
                      service timestamps log datetime msec
                      no service password-encryption
                      !
                      hostname Router
                      !
                      boot-start-marker
                      boot-end-marker
                      !
                      card type e1 0 3
                      no logging buffered
                      !
                      no aaa new-model
                      !
                      resource manager
                      !
                      network-clock-participate slot 1
                      network-clock-participate wic 3
                      ip subnet-zero
                      !
                      !
                      ip cef
                      no ip dhcp use vrf connected
                      !
                      ip dhcp pool ITS
                         network 10.0.0.0 255.255.0.0
                         option 150 ip 10.0.0.1
                         default-router 10.0.0.1
                      !
                      !
                      no ip domain lookup
                      ip name-server 192.168.2.87
                      ftp-server enable
                      no ftp-server write-enable
                      ftp-server topdir flash:/
                      isdn switch-type primary-ntt
                      !
                      !
                      trunk group 1 
                       max-calls data 10 direction out 
                       preemption enable 
                       preemption tone 4!
                      voice-card 0
                       dspfarm
                       no local-bypass
                      !
                      voice-card 1
                       dspfarm
                       no local-bypass
                      !
                      !
                      voice call send-alert
                      !
                      !
                      !
                      controller E1 0/3/0
                       clock source internal
                       pri-group timeslots 1-5,16
                       trunk-group 1 timeslots 1-5
                      !
                      controller E1 0/3/1
                       clock source internal
                       pri-group timeslots 1-2,16
                       trunk-group 1 timeslots 1-2
                      !
                      controller E1 1/0/0
                       clock source internal
                       pri-group timeslots 1-31
                       trunk-group 1 timeslots 1-31
                      !
                      controller E1 1/0/1
                       clock source internal
                       pri-group timeslots 1-10,16
                       trunk-group 1 timeslots 1-10
                      !
                      !
                      !
                      interface Loopback0
                       ip address 10.10.1.1 255.255.255.255
                      !
                      interface GigabitEthernet0/0
                       ip address 10.3.202.87 255.255.0.0
                       no ip proxy-arp
                       duplex auto
                       speed auto
                      !
                      interface GigabitEthernet0/1
                       ip address 10.0.0.2 255.255.0.0
                       shutdown
                       duplex auto
                       speed auto
                      !
                      interface FastEthernet0/1/0
                       switchport access vlan 2
                       no ip address
                       load-interval 30
                       duplex full
                       speed 100
                      !
                      interface FastEthernet0/1/1
                       no ip address
                      !
                      interface FastEthernet0/1/2
                       no ip address
                      !
                      interface FastEthernet0/1/3
                       no ip address
                      !
                      interface FastEthernet0/1/4
                       no ip address
                      !
                      interface FastEthernet0/1/5
                       no ip address
                      !
                      interface FastEthernet0/1/6
                       no ip address
                      !
                      interface FastEthernet0/1/7
                       no ip address
                      !
                      interface FastEthernet0/1/8
                       no ip address
                      !
                      interface Serial0/2/0
                       no ip address
                       encapsulation frame-relay
                       load-interval 30
                       shutdown
                       no keepalive
                       clockrate 2000000
                      !
                      interface Serial0/2/0.1 point-to-point
                       ip address 10.3.3.1 255.255.255.0
                       frame-relay interface-dlci 100
                      !
                      interface Serial0/2/1
                       no ip address
                       shutdown
                       clockrate 2000000
                      !
                      interface Serial0/3/0:15
                       no ip address
                       dialer pool-member 1
                       isdn switch-type primary-ntt
                       isdn protocol-emulate network
                       isdn T310 15000
                       isdn bchan-number-order descending
                       isdn integrate calltype all
                       no cdp enable
                      !
                      interface Serial0/3/1:15
                       no ip address
                       dialer pool-member 1
                       isdn switch-type primary-ntt
                       isdn protocol-emulate network
                       isdn T310 15000
                       isdn bchan-number-order descending
                       isdn integrate calltype all
                       no cdp enable
                      !
                      interface Serial1/0/0:15
                       no ip address
                       dialer pool-member 1
                       isdn switch-type primary-dms100
                       isdn protocol-emulate network
                       isdn T310 15000
                       isdn bchan-number-order descending
                       isdn integrate calltype all
                       no cdp enable
                      !
                      interface Serial1/0/1:15
                       no ip address
                       encapsulation ppp
                       dialer pool-member 1
                       isdn switch-type primary-ntt
                       isdn protocol-emulate network
                       isdn T310 15000
                       isdn bchan-number-order descending
                       isdn integrate calltype all
                       ppp multilink
                      !
                      interface Vlan1
                       ip address 10.0.0.1 255.255.0.0
                       load-interval 30
                      !
                      interface Vlan2
                       ip address 10.7.7.7 255.255.0.0
                      !
                      interface Dialer0
                       ip address 10.5.5.5 255.0.0.0
                       encapsulation ppp
                       load-interval 30
                       dialer pool 1
                       dialer remote-name Router
                       dialer string 4081234 class test
                       dialer load-threshold 10 outbound
                       dialer-group 1
                       ppp multilink
                       ppp multilink load-threshold 5 outbound !
                      interface Dialer1
                       ip address 192.168.253.1 255.255.255.0
                       dialer pool 1
                       dialer string 4085678 class test
                       dialer-group 1
                      !
                      interface Dialer2
                       ip address 192.168.252.1 255.255.255.0
                       dialer pool 1
                       dialer string 4087777 class test
                       dialer-group 1
                      !
                      ip default-gateway 5.5.5.6
                      ip classless
                      ip route 172.16.254.254 255.255.255.255 10.3.0.1 !
                      ip http server
                      !
                      !
                      map-class dialer test
                       dialer trunkgroup 1
                       dialer preemption level flash
                      dialer-list 1 protocol ip permit
                      snmp-server community public RO
                      snmp-server enable traps tty
                      !
                      !
                      !
                      control-plane
                      !
                      !
                      !
                      voice-port 0/3/0:15
                       echo-cancel enable type hardware
                      !
                      voice-port 0/3/1:15
                       echo-cancel enable type hardware
                      !
                      voice-port 1/0/0:15
                       compand-type u-law
                      !
                      voice-port 1/0/1:15
                      !
                      voice-port 2/0/0
                       shutdown
                      !
                      voice-port 2/0/1
                      !
                      voice-port 2/0/2
                      !
                      voice-port 2/0/3
                      !
                      voice-port 2/0/4
                      !
                      voice-port 2/0/5
                      !
                      voice-port 2/0/6
                      !
                      voice-port 2/0/7
                      !
                      !
                      !
                      !
                      !
                      !
                      dial-peer voice 100 pots
                       destination-pattern 1...
                       port 2/0/1
                       forward-digits all
                      !
                      dial-peer voice 2001 pots
                       trunkgroup 1
                       destination-pattern 2...
                       forward-digits all
                      !
                      dial-peer voice 3001 pots
                       trunkgroup 1
                       destination-pattern 3...
                       forward-digits all
                      !
                      dial-peer voice 300 pots
                       destination-pattern 4...
                       port 2/0/2
                       forward-digits all
                      !
                      dial-peer voice 10 pots
                       incoming called-number .
                       direct-inward-dial
                       forward-digits 0
                      !
                      dial-peer voice 5001 pots
                       trunkgroup 1
                       destination-pattern 5...
                       forward-digits all
                      !
                      dial-peer voice 500 pots
                       destination-pattern 6...
                       port 2/0/3
                       forward-digits all
                      !
                      dial-peer voice 800 pots
                       trunkgroup 1
                       destination-pattern 8...
                       forward-digits all
                      !
                      dial-peer data 50 pots
                       incoming called-number 650T
                      !
                      !
                      !
                      telephony-service
                       load 7960-7940 P00303020214
                       max-ephones 5
                       max-dn 5
                       ip source-address 10.0.0.1 port 2000
                       create cnf-files version-stamp Jan 01 2002 00:00:00  max-conferences 8 gain -6  transfer-system full-consult  transfer-pattern .T !
                      !
                      ephone-dn  1  dual-line
                       number 7000
                      !
                      !
                      ephone-dn  2
                       number 7002
                      !
                      !
                      ephone-dn  3
                       number 1003
                      !
                      !
                      ephone-dn  4
                       number 1004
                      !
                      !
                      ephone  1
                       mac-address 0030.94C2.6073
                       type 7960
                       button  1:1
                      !
                      !
                      !
                      ephone  2
                       mac-address 000C.851C.ED81
                       type 7960
                       button  1:2
                      !
                      !
                      !
                      ephone  3
                      !
                      !
                      !
                      ephone  4
                      !
                      !
                      alias exec c conf t
                      alias exec s sh run
                      !
                      line con 0
                       exec-timeout 0 0
                       privilege level 15
                      line aux 0
                      line vty 0 4
                       login
                      !
                      scheduler allocate 20000 1000
                      !
                      end

                      Legacy DDR (Dialer Map) Example

                      The following example shows how to associate the class parameter for legacy DDR.

                      Router# show running-config
                      Building configuration...
                      Current configuration : 1358 bytes
                      !
                      version 12.3
                      service timestamps debug datetime msec
                      service timestamps log datetime msec
                      no service password-encryption
                      !
                      hostname host2
                      !
                      boot-start-marker
                      boot-end-marker
                      !
                      card type t1 1
                      !
                      username client password 0 lab
                      memory-size iomem 10
                      no network-clock-participate aim 0
                      no network-clock-participate aim 1
                      no aaa new-model
                      ip subnet-zero
                      !
                      ip cef    
                      !
                      ip ips po max-events 100
                      no ftp-server write-enable
                      isdn switch-type primary-ni
                      !
                      controller T1 1/0
                      framing esf
                      linecode b8zs
                      cablelength long 0db
                      pri-group timeslots 1-24
                      !
                      controller T1 1/1
                      framing sf
                      linecode ami
                      cablelength long 0db
                      !
                      interface FastEthernet0/0
                      ip address 10.10.193.77 255.255.0.0
                      duplex auto
                      speed auto
                      !
                      interface FastEthernet0/1
                      ip address 192.168.10.1 255.255.255.0
                      shutdown
                      duplex auto
                      speed auto
                      !
                      interface Serial1/0:23
                      ip address 192.168.254.2 255.255.255.0
                      encapsulation ppp
                      dialer map ip 172.22.82.2 name gw3845 class dial1 20009
                      dialer-group 2
                      isdn switch-type primary-ni
                      ppp authentication chap
                      !
                      no ip classless
                      ip route 10.10.1.0 255.255.255.0 192.168.254.1
                      ip route 172.16.254.0 255.255.255.0 10.10.0.1
                      !
                      ip http server
                      no ip http secure-server
                      !
                      dialer-list 2 protocol ip permit
                      !
                      control-plane
                      !
                      line con 0
                      line aux 0
                      line vty 0 4
                      login
                      !
                      scheduler allocate 20000 1000
                      !
                      end

                      Dialer Profiles Example

                      The following example shows how to associate the class parameter for dialer profiles.

                      Router# show running-config
                      Building configuration...
                      Current configuration : 1689 bytes
                      !
                      version 12.3
                      service timestamps debug datetime msec
                      service timestamps log datetime msec
                      no service password-encryption
                      !
                      hostname host3
                      !
                      boot-start-marker
                      boot-end-marker
                      !
                      card type t1 1
                      no logging console
                      !
                      username uut password 0 lab
                      no network-clock-participate aim 0
                      no network-clock-participate aim 1
                      no aaa new-model
                      ip subnet-zero
                      !
                      ip cef    
                      !
                      ip ips po max-events 100
                      no ftp-server write-enable
                      isdn switch-type primary-ni
                      !
                      controller T1 1/0
                      framing esf
                      linecode b8zs
                      cablelength long 0db
                      pri-group timeslots 1-24
                      !
                      controller T1 1/1
                      framing sf
                      linecode ami
                      cablelength long 0db
                      !
                      no crypto isakmp enable
                      !
                      interface FastEthernet0/0
                      ip address 10.10.193.88 255.255.0.0
                      duplex auto
                      speed auto
                      !
                      interface FastEthernet0/1
                      ip address 10.10.1.1 255.255.255.0
                      duplex auto
                      speed auto
                      !
                      interface Serial0/3/0
                      no ip address
                      clockrate 2000000
                      !
                      interface Serial0/3/1
                      no ip address
                      clockrate 2000000
                      !
                      interface Serial1/0:23
                      no ip address
                      encapsulation ppp
                      dialer pool-member 1
                      isdn switch-type primary-ni
                      isdn protocol-emulate network
                      isdn T310 30000
                      isdn bchan-number-order descending
                      ppp authentication chap
                      !
                      i
                      interface Dialer2
                       ip address 192.168.252.1 255.255.255.0
                       dialer pool 1
                       dialer string 4087777 class test
                       dialer-group 1
                      !
                      ip default-gateway 5.5.5.6
                      ip classless
                      ip route 172.16.254.254 255.255.255.255 10.3.0.1 !
                      ip http server
                      !
                      !
                      map-class dialer test
                       dialer trunkgroup 1
                       dialer preemption level flash
                      dialer-list 1 protocol ip permit
                      snmp-server community public RO
                      snmp-server enable traps tty
                      !
                      dialer-list 1 protocol ip permit
                      !
                      control-plane
                      !
                      line con 0
                      exec-timeout 0 0
                      line aux 0
                      line vty 0 4
                      login
                      !
                      scheduler allocate 20000 8000
                      end

                      Maximum Number of Data and Voice Calls on the Dial-Out Trunk Group Example

                      The following sample configuration shows a maximum number of 500 data and voice calls configured on the trunk group, includes all B channels in the trunk group, and associates dialer test with the trunk group.

                      Router# show running-config
                      Building configuration...
                      Current configuration : 2283 bytes
                      !
                      version 12.3
                      service timestamps debug datetime msec
                      service timestamps log datetime msec
                      no service password-encryption
                      !
                      hostname host4
                      !
                      boot-start-marker
                      boot-end-marker
                      !
                      card type t1 1 1
                      no logging console
                      !
                      no aaa new-model
                      !
                      resource manager
                      !
                      no network-clock-participate slot 1
                      ip subnet-zero
                      !
                      ip cef
                      !
                      no ftp-server write-enable
                      isdn switch-type primary-ni
                      !
                      trunk group  1
                       max-calls any 500
                      !
                      voice-card 0
                      dspfarm
                      !
                      voice-card 1
                      dspfarm
                      !
                      controller T1 1/0
                      framing esf
                      linecode b8zs
                      !
                      controller T1 1/0/0
                      framing esf
                      linecode b8zs
                      pri-group timeslots 1-12,24
                      !
                      controller T1 1/0/1
                      framing esf
                      linecode b8zs
                      !
                      interface GigabitEthernet0/0
                      ip address 10.10.212.212 255.255.0.0
                      duplex auto
                      speed auto
                      !
                      interface GigabitEthernet0/1
                      no ip address
                      duplex auto
                      speed auto
                      !
                      interface Serial1/0/0:23
                      no ip address
                      dialer pool-member 1
                      isdn switch-type primary-ni
                      isdn protocol-emulate network
                      isdn T310 30000
                      isdn bchan-number-order descending
                      isdn integrate calltype all
                      trunk-group 1 1
                      no cdp enable
                      !
                      interface Dialer0
                      ip address 192.168.254.1 255.255.255.0
                      dialer pool 1
                      dialer string 4081234 class test
                      dialer-group 1
                      !
                      interface Dialer1
                      ip address 192.168.253.1 255.255.255.0
                      dialer pool 1
                      dialer string 4085678 class test
                      dialer-group 1
                      !
                      interface Dialer2
                      ip address 192.168.252.1 255.255.255.0
                      dialer pool 1
                      dialer string 4087777 class test
                      dialer-group 1
                      !
                      ip classless
                      ip route 192.168.10.0 255.255.255.0 Dialer0
                      ip route 192.168.11.0 255.255.255.0 Dialer1
                      ip route 192.168.12.0 255.255.255.0 Dialer2
                      ip route 172.16.254.254 255.255.255.255 GigabitEthernet0/0
                      !
                      ip http server
                      !
                      map-class dialer test
                      dialer trunkgroup 1
                      dialer-list 1 protocol ip permit
                      !
                      control-plane
                      !
                      voice-port 1/0/0:23
                      !
                      voice-port 2/0/0
                      !
                      voice-port 2/0/1
                      !
                      voice-port 2/0/2
                      !
                      voice-port 2/0/3
                      !
                      voice-port 2/0/4
                      !
                      voice-port 2/0/5
                      !        
                      voice-port 2/0/6
                      !
                      voice-port 2/0/7
                      !
                      dial-peer voice 100 pots
                      destination-pattern 1001
                      port 2/0/0
                      forward-digits all
                      !
                      dial-peer voice 2001 pots
                      destination-pattern 200.
                      port 1/0/0:23
                      forward-digits all
                      !
                      dial-peer voice 101 pots
                      destination-pattern 1002
                      port 2/0/1
                      !
                      line con 0
                      exec-timeout 0 0
                      line aux 0
                      line vty 0 4
                      login
                      !
                      scheduler allocate 20000 1000
                      !
                      end

                      Dial-Peer Configuration Example

                      Data dial peers enable the configuration and order assignment of dial peers so that the gateway can identify incoming calls as voice or data. The incoming called number specifies the number associated with the data dial peer. The following example shows a configuration for the voice and data dial-peers and incoming called number.

                      Router# show running-config
                      Building configuration...
                      Current configuration : 1978 bytes
                      !
                      version 12.3
                      service timestamps debug datetime msec
                      service timestamps log datetime msec
                      no service password-encryption
                      !
                      hostname host6
                      !
                      boot-start-marker
                      boot-end-marker
                      !
                      no aaa new-model
                      !
                      resource manager
                      !
                      no network-clock-participate slot 1
                      ip subnet-zero
                      !
                      ip cef
                      !
                      no ftp-server write-enable
                      isdn switch-type primary-ni
                      !
                      trunk group  1
                      max-calls any 2
                      !
                      voice-card 0
                      dspfarm
                      !
                      voice-card 1
                      dspfarm
                      !
                      controller T1 1/1/0
                      framing esf
                      linecode b8zs
                      pri-group timeslots 1-12,24
                      trunk-group 1 timeslots 2
                      !
                      controller T1 1/1/1
                      framing esf
                      linecode b8zs
                      !
                      interface FastEthernet0/0
                      ip address 10.10.193.90 255.255.0.0
                      duplex half
                      speed 10
                      !
                      interface FastEthernet0/1
                      no ip address
                      shutdown
                      duplex auto
                      speed auto
                      !
                      interface FastEthernet0/1/0
                      no ip address
                      shutdown
                      !
                      interface FastEthernet0/1/1
                      no ip address
                      shutdown
                      !
                      interface FastEthernet0/1/2
                      no ip address
                      shutdown
                      !
                      interface FastEthernet0/1/3
                      no ip address
                      shutdown
                      !
                      interface Serial1/1/0:23
                      no ip address
                      dialer pool-member 2
                      isdn switch-type primary-ni
                      isdn integrate calltype all
                      no cdp enable
                      !
                      interface Vlan1
                      no ip address
                      !
                      interface Dialer0
                      ip address 192.168.254.2 255.255.255.0
                      dialer pool 2
                      dialer string 6501234
                      dialer-group 2
                      !
                      ip classless
                      ip route 10.10.1.0 255.255.255.0 Dialer0
                      ip route 172.16.254.0 255.255.255.0 10.10.0.1
                      !
                      ip http server
                      !
                      dialer-list 2 protocol ip permit
                      !
                      control-plane
                      !
                      voice-port 0/2/0
                      !
                      voice-port 0/2/1
                      !
                      voice-port 0/2/2
                      !
                      voice-port 0/2/3
                      !
                      voice-port 1/1/0:23
                      !
                      dial-peer voice 100 pots
                      destination-pattern 2001
                      port 0/2/0
                      forward-digits all
                      !
                      dial-peer voice 10 pots
                      incoming called-number .
                      direct-inward-dial
                      port 1/1/0:23
                      !
                      dial-peer data 50 pots
                      incoming called-number 408T
                      !
                      dial-peer voice 101 pots  
                      destination-pattern 2002
                      port 0/2/1
                      forward-digits all
                      !
                      line con 0
                      exec-timeout 0 0
                      line aux 0
                      line vty 0 4
                      login
                      !
                      scheduler allocate 20000 1000
                      !
                      end

                      Disconnect Cause Example

                      This example shows the DisconnectCause information for a preemption call.

                      Router# 
                      show call history voice
                      Telephony call-legs: 2
                      SIP call-legs: 0
                      H323 call-legs: 0
                      Call agent controlled call-legs: 0
                      Total call-legs: 2 
                      GENERIC:
                      SetupTime=281680 ms
                      Index=1
                      PeerAddress=7002
                      PeerSubAddress=
                      PeerId=20002
                      PeerIfIndex=161
                      LogicalIfIndex=160
                      DisconnectCause=8 
                      DisconnectText=preemption (8)
                      ConnectTime=286160 ms
                      DisconnectTime=441190 ms
                      CallDuration=00:02:35 sec
                      CallOrigin=2
                      ReleaseSource=7
                      InternalErrorCode=1.1.8.11.35.0
                      ChargedUnits=0
                      InfoType=speech
                      TransmitPackets=0
                      TransmitBytes=0
                      ReceivePackets=6910
                      ReceiveBytes=1105600
                      TELE:
                      ConnectionId=[0x4E9D9EF1 0x23E411DA 0x8002A31F 0xB25BECEF]
                      IncomingConnectionId=[0x4E9D9EF1 0x23E411DA 0x8002A31F 0xB25BECEF]
                      CallID=1
                      TxDuration=0 ms
                      VoiceTxDuration=0 ms
                      FaxTxDuration=0 ms
                      CoderTypeRate=g711ulaw
                      NoiseLevel=0
                      ACOMLevel=0
                      SessionTarget=
                      ImgPages=0
                      CallerName=
                      CallerIDBlocked=False
                      OriginalCallingNumber=7002
                      OriginalCallingOctet=0x0
                      OriginalCalledNumber=
                      OriginalCalledOctet=0x80
                      OriginalRedirectCalledNumber=
                      OriginalRedirectCalledOctet=0x0
                      TranslatedCallingNumber=7002
                      TranslatedCallingOctet=0x0
                      TranslatedCalledNumber=
                      TranslatedCalledOctet=0x80
                      TranslatedRedirectCalledNumber=
                      TranslatedRedirectCalledOctet=0x0
                      GwCollectedCalledNumber=2000
                      GwReceivedCallingNumber=7002
                      GwReceivedCallingOctet3=0x0
                      GwReceivedCallingOctet3a=0x0 GENERIC:
                      SetupTime=282800 ms
                      Index=2
                      PeerAddress=2000
                      PeerSubAddress=
                      PeerId=2001
                      PeerIfIndex=144
                      LogicalIfIndex=42
                      DisconnectCause=8 
                      DisconnectText=preemption (8)
                      ConnectTime=286160 ms
                      DisconnectTime=441210 ms
                      CallDuration=00:02:35 sec
                      CallOrigin=1
                      ReleaseSource=7
                      InternalErrorCode=1.1.8.11.35.0
                      ChargedUnits=0
                      InfoType=speech
                      TransmitPackets=6910
                      TransmitBytes=1160880
                      ReceivePackets=6917
                      ReceiveBytes=1106720
                      TELE:
                      ConnectionId=[0x4E9D9EF1 0x23E411DA 0x8002A31F 0xB25BECEF]
                      IncomingConnectionId=[0x4E9D9EF1 0x23E411DA 0x8002A31F 0xB25BECEF]
                      CallID=2
                      TxDuration=0 ms
                      VoiceTxDuration=0 ms
                      FaxTxDuration=0 ms
                      CoderTypeRate=g711ulaw
                      NoiseLevel=-41
                      ACOMLevel=26
                      SessionTarget=
                      ImgPages=0
                      CallerName=
                      CallerIDBlocked=False
                      AlertTimepoint=282820 ms
                      Target tg label=1
                      OriginalCallingNumber=7002
                      OriginalCallingOctet=0x0
                      OriginalCalledNumber=
                      OriginalCalledOctet=0x80
                      OriginalRedirectCalledNumber=
                      OriginalRedirectCalledOctet=0x0
                      TranslatedCallingNumber=7002
                      TranslatedCallingOctet=0x0
                      TranslatedCalledNumber=2000
                      TranslatedCalledOctet=0x80
                      TranslatedRedirectCalledNumber=
                      TranslatedRedirectCalledOctet=0x0
                      GwCollectedCalledNumber=2000
                      GwOutpulsedCalledNumber=2000
                      GwOutpulsedCalledOctet3=0x80
                      GwReceivedCallingNumber=7002
                      GwReceivedCallingOctet3=0x0
                      GwReceivedCallingOctet3a=0x0
                      GwOutpulsedCallingNumber=7002
                      GwOutpulsedCallingOctet3=0x0
                      GwOutpulsedCallingOctet3a=0x0
                      DSPIdentifier=0/1:1
                      

                      Additional References

                      The following sections provide references related to configuring integrated data and voice for ISDN interfaces.

                      Related Documents

                      Related Topic

                      Document Title

                      Cisco IOS Voice Configuration Library, including library preface and glossary, other feature documents, and troubleshooting documentation.

                      Cisco IOS Voice Configuration Library

                      Voice command reference

                      Cisco IOS Voice Command Reference

                      Cisco IOS ISDN voice technologies

                      Cisco IOS ISDN Voice Configuration Guide

                      Cisco dial technologies

                      • Cisco IOS Dial Configuration Guide
                      • Cisco IOS Dial Technologies Command Reference

                      ISDN PRI configuration information

                      Configuring Network Side ISDN PRI Signaling, Trunking, and Switching

                      Multilevel precedence and preemption (MLPP) information

                      Multilevel Precedence and Preemption

                      ISDN voice interface information.

                      Configuring ISDN PRI Voice-Interface Support

                      Standards

                      Standard

                      Title

                      No new or modified standards are supported by this feature, and support for existing standards has not been modified by this feature.

                      MIBs

                      MIB

                      MIBs Link

                      • CISCO-VOICE-COMMON-DIAL-CONTROL-MIB
                      • CISCO-VOICE-DIAL-CONTROL-MIB

                      To locate and download MIBs for selected platforms, Cisco IOS releases, and feature sets, use Cisco MIB Locator found at the following URL:

                      http:/​/​www.cisco.com/​go/​mibs

                      RFCs

                      RFC

                      Title

                      No new or modified RFCs are supported by this feature, and support for existing RFCs has not been modified by this feature.

                      --

                      Technical Assistance

                      Description

                      Link

                      The Cisco Technical Support website contains thousands of pages of searchable technical content, including links to products, technologies, solutions, technical tips, and tools. Registered Cisco.com users can log in from this page to access even more content.

                      http:/​/​www.cisco.com/​techsupport