IP Routing BFD Configuration Guide, Cisco IOS Release 15E
OSPF Support for BFD over IPv4
Downloads: This chapterpdf (PDF - 1.2MB) The complete bookPDF (PDF - 2.47MB) | The complete bookePub (ePub - 250.0KB) | Feedback

OSPF Support for BFD over IPv4

OSPF Support for BFD over IPv4

The OSPF Support for BFD over IPv4 feature enables Open Shortest Path First (OSPF), which is a dynamic routing protocol, to regsiter with Bidirectional Forwarding Detection (BFD) to receive forwarding path detection failure messages from BFD.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for OSPF Support for BFD over IPv4

  • OSPF must be running on all participating routers.
  • The baseline parameters for BFD sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured.

Information About OSPF Support for BFD over IPv4

Overview of OSPF Support for BFD over IPv4

The OSPF Support for BFD over IPv4 feature enables Open Shortest Path First (OSPF), which is a dynamic routing protocol, to regsiter with Bidirectional Forwarding Detection (BFD) to receive forwarding path detection failure messages from BFD. You can either configure BFD Support for OSPF globally on all interfaces or configure it selectively on one or more interfaces.

There are two methods to enable OSPF Support for BFD:

  • Enable BFD for all interfaces for which OSPF is routing by using the bfd all-interfaces command in router configuration mode.

    Note


    Disable BFD support on individual interfaces using the ip ospf bfd [disable] command in interface configuration mode.


  • Enable BFD for a subset of interfaces for which OSPF is routing by using the ip ospf bfd command in interface configuration mode.

How to Configure OSPF Support for BFD over IPv4

Configuring OSPF Support for BFD over IPv4 for All Interfaces

To configure BFD for all OSPF interfaces, perform the steps in this section.

If you do not want to configure BFD on all OSPF interfaces and would rather configure BFD support specifically for one or more interfaces, see the Configuring OSPF Support for BFD over IPv4 for One or More Interfaces section.

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    router ospf process-id

    4.    bfd all-interfaces

    5.    exit

    6.    interface type number

    7.    ip ospf bfd [disable]

    8.    end

    9.    show bfd neighbors [details]

    10.    show ip ospf


DETAILED STEPS
      Command or Action Purpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 router ospf process-id


    Example:
    Device(config)# router ospf 4
     

    Specifies an OSPF process and enters router configuration mode.

     
    Step 4 bfd all-interfaces


    Example:
    Device(config-router)# bfd all-interfaces
     

    Enables BFD globally on all interfaces associated with the OSPF routing process.

     
    Step 5 exit


    Example:
    Device(config-router)# exit
     

    (Optional) Returns the router to global configuration mode. Enter this command only if you want to perform Step 7 to disable BFD for one or more interfaces.

     
    Step 6 interface type number


    Example:
    Device(config)# interface fastethernet 6/0
     

    (Optional) Enters interface configuration mode. Enter this command only if you want to perform Step 7 to disable BFD for one or more interfaces.

     
    Step 7 ip ospf bfd [disable]


    Example:
    Device(config-if)# ip ospf bfd disable
     

    (Optional) Disables BFD on a per-interface basis for one or more interfaces associated with the OSPF routing process.

    Note   

    Use the disable keyword only if you enabled BFD on all of the interfaces that OSPF is associated with using the bfd all-interfaces command in router configuration mode.

     
    Step 8 end


    Example:
    Device(config-if)# end
     

    Exits interface configuration mode and returns the device to privileged EXEC mode.

     
    Step 9 show bfd neighbors [details]


    Example:
    Device# show bfd neighbors detail
     

    (Optional) Displays information that can help verify if the BFD neighbor is active and displays the routing protocols that BFD has registered.

    Note   

    If hardware-offloaded BFD sessions are configured with Tx and Rx intervals that are not multiples of 50 ms, the hardware intervals are changed. However, output from the show bfd neighbors details command displays only the configured intervals, not the interval values that change.

     
    Step 10 show ip ospf


    Example:
    Device# show ip ospf
     

    (Optional) Displays information that can help verify if BFD for OSPF has been enabled.

     

    Configuring OSPF Support for BFD over IPv4 for All Interfaces

    To configure BFD for all OSPF interfaces, perform the steps in this section.

    If you do not want to configure BFD on all OSPF interfaces and would rather configure BFD support specifically for one or more interfaces, see the Configuring OSPF Support for BFD over IPv4 for One or More Interfaces section.

    SUMMARY STEPS

      1.    enable

      2.    configure terminal

      3.    router ospf process-id

      4.    bfd all-interfaces

      5.    exit

      6.    interface type number

      7.    ip ospf bfd [disable]

      8.    end

      9.    show bfd neighbors [details]

      10.    show ip ospf


    DETAILED STEPS
        Command or Action Purpose
      Step 1 enable


      Example:
      Device> enable
       

      Enables privileged EXEC mode.

      • Enter your password if prompted.
       
      Step 2 configure terminal


      Example:
      Device# configure terminal
       

      Enters global configuration mode.

       
      Step 3 router ospf process-id


      Example:
      Device(config)# router ospf 4
       

      Specifies an OSPF process and enters router configuration mode.

       
      Step 4 bfd all-interfaces


      Example:
      Device(config-router)# bfd all-interfaces
       

      Enables BFD globally on all interfaces associated with the OSPF routing process.

       
      Step 5 exit


      Example:
      Device(config-router)# exit
       

      (Optional) Returns the router to global configuration mode. Enter this command only if you want to perform Step 7 to disable BFD for one or more interfaces.

       
      Step 6 interface type number


      Example:
      Device(config)# interface fastethernet 6/0
       

      (Optional) Enters interface configuration mode. Enter this command only if you want to perform Step 7 to disable BFD for one or more interfaces.

       
      Step 7 ip ospf bfd [disable]


      Example:
      Device(config-if)# ip ospf bfd disable
       

      (Optional) Disables BFD on a per-interface basis for one or more interfaces associated with the OSPF routing process.

      Note   

      Use the disable keyword only if you enabled BFD on all of the interfaces that OSPF is associated with using the bfd all-interfaces command in router configuration mode.

       
      Step 8 end


      Example:
      Device(config-if)# end
       

      Exits interface configuration mode and returns the device to privileged EXEC mode.

       
      Step 9 show bfd neighbors [details]


      Example:
      Device# show bfd neighbors detail
       

      (Optional) Displays information that can help verify if the BFD neighbor is active and displays the routing protocols that BFD has registered.

      Note   

      If hardware-offloaded BFD sessions are configured with Tx and Rx intervals that are not multiples of 50 ms, the hardware intervals are changed. However, output from the show bfd neighbors details command displays only the configured intervals, not the interval values that change.

       
      Step 10 show ip ospf


      Example:
      Device# show ip ospf
       

      (Optional) Displays information that can help verify if BFD for OSPF has been enabled.

       

      Configuration Examples for OSPF Support for BFD over IPv4

      Example: Configuring OSPF Support for BFD over IPv4

      The following example shows how to configure BFD in an OSPF network. In the following example, a simple OSPF network consists of Device A and Device B. Fast Ethernet interface 0/1 on Device A is connected to the same network as Fast Ethernet interface 6/0 in Device B. The example, starting in global configuration mode, shows the configuration of BFD. For both Devices A and B, BFD is configured globally for all interfaces associated with the OSPF process.

      Configuration for Device A

      !
      interface Fast Ethernet 0/1
      ip address 172.16.10.1 255.255.255.0
      bfd interval 50 min_rx 50 multiplier 3
      !
      interface Fast Ethernet 3/0.1
      ip address 172.17.0.1 255.255.255.0
      !
      router ospf 123
      log-adjacency-changes detail
      network 172.16.0.0 0.0.0.255 area 0
      network 172.17.0.0 0.0.0.255 area 0
      bfd all-interfaces

      Configuration for Device B

      !
      interface Fast Ethernet 6/0
       ip address 172.16.10.2 255.255.255.0
       bfd interval 50 min_rx 50 multiplier 3
      !
      interface Fast Ethernet 6/1
       ip address 172.18.0.1 255.255.255.0
      !
      router ospf 123
       log-adjacency-changes detail
       network 172.16.0.0 0.0.255.255 area 0
       network 172.18.0.0 0.0.255.255 area 0
       bfd all-interfaces
      

      The output from the show bfd neighbors details command verifies that a BFD session has been created and that OSPF is registered for BFD support.

      Device A

      DeviceA# show bfd neighbors details
      
      OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
      172.16.10.1   172.16.10.2    1/2  1   532  (3 )      Up        Fa0/1          
      Local Diag: 0, Demand mode: 0, Poll bit: 0
      MinTxInt: 200000, MinRxInt: 200000, Multiplier: 5
      Received MinRxInt: 1000, Received Multiplier: 3
      Holdown (hits): 600(22), Hello (hits): 200(84453)
      Rx Count: 49824, Rx Interval (ms) min/max/avg: 208/440/332 last: 68 ms ago
      Tx Count: 84488, Tx Interval (ms) min/max/avg: 152/248/196 last: 192 ms ago
      Registered protocols: OSPF
      Uptime: 02:18:49
      Last packet: Version: 0
                  - Diagnostic: 0
                   I Hear You bit: 1     - Demand bit: 0
                   Poll bit: 0           - Final bit: 0
                   Multiplier: 3         - Length: 24
                   My Discr.: 2          - Your Discr.: 1
                   Min tx interval: 50000    - Min rx interval: 1000
                   Min Echo interval: 0
      

      The output from the show bfd neighbors details command from Device B verifies that a BFD session has been created:

      Device B

      DeviceB# attach 6 
      Entering Console for 8 Port Fast Ethernet in Slot: 6
      Type "exit" to end this session
      Press RETURN to get started!
      
      Device> show bfd neighbors details
      Cleanup timer hits: 0
      OurAddr       NeighAddr     LD/RD RH  Holdown(mult)  State     Int
      172.16.10.2   172.16.10.1    8/1  1   1000 (5 )      Up        Fa6/0          
      Local Diag: 0, Demand mode: 0, Poll bit: 0
      MinTxInt: 50000, MinRxInt: 1000, Multiplier: 3
      Received MinRxInt: 200000, Received Multiplier: 5
      Holdown (hits): 1000(0), Hello (hits): 200(5995)
      Rx Count: 10126, Rx Interval (ms) min/max/avg: 152/248/196 last: 0 ms ago
      Tx Count: 5998, Tx Interval (ms) min/max/avg: 204/440/332 last: 12 ms ago
      Last packet: Version: 0            - Diagnostic: 0
      I Hear You bit: 1     - Demand bit: 0
      Poll bit: 0           - Final bit: 0
      Multiplier: 5         - Length: 24
      My Discr.: 1          - Your Discr.: 8
      Min tx interval: 200000    - Min rx interval: 200000
      Min Echo interval: 0
      Uptime: 00:33:13
      SSO Cleanup Timer called: 0
      SSO Cleanup Action Taken: 0
      Pseudo pre-emptive process count: 239103 min/max/avg: 8/16/8 last: 0 ms ago
      IPC Tx Failure Count: 0
      IPC Rx Failure Count: 0
      Total Adjs Found: 1
      

      The output from the show ip ospf command verifies that BFD has been enabled for OSPF.

      Device A

      DeviceA# show ip ospf
      
       Routing Process "ospf 123" with ID 172.16.10.1
       Supports only single TOS(TOS0) routes
       Supports opaque LSA
       Supports Link-local Signaling (LLS)
       Initial SPF schedule delay 5000 msecs
       Minimum hold time between two consecutive SPFs 10000 msecs
       Maximum wait time between two consecutive SPFs 10000 msecs
       Incremental-SPF disabled
       Minimum LSA interval 5 secs
       Minimum LSA arrival 1000 msecs
       LSA group pacing timer 240 secs
       Interface flood pacing timer 33 msecs
       Retransmission pacing timer 66 msecs
       Number of external LSA 0. Checksum Sum 0x000000
       Number of opaque AS LSA 0. Checksum Sum 0x000000
       Number of DCbitless external and opaque AS LSA 0
       Number of DoNotAge external and opaque AS LSA 0
       Number of areas in this router is 1. 1 normal 0 stub 0 nssa
       External flood list length 0
       BFD is enabled
          Area BACKBONE(0)
              Number of interfaces in this area is 2 (1 loopback)
              Area has no authentication
              SPF algorithm last executed 00:00:08.828 ago
              SPF algorithm executed 9 times
              Area ranges are
              Number of LSA 3. Checksum Sum 0x028417
              Number of opaque link LSA 0. Checksum Sum 0x000000
              Number of DCbitless LSA 0
              Number of indication LSA 0
              Number of DoNotAge LSA 0
              Flood list length 0
      

      Device B

      DeviceB# show ip ospf
      
       Routing Process "ospf 123" with ID 172.18.0.1
       Supports only single TOS(TOS0) routes
       Supports opaque LSA
       Supports Link-local Signaling (LLS)
       Supports area transit capability
       Initial SPF schedule delay 5000 msecs
       Minimum hold time between two consecutive SPFs 10000 msecs
       Maximum wait time between two consecutive SPFs 10000 msecs
       Incremental-SPF disabled
       Minimum LSA interval 5 secs
       Minimum LSA arrival 1000 msecs
       LSA group pacing timer 240 secs
       Interface flood pacing timer 33 msecs
       Retransmission pacing timer 66 msecs
       Number of external LSA 0. Checksum Sum 0x0     
       Number of opaque AS LSA 0. Checksum Sum 0x0     
       Number of DCbitless external and opaque AS LSA 0
       Number of DoNotAge external and opaque AS LSA 0
       Number of areas in this router is 1. 1 normal 0 stub 0 nssa
       Number of areas transit capable is 0
       External flood list length 0
       BFD is enabled
          Area BACKBONE(0)
              Number of interfaces in this area is 2 (1 loopback)
              Area has no authentication
              SPF algorithm last executed 02:07:30.932 ago
              SPF algorithm executed 7 times
              Area ranges are
              Number of LSA 3. Checksum Sum 0x28417 
              Number of opaque link LSA 0. Checksum Sum 0x0     
              Number of DCbitless LSA 0
              Number of indication LSA 0
              Number of DoNotAge LSA 0
              Flood list length 0
      

      The output from the show ip ospf interface command verifies that BFD has been enabled for OSPF on the interfaces connecting Device A and Device B.

      Device A

      DeviceA# show ip ospf interface Fast Ethernet 0/1
      
      show ip ospf interface Fast Ethernet 0/1 
      Fast Ethernet0/1 is up, line protocol is up 
      Internet Address 172.16.10.1/24, Area 0 
      Process ID 123, Router ID 172.16.10.1, Network Type BROADCAST, Cost: 1
      Transmit Delay is 1 sec, State BDR, Priority 1, BFD enabled
      Designated Router (ID) 172.18.0.1, Interface address 172.16.10.2
      Backup Designated router (ID) 172.16.10.1, Interface address 172.16.10.1
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
      oob-resync timeout 40
      Hello due in 00:00:03
      Supports Link-local Signaling (LLS)
      Index 1/1, flood queue length 0
      Next 0x0(0)/0x0(0)
      Last flood scan length is 1, maximum is 1
      Last flood scan time is 0 msec, maximum is 0 msec
      Neighbor Count is 1, Adjacent neighbor count is 1 
      Adjacent with neighbor 172.18.0.1  (Designated Router)
      Suppress hello for 0 neighbor(s)

      Device B

      DeviceB# show ip ospf interface Fast Ethernet 6/1
      
      Fast Ethernet6/1 is up, line protocol is up 
      Internet Address 172.18.0.1/24, Area 0 
      Process ID 123, Router ID 172.18.0.1, Network Type BROADCAST, Cost: 1
      Transmit Delay is 1 sec, State DR, Priority 1, BFD enabled
      Designated Router (ID) 172.18.0.1, Interface address 172.18.0.1
      No backup designated router on this network
      Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
      oob-resync timeout 40
      Hello due in 00:00:01
      Supports Link-local Signaling (LLS)
      Index 1/1, flood queue length 0
      Next 0x0(0)/0x0(0)
      Last flood scan length is 0, maximum is 0
      Last flood scan time is 0 msec, maximum is 0 msec
      Neighbor Count is 0, Adjacent neighbor count is 0 
      Suppress hello for 0 neighbor(s)

      Additional References for OSPF Support for BFD over IPv4

      Technical Assistance

      Description Link

      The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

      To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

      Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

      http:/​/​www.cisco.com/​support

      Feature Information for OSPF Support for BFD over IPv4

      The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

      Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

      Table 1 Feature Information for OSPF Support for BFD over IPv4

      Feature Name

      Releases

      Feature Information

      OSPF Support for BFD over IPv4

      15.2(1)E

      The OSPF Support for BFD over IPv4 feature enables Open Shortest Path First (OSPF), which is a dynamic routing protocol, to regsiter with Bidirectional Forwarding Detection (BFD) to receive forwarding path detection failure messages from BFD.