IP Routing BFD Configuration Guide, Cisco IOS Release 15E
BFD - EIGRP Support
Downloads: This chapterpdf (PDF - 1.35MB) The complete bookPDF (PDF - 2.61MB) | The complete bookePub (ePub - 264.0KB) | Feedback

BFD - EIGRP Support

BFD - EIGRP Support

The BFD-EIGRP Support feature configures the Enhanced Interior Gateway Routing Protocol (EIGRP) with Bidirectional Forwarding Detection (BFD) so that EIGRP registers with BFD and receives all forwarding path detection failure messages from BFD.

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest caveats and feature information, see Bug Search Tool and the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the feature information table at the end of this module.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

Prerequisites for BFD-EIGRP Support

  • Enhanced Interior Gateway Routing Protocol (EIGRP) must be running on all participating routers.
  • The baseline parameters for Bidirectional Forwarding Detection (BFD) sessions on the interfaces over which you want to run BFD sessions to BFD neighbors must be configured using the bfd command.

Information About BFD-EIGRP Support

Overview of BFD-EIGRP Support

The BFD-EIGRP Support feature configures Bidirectional Forwarding Detection (BFD) feature for Enhanced Interior Gateway Routing Protocol (EIGRP) so that EIGRP registers with the BFD sessions on the routing interfaces, and receives forwarding path detection failure messages from BFD.

Use bfd interval milliseconds min_rx milliseconds multiplier interval-multiplier command to enable BFD on any interface. Use the bfd all-interfaces command in router configuration mode to enable BFD for all of the interfaces where EIGRP routing is enabled. Use the bfd interface type number command in router configuration mode to enable BFD for a subset of the interfaces where EIGRP routing is enabled.

How to Configure BFD-EIGRP Support

Configuring BFD - EIGRP Support

SUMMARY STEPS

    1.    enable

    2.    configure terminal

    3.    router eigrp as-number

    4.    Do one of the following:

    • bfd all-interfaces
    • bfd interface type number

    5.    end

    6.    show bfd neighbors [details]

    7.    show ip eigrp interfaces [type number] [as-number] [detail]


DETAILED STEPS
     Command or ActionPurpose
    Step 1 enable


    Example:
    Device> enable
     

    Enables privileged EXEC mode.

    • Enter your password if prompted.
     
    Step 2 configure terminal


    Example:
    Device# configure terminal
     

    Enters global configuration mode.

     
    Step 3 router eigrp as-number


    Example:
    Device(config)# router eigrp 123
     

    Configures the EIGRP routing process and enters router configuration mode.

     
    Step 4Do one of the following:
    • bfd all-interfaces
    • bfd interface type number


    Example:
    Device(config-router)# bfd all-interfaces


    Example:
    Device(config-router)# bfd interface FastEthernet 6/0
     

    Enables BFD globally on all interfaces associated with the EIGRP routing process.

    or

    Enables BFD on a per-interface basis for one or more interfaces associated with the EIGRP routing process.

     
    Step 5 end


    Example:
    Device(config-router)# end
     

    Exits router configuration mode and returns the router to privileged EXEC mode.

     
    Step 6 show bfd neighbors [details]


    Example:
    Device# show bfd neighbors details
     

    (Optional) Verifies that the BFD neighbor is active and displays the routing protocols that BFD has registered.

     
    Step 7 show ip eigrp interfaces [type number] [as-number] [detail]


    Example:
    Device# show ip eigrp interfaces detail
     

    (Optional) Displays the interfaces for which BFD support for EIGRP has been enabled.

     

    Configuration Examples for BFD-EIGRP Support

    Example: Configuring BFD in an EIGRP Network with Echo Mode Enabled by Default

    In the following example, the EIGRP network contains DeviceA, DeviceB, and DeviceC. Fast Ethernet interface 1/0 on DeviceA is connected to the same network as Fast Ethernet interface 1/0 on Device B. Fast Ethernet interface 1/0 on DeviceB is connected to the same network as Fast Ethernet interface 1/0 on DeviceC.

    DeviceA and DeviceB are running BFD Version 1, which supports echo mode, and DeviceC is running BFD Version 0, which does not support echo mode. The BFD sessions between DeviceC and its BFD neighbors are said to be running echo mode with asymmetry because echo mode will run on the forwarding path for DeviceA and DeviceB, and their echo packets will return along the same path for BFD sessions and failure detections, while their BFD neighbor DeviceC runs BFD Version 0 and uses BFD controls packets for BFD sessions and failure detections.

    The figure below shows a large EIGRP network with several devices, three of which are BFD neighbors that are running EIGRP as their routing protocol.



    The example, starting in global configuration mode, shows the configuration of BFD.

    Configuration for DeviceA

    interface Fast Ethernet0/0
    no shutdown 
    ip address 10.4.9.14 255.255.255.0
    duplex auto
    speed auto
    !
    interface Fast Ethernet1/0
    ip address 172.16.1.1 255.255.255.0
    bfd interval 50 min_rx 50 multiplier 3 
    no shutdown
    duplex auto
    speed auto
    !
    router eigrp 11
    network 172.16.0.0
    bfd all-interfaces
    auto-summary
    !
    ip default-gateway 10.4.9.1
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 10.4.9.1
    ip route 172.16.1.129 255.255.255.255 10.4.9.1
    !
    no ip http server
    !
    logging alarm informational
    !
    control-plane
    !
    line con 0
    exec-timeout 30 0
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    !
    end

    Configuration for DeviceB

    !
    interface Fast Ethernet0/0
    no shutdown
    ip address 10.4.9.34 255.255.255.0
    duplex auto
    speed auto
    !
    interface Fast Ethernet1/0
    ip address 172.16.1.2 255.255.255.0
    bfd interval 50 min_rx 50 multiplier 3
    no shtdown
    duplex auto
    speed auto
    !
    router eigrp 11
    network 172.16.0.0
    bfd all-interfaces
    auto-summary
    !
    ip default-gateway 10.4.9.1
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 10.4.9.1
    ip route 172.16.1.129 255.255.255.255 10.4.9.1
    !
    no ip http server
    !
    logging alarm informational
    !
    control-plane
    !
    line con 0
    exec-timeout 30 0
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    !
    end

    Configuration for DeviceC

    !
    !
    interface Fast Ethernet0/0
    no shutdown
    ip address 10.4.9.34 255.255.255.0
    duplex auto
    speed auto
    !
    interface Fast Ethernet1/0
    ip address 172.16.1.2 255.255.255.0
    bfd interval 50 min_rx 50 multiplier 3
    no shutdown
    duplex auto
    speed auto
    !
    router eigrp 11
    network 172.16.0.0
    bfd all-interfaces
    auto-summary
    !
    ip default-gateway 10.4.9.1
    ip default-network 0.0.0.0
    ip route 0.0.0.0 0.0.0.0 10.4.9.1
    ip route 172.16.1.129 255.255.255.255 10.4.9.1
    !
    no ip http server
    !
    logging alarm informational
    !
    control-plane
    !
    line con 0
    exec-timeout 30 0
    stopbits 1
    line aux 0
    stopbits 1
    line vty 0 4
    login
    !
    !
    end
    

    The output from the show bfd neighbors details command from DeviceA verifies that BFD sessions are created among all three devices and that EIGRP is registered for BFD support. The first group of output shows that DeviceC with the IP address 172.16.1.3 runs BFD Version 0 and therefore does not use the echo mode. The second group of output shows that DeviceB with the IP address 172.16.1.2 runs BFD Version 1, and the 50 millisecond BFD interval parameter had been adopted. The relevant command output is shown in bold in the output.

    
    DeviceA# show bfd neighbors details
    
    OurAddr
           NeighAddr
          LD/RD  RH/RS    Holdown(mult)  State     Int
    172.16.1.1    172.16.1.3
         5/3    1(RH)    150 (3 )       Up   Fa1/0 
    Session state is UP and not using echo function.
    Local Diag: 0, Demand mode: 0, Poll bit: 0
    MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
    Received MinRxInt: 50000, Received Multiplier: 3
    Holdown (hits): 150(0), Hello (hits): 50(1364284)
    Rx Count: 1351813, Rx Interval (ms) min/max/avg: 28/64/49 last: 4 ms ago
    Tx Count: 1364289, Tx Interval (ms) min/max/avg: 40/68/49 last: 32 ms ago
    Registered protocols: EIGRP
    Uptime: 18:42:45
    Last packet: Version: 0
                - Diagnostic: 0
                 I Hear You bit: 1     - Demand bit: 0
                 Poll bit: 0           - Final bit: 0
                 Multiplier: 3         - Length: 24
                 My Discr.: 3          - Your Discr.: 5
                 Min tx interval: 50000    - Min rx interval: 50000
                 Min Echo interval: 0
    OurAddr       NeighAddr
         LD/RD  RH/RS   Holdown(mult)  State     Int
    172.16.1.1    172.16.1.2
     
        6/1    Up        0    (3 )   Up        Fa1/0 
    Session state is UP and using echo function with 50 ms interval.
    Local Diag: 0, Demand mode: 0, Poll bit: 0
    MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
    Received MinRxInt: 1000000, Received Multiplier: 3
    Holdown (hits): 3000(0), Hello (hits): 1000(317)
    Rx Count: 305, Rx Interval (ms) min/max/avg: 1/1016/887 last: 448 ms ago
    Tx Count: 319, Tx Interval (ms) min/max/avg: 1/1008/880 last: 532 ms ago
    Registered protocols: EIGRP
    Uptime: 00:04:30
    Last packet: Version: 1
       
             - Diagnostic: 0
                 State bit: Up         - Demand bit: 0
                 Poll bit: 0           - Final bit: 0
                 Multiplier: 3         - Length: 24
                 My Discr.: 1          - Your Discr.: 6
                 Min tx interval: 1000000    - Min rx interval: 1000000
                 Min Echo interval: 50000
    

    The output from the show bfd neighbors details command on Device B verifies that BFD sessions have been created and that EIGRP is registered for BFD support. As previously noted, DeviceA runs BFD Version 1, therefore echo mode is running, and DeviceC runs BFD Version 0, so echo mode does not run. The relevant command output is shown in bold in the output.

    
    DeviceB# show bfd neighbors details 
    
    OurAddr       NeighAddr
         LD/RD  RH/RS   Holdown(mult)  State     Int
    172.16.1.2    172.16.1.1 
        1/6    Up        0    (3 )   Up        Fa1/0 
    Session state is UP and using echo function with 50 ms interval.
    Local Diag: 0, Demand mode: 0, Poll bit: 0
    MinTxInt: 1000000, MinRxInt: 1000000, Multiplier: 3
    Received MinRxInt: 1000000, Received Multiplier: 3
    Holdown (hits): 3000(0), Hello (hits): 1000(337)
    Rx Count: 341, Rx Interval (ms) min/max/avg: 1/1008/882 last: 364 ms ago
    Tx Count: 339, Tx Interval (ms) min/max/avg: 1/1016/886 last: 632 ms ago
    Registered protocols: EIGRP
    Uptime: 00:05:00
    Last packet: Version: 1 
               - Diagnostic: 0
                 State bit: Up         - Demand bit: 0
                 Poll bit: 0           - Final bit: 0
                 Multiplier: 3         - Length: 24
                 My Discr.: 6          - Your Discr.: 1
                 Min tx interval: 1000000    - Min rx interval: 1000000
                 Min Echo interval: 50000
    OurAddr       NeighAddr 
       
     LD/RD  RH/RS   Holdown(mult)  State     Int
    172.16.1.2    172.16.1.3
         3/6    1(RH)     118  (3 )   Up        Fa1/0 
    Session state is UP and not using echo function.
    Local Diag: 0, Demand mode: 0, Poll bit: 0
    MinTxInt: 50000, MinRxInt: 50000, Multiplier: 3
    Received MinRxInt: 50000, Received Multiplier: 3
    Holdown (hits): 150(0), Hello (hits): 50(5735)
    Rx Count: 5731, Rx Interval (ms) min/max/avg: 32/72/49 last: 32 ms ago
    Tx Count: 5740, Tx Interval (ms) min/max/avg: 40/64/50 last: 44 ms ago
    Registered protocols: EIGRP
    Uptime: 00:04:45
    Last packet: Version: 0
                - Diagnostic: 0
                 I Hear You bit: 1     - Demand bit: 0
                 Poll bit: 0           - Final bit: 0
                 Multiplier: 3         - Length: 24
                 My Discr.: 6          - Your Discr.: 3
                 Min tx interval: 50000    - Min rx interval: 50000
                 Min Echo interval: 0
    

    The figure below shows that Fast Ethernet interface 1/0 on DeviceB has failed. When Fast Ethernet interface 1/0 on DeviceB is shut down, the BFD statistics of the corresponding BFD sessions on DeviceA and DeviceB are reduced.



    When Fast Ethernet interface 1/0 on DeviceB fails, BFD will no longer detect Device B as a BFD neighbor for DeviceA or for DeviceC. In this example, Fast Ethernet interface 1/0 has been administratively shut down on DeviceB.

    The following output from the show bfd neighbors command on DeviceA now shows only one BFD neighbor for DeviceA in the EIGRP network. The relevant command output is shown in bold in the output.

    DeviceA# show bfd neighbors
    OurAddr       NeighAddr
     
        LD/RD  RH/RS   Holdown(mult)  State     Int
    172.16.1.1    172.16.1.3
     
        5/3    1(RH)     134  (3 )   Up        Fa1/0 
    

    The following output from the show bfd neighbors command on DeviceC also now shows only one BFD neighbor for DeviceC in the EIGRP network. The relevant command output is shown in bold in the output.

    DeviceC# show bfd neighbors
    
    OurAddr       NeighAddr 
     
       LD/RD RH  Holdown(mult)  State     Int
    172.16.1.3    172.16.1.1
     
        3/5  1   114  (3 )      Up        Fa1/0 

    Additional References for BFD-EIGRP Support

    Technical Assistance

    Description Link

    The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies.

    To receive security and technical information about your products, you can subscribe to various services, such as the Product Alert Tool (accessed from Field Notices), the Cisco Technical Services Newsletter, and Really Simple Syndication (RSS) Feeds.

    Access to most tools on the Cisco Support website requires a Cisco.com user ID and password.

    http:/​/​www.cisco.com/​support

    Feature Information for BFD-EIGRP Support

    The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

    Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/​go/​cfn. An account on Cisco.com is not required.

    Table 1 Feature Information for BFD-EIGRP Support

    Feature Name

    Releases

    Feature Information

    BFD-EIGRP Support

    15.2(1)E

    The BFD-EIGRP Support feature configures the Enhanced Interior Gateway Routing Protocol (EIGRP) with Bidirectional Forwarding Detection (BFD) so that EIGRP registers with BFD and receives all forwarding path detection failure messages from BFD.