Guest

Cisco Catalyst 2950 Series Switches

Configuring EtherChannel and 802.1Q Trunking Between Catalyst L2 Fixed Configuration Switches and a Router (InterVLAN Routing)

Cisco - Configuring EtherChannel and 802.1Q Trunking Between Catalyst L2 Fixed Configuration Switches and a Router (InterVLAN Routing)

Document ID: 24042

Updated: Aug 30, 2005

   Print

Introduction

This document provides a sample configuration for Fast EtherChannel (FEC) and IEEE 802.1Q trunking between Cisco Catalyst Layer 2 (L2) fixed configuration switches and a Cisco router. The Catalyst L2 fixed configuration switches include the 2900/3500XL, 2940, 2950/2955, and 2970 switches. This document uses a Cisco 7200 router. But you can use any other router that supports EtherChannel and 802.1Q trunking to get the same results. The Requirements section of this document provides a list of routers that support EtherChannel and 802.1Q trunking.

Prerequisites

Requirements

Before you attempt this configuration, note these requirements:

  • The FEC and 802.1Q trunking features are available on the Catalyst L2 fixed configuration switches in Cisco IOS® Software Release 12.0(5.2)WC(1) and later. The Catalyst 2940 and 2955/2950 switches do not support Inter-Switch Link Protocol (ISL) trunking due to hardware limitations.

  • Cisco routers support EtherChannel and 802.1Q trunking features in Cisco IOS Software Release 12.0(T) and later. However, all routers do not support both features. Use this table in order to determine which router platforms support FEC as well as 802.1Q trunking features:

    Router Platform EtherChannel IEEE 802.1Q Encapsulation
    Cisco 1710 router No Yes
    Cisco 1751 router No Yes
    Cisco 2600 series No1 Yes
    Cisco 3600 series No1 Yes
    Cisco 3700 series No1 Yes
    Cisco 4000-M series (4000-M, 4500-M, 4700-M) No Yes
    Cisco 7000 series (RSP2 7000, RSP 7000CI) Yes Yes
    Cisco 7100 No Yes
    Cisco 7200 series Yes Yes
    Cisco 7500 series (RSP1, RSP2, RSP4) Yes Yes

    1 An exception to EtherChannel support on Cisco 2600, 3600, and 3700 series routers is when you have installed either the NM-16ESW or NM-36ESW Ethernet Switch Network Module. Each of these modules supports a maximum of six EtherChannels, with up to eight ports in an EtherChannel bundle.

    2 RSP = Route Switch Processor

Components Used

This configuration was developed and tested with these software and hardware versions:

  • Catalyst 2950 switch that runs Cisco IOS Software Release 12.1(9)EA1d

  • Cisco 7200 router that runs Cisco IOS Software Release 12.2(3)

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Background Theory

EtherChannel provides incremental speeds between Fast Ethernet (FE) and Gigabit Ethernet (GE) through the group of multiple equal-speed ports into a logical port channel. EtherChannel combines multiple FEs up to 800 Mbps or GEs up to 8 Gbps. The combination provides fault-tolerant, high-speed links between switches, routers, and servers. Trunking carries traffic from several VLANs over a point-to-point link between the two devices. The purpose of the configuration of trunking between the switch and the router is to provide interVLAN communication. In a campus network, you configure trunking over an EtherChannel link to carry the multiple-VLAN information over a high-bandwidth channel.

Configure

In this section, you are presented with the information to configure the features described in this document.

For explanations of the commands in the document, refer to these documents:

Note: The Catalyst 2950 switch commands and configuration in this document are applicable to switches that run Cisco IOS Software Release 12.1(6)EA2 and later. If you run Cisco IOS Software Release 12.0(5.2)WC(1), you need different commands for the configuration. Refer to these documents for configurations on switches that run Cisco IOS Software Release 12.0(5.2)WC(1):

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

158a.gif

Note: Native VLAN is the VLAN that you configure on the Catalyst interface before you configure the trunking on that interface. By default, all interfaces are in VLAN 1. Therefore, VLAN 1 is the native VLAN that you can change. On an 802.1Q trunk, all VLAN packets except the native VLAN are tagged. You must configure the native VLAN in the same way on each side of the trunk. Then, the router or switch can recognize to which VLAN a frame belongs when the router or switch receives a frame with no tag. In the diagram in this section, VLAN 10 has been configured as the native VLAN. For interVLAN routing, be sure to configure the default gateway on all workstations that connect to the switches. This default gateway is the IP address that you configure on the subinterface. You create a subinterface on the router for each VLAN. In this example, workstation1 has been configured with default gateway 10.10.10.1. This gateway is the IP address of subinterface port channel 1.10. Workstation2 has been configured with default gateway 10.10.11.1. This gateway is the IP address of subinterface port channel 1.20.

Configurations

This document uses these configurations:

Catalyst 2950 Switch
Cat2950#
Cat2950# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.


!--- Set the VLAN Trunk Protocol (VTP) mode to server,
!--- and set the VTP domain name to cisco.

Cat2950(config)# vtp mode server         
Setting device to VTP SERVER mode
Cat2950(config)# vtp domain cisco
Changing VTP domain name from VitalCom to cisco


!--- Create two VLANs: VLAN 10 and VLAN 20.

Cat2950(config)# vlan 10
Cat2950(config-vlan)# exit
Cat2950(config)# vlan 20
Cat2950(config-vlan)# exit


!--- Configure ports Fa0/5 through Fa0/14 in VLAN 10,
!--- and configure ports Fa0/15 through Fa0/26 in VLAN 20.

Cat2950(config)# interface range fa0/5 - 14
Cat2950(config-if-range)# switchport access vlan 10
Cat2950(config-if-range)# exit
Cat2950(config)# interface range fa0/15 - 26
Cat2950(config-if-range)# switchport access vlan 20
Cat2950(config-if-range)# ^Z
Cat2950#
00:32:39: %SYS-5-CONFIG_I: Configured from console by console


!--- Configure the management interface so that you can access
!--- the switch remotely with Telnet.

Cat2950# configure terminal
Cat2950(config)# interface vlan 10
Cat2950(config-if)# ip address 10.10.10.10 255.255.255.0
Cat2950(config-if)# no shutdown
00:24:07: %LINK-3-UPDOWN: Interface Vlan10, changed state to up
Cat2950(config-if)# ^Z
00:24:12: %SYS-5-CONFIG_I: Configured from console by console
Cat2950# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.


!--- Configure the default gateway so that you can access
!--- the switch from any VLAN. The default gateway is
!--- the IP address of the subinterface on the router for VLAN 10.

Cat2950(config)# ip default-gateway 10.10.10.1 


!--- Configure a logical channel interface.

Cat2950(config)# interface port-channel 1
Cat2950(config-if)# exit


!--- Assign ports to the logical channel interface in order to form
!--- an EtherChannel.
!--- Note: Set the channel mode on the switch to on because the Cisco 7200
!--- router on the other end does not support Port Aggregation Protocol (PAgP).

Cat2950(config)# interface fa0/2
Cat2950(config-if)# channel-group 1 mode on
Cat2950(config-if)# exit
Cat2950(config)#
00:25:38: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:25:39: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to up
Cat2950(config)# interface fa0/3
Cat2950(config-if)# channel-group 1 mode on
Cat2950(config-if)# exit


!--- In order to configure trunking over EtherChannel, enable trunking
!--- over the logical channel interface.

Cat2950(config)# interface port-channel 1
Cat2950(config-if)# switchport mode trunk
Cat2950(config-if)#
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed
 state to down
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed
 state to down
00:27:14: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to down
00:27:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed
 state to up
00:27:17: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/3, changed
 state to up
00:27:18: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up
00:27:19: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to up


!--- Configure VLAN 10 as the native VLAN for untagged traffic.

Cat2950(config-if)# switchport trunk native vlan 10
Cat2950(config-if)# ^Z
00:24:12: %SYS-5-CONFIG_I: Configured from console by console
Cat2950#
Cat2950# show running-config
Building configuration...


Current configuration : 2390 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
vtp domain VitalCom
vtp mode transparent
!
vlan 10
!
vlan 20
!
spanning-tree extend system-id
!
!
interface Port-channel1
 switchport trunk native vlan 10
 switchport mode trunk
 no ip address
 flowcontrol send off
!
interface FastEthernet0/1
 no ip address
!
interface FastEthernet0/2
 switchport trunk native vlan 10
 switchport mode trunk
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/3
 switchport trunk native vlan 10
 switchport mode trunk
 no ip address
 channel-group 1 mode on
!
interface FastEthernet0/4
 no ip address
!
interface FastEthernet0/5
 switchport access vlan 10
 no ip address
!


!--- Output suppressed.


!
interface FastEthernet0/15
 switchport access vlan 20
 no ip address
!


!--- Output suppressed.

interface FastEthernet0/26
 switchport access vlan 20
 no ip address
!
interface Vlan10
 ip address 10.10.10.10 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.10.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Cat2950#

Cisco 7200 Router
Cisco7200#
Cisco7200# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.


!--- Create a logical channel interface in order to form an EtherChannel.

Cisco7200(config)# interface port-channel 1
Cisco7200(config-if)# exit


!--- Configure the ports Fa3/0 and Fa4/0 as members of the
!--- logical channel in order to form an EtherChannel group.

Cisco7200(config)# interface fa3/0
Cisco7200(config-if)# channel-group 1

FastEthernet3/0 added as member-1 to port-channel1
 Cisco7200(config-if)# exit
Cisco7200(config)#
00:25:06: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed
 state to up
Cisco7200(config)# interface fa4/0
Cisco7200(config-if)# channel-group 1

FastEthernet4/0 added as member-2 to port-channel1
 Cisco7200(config-if)# exit


!--- Configure subinterfaces over port channel for VLAN 10 and VLAN 20
!--- in order to configure trunking over EtherChannel. Assign the IP address 
!--- to interVLAN routing. Configure VLAN 10 as the native VLAN 
!--- for untagged traffic.

Cisco7200(config)# interface port-channel 1.10
Cisco7200(config-subif)# encapsulation dot1Q 10 native
Cisco7200(config-subif)# ip address 10.10.10.1 255.255.255.0
Cisco7200(config-subif)# exit
Cisco7200(config)# interface port-channel 1.20
Cisco7200(config-subif)# encapsulation dot1Q 20
Cisco7200(config-subif)# ip address 10.10.11.1 255.255.255.0
Cisco7200(config-subif)# exit
Cisco7200(config)# exit
Cisco7200#
Cisco7200# show running-config
Building configuration...

Current configuration : 987 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco7200
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!
!
interface Port-channel1
 no ip address
 hold-queue 150 in
!
interface Port-channel1.10
 encapsulation dot1Q 10 native
 ip address 10.10.10.1 255.255.255.0
!
interface Port-channel1.20
 encapsulation dot1Q 20
 ip address 10.10.11.1 255.255.255.0
!

!--- Output suppressed.

!
interface FastEthernet3/0
 no ip address
 channel-group 1
!
interface FastEthernet4/0
 no ip address
 channel-group 1
!
ip classless
no ip http server
!
!
!
gatekeeper
 shutdown
!
!
line con 0
line aux 0
line vty 5 15
!
end

Verify

This section provides information that you can use to confirm your configuration works properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Catalyst 2950 show Commands

  • show etherchannel

  • show interfaces interface-id switchport

  • show interfaces interface-id trunk

show etherchannel

The show etherchannel command displays EtherChannel information. The command also displays the load-balance or frame-distribution scheme, port, and port channel information. The command syntax is:

show etherchannel [channel-group-number] {brief | detail | load-balance | port |
port-channel | summary}

Note: This command should be on one line.

Cat2950# show etherchannel 1 detail
Group state = L2
Ports: 2   Maxports = 8
Port-channels: 1 Max Port-channels = 1
                Ports in the group:
                -------------------
Port: Fa0/2
------------
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1
Port index    = 0           Load = 0x00
Age of the port in the current state: 00d:17h:51m:49s
Port: Fa0/3
------------
Port state    = Up Mstr In-Bndl
Channel group = 1           Mode = On/FEC     Gcchange = 0
Port-channel  = Po1         GC   = 0x00010001    Pseudo port-channel = Po1
Port index    = 0           Load = 0x00
Age of the port in the current state: 00d:17h:51m:49s

                Port-channels in the group:
                ----------------------
Port-channel: Po1
------------
Age of the Port-channel   = 00d:17h:54m:02s
Logical slot/port   = 1/0           Number of ports = 2
GC                  = 0x00010001      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Ports in the Port-channel:
Index   Load   Port    EC state
------+------+------+------------
  0     00     Fa0/2    on
  0     00     Fa0/3    on

Time since last port bundled:    00d:17h:51m:50s    Fa0/3
Time since last port Un-bundled: 00d:17h:51m:53s    Fa0/3
Cat2950#

show interfaces interface-id switchport

The show interfaces interface-id switchport command displays the switchport configuration of the interface in the Administrative Mode field and the Administrative Trunking Encapsulation field of the output.

Cat2950# show interfaces port-channel 1 switchport
Name: Po1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 10 (VLAN0010)
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

Protected: false
Voice VLAN: none (Inactive)
Appliance trust: none
Cat2950#

show interfaces interface-id trunk

The show interfaces interface-id trunk command displays the trunk configuration of the interface.

Cat2950# show interfaces port-channel 1 trunk

Port      Mode         Encapsulation  Status        Native vlan
Po1       on           802.1q         trunking      10

Port      Vlans allowed on trunk
Po1       1-4094

Port      Vlans allowed and active in management domain
Po1       1,10,20

Port      Vlans in spanning tree forwarding state and not pruned
Po1       1,10,20
Cat2950#

Cisco 7200 Router show Commands

  • show interfaces port-channel channel-number
  • show interfaces interface.subinterface

show interfaces port-channel channel-number

You can use the show interfaces port-channel channel-number command in order to verify the port channel interface and the channel member ports.

Cisco7200# show interfaces port-channel 1
Port-channel1 is up, line protocol is up
  Hardware is FEChannel, address is 00d0.63b2.8854 (bia 0000.0000.0000)
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
    No. of active members in this channel: 2
        Member 0 : FastEthernet3/0 , Unknown duplex, 100Mb/s
        Member 1 : FastEthernet4/0 , Unknown duplex, 100Mb/s
  Last input 00:00:00, output never, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/80, 0 drops; input queue 0/150, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     79434 packets input, 6020431 bytes
     Received 2099 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1137 packets output, 359153 bytes, 0 underruns(0/0/0)
     6 output errors, 0 collisions, 6 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
Cisco7200#

show interfaces interface.subinterface

You can use the show interfaces interface.subinterface command in order to verify the trunk configuration.

Cisco7200# show interfaces port-channel 1.10
Port-channel1.10 is up, line protocol is up
  Hardware is FEChannel, address is 00d0.63b2.8854 (bia 0000.0000.0000)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.
  ARP type: ARPA, ARP Timeout 04:00:00
Cisco7200#

Cisco7200# show interfaces port-channel 1.20
Port-channel1.20 is up, line protocol is up
  Hardware is FEChannel, address is 00d0.63b2.8854 (bia 0000.0000.0000)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.
  ARP type: ARPA, ARP Timeout 04:00:00
Cisco7200#

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 30, 2005
Document ID: 24042