Guest

Cisco 800 Series Routers

Configuring a Cisco 827 Router Using PPPoA With CHAP and PAP

Cisco - Configuring a Cisco 827 Router Using PPPoA With CHAP and PAP

Document ID: 12886

Updated: Nov 23, 2007

   Print

Introduction

The sample configurations in this document show a Cisco 827 Digital Subscriber Line (DSL) Router connecting to a Cisco 6130 Digital Subscriber Line Access Multiplexer (DSLAM) and terminating on a Cisco 6400 Universal Access Concentrator (UAC). Each configuration uses Point-to- Point Protocol over Asynchronous Transfer Mode (PPPoA). The Asynchronous Transfer Mode (ATM) interface is configured for AALMUX PPP encapsulation.

One configuration shows PPPoA using Challenge Handshake Authentication Protocol (CHAP). The second configuration shows PPP over ATM using Password Authentication Protocol (PAP).

Before You Begin

Conventions

For more information on document conventions, see the Cisco Technical Tips Conventions.

Prerequisites

There are no specific prerequisites for this document.

Components Used

The information in this document is based on the software and hardware versions below.

  • Cisco 827-4V customer premises equipment (CPE) IOS® Software Release 12.1(1)XB

  • Cisco 6400 UAC-NRP IOS Software Release 12.0(7)DC

  • Cisco 6400 UAC-NSP IOS Software Release 12.0(4)DB

  • Cisco 6130 DSLAM-NI2 IOS Software Release 12.1(1)DA

The information presented in this document was created from devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If you are working in a live network, ensure that you understand the potential impact of any command before using it.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses the network setup shown in the diagram below.

827pppoachap.gif

PPPoA Using CHAP Configurations

When using interface virtual-template, configure only ppp chap hostname username and ppp chap password password . The ppp authentication chap callin command is not supported. In this example interface dialer is used, which is not affected.

Cisco 827
Current configuration: 
! 
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication chap callin 
 ppp chap hostname username
 
 ppp chap password password

! 
ip classless 
!
ip route 0.0.0.0 0.0.0.0 Dialer0 
! 
dialer-list 1 protocol ip permit 
!
end

Cisco Access 6400 NRP1
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication chap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

PPPoA Using PAP Configuration

When using interface virtual-template, configure only ppp pap sent-username username password password . The ppp authentication pap callin command is not supported. In this example interface dialer is used, which is not affected.

Cisco 827
version 12.1 
!
service timestamps debug datetime msec 
service timestamps log datetime msec 
! 
hostname R1 
! 
ip subnet-zero 
! 
interface Ethernet0 
 ip address 10.0.0.1 255.0.0.0 
 no ip directed-broadcast 
 no ip mroute-cache 
! 
interface ATM0 
 no ip address 
 no ip directed-broadcast 
 no ip mroute-cache 
 no atm ilmi-keepalive 
 pvc 1/150 
  encapsulation aal5mux ppp dialer 
  dialer pool-member 1 
 ! 
 hold-queue 224 in 
! 
interface Dialer0 
 ip address 172.18.0.1 255.255.0.0 
 no ip directed-broadcast 
 encapsulation ppp 
 dialer pool 1 
 dialer-group 1 
 ppp authentication pap callin
ppp pap sent-username username password password

! 
ip classless 
! 
ip route 0.0.0.0 0.0.0.0 Dialer0 
!
no ip http server 
! 
dialer-list 1 protocol ip permit 
! 
voice-port 1 
 timing hookflash-in 0 
! 
voice-port 2 
 timing hookflash-in 0 
! 
voice-port 3 
 timing hookflash-in 0 
! 
voice-port 4 
 timing hookflash-in 0 

Cisco Access 6400 NRP1
username 
username
 password 
password
 

!--- The username and password values must match 
!--- the username and password values of the remote device. 

!
interface ATM0/0/0.200 point-to-point
 no ip directed-broadcast
 no ip route-cache 
 pvc 1/301 
  encapsulation aal5mux ppp Virtual-Template11
 !
 interface Virtual-Template11 
  ip address 172.18.0.2 255.255.0.0 
  no ip directed-broadcast 
  ppp authentication pap
! 
ip route 10.0.0.1 255.255.255.255 172.18.0.1

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Nov 23, 2007
Document ID: 12886