Guest

Symmetrical High-Data-Rate DSL (G.SHDSL)

Configuring CPE Back-to-Back Through G.SHDSL Ports

Document ID: 25900

Updated: Apr 23, 2006

   Print

Introduction

This document provides a sample configuration for the configuration of two routers back-to-back through the Multirate Symmetric High-Speed Digital Subscriber Line (G.SHDSL) ports. It describes how a G.SHDSL Cisco� router can be configured to work as�a Central Office (CO) DSL device that terminates a connection from another remote G.SHDSL CPE device.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • 828 Customer Premises Equipment (CPE) running Cisco IOS® Software Release 12.2(8)T1

  • 2612 router running Cisco IOS Software Release 12.2(8)T

  • 2612 router using a WAN Interface Card (WIC)-1SHDSL

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses this network setup:

dsl_cpe_config1.gif

Configurations

This document uses these configurations:

Note: In this configuration the 828A is configured with the equipment type "CO," which simulates the signaling from the CO. While the 2612 with the G.SHDSL WIC is configured with the equipment type "CPE."

DSL5-828A(Cisco 828 CPE Acting as a CO)
DSL5-828A#show run
Building configuration...

Current configuration : 769 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname DSL5-828A
!
!
ip subnet-zero
!
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CO
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Dialer0
 ip address 1.1.1.1 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!         
dialer-list 1 protocol ip permit
!
line con 0
 stopbits 1
line vty 0 4
!
scheduler max-task-time 5000
end

DSL4-2612A (Cisco 2612 Router acting as CPE)
dsl4-2612a#show run
Building configuration...

Current configuration : 927 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname dsl4-2612a
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface ATM0/0
 no ip address
 no atm ilmi-keepalive
 pvc 0/35 
  encapsulation aal5snap
 !
 pvc 8/35 
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
 dsl equipment-type CPE
 dsl operating-mode GSHDSL symmetric annex A
 dsl linerate AUTO
!
interface Ethernet0/0
 ip address 172.16.1.2 255.255.255.0
 shutdown
 half-duplex
!         
interface TokenRing0/0
 no ip address
 shutdown
 ring-speed 16
!
interface Dialer0
 ip address 1.1.1.2 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer-group 1
!
ip classless
ip http server
ip pim bidir-enable
!
!
dialer-list 1 protocol ip permit
!
call rsvp-sync
!
!
mgcp profile default
!         
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
!
end

Command Reference

This section documents modified commands. All other commands used with this feature are documented in the Cisco IOS Software Release 12.2 command reference publications.

Modified Commands

  • dsl equipment-type

  • dsl linerate

  • dsl operating-mode (g.shdsl)

dsl equipment-type

Issue the dsl equipment-type command in ATM interface mode to configure the DSL ATM interface to function as CO equipment or CPE. Use the no form of this command to restore the default equipment type.

  • dsl equipment-type {co | cpe}

  • no dsl equipment-type

The syntax descriptions for these commands are:

  • co—Configures the DSL ATM interface to function as CO equipment.

  • cpe—Configures the DSL ATM interface to function as CPE.

Defaults

The DSL ATM interface functions as CPE.

Interface Command Mode

The ATM interface for the G.SHDSL WIC was integrated into these Cisco IOS Software releases:

  • 12.2(4)XL—on the Cisco 2600 series routers

  • 12.2(8)T—on the Cisco 2600 series and Cisco 3600 series routers

Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you issue this command. The ATM interface must also be in the shutdown state before you issue this command. This example shows how to configure DSL ATM interface 1/1 to function as CO equipment.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 1/1 
Router(config-if)#dsl equipment-type co 

Router(config-if)#end 
Router# clear interface atm 0/1 

Router#

Related Commands

  • dsl linerate—Specifies a line rate for the DSL ATM interface.

  • dsl operating-mode (g.shdsl)—Specifies an operating mode of the DSL ATM interface.

dsl linerate

Issue the dsl linerate command in ATM interface mode to specify a line rate for the DSL ATM interface. Use the no form of this command to restore the default line rate.

  • dsl linerate {kbps | auto}

  • no dsl linerate

The syntax descriptions for these commands are:

  • kbps—Specifies a line rate in kilobits per second for the DSL ATM interface. Allowable entries are 72, 136, 200, 264, 392, 520, 776, 1032, 1160, 1544, 2056, and 2312.

  • auto—Configures the DSL ATM interface to automatically train for an optimal line rate by negotiating with the far-end DSL Access Multiplier (DSLAM) or WIC.

Defaults

The DSL ATM interface automatically synchronizes its line rate with the far-end DSLAM or WIC.

Interface Command Mode

The ATM interface for the G.SHDSL WIC was integrated into these Cisco IOS Software releases:

  • 12.2(4)XL—on the Cisco 2600 series routers

  • 12.2(8)T—on the Cisco 2600 series and Cisco 3600 series routers

Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you issue this command. The ATM interface must also be in the shutdown state before you issue this command. This example shows how to configure DSL ATM interface 0/1 to operate at a line rate of 1040 kbps:

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/1 
Router(config-if)#dsl linerate 1040 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router# 

Related Commands

  • dsl equipment-type—Configures the DSL ATM interface to function as CO equipment or CPE.

  • dsl operating-mode (g.shdsl)—Specifies an operating mode of the DSL ATM interface. Use the no form of this command to restore the default operating mode.

dsl operating-mode (g.shdsl)

Issue the dsl operating-mode ATM interface command to specify an operating mode of the DSL for an ATM interface. Use the no form of this command to restore the default operating mode.

  • dsl operating-mode gshdsl symmetric annex {A | B}

  • no dsl operating-mode

The syntax descriptions for these commands are:

  • gshdsl—Configures the DSL ATM interface to operate in multirate high-speed mode per ITU G.991.2.

  • symmetric—Configures the DSL ATM interface to operate in symmetrical mode per ITU G.991.2.

  • annex {A | B}—Specifies the regional operating parameters. Enter A for North America and B for Europe. The default is A.

Defaults

The default operating mode is G.SHDSL symmetric annex A.

Interface Command Mode

The ATM interface for the G.SHDSL WIC was introduced in Cisco IOS Software Release 12.1(3)X, and integrated into these Cisco IOS Software releases.

  • 12.2(2)T—on the Cisco 1700 series routers

  • 12.2(4)XL—on the Cisco 2600 series routers

  • 12.2(8)T—on the Cisco 2600 series and Cisco 3600 series routers

Usage Guidelines

This configuration command applies to a specific ATM interface. You must specify the ATM interface before you issue this command. The ATM interface must also be in the shutdown state before you enter this command. This example shows how to configure DSL ATM interface 0/0 to operate in G.SHDSL mode.

Router#configure terminal 
  
Enter configuration commands, one per line. End with CNTL/Z. 
Router(config)#interface atm 0/0 
Router(config-if)#dsl operating-mode gshdsl symmetric annex A 

Router(config-if)#end 
Router#clear interface atm 0/1 

Router#

Related Commands

  • dsl equipment-type—Configures the DSL ATM interface to function as CO equipment or CPE.

  • dsl linerate—Specifies a line rate for the DSL ATM interface.

Verify

You should see this output going across the console session. Issue the term mon command, if you are Telneted into the routers, to view the console messages.

00:51:25: %GSI-6-RESET: Interface ATM0/0, bringing up the line. 
It may take several seconds for the line to be active. 
00:52:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
00:52:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
00:52:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
00:52:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
00:52:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
00:52:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up 

This section provides information you can use to confirm your configuration is working properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

  • show running-config—Verifies the current configuration, and views the status for all controllers.

  • show controllers atm slot/port—Views ATM controller statistics.

  • show atm vc—Verifies the Permanent Virtual Circuit (PVC) status.

  • show dsl interface atm—Views the status of the G.SHDSL modem

  • show interface atm—Views the status of the ATM interface.

This is example output from the show atm vc command. Make sure that the active PVCs are up.

dsl4-2612a#show atm vc 
           VCD /                                        Peak  Avg/Min Burst 
Interface  Name         VPI   VCI  Type   Encaps   SC   Kbps   Kbps   Cells  Sts 
0/0        1              0    35  PVC    SNAP     UBR    2304                UP 
0/0        2              8    35  PVC    MUX      UBR    2304                UP

This is example output from the show dsl interface atm command. If the line is down, the Line is not active. Some of the values may not be accurate. statement appears. You can also verify whether the equipment type and operating mode configuration are correct for your application.

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Data (0x1) 
 Received SNR:           39 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5 

dsl4-2612a#show dsl interface atm 0/0 
Globespan G.SHDSL/SDSL Chipset Information 

Line is not active. Some of the values printed may not be accurate. 
 Equipment Type:         Customer Premise 
 Operating Mode:         G.SHDSL Annex A 
 Clock Rate Mode:        Auto rate selection Mode 
 Reset Count:            1 
 Actual rate:            2312 Kbps 
 Modem Status:           Idle (0x0) 
 Received SNR:           38 dB 
 SNR Threshold:          23 dB 
 Loop Attenuation:      -0.3400 dB 
 Transmit Power:         7.5 dBm 
 Receiver Gain:          4.3900 dB 
 Last Activation Status: No Failure (0x0) 
 CRC Errors:             33372 
 Chipset Version:        1 
 Firmware Version:       R1.5

If you are unable to ping across the ATM circuit, verify that the ATM interface is UP/UP by issuing the show interface command for the ATM interface on both routers. Issue the show interface atm command to view the status of the ATM interface. Make sure that the ATM slot, port, and the line protocol are up, as this example shows.

DSL5-828A#show interfaces atm0 
ATM0 is up, line protocol is up 
  Hardware is PQUICC_SAR (with Globespan G.SHDSL module) 
  MTU 1500 bytes, sub MTU 1500, BW 2312 Kbit, DLY 80 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ATM, loopback not set 
  Encapsulation(s): AAL5, PVC mode 
  10 maximum active VCs, 2 current VCCs 
  VC idle disconnect time: 300 seconds 
  Last input never, output 00:00:08, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: None 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     261 packets input, 11170 bytes, 0 no buffer 
     Received 0 broadcasts, 0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort 
     264 packets output, 11388 bytes, 0 underruns 
     0 output errors, 0 collisions, 2 interface resets 
     0 output buffer failures, 0 output buffers swapped out

Troubleshooting

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

Note: Refer to Important Information on Debug Commands before you use debug commands.

  • debug atm events—Identifies ATM related events as they are generated.

  • debug atm errors—Indicates which interfaces have trouble.

This is sample debug information from an ATM interface, running the debugs listed in this section, and coming online (keep in mind that it might take 30 seconds or more for the circuit to come up).

01:07:15: ATM0/0 dslsar_1a_reset: PLIM type is 19, Rate is 2304Mbps 
01:07:15: ATM0/0 dslsar_1a_shutdown: state=4 
01:07:15: dslsar disable ATM0/0 

01:07:15: %GSI-6-RESET: Interface ATM0/0, bringing up the line.
It may take several seconds for the line to be active. 
01:07:15: Resetting ATM0/0 
01:07:15:  dslsar_1a_config(ATM0/0) 
01:07:15:  dslsar_1a_enable(ATM0/0) 
01:07:15: ATM0/0: dslsar_init(825AD084,FALSE) 
01:07:15: dslsar disable ATM0/0 

01:07:16: ATM0/0 dslsar_init: DSLSAR TXRX disabled 

01:07:16: ATM0/0 dslsar_1a_enable: restarting VCs: 0 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 1, vc = 0x82A17BE0adb->flags = 0x4800C 
01:07:16: (ATM0/0)1a_enable,calling atm_activate_pvc, vcd = 2, vc = 0x82A1863Cadb->flags = 0x4800C 
dsl4-2612a# 
dsl4-2612a# 
01:07:16: %SYS-5-CONFIG_I: Configured from console by console 
01:07:19: dslsar disable ATM0/0 

01:08:03: ATM0/0 dslsar_MatchSARTxToLineSpeed(): usbw 2304, clkPerCell 6360 prev_clkPerCell 9702 
01:08:03: ATM0/0 dslsar_update_us_bandwidth(): upstream bw =2304 Kbps 
01:08:09:  dslsar_periodic: ENABLING DSLSAR 

01:08:09: dslsar enable ATM0/0 

01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:1 vpi:0 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 1, vpi 0, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 2304, tbds_per_tsi = 15, max_pkt_len = 4470, 
max_tx_time = 1862ATM0/0 last_address 0x12E14 

01:08:09: %ATM-5-UPDOWN: Changing VC 0/35 VC-state to PVC activated. 
01:08:09:  dslsar_1a_setup_vc(ATM0/0): vc:2 vpi:8 vci:35 state 2 
01:08:09: ATM0/0 dslsar_vc_setup: vcd 2, vpi 8, vci 35, avgrate 0 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 1 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:09: %ATM-5-UPDOWN: Changing VC 8/35 VC-state to PVC activated. 
01:08:09: CONFIGURING VC 1 (0/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 1:  slot 0 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 1 (0/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 1, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 
01:08:09: CONFIGURING VC 2 (8/35) IN TX SCHEDULE TABLE SET 0 
01:08:09: Forcing Peakrate and Avgrate to: 2304 
01:08:09: Requested QoS: Peakrate = 2304, Avgrate = 2304, Burstsize =0 
01:08:09: Configuring VC 2:  slot 1 in TST 5 
01:08:09: SUCCESSFUL CONFIGURATION OF  VC 2 (8/35), QOS Type 4 
01:08:09: ATM0/0: vcd = 2, bw = 1152, tbds_per_tsi = 15, max_pkt_len = 4470, max_tx_time = 3725 

01:08:10: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up 
01:08:10: %DIALER-6-BIND: Interface Vi1 bound to profile Di0 
01:08:11: %LINK-3-UPDOWN: Interface ATM0/0, changed state to up 
01:08:11:  dslsar_atm_lineaction(ATM0/0): state=4 
01:08:12: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0/0, changed state to up 
01:08:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access1, changed state to up

Related Information

Updated: Apr 23, 2006
Document ID: 25900