Guest

IP Routing

How OSPF Injects a Default Route into a Stub or Totally Stub Area

Cisco - How OSPF Injects a Default Route into a Stub or Totally Stub Area

Document ID: 47869

Updated: Aug 10, 2005

   Print

Introduction

This document shows how Open Shortest Path First (OSPF) injects a default route into a stub or totally stub area.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to find more information on the commands used in this document.

Network Diagram

This document uses the network setup shown in this diagram.

ospfdb10a.gif

Configurations

This document uses the configurations shown here.

Router 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 stub

end

Router 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 stub

end

Verify

This section provides information you can use to confirm your configuration is working properly.

The Output Interpreter Tool (registered customers only) (OIT) supports certain show commands. Use the OIT to view an analysis of show command output.

  • show ip ospf database—Displays a list of the Link State Advertisements (LSAs) and types them into a link state database. This list shows only the information in the LSA header.

  • show ip ospf database summary <link-state id> —Displays the area border router (ABR) summary links.

  • show ip route—Displays the current status of the routing table.

Examine the OSPF Database in a Stub Area

The ABR for the stub area originates a summary LSA with a link ID of 0.0.0.0. It does this even if it does not have a default route. You can see this happen with the show ip ospf database command.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
2.2.2.2    2.2.2.2     19     0x80000001     0x8F8B         1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#           Checksum 
5.0.0.0    2.2.2.2     9       0x80000001     0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     1335    0x80000059     0x56DA         2 
2.2.2.2    2.2.2.2     4       0x80000013     0x7FF3         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     20      0x80000001         0x75C0 
6.0.0.0    2.2.2.2     13      0x80000001         0x2709 


r2.2.2.2#show ip ospf database summary 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Summary Net Link States (Area 1) 

  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 0.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) injects a default route 
  !--- into the stub area. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x75C0 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 1 
  

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table

!--- The ABR (Router 2.2.2.2) does not have a default route
!--- in its routing table.


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 

Examine the OSPF Database in a Totally Stub Area

If you change area 1 in the stub area example from a stub area to a totally stub area, the ABR still injects the 0.0.0.0 summary LSA into area 1. The only difference is that other summary LSAs are not sent into the totally stub area.

Note: The only configuration change made was to the ABR. The no-summary statement was added to its OSPF configuration: area 1 stub no-summary.

This command output shows what the OSPF database looks like in a totally stub area.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
2.2.2.2    2.2.2.2     617     0x80000001   0x8F8B           1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
5.0.0.0    2.2.2.2     608     0x80000001   0x8E61 

                Summary ASB Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
1.1.1.1    2.2.2.2     243     0x80000003   0x8F5E 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
1.1.1.1    1.1.1.1     1934    0x80000059   0x56DA           2 
2.2.2.2    2.2.2.2     247     0x80000015   0x7BF5           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     249     0x80000003         0x71C2  

!--- Notice that this is the only summary LSA 
!--- in the totally stub area. 


r1.1.1.1#show ip route ospf 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:11, Serial2/1/0 

The ABR does not originate a summary LSA for 6.0.0.0/8. As a result, Router 1.1.1.1 no longer has a route for 6.0.0.0/8. The only inter-area route this router has is the default route.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 10, 2005
Document ID: 47869