Guest

IP Routed Protocols

Policy Based Routing with the Multiple Tracking Options Feature Configuration Example

Document ID: 48003

Updated: Aug 10, 2005

   Print

Introduction

This document provides a sample configuration for policy based routing with the Multiple Tracking Options feature. This feature was introduced in Cisco IOS® Software Release 12.3(4)T. Refer to PBR Support for Multiple Tracking Options for more information.

This feature extends the capabilities of objective tracking to verify the next hop IP address before forwarding the traffic to the next hop. The verification method can be an Internet Control Message Protocol (ICMP) ping, User Datagram Protocol (UDP) ping, or a Hypertext Transfer Protocol (HTTP) GET request. ICMP is the most common verification method used on the Internet. The Multiple Tracking Options feature is most suitable for routers which have multiple Ethernet connections as the next hop. Normally, Ethernet interfaces connect to digital subscriber line (DSL) or cable modems. Currently, there is no method to detect a failure upstream in the ISP broadband network—the Ethernet interface remains up and any form of static routing points to that interface. The strength of this feature allows you to backup two Ethernet interfaces, choose the interface which is available by sending ICMP pings to verify reachablity, and then route traffic out to that interface.

Prerequisites

Requirements

Before you attempt this configuration, ensure that you meet this requirement:

  • Load the Enterprise Base IOS Feature set to your routers, if you have not already done so. If you have paid for this feature set, you can download it from the Download Software Area (registered customers only) .

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

This section presents the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup. In this scenario, R1 is connected to two different ISPs (ISP-1 and ISP-2). R1 tracks the reachability to both ISP routers.

pbrtracking_01.gif

Configuration

This document uses this configuration:

R1
R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Track Router 1's reachability.

!         
track 124 rtr 2 reachability

!--- Track Router 2's reachability.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Enable policy routing on the outgoing interface.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Define a route-map to set the next hop depending on 
!--- the state of the tracked routers.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Define and start Router 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Define and start Router 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Verify

This section provides information you can use to confirm your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

  • show track—Displays tracking information.

  • show track brief—Displays limited tracking information.

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

From the show track brief command output, you can see that both ISPs are reachable. If you shut down the interface that is connected to ISP-1, it is shown as down when tracked.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

Note: PBR requires tracking in order to determine whether the interface or the route is active. In order to view the status of the route tracking, you can also use the show route-map command.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Aug 10, 2005
Document ID: 48003