Guest

IBM Networking

DLSw Ethernet Redundancy Configuration Example

Document ID: 12345

Updated: Sep 09, 2005

   Print

Introduction

This sample configuration implements the Cisco IOS® software Ethernet Redundancy feature on a Data-Link Switching (DLSw) network. Also included in this document are techniques to debug this feature. The Ethernet Redundancy feature was added in Cisco IOS Software Release 12.0(5)T.

This sample configuration shows how to implement the Ethernet Redundancy feature and the commands used to monitor the status of the connections. Three scenarios are simulated in which failure occurs while the debug commands are running in order to show the behavior of each router.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This document is not restricted to specific software and hardware versions.

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

8-a.gif

Configuration Notes

  • Controller A is configured to establish two Logical Link Control (LLC) sessions with the host; it uses a Local Service Access Point (LSAP) value of 0x04 and 0x08, respectively. Controller B attempts to establish only one LLC session, and the host uses a LSAP value of 0x04.

  • For this sample configuration, when both DLSw routers are up, Controller A connects to the host with the router Avimimus, and Controller B connects to the host with the router Turbo. Load balancing is accomplished when both routers are up and work properly.

  • Here are the MAC addresses of the controllers and the configurations:

    • Controller A

      smac = 0000.2222.0000 (cann), dmac = 0000.6666.0000 (cann)
      lsap = 0x04 and lsap = 0x08, dsap = 0x04 for both connections

      For easy reference, these are the bit swap values of this MAC address:

      smac = 0000.4444.0000 (non-cann), dmac = 0000.6666.0000 (non-cann)
    • Controller B

      smac = 0000.1111.0000 (cann), dmac = 0000.7777.0000 (cann)
      lsap = 0x08, dsap = 0x04

      For easy reference, these are the bit swap values of this MAC address:

      smac = 0000.8888.0000 (non-cann), dmac = 0000.EEEE.0000 (non-can)
  • The host has this MAC address:

    smac = 4000.3745.0000 (non-can) 
    lsap = 0x04

    For easy reference, this is the bit swap value of the MAC address of the host:

    smac = 0200.eca2.0000 (cann)
    
  • Avimimus is configured to be the master DLSw router, and Turbo is configured to be the slave DLSw router. Avimimus is assigned a lower priority value to achieve this configuration. The default priority is 100. Listed here are the commands used to specify the priority value for each router:

    • Avimimus—dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10

    • Turbo—dlsw transparent redundancy-enable 9999.9999.9999

    Both routers must be configured to use the same multicast MAC address for communication (9999.9999.9999).

  • Avimimus has this MAC address configured:

    Ethernet 0:
    smac = 0000.3333.0000 (cann), 0000.CCCC.0000 (non-cann)
  • Turbo has this MAC address configured:

    Ethernet 0:
    smac = 0000.5555.0000 (cann), 0000.AAAA.0000 (non-cann)
  • Avimimus is configured to do this MAC address mapping:

    local mac: 0000.6666.0000 --> remote mac: 0200.ECA2.0000 (cann)

    For easy reference, these are the bit swap values of this MAC address:

    local mac: 0000.6666.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Turbo is configured to do this MAC address mapping:

    local mac: 0000.7777.0000 --> remote mac: 0200.ECA2.0000 (cann)

    For easy reference, these are the bit swap values of the MAC address:

    local mac: 0000.EEEE.0000 --> remote mac: 4000.3745.0000 (non-can)
  • Listed here are the commands to specify the MAC address mapping at the DLSw routers:

    • Avimimus—dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000

    • Turbo—dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000

    Note: All MAC addresses configured in these commands must be in canonical format. The "local-mac" value represents the Destination MAC (DMAC) to which the Ethernet end stations point (0000.6666.0000 and 0000.7777.0000, in this case). The "remote-mac" value is the canonical representation of the remote host that you attempt to reach through DLSw. The "neighbor" value represents the MAC address of the Ethernet interface of the other DLSw redundant router.

Configurations

This document uses these configurations:

Master DLSw Redundant Router
avimimus# show run
Building configuration...
!
hostname avimimus
! 
dlsw local-peer peer-id 1.1.1.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
!
interface Ethernet0
 mac-address 0000.3333.0000
 ip address 5.5.5.3 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 media-type 10BaseT
 standby timers 3 10
 standby priority 150 preempt
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
 dlsw transparent redundancy-enable 9999.9999.9999 master-priority 10

!--- This is the command used to specify the priority value of Avimimus.

 dlsw transparent map local-mac 0000.6666.0000 remote-mac 0200.eca2.0000 neighbor 0000.5555.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial0
 ip address 1.1.1.1 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
 clockrate 4000000
!
end

Slave DLSw Redundant Router
turbo# show run
Building configuration...
!
hostname turbo
!
dlsw local-peer peer-id 2.2.2.1
dlsw remote-peer 0 tcp 3.3.3.1
dlsw transparent switch-support
!
interface Ethernet0
 mac-address 0000.5555.0000
 ip address 5.5.5.1 255.255.255.0
 no ip redirects
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 standby timers 3 10
 standby priority 100
 standby mac-address 0000.3333.3333
 standby ip 5.5.5.4
dlsw transparent redundancy-enable 9999.9999.9999

!--- This is the command used to specify the priority value of Turbo.

dlsw transparent map local-mac 0000.7777.0000 remote-mac 0200.eca2.0000 neighbor 0000.3333.0000

!--- This is the command used to specify the MAC address mapping at the DLSw router.

!
interface Serial1
 ip address 2.2.2.1 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
!
end

Token Ring DLSw Router
limno# show run 
!
hostname limno
!
source-bridge ring-group 100
!
dlsw local-peer peer-id 3.3.3.1
dlsw remote-peer 0 tcp 2.2.2.1
dlsw remote-peer 0 tcp 1.1.1.1
!
interface TokenRing0
 ring-speed 16
 source-bridge 10 1 100
 source-bridge spanning 
!
interface Serial0
 ip address 1.1.1.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
interface Serial1
 ip address 2.2.2.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 clockrate 4000000
!
end

Verify

This section provides information you can use to confirm your configuration works properly. All of the show command output from this configuration is presented. There is commentary with the command output to help you locate important sections.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

This section is divided into these subsections:

show dlsw circuits and show llc Command Output

In this section, the show dlsw circuits and show llc command output is presented.

Master DLSw Redundant Router
avimimus# show dlsw circuits
Index     local addr(lsap)   remote addr(dsap)  state     uptime
738197594 0000.4444.0000(04) 4000.3745.0000(04) CONNECTED 3d02h
335544411 0000.4444.0000(08) 4000.3745.0000(04) CONNECTED 3d02h
Total number of circuits connected: 2 

The DLSw circuits are established between the end station MAC (0000.4444.0000) and the host MAC. The end station is not actually pointing to 4000.3745.0000, but the router is doing the MAC address mapping specified in the dlsw transparent map command.

Master DLSw Redundant Router
avimimus# show llc brief
LLC2 Connections: total of 3 connections
Et0 NORMAL 0000.aaaa.0000 0000.cccc.0000 94 94
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 04
Et0 NORMAL 0000.4444.0000 0000.6666.0000 04 08

The first LLC session is established between the DLSw Ethernet Redundant routers using a SAP value of 0x94. MAC addresses for the DLSw routers appear in non-canonical format. For more information, refer to the show dlsw transparent Command Output section of this document.

The other two LLC sessions refer to when the end devices communicate with the MAC address configured in the router. That is, 0000.6666.0000 is the DMAC address configured in the end stations. All the LLC sessions appear to originate from the interface Ethernet 0 (Et0); however, the MAC addresses listed afterwards are displayed in non-canonical format. They are listed this way for easy reference to the show dlsw commands, which display all MAC addresses in non-canonical format.

Master DLSw Redundant Router
avimimus# show llc 
LLC2 Connections: total of 3 connections
Ethernet0 DTE: 0000.aaaa.0000 0000.cccc.0000 94 94 state NORMAL
V(S)=5, V(R)=7, Last N(R)=5, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 04 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 8920/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.4444.0000 0000.6666.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 9100/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

Slave DLSw Redundant Router
turbo# show dlsw circuits
Index      local addr(lsap)   remote addr(dsap)  state     uptime
2634022913 0000.8888.0000(08) 4000.3745.0000(04) CONNECTED 4d00h
Total number of circuits connected: 1


turbo# show llc brief
LLC2 Connections: total of 2 connections
Et0 NORMAL 0000.cccc.0000 0000.aaaa.0000 94 94
Et0 NORMAL 0000.8888.0000 0000.eeee.0000 04 08


turbo# show llc
LLC2 Connections: total of 2 connections
Ethernet0 DTE: 0000.cccc.0000 0000.aaaa.0000 94 94 state NORMAL
V(S)=7, V(R)=5, Last N(R)=7, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 7480/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200


Ethernet0 DTE: 0000.8888.0000 0000.eeee.0000 04 08 state NORMAL
V(S)=1, V(R)=1, Last N(R)=1, Local window=7, Remote Window=127
akmax=3, n2=8, 
xid-retry timer 0/0 ack timer 0/1000 
p timer 0/1000 idle timer 2410/10000 
rej timer 0/3200 busy timer 0/9600 
akdelay timer 0/100 txQ count 0/200

show dlsw transparent Command Output

In this section, the show dlsw transparent command output is presented.

Master DLSw Redundant Router
avimimus# show dlsw transparent neighbor
Interface Ethernet0
0000.cccc.0000 SELF Master
0000.aaaa.0000 Rcvd Master-Accepted VALID

The show dlsw transparent neighbor command displays the DLSw neighbors in a transparent bridged domain. All MAC addresses listed are shown in non-canonical format. However, when you configure the neighbor router (with the dlsw transparent map command), use the canonical format. Router Avimimus has the lowest priority and so is the master router.

Master DLSw Redundant Router
avimimus# show dlsw transparent cache

Interface Ethernet0
Circuit Cache

local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) NEGATIVE 0000.aaaa.0000
Total number of circuits in the Cache: 3

The show dlsw transparent cache command displays the master circuit cache for the broadcast domain. This router is aware of the connection that is established on the second router; this corresponds with the entry marked with a NEGATIVE state.

Master DLSw Redundant Router
avimimus# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE MAC     BACKUP
---------      ----------     ------
0000.6666.0000 4000.3745.0000 0000.aaaa.0000 STATIC
0000.eeee.0000 4000.3745.0000 0000.aaaa.0000 DYNAMIC(Passive)

In the previous output, the router is aware of both the translation specified in its configuration (see entry marked STATIC) and also the entry that is configured in the second router (entry marked DYNAMIC). The LOCAL MAC address is the MAC address that must be used by the end stations as DMAC.

The router then performs the translation to the MAC addresses that appear under the column REMOTE MAC. The REMOTE MAC must match the real MAC of the remote destination to which DLSw provides connectivity.

The second entry is on a Passive state, which means that the second router is alive and provides its own translation. In the case of a failure, Avimimus takes over that responsibility.

Slave DLSw Redundant Router
turbo# show dlsw transparent neighbor 

Interface Ethernet0
0000.aaaa.0000 SELF      Slave
0000.cccc.0000 Connected MASTER.



turbo# show dlsw transparent cache 

Interface Ethernet0
Circuit Cache 

local addr(lsap)   remote addr(dsap)     state    Owner
0000.8888.0000(08) 4000.3745.0000(04)    POSITIVE SELF
Total number of circuits in the Cache: 1


turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Passive)

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshooting Commands

This section presents all of the debug command output from this configuration. Commentary is included with the command output to help you locate important sections.

Note: Before issuing debug commands, refer to the Important Information on Debug Commands.

This section is divided into these subsections:

debug dlsw transparent Command Output During Simulated Failure of the Master Router

This section presents the debug dlsw transparent command output that is generated during simulated failures of the master router.

  • debug dlsw transparent master—Displays debug messages related to master-slave events.

  • debug dlsw transparent circuits—Displays debug messages related to the master circuit cache for the transparent bridged domain.

  • debug dlsw transparent address-map—Displays debug messages related to the MAC address mappings on the local router and any mappings for which the local router acts as backup for a neighbor peer.

Master DLSw Redundant Router
avimimus# show debug
DLSw:
DLSw Ethernet Redundancy - Master debugging is on
DLSw Ethernet Redundancy - Circuits debugging is on
DLSw Ethernet Redundancy - Address Map debugging is on

Mar 5 18:07:10.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:30.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:40.039: DLSW-ER: Sending MP Frame
Mar 5 18:07:50.039: DLSW-ER: Sending MP Frame
Mar 5 18:08:00.047: DLSW-ER: Sending MP Frame
Mar 5 18:08:10.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:20.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:30.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:40.051: DLSW-ER: Sending MP Frame
Mar 5 18:08:50.051: DLSW-ER: Sending MP Frame

The Master DLSw Redundant Router sends a Master Present (MP) frame every 10 seconds.

Here, a failure is introduced when the Ethernet interface is shut down:

Master DLSw Redundant Router
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# shut


Mar 5 18:09:00.951: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Init
Mar 5 18:09:02.951: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
Mar 5 18:09:02.951: DLSW-ER:dm_action_b: LLC2 session dead freeing neighbor 0000.aaaa.0000
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.951: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:09:02.971: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:02.979: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:03.951: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to down

Here are the debugs taken from the slave router during the failure:

Slave DLSw Redundant Router
turbo#
Mar 5 18:09:10.251: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Standby -> Active
Mar 5 18:09:10.583: DLSW-ER:dm_action_r: LLC2 session dead to neighbor 0000.cccc.0000 
Mar 5 18:09:10.587: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.591: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:09:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:10.595: DLSW-ER:dm_action_u: Freeing current master 0000.cccc.0000
Mar 5 18:09:10.599: DLSW-ER:dm_action_u: Changing state to Master
Mar 5 18:09:20.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:30.595: DLSW-ER: Sending MP Frame

In the previous syntax, Turbo becomes the master router and also takes over the translation that was configured in the Avimimus router.

Here are the debugs on Turbo when the end stations that are connected through Avimimus reattempt the connection to the host:

Slave DLSw Redundant Router
turbo#
Mar 5 18:09:40.595: DLSW-ER: Sending MP Frame
Mar 5 18:09:40.927: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.939: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:40.995: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:40.999: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4

In the previous syntax, you see that Turbo completes the required translations (that were previously owned by Avimimus) to set up the first LLC session from Controller A. This session uses LSAP 0x04 and RSAP 0x04.

Slave DLSw Redundant Router
Mar 5 18:09:41.963: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.975: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.979: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:41.983: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8

In the previous syntax, you see that Turbo completes the required translations (that were previously owned by Avimimus) to set up the second LLC session from Controller A. This session uses LSAP 0x08 and RSAP 0x04.

Slave DLSw Redundant Router
Mar 5 18:09:41.991: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:41.995: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:09:41.999: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4

The first DLSw circuit has been established, indicated by the UGotIt phrase.

Slave DLSw Redundant Router
Mar 5 18:09:42.003: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:42.971: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:09:42.975: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:09:42.983: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8

The second DLSw circuit is completed.

Slave DLSw Redundant Router
Mar 5 18:09:42.987: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:09:50.595: DLSW-ER: Sending MP Frame

Here are all the DLSw commands that indicate that Turbo has taken over Avimimus and that the circuits are all connected through Turbo:

Slave DLSw Redundant Router
turbo# show dlsw transparent cache
Interface Ethernet0
Circuit Cache
local addr(lsap)   remote addr(dsap)  state    Owner
0000.4444.0000(04) 4000.3745.0000(04) POSITIVE SELF
0000.4444.0000(08) 4000.3745.0000(04) POSITIVE SELF
0000.8888.0000(08) 4000.3745.0000(04) POSITIVE SELF
Total number of circuits in the Cache: 3

turbo# show dlsw transparent map 

Interface Ethernet0
LOCAL Mac      REMOTE Mac     BACKUP
---------      ----------     ------
0000.eeee.0000 4000.3745.0000 0000.cccc.0000 STATIC
0000.6666.0000 4000.3745.0000 0000.cccc.0000 DYNAMIC(Active)

In the previous syntax, you can see that the status of the second translation is now DYNAMIC(Active), which indicates that Avimimus must be down.

Slave DLSw Redundant Router
turbo# show dlsw circuits
Index       local addr(lsap)    remote addr(dsap)   state     uptime
4009754676  0000.4444.0000(04) 4000.3745.0000(04) CONNECTED  00:01:05
1610612789  0000.4444.0000(08) 4000.3745.0000(04) CONNECTED  00:01:04
2634022913  0000.8888.0000(08) 4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 3

debug dlsw transparent Command Output During Recovery of the Master Router

This section presents the debug dlsw transparent command output that is generated during the recovery of the master router.

Master DLSw Redundant Router
avimimus# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
avimimus(config)# interface ethernet0
avimimus(config-if)# no shut

Mar 5 18:12:00.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.127: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
Mar 5 18:12:03.595: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Listen -> Active
Mar 5 18:12:04.127: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed 
 state to up
Mar 5 18:12:10.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.599: DLSW-ER: New neighbor: master 0000.cccc.0000, neighbor 0000.aaaa.0000
Mar 5 18:12:10.599: DLSW-ER:dm_action_a: Rcvd MP with worse priority from 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.aaaa.0000
Mar 5 18:12:10.607: DLSW-ER: Sending MC to 0000.aaaa.0000
Mar 5 18:12:10.615: DLSW-ER:dm_action_d: Received MA from neighbor 0000.aaaa.0000 

In the previous syntax, Avimimus has received a Master Accept (MA) message from Turbo, which confirms that Avimimus is now the new master.

Here, the two routers exchange BACKMEUP_REQ for the mappings for which they are configured. Each request must be followed by an ACK.

Slave DLSw Redundant Router
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.6666.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.615: DLSW-ER: Sending DN to 0000.aaaa.0000
Mar 5 18:12:10.623: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for map entry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.623: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:10.651: DLSW-ER:dm_action_f: Rcvd CO from 0000.aaaa.0000
Mar 5 18:12:10.667: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.aaaa.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.667: DLSW-ER: Sending BACKMEUP_ACK 0000.eeee.0000 --> 4000.3745.0000 to 
 neighbor 0000.aaaa.0000 (617321C8)
Mar 5 18:12:19.731: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.735: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:20.647: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.aaaa.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:20.647: DLSW-ER:Sourcing a TestFrame 0000.6666.0000 --> 0000.aaaa.0000 on Ethernet0
Mar 5 18:12:30.087: DLSW-ER: Sending MP Frame

Here are the debugs taken from Turbo when the master router Avimimus comes up:

Slave DLSw Redundant Router
turbo#
Mar 5 18:12:00.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:03.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Active -> Speak
Mar 5 18:12:10.087: DLSW-ER: New neighbor: master 0000.aaaa.0000, neighbor 0000.cccc.0000
Mar 5 18:12:10.091: DLSW-ER:dm_action_o: Rcvd MP with better priority: 0000.cccc.0000
Mar 5 18:12:10.595: DLSW-ER: Sending MP Frame
Mar 5 18:12:10.611: DLSW-ER:dm_action_l: LLC2 up for neighbor 0000.cccc.0000
Mar 5 18:12:10.611: DLSW-ER: Sending MA to 0000.cccc.0000

Turbo acknowledges the message from Avimimus, and then Turbo becomes the slave.

Slave DLSw Redundant Router
Mar 5 18:12:10.615: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.623: DLSW-ER:dm_action_c: Rcvd MC with better priority from 0000.cccc.0000
Mar 5 18:12:10.627: DLSW-ER:dm_action_c: Changing state: Master to Slave

Turbo becomes the slave router.

Slave DLSw Redundant Router
Mar 5 18:12:10.627: DLSW-ER:Rcvd BACKMEUP_REQ from 0000.cccc.0000 for mapentry 0000.6666.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.635: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(4) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000
Mar 5 18:12:10.643: DLSW-ER:calling admin_stop for ckt(0000.4444.0000(8) 4000.3745.0000(4)) with 
 lmac 0000.6666.0000

In the previous syntax, Turbo terminates the DLSw circuits that must be owned by Avimimus. (The circuits must be torn down when the master comes back up.) This termination happens after Turbo receives the BACKMEUP_REQ from Avimimus.

Slave DLSw Redundant Router
Mar 5 18:12:10.643: DLSW-ER: dm_action_n: Rcvd DN frame from 0000.cccc.0000
Mar 5 18:12:10.647: DLSW-ER:Sending CO frame # 0 to 0000.cccc.0000
Mar 5 18:12:10.651: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.655: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:10.659: DLSW-ER:dm_action_s: LLC2 session up to neighbor 0000.cccc.0000
Mar 5 18:12:10.659: DLSW-ER: Sending BACKMEUP_REQ 0000.eeee.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)
Mar 5 18:12:10.671: DLSW-ER:Rcvd BACKMEUP_ACK from 0000.cccc.0000 for mapentry 0000.eeee.0000 
 --> 4000.3745.0000
Mar 5 18:12:10.675: DLSW-ER:Sourcing a TestFrame 0000.eeee.0000 --> 0000.cccc.0000 on Ethernet0
Mar 5 18:12:13.603: %STANDBY-6-STATECHANGE: Standby: 0: Ethernet0 state Speak -> Standby
Mar 5 18:12:19.723: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.727: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:19.731: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:19.735: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:20.643: DLSW-ER: Sending BACKMEUP_ACK 0000.6666.0000 --> 4000.3745.0000 
 to neighbor 0000.cccc.0000 (45B47C)

turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)   4000.3745.0000(04) CONNECTED  4d01h
Total number of circuits connected: 1

Presented in the syntax here are the debugs that occur when the end stations try to reestablish the connection. Avimimus is back up to serve as the master router.

Master DLSw Redundant Router
avimimus#
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.079: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:40.087: DLSW-ER: Sending MP Frame
Mar 5 18:12:41.071: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:Replacing dmac 0000.6666.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.075: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:41.079: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:4
Mar 5 18:12:41.079: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000
Mar 5 18:12:42.075: DLSW-ER:MS->CSM:UGotIt 4000.3745.0000:4 0000.4444.0000:8
Mar 5 18:12:42.075: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.6666.0000


avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  00:00:08
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  00:00:08
Total number of circuits connected: 2

debug dlsw transparent Command Output During Slave Router DLSw Circuit Establishment

This section presents the debug dlsw transparent command output that is generated when the slave router attempts to bring up a DLSw circuit.

It is useful to examine the communication between the slave and the master before the slave receives permission to accept the circuit.

The scenario is simulated when the existing DLSw circuit is cleared on the slave router.

Slave DLSw Redundant Router
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
2634022913  0000.8888.0000(08)  4000.3745.0000(04) CONNECTED   4d02h
Total number of circuits connected: 1


turbo# clear dlsw circuits 2634022913
turbo#
Mar 5 20:02:37.426: DLSW-ER:CG -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:37.430: DLSW-ER:CSM->MS: CG:OK: 4000.3745.0000:4 0000.8888.0000:8 

Turbo tells the master router to clear its cache entry for the just-erased circuit.

Slave DLSw Redundant Router
Mar 5 20:03:07.398: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.462: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:07.466: DLSW-ER:CSM->MS: C_INQ:NEW: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:07.470: DLSW-ER:IW -> 0000.cccc.0000: 4000.3745.0000:4 0000.8888.0000:8

Turbo receives an incoming request from the end device to connect to the end host. At 20:03:07.470, Turbo notifies the master router of this request.

Slave DLSw Redundant Router
Mar 5 20:03:07.474: DLSW-ER:CSM->MS: IW:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.458: DLSW-ER:Replacing dmac 0000.eeee.0000 with 4000.3745.0000 on a frame 
 from Ethernet0
Mar 5 20:03:08.462: DLSW-ER:CSM->MS: C_INQ:PENDING: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.474: DLSW-ER:dm_action_k: Rcvd UG for 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.478: DLSW-ER:action_a(): target mapped from (wan) 4000.3745.0000 ---> 
 0000.eeee.0000

Turbo gets a UG from its master, and the circuit is brought up.

Slave DLSw Redundant Router
turbo# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
385876023   0000.8888.0000(08)  4000.3745.0000(04) CONNECTED  00:00:33
Total number of circuits connected: 1

Here is the data taken at the master router at the time the slave attempts to bring up the circuit.

Master DLSw Redundant Router
avimimus# show dlsw circuits
Index        local addr(lsap)    remote addr(dsap)   state     uptime
3070230625  0000.4444.0000(04)  4000.3745.0000(04) CONNECTED  01:49:13
4194304098  0000.4444.0000(08)  4000.3745.0000(04) CONNECTED  01:49:13
Total number of circuits connected: 2


avimimus# show dlsw transparent cache
Interface Ethernet0
Circuit Cache

local addr(lsap)        remote addr(dsap)     state     Owner
0000.4444.0000(04)     4000.3745.0000(04)   POSITIVE    SELF
0000.4444.0000(08)     4000.3745.0000(04)   POSITIVE    SELF
0000.8888.0000(08)     4000.3745.0000(04)   NEGATIVE    0000.aaaa.0000
Total number of circuits in the Cache: 3

Mar 5 20:02:37.433: DLSW-ER:dm_action_h: Rcvd CG <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:02:41.409: DLSW-ER: Sending MP Frame
Mar 5 20:02:51.409: DLSW-ER: Sending MP Frame
Mar 5 20:03:01.417: DLSW-ER: Sending MP Frame
Mar 5 20:03:07.473: DLSW-ER:dm_action_j: Rcvd IW <- 
 0000.aaaa.0000 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:08.473: DLSW-ER:UG -> 0000.aaaa.0000: 4000.3745.0000:4 0000.8888.0000:8
Mar 5 20:03:11.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:21.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:31.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:41.421: DLSW-ER: Sending MP Frame
Mar 5 20:03:51.421: DLSW-ER: Sending MP Frame
avimimus#un all

Related Information

Updated: Sep 09, 2005
Document ID: 12345