Guest

IBM Networking

Configuring SNA Switching Services Over DLSw

Cisco - Configuring SNA Switching Services Over DLSw

Document ID: 12253

Updated: Sep 09, 2005

   Print

Introduction

This document describes how to configure a router and a mainframe computer to use Systems Network Architecture Switching Services (SNASw) over Data-Link Switching (DLSw), to connect upstream to the mainframe and downstream to a legacy Physical Unit (PU) 2.0 node. In this document???s example, the upstream connection to the mainframe is through a Channel Interface Processor (CIP), and the PU 2.0 node connects to the mainframe over the Dependent Logical Unit Requester (DLUR) pipe established by SNASw.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • SNASw 4700 with Cisco IOS?? Software Release 12.1(7)

  • CIP 7507 with Cisco IOS Software Release 12.1(7)

  • Downstream Physical Unit (DSPU) 4700 with Cisco IOS Software Release 12.0(10)

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

For more information on document conventions, refer to Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

dlsw_snasw.gif

The DSPU is only used to bring up a PU on the Token Ring. Note that the remote MAC (rmac) to which it connects is the MAC address that is specified on the Virtual Data-link Control (VDLC) port that is defined to SNASw on Brachio.

Configurations

This document uses these configurations:

A link statement is required only for the upstream connection, and only one VDLC port definition is needed by both the upstream and the downstream connections.

Brachio ??? SNASwitch Router Configuration
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname brachio
!
no logging buffered
!
!
!
!
!
ip subnet-zero
no ip domain-lookup
!
cns event-service server
!
source-bridge ring-group 2
dlsw local-peer peer-id 10.64.3.195
dlsw remote-peer 0 tcp 10.64.3.194
dlsw remote-peer 0 tcp 192.168.25.18
!
!
interface TokenRing0
ip address 10.64.3.195 255.255.255.240
ip ospf authentication-key mypasswo
ring-speed 16
!
interface TokenRing1
ip address 192.168.25.19 255.255.255.240
ring-speed 16
source-bridge 200 1 2
!
snasw cpname P390.BRACHIO
snasw dlus P390.P390SSCP
snasw port PVDLC vdlc 2 mac 4000.0000.1234
snasw link LVDLC port PVDLC rmac 4000.0000.0001
!
router ospf 1
log-adjacency-changes
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
no ip http server
!
!
!
line con 0
exec-timeout 0 0
transport input none                                                  
line aux 0
line vty 0 4
login
!
end

FEP ??? CIP Router Configuration
!
version 12.1
service timestamps debug datetime
service timestamps log datetime
no service password-encryption
!
hostname FEP
!
boot system flash slot0:rsp-a3jsv-mz.121-7.bin
logging buffered 64000 debugging
!
!
!
microcode CIP flash slot0:cip27-17
microcode reload

!
source-bridge ring-group 60
dlsw local-peer peer-id 10.64.3.194
dlsw remote-peer 0 tcp 10.64.3.195
!
!
interface TokenRing0/0
ip address 10.64.3.194 255.255.255.240
ip nat inside
ip ospf authentication-key pass
no ip mroute-cache
ethernet-transit-oui 90-compatible
ring-speed 16
multiring all
source-bridge 100 1 60
source-bridge spanning
llc2 local-window 127
!
!
interface Channel5/0
no ip address
no keepalive
csna 0100 40
!
interface Channel5/1
no ip address
no keepalive
shutdown
!
interface Channel5/2
no keepalive
lan TokenRing 0
source-bridge 600 1 60
adapter 0 4000.0000.0001
!
!
router ospf 1
log-adjacency-changes
redistribute static
network 0.0.0.0 255.255.255.255 area 0                                
default-information originate
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
exec-timeout 0 0
password cisco
login
!

Para ??? DSPU Router Configuration
!
version 12.0
service timestamps debug datetime msec
service timestamps log uptime
no service password-encryption
!
hostname para
!
enable secret 5 $1$py25$yYt4gnt.YlmsBH00wQW3G1
enable password parra
!
ip subnet-zero
!
source-bridge ring-group 300
dlsw local-peer peer-id 192.168.25.18
dlsw remote-peer 0 tcp 10.64.3.195
!
!
dspu vdlc 300 4000.0000.5678
dspu vdlc enable-host lsap 12
!
dspu host DPU4 xid-snd 01700004 rmac 4000.0000.1234 rsap 4 lsap 12    
!
dspu vdlc start DPU4
!
!
interface TokenRing0
ip address 192.168.25.18 255.255.255.240
no ip directed-broadcast
ring-speed 16
source-bridge 200 1 300
source-bridge spanning
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 0
!
ip classless
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
line vty 0 4
password parra
login
!
end

Mainframe ??? VTAM Configuration
XCA Major Node
XCAE40R VBUILD TYPE=XCA
*/*
XPE40R    PORT CUADDR=E40,ADAPNO=0,SAPADDR=4,MEDIUM=RING,   -
DELAY=0,TIMER=30
*/*
*/* --------------------------------------- XCAE40R PERIPHERAL NODES
*/* ----------------------------------------------------------------
*/*
XGE40R   GROUP DIAL=YES,CALL=IN,ANSWER=ON,ISTATUS=ACTIVE
XGRL00    LINE
XGRP00      PU
*/*
XGRL01    LINE
XGRP01      PU
*/*
XGRL02    LINE
XGRP02      PU
*/*
XGRL03    LINE
XGRP03      PU
*/*
XGRL04    LINE
XGRP04      PU
*/*
XGRL05    LINE
XGRP05      PU
*/*
XGRL06    LINE
XGRP06      PU
Switched Major Node for SNASwitch Control Point
VBUILD TYPE=SWNET
*
*
BRACHPU  PU    ADDR=01,      NOT USED                   X
DISCNT=NO,                 WHEN TO DISCONNECT           X
ANS=CONTINUE,                                           X
ISTATUS=ACTIVE,                                         X
NETID=P390,                                             X
CPCP=YES,                                               X
CONNTYPE=APPN,                                          X
CPNAME=BRACHIO,                                         X
HPR=YES,                                                X
PUTYPE=2
*
Switched Major Node for PU2.0 Devices Connected via DLUR Pipe
VBUILD TYPE=SWNET,         INCREASE # IF MORE PU        X
MAXGRP=19,                 MAX NO OF PATH GROUPS        X
MAXNO=19                   MAX NO OF 'TEL' NOS
*
*
DPU4     PU    ADDR=01,      NOT USED                   X
DISCNT=NO,                 WHEN TO DISCONNECT           X
IDBLK=017,                 **  MUST MATCH 'PU' CUST     X
IDNUM=00004,  MUST MATCH 'PU' CUST (LAST 5 OF TR ADDR!) X
IRETRY=YES,                REPOLL ON IDLE DETECT T/O  ? X
LOGAPPL=A06TSO,            INITIAL LOGON                X
MAXDATA=265,               PIU SIZE (FIXED FOR DCA CS)  X
MAXOUT=7,                  NO OF PIUS BEFORE RESPONSE ? X
MAXPATH=1,                 MAX NO OF 'DIALOUT' PATHS    X
PASSLIM=7,                 MAX NO OF CONTIG PIUS SENT ? X
USSTAB=USSS,                                            X
MODETAB=ISTINCLM,                                       X
DLOGMOD=M2782,                                          X
SSCPFM=USSSCS,                                          X
PUTYPE=2
*
*
DLU42    LU    LOCADDR=2
DLU43    LU    LOCADDR=3
DLU44    LU    LOCADDR=4
DLU45    LU    LOCADDR=5
DLU46    LU    LOCADDR=6
DLU47    LU    LOCADDR=7
*

Verify

This section provides information that you can use to confirm that your configuration is working properly.

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

These examples of show command output display status information for the routers in the sample configuration:

para# show dspu

dspu host DPU4 Vdlc  PU STATUS Active
FRAMES RECEIVED 7 FRAMES SENT 7
LUs USED BY DSPU 0 LUs ACTIVE 0
LUs USED BY API 0 LUs ACTIVE 0
LUs ACTIVATED BY HOST BUT NOT USED 6

brachio# show snasw link

Number of links 2
SNA Links                                                            HPR
Link Name     State    Port Name   Adjacent CP Name  Node Type     Sess  Sup
---------    --------  ---------   ----------------  ------------  ----  ---
1> @I000003   Active    PVDLC      P390.DPU4         LEN Node         7  No
2> LVDLC      Active    PVDLC      P390.P390SSCP     Network Node     2  Yes

brachio# show snasw dlus

Number of Dependent LU Servers 1
SNA Dependent LU Servers
DLUS Name          Default?  Backup?  Pipe State         PUs
-----------------  --------  -------  ----------------  -------
1> P390.P390SSCP      Yes       No       Active            1

brachio# show snasw pu

Number of DLUR PUs 1
SNA DLUR PUs
PU Name    PU ID     State       DLUS Name
--------  --------  --------  -----------------
1> DPU4    01700004  Active    P390.P390SSCP

These examples of display command output show the status of the Virtual Telecommunications Access Method (VTAM):

D NET,ID=SNASW1,E

IST097I DISPLAY ACCEPTED
IST075I NAME = SNASW1, TYPE = SW SNA MAJ NODE 231
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST084I NETWORK RESOURCES:
IST089I BRACHPU  TYPE = PU_T2.1          , ACTIV--L--
IST1500I STATE TRACE = OFF
IST314I END

D NET,ID=XCAE40R,E

IST097I DISPLAY ACCEPTED
IST075I NAME = XCAE40R, TYPE = XCA MAJOR NODE 234
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1021I MEDIUM=RING,ADAPNO= 0,CUA=0E40,SNA SAP= 4
IST654I I/O TRACE = OFF, BUFFER TRACE = OFF
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST170I LINES:
IST232I XGRL00   ACTIV
IST232I XGRL01   ACTIV
IST232I XGRL02   ACTIV
IST232I XGRL03   ACTIV
IST232I XGRL04   ACTIV
IST232I XGRL05   ACTIV
IST232I XGRL06   ACTIV
IST314I END

D NET,ID=CISCOPU4,E

IST097I DISPLAY ACCEPTED
IST075I NAME = CISCOPU4, TYPE = SW SNA MAJ NODE 237
IST486I STATUS= ACTIV, DESIRED STATE= ACTIV
IST1656I VTAMTOPO = REPORT, NODE REPORTED - YES
IST084I NETWORK RESOURCES:
IST089I DPU4     TYPE = PU_T2.1          , ACTIV
IST089I DLU42    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU43    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU44    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU45    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU46    TYPE = LOGICAL UNIT     , ACTIV
IST089I DLU47    TYPE = LOGICAL UNIT     , ACTIV
IST314I END

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Sep 09, 2005
Document ID: 12253