Guest

Cisco LocalDirector 400 Series

Troubleshooting Content Load Balancing in LocalDirector 4.1.1

Cisco - Troubleshooting Content Load Balancing in LocalDirector 4.1.1

Document ID: 28847

Updated: Jan 31, 2006

   Print

Introduction

This document provides a sample configuration and additional commands to troubleshoot the content load-balancing feature available in Cisco LocalDirector 416 (Version 4.1.1).

Note: Several issues with Content Load Balancing have been corrected in the most recent releases of the code for the LocalDirector. It is strongly recommended that you use version 4.2.4 or higher. Refer to the Software Download page (registered customers only) for more information.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This configuration was developed and tested using these software and hardware versions:

  • LocalDirector 416 (Version 4.1.1), with clients running Windows 2000 Server, Windows NT 4.0 Service Pack 4.0, and Windows 98

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to Cisco Technical Tips Conventions for more information on document conventions.

Network Diagram

load_balancing.jpg

Configuration

A client's request for /index.htm pages goes to server 172.18.124.205 or 172.18.124.207. Get requests with /rtp/local-director go to server 172.18.124.101. All other requests go to 172.18.124.206.

LocalDirector 416 (Version 4.1.1.)
Current configuration:
 syslog output 20.3
 no syslog console
 enable password 000000000000000000000000000000 encrypted
 hostname 38-ld416
 no shutdown ethernet 0
 no shutdown ethernet 1
 no shutdown ethernet 2
 interface ethernet 0 auto
 interface ethernet 1 auto
 interface ethernet 2 auto
 mtu 0 1500
 mtu 1 1500
 mtu 2 1500
 multiring all
 no secure  0
 no secure  1
 no secure  2
 ping-allow 0
 ping-allow 1
 no ping-allow 2
 ip address 172.18.124.209 255.255.255.0
 route 0.0.0.0 0.0.0.0 172.18.124.1 1
 arp timeout 30
 no rip passive
 rip version 1
 failover ip address 0.0.0.0
 no failover
 failover hellotime 30
 password cisco
 snmp-server enable traps
 snmp-server community public
 no snmp-server contact
 no snmp-server location
 no dns-boomerang enable
 content-rule nsteam depth 1024 "/index*.htm*"
 content-rule jahrule depth 1024 "/rtp/local-director/*"
 virtual 172.18.124.219:80:0:tcp:jahrule is
 virtual 172.18.124.219:80:0:tcp is
 virtual 172.18.124.219:80:0:tcp:nsteam is
 service 172.18.124.219:80:0:tcp clb-close
 real 172.18.124.205:80:0:tcp is
 real 172.18.124.101:80:0:tcp is
 real 172.18.124.206:80:0:tcp is
 real 172.18.124.207:80:0:tcp is
 bind 172.18.124.219:80:0:tcp:jahrule 172.18.124.101:80:0:tcp
 bind 172.18.124.219:80:0:tcp 172.18.124.206:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.205:80:0:tcp
 bind 172.18.124.219:80:0:tcp:nsteam 172.18.124.207:80:0:tcp
end

Sample show Command Output

show real

Verify the REAL Server status.

LocalDirector# show real
  Real Machines:  
                                                       No Answer  TCP Reset   DataIn   Machine

                            Connect  State Thresh   Reassigns  Reassigns   Conns  
 172.18.124.205:80:0:tcp       0      IS      8         0          0         0
 172.18.124.101:80:0:tcp       0      IS      8         0          0         0
 172.18.124.206:80:0:tcp       0      IS      8         0          0         0
 172.18.124.207:80:0:tcp       0      IS      8         0          0         0

show server

Verify the service configuration.

LocalDirector# show service
  Virtual Machine(s)              Service
 172.18.124.219:80:0:tcp         clb-close

show rule

View rules.

LocalDirector# show rule
  Name            Depth           Content-String
  nsteam          1024            "/index*.htm*"
  jahrule         1024            "/rtp/local-director/*"

View specific rule.

LocalDirector# show rule jahrule

  Name            Depth           Content-String
  jahrule         1024            "/rtp/local-director/*"

show bind

Verify bindings.

LocalDirector# show bind

 Virtual Machine(s)                      Real Machines/Urls
 172.18.124.219:80:0:tcp:jahrule(IS)
 172.18.124.101:80:0:tcp (IS)
 172.18.124.219:80:0:tcp (IS)
 172.18.124.206:80:0:tcp (IS)
 172.18.124.219:80:0:tcp:nsteam(IS)
 172.18.124.205:80:0:tcp (IS)
 172.18.124.207:80:0:tcp (IS)

Editing Rules

  1. Unbind by using the no bind command.

  2. Disable virtual servers using rule by using the to no-inservice command.

  3. Remove virtual servers by using the no virtual command.

  4. Edit the rule by typing the no rule command.

Related Information

Updated: Jan 31, 2006
Document ID: 28847