Guest

Cisco LocalDirector 400 Series

Configuring MultiNode Load Balancing on LocalDirector

Document ID: 12616

Updated: Jan 31, 2006

   Print

Introduction

LocalDirector uses the Cisco Appliance Server Architecture (CASA) to exist in the MultiNode Load Balancing (MNLB) environment. In the MNLB environment, LocalDirector has a Service Manager configuration. Cisco routers have Forwarding Agent configurations. The Service Manager determines the load balancing for the Forwarding Agents. Service Manager bases this determination on information from real servers. This setup increases network efficiency and scalability, and also adds application-aware balancing.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

This configuration was developed and tested with the use of these software and hardware versions:

  • LocalDirector software version 3.1.3

  • Cisco IOS® Software Release 12.0

  • LocalDirector 430

Conventions

For more information on document conventions, refer to the Cisco Technical Tips Conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: To find additional information on the commands used in this document, use the Command Lookup Tool (registered customers only) .

Network Diagram

This document uses this network setup:

config_mnlb-01.gif

Configurations

This document uses these configurations:

Service Manager Configuration (LocalDirector)
: Saved

: LocalDirector 430 Version 3.1.3 
syslog output 20.3 
no syslog console 
hostname cisco-ld 
no shutdown ethernet 0 
shutdown ethernet 1 
shutdown ethernet 2 
no shutdown ethernet 3 
interface ethernet 0 100full 
interface ethernet 1 auto 
interface ethernet 2 auto 
interface ethernet 3 100full 
mtu 0 1500 
mtu 1 1500 
mtu 2 1500 
mtu 3 1500 
multiring all 
no secure 0 
no secure 1 
no secure 2 
no secure 3 
no ping-allow 0 
no ping-allow 1 
no ping-allow 2 
ping-allow 3 
ip address 172.16.9.25 255.255.255.0 
route 172.16.10.0 255.255.255.0 172.16.9.5 1 
route 172.16.8.7 255.255.255.255 172.16.9.7 1 
route 172.16.8.8 255.255.255.255 172.16.9.8 1 
route 0.0.0.0 0.0.0.0 172.16.9.1 1 
no rip passive 
failover ip address 172.16.9.26 
failover 
telnet 172.16.0.0 255.255.0.0 
virtual 10.10.10.100:0:0:tcp is 
virtual 10.10.10.110:0:0:tcp is 
redirection 10.10.10.100:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
redirection 10.10.10.110:0:0:
tcp dispatched casa wildcard-ttl 60 fixed-ttl 60 igmp 224.0.1.2 port 1637 
real 172.16.10.3:0:0:tcp is 
real 172.16.10.4:0:0:tcp is 
real 172.16.10.5:0:0:tcp is 
real 172.16.10.6:0:0:tcp is 
bind 10.10.10.100:0:0:tcp 172.16.10.3:0:0:tcp 
bind 10.10.10.100:0:0:tcp 172.16.10.5:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.4:0:0:tcp 
bind 10.10.10.110:0:0:tcp 172.16.10.6:0:0:tcp 

Forwarding Agent Configuration (Cisco Router)
Building configuration... 

Current configuration: 

! 
version 12.0 
service timestamps debug uptime 
service timestamps log uptime 
service password-encryption 
! 
hostname router-a 
! 
ip subnet-zero 
no ip domain-lookup 
! 
ip cef distributed 
ip casa 172.16.8.7 224.0.1.2 
 forwarding-agent 1637 
! 
! 
process-max-time 200 
! 
interface Channel0/0 
 description RD0713 DE10 SYSF 9910 SYSJ 
 ip address 172.16.10.1 255.255.255.0 
 ip directed-broadcast 
 ip route-cache same-interface 
 no keepalive 
 claw DD10 00 172.16.10.3 TCPIP CIPTCP TCPIP TCPIP 
 claw DE10 00 172.16.10.5 TCPIP CIPTCP TCPIP TCPIP 
 claw DF10 00 172.16.10.4 TCPIP CIPTCP TCPIP TCPIP 
 claw DG20 00 172.16.10.6 TCPIP CIPTCP TCPIP TCPIP 
! 
interface Channel0/2 
 no ip address 
 no ip directed-broadcast 
 no keepalive 
 shutdown 
! 
interface FastEthernet1/0/0 
 ip address 172.16.9.7 255.255.255.0 
 no ip redirects 
 no ip directed-broadcast 
 ip route-cache flow 
 no ip route-cache distributed 
 ip igmp join-group 224.0.1.2 
 no ip mroute-cache 
 full-duplex 
 no mop enabled 
 standby use-bia 
 standby priority 105 preempt 
 standby ip 172.16.9.6 
 standby track Channel0/0 
! 
router rip 
 version 2 
 redistribute static 
 network 172.16.0.0 
! 
no ip classless 
ip route 0.0.0.0 0.0.0.0 172.16.9.1 
no ip http server 
! 
line con 0 
line aux 0 
line vty 0 4 
! 
end

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

This section provides information you can use to troubleshoot your configuration.

Troubleshoot Commands

Certain show commands are supported by the Output Interpreter Tool (registered customers only) , which allows you to view an analysis of show command output.

Note: Before you issue the debug commands, refer to Important Information on Debug Commands.

  • debug ip casa affinities—Enables debugs for CASA affinities.

  • debug ip casa packets—Enables debugs for CASA packets.

  • debug ip casa wildcards—Enables debugs for CASA wildcards.

  • show ip casa affinities—Displays statistics about affinities.

  • show ip casa oper—Displays operational information.

  • show ip casa stats —Displays statistical information.

  • show ip casa wildcard—Displays information about wildcard affinities.

For more information on the MNLB commands on LocalDirector, refer to MNLB Feature Set for LD: Command Reference.

Sample debug Output

This output is from the debug ip casa affinities command:

Router# debug ip casa affinities
16:15:36:Adding fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.1.1:54787 -> 10.10.10.10:23 proto = 6
16:15:36:    flags = 0x2, appl addr = 10.10.3.2, interest = 0x5/0x100
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0
16:15:36:Adding fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:Updating fixed affinity:
16:15:36:    10.10.10.10:23 -> 10.10.1.1:54787 proto = 6
16:15:36:    flags = 0x2, appl addr = 0.0.0.0, interest = 0x3/0x104
16:15:36:    int ip:port = 10.10.2.2:1638, sequence delta = 0/0/0/0

Related Information

Updated: Jan 31, 2006
Document ID: 12616