Guest

Cisco 500 Series Cache Engines

Cache Engine 500 Series WCCP Policy Redirection Configuration Example

Document ID: 12658

Updated: Jan 08, 2007

   Print

Introduction

This document provides a sample configuration that demonstrates how to set up a Web Cache Communication Protocol version 2 (WCCPv2) policy redirection in a Cisco 500 Series Cache Engine. In this sample configuration, you use the table-map command in the BGP configuration and mapping the external entry attribute WCCP tag into the routing table in order to classify packets with Border Gateway Protocol (BGP) attributes associated with the source or destination IP address of a packet.

Prerequisites

Requirements

There are no specific requirements for this document.

Components Used

The information in this document is based on these software and hardware versions:

  • Cisco 7513 Router that runs Cisco IOS® Software Release 12.0(14)S

  • Cisco Cache Engine 550 that runs Cisco Cache Software Release 2.3

  • Cisco 2600 Router that runs Cisco IOS Software Release 12.0

  • Windows NT Web servers

The information in this document was created from the devices in a specific lab environment. All of the devices used in this document started with a cleared (default) configuration. If your network is live, make sure that you understand the potential impact of any command.

Conventions

Refer to the Cisco Technical Tips Conventions for information on document conventions.

Configure

In this section, you are presented with the information to configure the features described in this document.

Note: Use the Command Lookup Tool (registered customers only) to obtain more information on the commands used in this section.

Network Diagram

This document uses this network setup:

wwcp_2_policy.gif

Only traffic that travels to destination PC2 (which belongs to AS30) is redirected to the Cache Engine, while other Autonomous System (AS) traffic (RouterD, http server 3.3.3.3 in AS33) is not.

Configurations

This document uses these configurations:

RouterA
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.17.241.27 255.255.255.0
!
router bgp 10
bgp log-neighbor-changes
network 2.2.2.0
network 172.17.241.0
redistribute connected
neighbor 2.2.2.1 remote-as 20

RouterB
!
ip wccp web-cache password ww policy destination 60
ip cef distributed
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet5/0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip route-cache same-interface
!
router bgp 20
table-map dst
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip classless
!
access-list 1 permit 3.0.0.0 0.255.255.255
route-map DST permit 10
match ip address 1
set ip wccp 60
!
route-map DST permit 20

RouterC
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Ethernet5/0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 30
network 3.3.3.0
redistribute connected
neighbor 1.1.1.2 remote-as 20
neighbor 1.1.1.2 send-community
neighbor 1.1.1.2 route-map setcomm out
neighbor 3.3.3.3 remote-as 33
!
ip classless
ip bgp-community new-format
!
access-list 1 permit 77.0.0.0 0.255.255.255
route-map setcomm permit 10
match ip address 1
set community 4433:1050
!
route-map setcomm permit 20
!

RouterD
!
interface Ethernet0
ip address 3.3.3.3 255.255.255.0
!
router bgp 33
bgp log-neighbor-changes
network 33.33.33.0
redistribute connected
neighbor 3.3.3.1 remote-as 30
!
ip classless
ip http server

Related Commands

You can configure the router examples to these scenarios:

table-map

Use the table-map command in order to change the WCCP policy from destination to source. The traffic that is redirected is now represented by every HTTP request with the source IP address specified in the route-map src.

!
router bgp 20
table-map src
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip wccp web-cache password WW policy source 60
!
access-list 1 permit 172.0.0.0 0.255.255.255
route-map src permit 10
match ip address 1
set ip wccp 60
!
route-map src permit 20
!

match as-path

Change the condition that applies the WCCP tag to the BGP advertised routes. In the RouterC configuration, the WCCP tag is applied to the BGP routes that belong to the particular community 4433:1050. You can use the match as-path command in order to select other criteria in RouterB such as the as-path.

ip as-path access-list 121 permit ^30$
!
route-map setlist permit 10
match as-path 121
set ip wccp 60
!

Verify

There is currently no verification procedure available for this configuration.

Troubleshoot

There is currently no specific troubleshooting information available for this configuration.

Related Information

Updated: Jan 08, 2007
Document ID: 12658