Troubleshooting


Revised: September 17, 2012, OL-26823-01

Introduction

This chapter provides details for troubleshooting SNMP Real-time monitoring using Cisco SCE.

Error Message When Viewing a Report

Reports Missing Data

Error Message When Viewing a Report

Problem

Apparent Error Message: viewing a report returns with an error message.

Error opening <RRD archive name>.rrd: No such file or directory

Cause and Solution

MRTG did not create RRD DB files. Verify that your <RTM Folder>/sce_<SCE IP> does not contain *.rrd files.

There are two possible reasons that MRTG did not create the RRD DB files:

1. MRTG execution failed and you should check that the following settings are correct:

a. Verify the SCE is accessible, for example ping.

b. Verify that the SCE SNMP agent is enabled.

c. Verify that the SCE community string is configured correctly in the RTM user configuration file.

d. Verify that the RTM directory is configured correctly in the user configuration file. The path cannot contain white space.


Note Use slash or '\\' as the path delimiter.


e. Verify the RRDTool bin directory is configured correctly in the user configuration file.


Note Use slash or '\\' as the path delimiter.


f. Run MRTG from a command prompt and verify that it completes with no errors:

perl <MRTG bin folder>/mrtg<RTM folder>/mrtg-cfg/<SCE address>_scabb_mrtg.cfg
 
   

2. Cron did not invoke MRTG.

a. Verify cron is configured correctly—Check that the MRTG invocation command for the specific SCE platform is correct.

b. If using PyCron, try running MRTG from PyCron GUI and verify that it completes with return code 0

Problem

Apparent Error Message: viewing a report returns with an error message The server encountered an internal error or misconfiguration and was unable to complete your request.

Cause

This error message appears on Unix/Linux systems if the web server user does not have execution permissions on the report CGI files of the SCE platform.

Solution

Add execute permissions for all users to all .cgi files.

Problem

Apparent Error Message: viewing a report returns with an error message.

ERROR: Opening <report image filename>.png' for write: Permission denied.

Cause

This error message appears on UNIX/Linux systems if the web server user does not have write permissions on the SCE platform directory in the RTM directory.

Solution

Add write permissions for all users to all SCE directories in the RTM directory.

Problem

Apparent Error Message: viewing a report returns with an error message.

ERROR: opening <RRD archive name>.rrd': Permission denied.

Cause

This error message appears on UNIX/Linux systems if the web server user does not have read permissions on RRD archive files in the SCE platform directory.

Solution

Add read permissions for all users to all RRD archive files. The example crontab.txt file created by the rtmcmd for Unix/Linux systems contains a permissions change command for each monitored SCE. The permissions change command follows the MRTG invocation.

Reports Missing Data

Problem

Cause and Solution

Problem

Reports missing data. There is a sheer drop in reported traffic.

Cause and Solution

Cron has stopped invoking MRTG.

1. Verify that the *.rrd files in the sce_<SCE IP> folder was not modified during the past five minutes.

2. Verify Cron is configured as a service and that the service active.

3. Run MRTG from a command line and verify that it completes with no errors.

perl <MRTG bin folder>/mrtg<RTM folder>/mrtg-cfg/<SCE address>_scabb_mrtg.cfg
 
   

4. Check that Cron settings are correct.