簡介
本文描述如何配置與Google Contact Center Artificial Intelligence(CCAI)整合的聯絡中心企業版(CCE)虛擬助理語音(VAV)。
作者:Ramiro Amaya思科TAC工程師Adithya Udupa和思科工程師Raghu Guvvala。
必要條件
需求
思科建議您瞭解以下主題:
- 思科整合客服中心企業版(UCCE)版本12.6
- 思科套裝客服中心企業版(PCCE)版本12.6
- 客戶語音入口網站(CVP)
- Google對話流
- 控制中心
採用元件
本檔案中的資訊是根據以下軟體版本:
- UCCE版本12.6
- CVP 12.6 ES6
- Google對話流
- 控制中心
本文中的資訊是根據特定實驗室環境內的裝置所建立。文中使用到的所有裝置皆從已清除(預設)的組態來啟動。如果您的網路運作中,請確保您瞭解任何指令可能造成的影響。
背景
虛擬助理語音(VAV)功能使IVR平台能夠與基於雲的語音服務整合。
此功能支援類似人類的互動,使您能夠在IVR內快速高效地解決問題。
在CCE 12.6中針對思科計費客戶改進了以前稱為Customer Virtual Assistant(CVA)的VAV功能。 VAV
附註:在此版本中僅支援Google自然語言處理(NLP)。
設定
Dialogflow專案
需要建立Google Dialogflow代理,並且需要新增知識庫,然後才能啟動Agent Answers配置。你需要Google服務帳戶、Google專案和Dialogflow虛擬代理。然後,可以將知識庫新增到Dialogflow虛擬代理中。
什麼是對話流?
Google Dialogflow是一個對話使用者體驗(UX)平台,為裝置、應用和服務實現品牌獨特的自然語言互動。換句話說,Dialogflow是一個提供NLP/NLU(自然語言理解)服務的框架。思科與Google Dialogflow for Cisco Virtual Agent and for Agent Answers and Transcript整合。
這對您意味著什麼?也就是說,您基本上可以在Dialogflow上建立虛擬代理,然後將其與Cisco Contact Center Enterprise整合。
如果您需要有關如何建立虛擬代理或Dialogflow專案的資訊,請訪問:配置CVP CVA
按照以下步驟將知識庫新增到Virtual Assistant Voice(VAV)。
附註: VAV不需要使用知識庫,但是出於配置目的,需要建立需要配置知識庫的代理配置檔案。
步驟1.登入到Dialogue Console,選擇該代理,然後按一下Knowledge:Dialogflow控制檯

步驟2. 在「知識庫」(Knowledge Bases)頁面上,按一下建立知識庫,命名知識庫,然後按一下儲存。

步驟3. 向剛建立的知識庫新增文檔或連結。按一下Create the first one。

步驟4.在「建立」頁面上,鍵入文檔名稱,選擇「知識」型別、Mime型別和資料來源。

步驟5.按一下CREATE。

步驟6.建立Google AI配置檔案。
1.更新dialogflow代理的KB或FAQ後,登入Google Agent Assist,然後選擇用於KB/FAQ的專案。
2.選擇對話配置檔案並按一下新建,如下圖所示。

3.在建立對話配置檔案時更新這些詳細資訊,然後按一下建立按鈕。
- 顯示名稱 — 為識別配置檔案提供任意名稱。
- 建議型別 — 根據您在Dialogflow使用者介面(DF UI)的「知識庫」(KB)頁籤中選擇的內容,按一下該選項。它必須是常見問題或文章。
- 執行此操作後,在DF UI頁面中建立的所有知識庫將自動出現在此處。選擇正確的一個。
- 已更新其他一些必填欄位(如情緒分析)或根據要求(如置信度閾值或最大建議等)更新預設值。


- 現在,對話配置檔案顯示在座席助手URL上。
- 複製整合ID。按一下複製到剪貼簿按鈕。稍後將在控制中心配置中使用此功能。

附註: 呼叫記錄不需要對話流配置。
Webex控制中心組態
在控制中心的Cisco Webex控制中心中建立CAI配置。CCAI配置利用CAI聯結器來呼叫CAI服務。有關詳細資訊,請參閱Webex幫助中心的配置聯絡中心AI文章
步驟1.確保已安裝Cloud Connect發佈者和訂戶。有關詳細資訊,請參閱Cisco Unified Contact Center Enterprise中的安裝雲連線部分 安裝和升級指南。
步驟2.登入到Webex Control Hub。導航到聯絡中心,然後點選Cloud Connect。

步驟3.在「雲連線」視窗中,輸入主雲連線的名稱和完全限定域名(FQDN)。

步驟4.在「雲連線」視窗中輸入主雲連線的名稱和FQDN,然後按一下註冊。
步驟5.新增聯結器。在「Contact Center(聯絡中心)」視窗中,選擇「Connectors(聯結器)」頁籤。

步驟6.如果已新增聯結器,但需要再新增一個聯結器,請按一下Add More。使用Google登入並按照說明操作。

步驟7.現在新增功能。在Contact Center頁面上,按一下Features,然後按一下New。

步驟8.您現在位於「建立新聯絡中心功能」頁中。按一下聯絡中心AI配置。

步驟9.提供功能資訊,選擇已新增的聯結器並建立Google配置檔案。

CCE配置
步驟1.在UCCE AW上,開啟Cisco Web Administration工具並導航到Inventory。按一下「New」。

步驟2.新增雲連線並提供FQDN和憑據。

附註:有關PCCE證書交換,請參閱以下文檔:PCCE解決方案中的自簽名證書和管理SPOG的PCCE元件證書。有關UCCE的資訊,請參閱在UCCE上交換的自簽名證書。
步驟3.在CVP操作控制檯(OAMP)中配置雲連線。 有關詳細資訊,請參閱Cisco Unified Customer Voice Portal的管理指南中的配置CVP裝置用於雲連線部分。
註:僅適用於UCCE。PCCE不需要此步驟。

步驟4.將Cloud Connect證書匯入CVP伺服器。有關詳細資訊,請參閱配置中的將Cloud Connect Certificate to Unified CVP Keystore部分 思科統一客戶語音門戶指南。
步驟5.在Unified CCE管理控制檯中,執行此操作以關聯所有呼叫型別的CAI配置:
- 在AW Web管理工具上,導航到功能並選擇聯絡中心AI。

2.選擇思科計費的人工智慧服務。

3.在「聯絡中心AI」頁面上,選擇之前在「控制中心」中配置的CAI。

步驟6.要將CAI配置僅應用於呼叫型別的子集或覆蓋特定呼叫型別的全域性配置,請執行以下操作:
1.在Web管理工具中,導航到路由設定並選擇呼叫型別。

2.按一下Contact Center AI,然後選擇在Control Hub上配置的聯絡中心AI。

CVP配置
步驟1.在CVP Call Studio上,開啟call studio應用程式。

步驟2.在Dialogflow元素上,確保服務帳戶ID為空。
步驟3.如果要使用預設配置ID,請保留VoiceXML屬性和值null,或在VoiceXML屬性上將CAI.configId新增為Control Hub中配置的屬性和配置值。

驗證
目前沒有適用於此組態的驗證程序。
疑難排解
要收集的日誌
- UCCE/PCCE:Tomcat日誌
- 雲連線:cloudconnectmgmt(檔案檢視activelog hybrid/log/cloudconnectmgmt/cloudconnectmgmt.YYYY-MMM-DD.0.log)
- CVP:VXML伺服器日誌
- CVVB:Speechserver(引擎日誌)
- Call Studio應用程式
- Google對話流
案例
協調
- UCCE/PCCE:Tomcat日誌
- Cloud Connect:cloudconnectmgmt(檔案檢視活動日誌hybrid/log/cloudconnectmgmt/cloudconnectmgmt.YYYY-MMM-DD.0.log)
- CVP:VXML伺服器日誌
- CVVB:Speechserver
在PCCE中新增VVB/Cloud Connect時,通過延遲同步實現按比例增長的部署。因此,請等待最多10分鐘,以便在VVB中反映詳細資訊。
在PCCE 2k部署中新增Cloud Connect時的協調會立即發生
要檢查的日誌檔案 — \icm\tomcat\logs\CCBU*.log

用於協調的VVB API為https://<vvb-host>/adminapi/cloudConnect。在tomcat日誌檔案中搜尋此項以檢查VVB響應。
在錯誤響應情況下,檢查該API在直接在VVB上呼叫時是否有效
對於升級方案上的協調,可以在System_Attribute表中檢查任務狀態。

同步失敗 — CCEadmin
UCCE/PCCE:Tomcat日誌
雲連線:cloudconnectmgmt(檔案檢視activelog hybrid/log/cloudconnectmgmt/cloudconnectmgmt.YYYY-MMM-DD.0.log)
已成功檢索雲連線的檢查詳細資訊(例如,令牌、組織ID等) — invoke /unifiedconfig/config/contactcenterai/token
獲取這些詳細資訊時出現的任何錯誤都表明Cloud Connect存在問題 — 服務關閉/憑據更改/未命中證書等,

檢查用於獲取預設配置的ControlHub API中是否存在任何錯誤:https://<service_base_url>/cms/api/auxiliary-data/resources/ccai-config/1534?orgId=<ord_id>

同步失敗 — CVVB
CVVB:speechconfig
雲連線:cloudconnectmgmt(檔案檢視activelog hybrid/log/cloudconnectmgmt/cloudconnectmgmt.YYYY-MMM-DD.0.log)
問題: 無法同步服務<TTS/ASR/NLP>的配置:伺服器捕獲到異常。
Speechserver日誌:

語音伺服器日誌:
Speechserver/logs/SpeechServer
Speechserver/logs/Speechconfig

問題的原因是語音配置尚未正確部署。
解決方案:檢查語音配置日誌

獲取配置失敗
雲連線:cloudconnectmgmt(檔案檢視activelog hybrid/log/cloudconnectmgmt/cloudconnectmgmt.YYYY-MMM-DD.0.log)
CVP:VXML伺服器日誌
CVVB:Speechserver
問題1:
應為OAuth2訪問令牌、登入cookie或其他有效身份驗證憑據。
日誌:
Speechserver/logs/SpeechServer

原因:VVB語音伺服器和Google之間的時間不同步
解決方案:配置適當的NTP伺服器
問題2:
雲連線初始化時出錯(isCloudConnectConfigured:假)

原因:
1.雲連線配置可能錯誤
2.令牌發佈伺服器可能很忙
解決方案:
1.檢查配置
2.重新啟動Speechserver
呼叫失敗
- CVP:VXML伺服器日誌
- CVVB:Speechserver
- Call Studio應用程式日誌
- Dialoflow stackdriver日誌
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