简介
本文档介绍如何在vManage的实际分配计数不匹配时清除CSSM门户中的许可证分配。
问题
vManage实例和思科智能软件管理器(CSSM)门户之间可能存在许可不匹配。这可能表现为许可证计数不正确,设备删除后许可证未释放。
症状
- vManage和CSSM门户中的许可证计数显示不同的值。
- vManage中的已删除设备不会在CSSM中释放其分配的许可证,导致可用许可证短缺。
- 在CSSM中复制许可证报告(旧报告和新报告汇总)。
- 怀疑遇到以下漏洞:Cisco Bug ID CSCwj27435或Cisco Bug ID CSCwm39910
- vManage admin-tech文件var/log/nms/vmanage-server.log中的错误消息类似:
[vmanage-0] [SmartLicensingManager || SmartLicense: Failed to report license usage for tenant default : Exception: {"product_instance_identifier":["The identity for the instance is not valid.Please re-register the instance."]}
示例:
在vManage中可以看到,许可设备数量为298,许可证总数为300。

但是,在许可门户中,它显示正在使用598个许可证。它报告许可证使用量重复(300+298 = 598),在取消分配2个许可证之前报告了300个许可证,在取消分配两个许可证之后报告了298个许可证。

根本原因
确定的主要原因是vManage数据库中的陈旧许可证条目以及可能错误的智能代理租户组件信息。这阻止了与CSSM门户的准确报告和同步。
解决方案
要重新激活vManage与CSSM门户的同步,您需要打开TAC案例,请求帮助执行BUG中记录的解决方法。
但是,如果CSSM门户中的使用和可用许可证不匹配仅存在问题,则可以删除当前许可分配并等待vManage生成新报告。
从思科中心门户(CSSM)清除平衡
如果您没有删除任何重复或不正确报告的正确权限,则此步骤通常需要与思科许可团队接洽。
- 在Cisco Software Portal中,导航到Smart Software Manager > Manage licenses >选择您的智能和虚拟帐户>Inventory > Licenses选项卡,然后单击许可证。




- 现在,您会看到计数器许可证在使用0和所有可用的许可证。
在vManage中同步许可证
清理门户后,从vManage启动许可证同步。
等待至少24小时,使vManage再次同步到CSSM门户。