次に、カスタムのメンテナンス モード プロファイルを作成する例を示します。
switch# configure maintenance profile maintenance-mode
Please configure 'system mode maintenance always-use-custom-profile' if you want to use custom
profile always for maintenance mode.
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-mm-profile)# router bgp 100
switch(config-mm-profile-router)# isolate
switch(config-mm-profile-router)# exit
switch(config-mm-profile)# sleep instance 1 10
switch(config-mm-profile)# interface ethernet 1/1
switch(config-mm-profile-if-verify)# shutdown
switch(config-mm-profile-if-verify)# end
Exit maintenance profile mode.
次に、カスタムの通常モード プロファイルを作成する例を示します。
switch# configure maintenance profile normal-mode
Please configure 'system mode maintenance always-use-custom-profile' if you want to use custom
profile always for maintenance mode.
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-mm-profile)# interface ethernet 1/1
switch(config-mm-profile-if-verify)# no shutdown
switch(config-mm-profile-if-verify)# exit
switch(config-mm-profile)# sleep instance 1 20
switch(config-mm-profile)# router bgp 100
switch(config-mm-profile-router)# no isolate
switch(config-mm-profile-router)# end
Exit maintenance profile mode.
次に、IPv6 プロトコル用にカスタムのメンテナンス モードおよび通常モード プロファイルを作成する例を示します。
switch# configure terminal
switch(config)# configure maintenance profile maintenance-mode
Please configure 'system mode maintenance always-use-custom-profile' if you want to use custom
profile always for maintenance mode.
switch(config-mm-profile)# router ospfv3 ospf_ipv6
switch(config-mm-profile-router)# shutdown
switch(config-mm-profile-router)# exit
switch(config-mm-profile)# router eigrp 660
switch(config-mm-profile-router)# address-family ipv6 unicast
switch(config-mm-profile-router-af)# shutdown
switch(config-mm-profile-router-af)# exit
switch(config-mm-profile)# router isis isp
switch(config-mm-profile-router)# set-overload-bit always
switch(config-mm-profile-router)# address-family ipv6 unicast
switch(config-mm-profile-router-af)# shutdown
switch(config-mm-profile-router-af)# exit
switch# configure terminal
switch(config)# configure maintenance profile normal-mode
Please configure 'system mode maintenance always-use-custom-profile' if you want to use custom
profile always for maintenance mode.
switch(config-mm-profile)# router isis isp
switch(config-mm-profile-router)# no set-overload-bit always
switch(config-mm-profile-router)# address-family ipv6 unicast
switch(config-mm-profile-router-af)# no shutdown
switch(config-mm-profile-router-af)# exit
switch(config-mm-profile)# router eigrp 660
switch(config-mm-profile-router)# address-family ipv6 unicast
switch(config-mm-profile-router-af)# no shutdown
switch(config-mm-profile-router-af)# exit
switch(config-mm-profile)# router ospfv3 ospf_ipv6
switch(config-mm-profile-router)# no shutdown
switch(config-mm-profile-router)# exit
switch# show maintenance profile
[Normal mode]
router isis isp
no set-overload-bit always
address-family ipv6 unicast
no shutdown
router eigrp 660
address-family ipv6 unicast
no shutdown
router ospfv3 ospf_ipv6
no shutdown
[Maintenance Mode]
router ospfv3 ospf_ipv6
shutdown
router eigrp 660
address-family ipv6 unicast
shutdown
router isis isp
set-overload-bit always
address-family ipv6 unicast
shutdown
次に、VPC 用にカスタムのメンテナンス モード プロファイルおよびカスタムの通常モード プロファイルを作成する例を示します。
switch# configure terminal
switch(config)# configure maintenance profile maintenance-mode
switch(config-mm-profile)# router bgp 100
switch(config-mm-profile-router)# isolate
switch(config-mm-profile-router)# exit
switch(config-mm-profile)# interface port channel 5
switch(config-mm-profile-if-verify)# vpc orphan port suspend
switch(config-mm-profile-if-verify)# exit
switch(config-mm-profile)# interface port channel 6
switch(config-mm-profile-if-verify)# vpc orphan port
suspend switch(config-mm-profile-if-verify)# exit
switch(config-mm-profile)# sleep instance 1 5
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# shutdown
switch# configure terminal
switch(config)# configure maintenance profile normal-mode
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# no shutdown
switch(config-mm-profile-vpc-domain)# exit
switch(config-mm-profile)# sleep instance 1 60
switch(config-mm-profile)# interface port channel 5
switch(config-mm-profile-if-verify)# no vpc orphan port suspend
switch(config-mm-profile-if-verify)# exit
switch(config-mm-profile)# interface port channel 6
switch(config-mm-profile-if-verify)# no vpc orphan port suspend
switch(config-mm-profile-if-verify)# exit
switch(config-mm-profile)# router bgp 100
switch(config-mm-profile-router)# no isolate
switch# show maintenance profile
[Normal Mode]
vpc domain 1
no shutdown
sleep instance 1 60
interface port-channel 5
no vpc orphan-port suspend
interface port-channel 6
no vpc orphan-port suspend router
bgp 100
no isolate
[Maintenance Mode]
router bgp 100
isolate
interface port-channel 5 vpc
orphan-port suspend
interface port-channel 6 vpc
orphan-port suspend
sleep instance 1 5
vpc domain 1 shutdown
次に、isolate コマンドを使用してすべてのプロトコルをメンテナンス モードにする例を示します。
switch(config)# system mode maintenance
Following configuration will be applied:
router bgp 100
isolate
router ospf 100
isolate
router isis 100
isolate
Do you want to continue (y/n)? [no] y
Generating a snapshot before going into maintenance mode
Starting to apply commands...
Applying : router bgp 100
Applying : isolate
Applying : router ospf 100
Applying : isolate
Applying : router isis 100
Applying : isolate
Maintenance mode operation successful.
次に、スイッチのすべてのプロトコルおよびインターフェイスをシャットダウンする例を示します。
switch# configure terminal
switch(config)# system mode maintenance shutdown
Following configuration will be applied:
router bgp 64581
shutdown
router eigrp p2
shutdown
address-family ipv6 unicast
shutdown
router eigrp 0
shutdown
address-family ipv6 unicast
shutdown
router ospf 200
shutdown
router isis 70
shutdown
vpc domain 2
shutdown
system interface shutdown
NOTE: 'system interface shutdown' will shutdown all interfaces excluding mgmt 0
Do you want to continue (yes/no)? [no] yes
Generating a snapshot before going into maintenance mode
Starting to apply commands...
Applying : router bgp 64581
Applying : shutdown
Applying : router eigrp p2
Applying : shutdown
Applying : address-family ipv6 unicast
Applying : shutdown
Applying : router eigrp 0
Applying : shutdown
Applying : address-family ipv6 unicast
Applying : shutdown
Applying : router ospf 200
Applying : shutdown
Applying : router isis 70
Applying : shutdown
Applying : vpc domain 2
Applying : shutdown2016 Jan 15 11:10:36.080386 CP-BL26-N7K-1A %$ VDC-1 %$ %VPC-2-VPC_SHUTDOWN: vPC shutdown status is ON
Applying : system interface shutdown
Maintenance mode operation successful.
switch(config)# 2016 Jan 15 11:10:42.057678 CP-BL26-N7K-1A %$ VDC-1 %$ %MMODE-2-MODE_CHANGED: System changed to "maintenance" mode.
2016 Jan 15 11:10:42.058167 CP-BL26-N7K-1A %$ VDC-1 %$ %MMODE-2-MODE_CHANGE_WARN: System will be moved to "normal" mode in 5 minutes
次に、メンテナンス モードから通常モードに戻る例を示します。
switch# configure terminal
switch(config)# no system mode maintenance dont-generate-profile
Following configuration will be applied:
interface Ethernet1/1
no shutdown
sleep instance 1 20
router bgp 100
no isolate
Do you want to continue (y/n)? [no] yes
Starting to apply commands...
Applying : interface Ethernet1/1
Applying : no shutdown
Applying : sleep instance 1 20
Applying : router bgp 100
Applying : no isolate
Maintenance mode operation successful.
Generating Current Snapshot
Please use 'show snapshots compare before_maintenance after_maintenance' to check the
health of the system
次に、FabricPath 用にカスタムのメンテナンス モードおよび通常モード プロファイルを作成する例を示します。
switch# configure maintenance profile maintenance-mode
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-mm-profile)# fabricpath domain default
switch(config-mm-profile-fabricpath-isis)# set-overload-bit always
switch(config-mm-profile-fabricpath-isis)# end
Exit maintenance profile mode.
switch#
switch# configure maintenance profile normal-mode
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-mm-profile)# fabricpath domain default
switch(config-mm-profile-fabricpath-isis)# no set-overload-bit always
switch(config-mm-profile-fabricpath-isis)# end
Exit maintenance profile mode.
switch#
switch# show maintenance profile
[Normal Mode]
fabricpath domain default
no set-overload-bit always
[Maintenance Mode]
fabricpath domain default
set-overload-bit always
次に、バーチャル ポート チャネル(vPC)用にカスタムのメンテナンス モードおよび通常モード プロファイルを作成する例を示します。
switch# configure maintenance profile maintenance-mode
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# shutdown
switch(config-mm-profile-vpc-domain)# exit
switch(config-mm-profile)# system interface shutdown
switch(config-mm-profile)# end
Exit maintenance profile mode.
switch#
switch# configure maintenance profile normal-mode
Enter configuration commands, one per line. End with CNTL/Z.
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# no shutdown
switch(config-mm-profile-vpc-domain)# exit
switch(config-mm-profile)# no system interface shutdown
switch(config-mm-profile)# end
Exit maintenance profile mode.
switch#
switch# show maintenance profile
[Normal Mode]
vpc domain 1
no shutdown
no system interface shutdown
[Maintenance Mode]
vpc domain 1
shutdown
system interface shutdown
![](/c/dam/en/us/td/i/templates/note.gif) (注) |
FEX グループを作成するには、fex-group
name コマンドを使用します。FEX グループで FEX を追加または削除するには、fex
range コマンドを使用します。FEX グループをシャットダウンするには、system fex-group
name
shutdown コマンドを使用します。FEX グループを起動するには、no system fex-group
name
shutdown コマンドを使用します。
|
次に、FEX を使用して vPC をアップグレードするためのメンテナンス モード プロファイルおよび通常モード プロファイルを作成する例を示します(以下のトポロジを参照)。
N5K-1 configuration:
switch# configure terminal
switch(config)# configure maintenance profile maintenance-mode
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# shutdown
switch(config-mm-profile)# system interface shutdown
switch# configure terminal
switch(config)# configure maintenance profile normal-mode
switch(config-mm-profile)# no system interface shutdown
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# no shutdown
N5K-2 configuration:
switch# configure terminal
switch(config)# configure maintenance profile maintenance-mode
switch(config-mm-profile)# system fex-group fg1 shutdown
switch(config-mm-profile)# sleep 900
switch(config-mm-profile)# system fex-group fg2 shutdown
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# shutdown
switch(config-mm-profile-vpc-domain)# exit
switch(config-mm-profile)# system interface shutdown
switch# configure terminal
switch(config)# configure maintenance profile normal-mode
switch(config-mm-profile)# no system interface shutdown
switch(config-mm-profile)# vpc domain 1
switch(config-mm-profile-vpc-domain)# no shutdown
switch(config-mm-profile-vpc-domain)# exit
switch(config-mm-profile)# no system fex-group fg2 shutdown
switch(config-mm-profile)# no system fex-group fg1 shutdown
次に、vPC VLAN トラフィックを伝送するポート チャネルまたは通常の L2 イーサネット インターフェイス(vPC ピア リンクを除く)が存在していて、対応するスイッチ仮想インターフェイス(SVI)の状態がこれらのインターフェイスによって制御されるべきではないときに使用されるコンフィギュレーションを示します。
Port-channel configuration
switch(config)# interface port-channel3
switch(config-if)# description "L2-Cross Link eth3/3 eth4/3 eth5/3 eth6/3"
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1101-1500
switch(config-if)# spanning-tree port type network
switch(config-if)# lacp min-links 2
switch(config-if)# switchport autostate exclude vlan 1101-1500
L2 Ethernet configuration
switch(config)# interface ethernet 3/3
switch(config-if)# switchport
switch(config-if)# switchport mode trunk
switch(config-if)# switchport trunk allowed vlan 1101-1500
switch(config-if)# switchport autostate exclude vlan 1101-1500
Border Gateway Protocol(BGP)の isolate モードは直接ルートを撤回しないため、BGP での redistribute direct コンフィギュレーションはトラフィックを招きます。次に、route-map コマンドを使用して BGP が isolate モードで直接ルートを撤回できるようにする例を示します。
ポリシー設定
タグ 200 設定を持つ SVI を除外するには、メンテナンス モードで route-map my-rmap-deny を使用します。
switch(config)# route-map my-rmap-deny deny 10
switch(config-route-map)# match tag 200
switch(config-route-map)# exit
switch(config)# route-map my-rmap-deny permit 20
タグ 200 設定を持つ SVI を含めるには、通常モードで route-map
my-rmap-permit を使用します。
switch(config)# route-map my-rmap-permit permit 10
switch(config-route-map)# match tag 200
switch(config-route-map)# exit
switch(config)# route-map my-rmap-permit permit 20
仮想 IP(vIP)/スイッチ仮想インターフェイス(SVI)設定
switch(config)# interface loopback 200
switch(config-if)# ip address 192.0.2.100/8 tag 200
switch(config)# interface vlan 2
switch(config-if)# ip address 192.0.2.108/8 tag 200
....
switch(config)# interface vlan 3
switch(config-if)# ip address 192.0.2.102/8 tag 200
BGP の設定
switch(config)# feature bgp
switch(config)# router bgp 100
switch(config-router)# neighbor 192.0.2.100
....
メンテナンス モード プロファイル
switch# configure maintenance profile maintenance-mode
switch(config-mm-profile)# router bgp 200
switch(config-mm-profile-router)# address-family ipv4 unicast
switch(config-mm-profile-router-af)# redistribute direct route-map my-rmap-deny
switch(config-mm-profile-router-af)# exit
switch(config-mm-profile)# sleep instance 1 10
通常モード プロファイル
switch# configure maintenance profile normal-mode
switch(config-mm-profile)# router bgp 100
switch(config-mm-profile-router)# address-family ipv4 unicast
switch(config-mm-profile-router-af)# redistribute direct route-map my-rmap-permit
switch(config-mm-profile-router-af)# exit
switch(config-mm-profile)# sleep instance 1 20