はじめに
このドキュメントでは、Cisco Umbrellaダッシュボードエラー「Please enter a valid IP.」の解決方法について説明します。
前提条件
要件
このドキュメントに関する固有の要件はありません。
使用するコンポーネント
このドキュメントの情報は、Cisco Umbrellaに基づくものです。
このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されました。このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。本稼働中のネットワークでは、各コマンドによって起こる可能性がある影響を十分確認してください。
問題
この記事では、Umbrellaダッシュボードでネットワークを登録する際の「Please enter a valid IP(有効なIPを入力してください)」エラーの解決方法について説明します。
valid_IP.png(有効なIPアドレス)
解決方法
現時点でのUmbrellaダッシュボードでは、有効なCIDR表記ブロックのみを受け入れることができます。これにはCIDRに似た範囲のサポートは含まれず(たとえば、/30は4つのIPであるため、アドレス+4を開始します)、このエラーが返される可能性があります。この時点では、有効で正確なCIDRブロック一致のみがダッシュボードに受け入れられます。完全に一致しない入力を入力すると、このエラーが発生する可能性があります。
部分的なCIDRブロックである目的のネットワークを追加するには、ネットワークの合計IPブロック(使用可能およびブロードキャスト)を記述したCIDRブロック、またはIP範囲を形成する複数のブロック(/31および2つの/32など)を使用する必要があります。 サードパーティのWebサイトを使用して、使用しているCIDR表記が正しいことを確認できます。たとえば、このサードパーティのWebサイトでは、ネットワーク範囲に基づいて正しいCIDR表記を提供できます。すべての登録を同じポリシーに適用して、すべてのIPに一貫したポリシーを適用できます。
例:
- 10.0.0.1/30(無効なCIDR、有効なIPエラー)
代わりに、次を登録します。
- 10.0.0.1/32
- 10.0.0.2/31
- 10.0.0.4/32
- 10.0.0.0/30(有効なCIDR、受け入れ可能)
原因
このエラーは、登録されるIPアドレス範囲のCIDR表記が無効な場合に発生することがあります。