Cisco Crosswork Hierarchical Controller データシート

データ シート

ダウンロード オプション

  • PDF
    (2.1 MB)
    Adobe Reader を使ってさまざまなデバイスで表示
Updated: 2023 年 7 月 18 日

偏向のない言語

この製品のドキュメントセットは、偏向のない言語を使用するように配慮されています。このドキュメントセットでの偏向のない言語とは、年齢、障害、性別、人種的アイデンティティ、民族的アイデンティティ、性的指向、社会経済的地位、およびインターセクショナリティに基づく差別を意味しない言語として定義されています。製品ソフトウェアのユーザインターフェイスにハードコードされている言語、RFP のドキュメントに基づいて使用されている言語、または参照されているサードパーティ製品で使用されている言語によりドキュメントに例外が存在する場合があります。シスコのインクルーシブ ランゲージの取り組みの詳細は、こちらをご覧ください。

翻訳について

このドキュメントは、米国シスコ発行ドキュメントの参考和訳です。リンク情報につきましては、日本語版掲載時点で、英語版にアップデートがあり、リンク先のページが移動/変更されている場合がありますことをご了承ください。あくまでも参考和訳となりますので、正式な内容については米国サイトのドキュメントを参照ください。

ダウンロード オプション

  • PDF
    (2.1 MB)
    Adobe Reader を使ってさまざまなデバイスで表示
Updated: 2023 年 7 月 18 日
 

 

Cisco Crosswork Optimization Engine は、リアルタイムのネットワーク オプティマイゼーション機能を提供します。これにより、オペレータは効果的にネットワークユーティリティを最大化し、リアルタイムのトラフィック エンジニアリングとプロアクティブな最適化を使用してサービス速度を向上させることができます。

ネットワークオペレータは、ネットワークオペレーションを効率的に実行するというプレッシャーに対処しながら、ネットワークトラフィックの急増に対応するという課題に直面しています。迅速なサービスとネットワークの解決策を提供することは、ビジネスを存続させる上で不可欠です。ネットワークオペレータは、オペレータの最小限の介入によって、帯域幅の最適化を自動化し、効率的にトラフィックを誘導できるようにするためのツールセットを必要としています。

Figure of network development lifecycle with related actions for each phase

図 1.                           

ネットワーク開発ライフサイクルと各フェーズの関連アクションの図

一般的なネットワーク開発ライフサイクルでは、従来は人間の介入によって手動で実行されるフィードバックループが常に存在します。ネットワーク自動化の目的は、フィードバックループを自動化して、ネットワークイベントに対する迅速な対応と、ネットワーク上で実行するアクションの迅速な決定を可能にすると同時に、ネットワーク内のオペレータの意図に沿うことです。

上記のネットワーク運用ライフサイクルを見ると、Crosswork Optimization Engine は、「Near Real-Time Feedback Loop」で説明されているように、クローズドループ最適化サイクルのニーズを満たすように構築されています。Crosswork Optimization Engine によって、オペレータは最適化の目的を定義して導入し、継続的に監視および追跡することで、当初の目的を維持することができます。

Crosswork Optimization Engine at a glance

図 2.                           

Crosswork Optimization Engine の概要

機能と利点

表 1.                    Crosswork Optimization Engine の機能と関連する利点の概要

機能

利点

トポロジの自動検出

IETF 標準の BGP-LS に基づいて、複数のベンダーの IP トポロジを自動的に検出します。

クローズドループ フィードバック

Crosswork Optimization Engine は、BGP-LS や PCEP などのリアルタイムプロトコルを活用して、ネットワーク状態のクローズドループ トラッキングを可能にし、ネットワーク状態の変化に迅速に対応します。クローズドループの自動化により自己修復ネットワークを実現します。

ダイナミック SLA 管理

業界で実証されたセグメント ルーティング アルゴリズムで、定義された目的に基づいて SLA オブジェクトを動的に管理します。

リアルタイムの可視化

ネットワークのリアルタイムの可視性を実現し、常に現在の状態と同期して、基盤となるインフラストラクチャを真に表現します。

SRv6 の検出と可視化

SRv6 ネットワーク、ポリシー、およびトポロジ情報を検出して可視化できます。

FlexAlgo の検出と可視化

FlexAlgo デバイスの参加を検出して可視化できます。メトリックタイプなどの選択された定義で、アフィニティ、アドバタイズメント、および優先順位の包含/除外が可能です。

SR ポリシーのライフサイクル管理

使いやすい GUI で、セグメント ルーティング トラフィック エンジニアリング(SR-TE)ポリシーの CRUD 操作を促進します。

Tree-SID トポロジの可視化とプロビジョニング

パスの視覚化とポリシーの詳細を含む、Tree-SID ネットワークとプロビジョニングされたポリシーを検出して可視化できます。

COE を使用して静的 Tree-SID をプロビジョニングし、動的に検出します。

RSVP-TE トンネルライフサイクル管理

使いやすい GUI で、RSVP-TE トンネルの CRUD 操作を促進します。

API フレームワーク

事前定義されたオープンでプログラム可能な API に基づいて、独自のアプリケーションを開発できます。

帯域幅機能パック

ユーザが追加の帯域幅管理関連のユースケースを活用できるようにします。

リアルタイムのマルチベンダー可視性

エンドツーエンドの可視性は、ネットワークオペレータがネットワークを効率的に運用するために重要です。Crosswork Optimization Engine は、そのような可視性だけでなく、異なるレイヤ間(L2 隣接関係と L3 IP トポロジ)および各レイヤ間の関係を視覚化する機能も提供します。

Crosswork Optimization Engine は、IETF 標準の BGP-LS プロトコルを活用して、次のような機能により IP ネットワークを自動的に検出します。

●     最新の可視性:ネットワーク インフラストラクチャのリアルタイムの可視性を維持し、ネットワークオペレータに実際のトポロジを正確に表示します。

●     階層表示:トポロジの階層表示により、オペレータはトポロジの可視化でさまざまなレベルの粒度を定義できます。

●     SR-MPLS と SRv6 の両方のネットワークを可視化します。

Policy Details Page in Crosswork Optimization Engine

図 3.                           

Crosswork Optimization Engine のポリシー詳細ページ

SRv6 の可視化:

SRv6 Policy Details Page in Crosswork Optimization Engine

図 4.                           

Crosswork Optimization Engine の SRv6 ポリシー詳細ページ

FlexAlgo の可視化:

Example of two FlexAlgos displayed in the Crosswork Optimization Engine GUI

図 5.                           

Crosswork Optimization Engine GUI に表示される 2 つの FlexAlgo の例

Tree-SID の可視化:

Example of a Tree-SID policy with policy details displayed on the Crosswork Optimization UI

図 6.                           

Crosswork Optimization UI にポリシーの詳細が表示された Tree-SID ポリシーの例

Example of Tree-SID provisioning UI

図 7.                           

Tree-SID プロビジョニング UI の例

SR-TE ポリシーおよび RSVP-TE トンネルライフサイクル管理のシンプルなワークフロー

Crosswork Optimization Engine は、SR-TE ポリシーと RSVP-TE トンネルのライフサイクルを管理するための使いやすい UI も提供します。この UI により、ネットワークオペレータは次のことが可能です。

1.     直感的なワークフローを使用した SR-TE ポリシーまたは RSVP-TE トンネルの作成、変更、および削除。

2.     SR-TE ポリシーと RSVP-TE トンネルのダイナミックパスの計算を継続的に追跡し、SLA の目的を維持。

3.     SRTE ポリシーまたは RSVP-TE トンネルをネットワークに展開する前にプレビュー。

SR Policy Provisioning screen in Crosswork Optimization Engine

図 8.                           

Crosswork Optimization Engine の SR ポリシープロビジョニング画面

Details to enter to provision a new RSVP-TE tunnel from the Crosswork Optimization Engine GUI

図 9.                           

Crosswork Optimization Engine GUI から新しい RSVP-TE トンネルをプロビジョニングするために入力する詳細

帯域幅管理機能パック:

Crosswork Optimization Engine 機能パックを使用すると、ユーザーはトラフィック エンジニアリング操作を強化し、帯域幅のユースケースを含めたり、ネットワークのインテントとして帯域幅を保持したりできます。Crosswork Optimization Engine 3.0 では、次の帯域幅管理機能と機能パックが提供されます。

1.     オンデマンド帯域幅:

名前が示すように、オンデマンド帯域幅では、オペレータ/ユーザーは、特定のデバイスセット間で要求された帯域幅を使用して、セグメント ルーティング トラフィック エンジニアリング(SR-TE)ベースのポリシーをプロビジョニングできます。これはソフト帯域幅保証であり、遅延/TE/IGP などの二次的な最適化の目的を含めることができます。

2.     ローカル輻輳緩和:

ローカル輻輳緩和は、ローカルインターフェイスレベルの輻輳の問題を解決します。これは、輻輳したリンクのいずれかの側におけるデバイス間のトラフィックのみを戦術的 SR-TE ポリシーで再ルーティングすることで行います。緩和は輻輳したインターフェイスにローカライズされ、エンドツーエンドポリシーは再ルーティングされません。この機能により、オペレータはループ内に人間を介入させることで、ネットワークの制御をある程度取り戻すことができます。輻輳が検出されると、緩和の推奨事項がユーザーに提供され、ユーザーが確認した場合のみ、ネットワークに適用されます。また、ネットワークの長期的な輻輳パターンや障害パターンを把握するためのモニタリングツールとしても使用でき、オペレータはネットワークの特定の部分のキャパシティを増やしたり、メンテナンスを実行したりすることができます。

3.     SR 回線型マネージャ

セグメントルーティング回線型(SR 回線型)は、セグメント ルーティング ネットワーク上で回線のようなサービス(光回線、TDM)を転送する予測可能な方法を提供する新しい方法です。これを行うために、SR 回線型は、特定のサービスがパス(およびバックアップパス)に沿って必要な帯域幅を取得することを保証する帯域幅管理メカニズムを提供します。セグメント ルーティング ポリシー自体は、プロビジョニング時にいくつかの厳密なルール(明示的なパスのみ、同じルーティング、相互ルーティング(保証された遅延)、帯域幅の保証、障害からの保護、および多様性)に従うことになっています。

Related image, diagram or screenshot

図 10.                        

SR 回線型ポリシーのプロビジョニング

これらの機能パックがネットワークに適しているかどうかについては、シスコのアカウント担当者にお問い合わせください。

サポートされるプロトコル

表 2.                    標準プロトコルのサポート:キープロトコル

プロトコル

タイトル

RFC 5440

パス計算要素(PCE)通信プロトコル(PCEP)

RFC 8231

ステートフル PCE 用パス計算要素通信プロトコル(PCEP)拡張機能

RFC 8281

ステートフル PCE モデルでの PCE 開始 LSP 設定のパス計算要素通信プロトコル(PCEP)拡張機能

RFC 3209

RSVP-TE: Extensions to RSVP for LSP Tunnels

RFC 3630

OSPF バージョン 2 へのトラフィック エンジニアリングの拡張

RFC 3784

IS-IS Extensions for Traffic Engineering(TE)

RFC 7752

リンクステートおよびトラフィックエンジニアリング(TE)のノースバウンド配信

draft-ietf-spring-sr-replication-segment

マルチポイントサービス配信のための SR レプリケーションセグメント

draft-ietf-pim-sr-p2mp-policy

セグメント ルーティング ポイントツーマルチポイント ポリシー

draft-ietf-pce-sr-p2mp-policy

セグメント ルーティング ポイントツーマルチポイント ポリシーの p2mp sr ポリシー用の PCEP 拡張

サポートされるすべての RFC と IETF ドラフトの詳細なリスト、および詳細については、シスコのアカウント担当者にお問い合わせください。

ライセンス

Cisco Crosswork Optimization Engine には、SMART 対応のソフトウェア サブスクリプション ライセンスがあります。詳細については、シスコのアカウント担当者にお問い合わせください。

システム要件:クラスタ内の Crosswork Optimization Engine

COE 5.0 のインストールには、vCenter 経由と CSP デバイス経由の 2 つのオプションがあります。両方のオプションのシステム要件については、行 1 および 2 を参照してください。

表 3.                    Crosswork Optimization Engine 5.0 システム要件

システムリソースの種類

要件の詳細

ハイパーバイザと vCenter

●  VMware vSphere 6.7 以降
●  VMware vCenter Server 7.0 および ESXi 7.0
●  VMware vCenter Server 6.7 (Update 3g 以降)および ESXi 6.7 (Update 1)

インストールは Crosswork インストーラから行う必要があります。

CSP DC の要件*

●  Cisco CSP リリース 2.8.0.276

許可されたハードウェアのリスト:

●  UCSC-C220-M4S, UCSC-C240-M4SX
●  N1K-1110-X 、N1K-1110-S
●  CSP-2100 、CSP-2100-UCSD 、CSP-2100-X1 、CSP-2100-X2 CSP-5200 、CSP-5216 、CSP-5228
●  CSP-5400 、CSP-5436 、CSP-5444 、CSP-5456

CPU/メモリ/ストレージプロファイル(VM 単位)

データセンターのホストプラットフォームは、次の最小構成の 3 つの VM に対応する必要があります。多様性を確保するため、VM を個別の物理サーバーでホストすることを推奨します。

vCenter:

●  12 個の vCPU | 96 GB の RAM メモリ | 1 TB のディスク容量

CSP:

●  12 CPU コア | 96 GB の RAM メモリ | 1 TB のディスク容量

注:インストール時に VM メモリと CPU のサイズを調整したり、インストール後に再調整したりすることができます。

ストレージ要件は、サポートされているデバイスの数や選択した導入タイプなどの要因によって異なります。パフォーマンスにより、従来のハードディスクドライブ(HDD)よりも、ソリッドステートドライブ(SSD)が優先されます。HDD を使用している場合、最低速度は 15,000 RPM 以上です。

VM データストアのディスクアクセス遅延は 10 ミリ秒未満 または 5000 IOPS より大きい必要があります。SSD または高性能ディスクが推奨されます。

●  デフォルトでは、VM のリソースに「ハード」予約を適用すると、要件は 12vCPU の 100% のメモリ(つまり大規模の場合は 96 Gb )、改定後の VM あたりの予約は 18 GHz となり、以前のデフォルトである 24 Gb と 16 GHz よりも高くなります。

追加の SSD ストレージ

Crosswork OVA(vCenter の場合)または各 CSP ノードの Crosswork QCOW2 イメージ(CSP の場合)に対して、約 50 GB のストレージが必要です。

ネットワーク接続

実稼働環境への展開では、管理ネットワーク用とデータネットワーク用のデュアルインターフェイスを使用することを推奨します。

VM を個別の物理ホストに展開する場合、ホスト間のネットワーク接続は 10 Gbps 以上である必要があります。

IP アドレス

●  管理およびデータネットワーク用の 2 つの IP サブネットです。それぞれに 4 つの割り当て可能な IP アドレス(IPv4 または IPv6 )が許可されます。各 Crosswork VM には、それぞれ管理サブネットとデータサブネットからの IP アドレスが必要です。さらに、全体としてのインストールでは、管理サブネットとデータサブネットからそれぞれ 1 つの仮想 IP (VIP )アドレスが必要です。各サブネット上の IP アドレスの総数は 4 つで、2 つのサブネット全体で合計 8 つの IP アドレスになります。
●  注: IPv6 クラスタを展開する場合、インストーラは IPv6 対応のコンテナ /VM で実行する必要があります。
●  注: この時点では、IP の割り当ては永続的であり、再展開しない限り変更できません。詳細については、シスコ カスタマー エクスペリエンス チームにお問い合わせください。
●  デュアルスタック構成は、Crosswork プラットフォーム インフラストラクチャではサポートされていません。したがって、環境のすべてのアドレスは IPv4 または IPv6 である必要があります。1 つのインターフェイスで、両方を設定しないでください。

アップグレード要件

「N」個の UCS または CSP ノードの Crosswork クラスタのアップグレードでは、OVA のアップグレードに「N + 1」個の UCS または CSP ノードが必要です。たとえば、3 つの「ノード」のクラスタでは、アップグレードに追加のノードが 1 つ必要になり、合計で 4 つの「ノード」または UCS/CSP が必要になります。

追加ノードは、アップグレードを容易にする目的でアップグレード中に一時的に使用されます。アップグレード後、N 個のノードのクラスタは同じ数のノード/リソースで続行されます。

*CSP オプションを展開する前に、ローカルアカウントチームまたはカスタマー エクスペリエンス チームにお問い合わせください。

システム要件:Crosswork Data Gateway

表 4.                    Crosswork Data Gateway 5.0 システム要件

システムリソースの種類

要件の詳細

ハイパーバイザと vCenter

●  VMware vSphere 6.7 以降
●  VMware vCenter Server 7.0 および ESXi 7.0
●  VMware vCenter Server 6.7 (Update 3g 以降)および ESXi 6.7 (Update 1)

注:インストールは vCenter からのみ行うことができます。

CSP DC の要件*

●  Cisco CSP リリース 2.8.0.276 *

許可されたハードウェアのリスト:

●  UCSC-C220-M4S, UCSC-C240-M4SX
●  N1K-1110-X 、N1K-1110-S
●  CSP-2100 、CSP-2100-UCSD 、CSP-2100-X1 、CSP-2100-X2 CSP-5200 、CSP-5216 、CSP-5228
●  CSP-5400 、CSP-5436 、CSP-5444 、CSP-5456

メモリ

●  標準:48 GB
●  拡張:112 GB

ディスク容量

●  標準:60 GB (最小)
●  拡張:560 GB (最小)

CPU

●  標準:12
●  拡張:20

インターフェイス

●  最小値:1
●  最大値:3

Crosswork Data Gateway は、次の組み合わせに従って、1、2、または 3 つのインターフェイスのいずれかで展開できます。

注:インストールプロセスでは、vNIC0 および vNIC1 IP のみが要求されます。vNIC2 IP は、Crosswork アプリケーションのアドミニストレーション ガイドの「Create/Edit a Crosswork Data Gateway Pool」の章で説明されているように、Crosswork Data Gateway プールの作成時に割り当てられます。

NIC の数

vNIC0

vNIC1

vNIC2

1

●  管理トラフィック
●  制御 / データトラフィック
●  デバイス アクセス トラフィック

-

-

2

●  管理トラフィック
●  制御 / データトラフィック
●  デバイス アクセス トラフィック

-

3

●  管理トラフィック
●  制御 / データトラフィック
●  デバイス アクセス トラフィック

管理トラフィック:UI とコマンドラインにアクセスし、サーバー間で制御/データ情報を渡します(たとえば、Crosswork アプリケーションから Crosswork Data Gateway または NSO)。

制御/データトラフィック:Crosswork Data Gateway と Crosswork アプリケーションおよびその他の外部データ宛先間でデータと構成を転送する場合に使用されます。

デバイス アクセス トラフィック:デバイス管理(KPI 設定またはプレイブック実行の結果として NSO または Crosswork アプリケーションからデバイスに転送)および Crosswork Data Gateway に転送されるテレメトリデータ用に使用されます。

VM を個別の物理ホストに展開する場合、ホスト間のネットワーク接続は 10 Gbps 以上である必要があります。

IP アドレス

使用するインターフェイスの数に基づいて、1、2、または 3 つの IPv4/IPv6 アドレス。

注:Crosswork はデュアルスタック構成をサポートしていません。したがって、環境のすべてのアドレスは IPv4 または IPv6 である必要があります。

*CSP オプションを展開する前に、ローカルアカウントチームまたはカスタマー エクスペリエンス チームにお問い合わせください。

発注情報

Cisco Crosswork Optimization Engine の発注に関する詳細は、シスコのアカウント担当者にお問い合わせください。

シスコおよびパートナーの提供サービス

シスコでは、Cisco Crosswork を使用してお客様の成功を支援するために、幅広いサービスを用意しています。これらのシスコサービスは、運用効率の改善とネットワーク制御の向上を目的として、スタッフ、プロセス、ツール、パートナーをお客様に合わせた形で組み合わせて提供されます。シスコアドバンスドサービスは、アーキテクチャ主導型のアプローチによってネットワーク インフラストラクチャをビジネスの目的に合致させ、長期にわたる価値を提供します。Cisco Crosswork 製品を Cisco SMARTnet™ サービスと組み合わせて使用することで、シスコのネットワーク専門家や高い実績を持つリソースにいつでも直接アクセスして、ミッションクリティカルな問題を解決できます。シスコサービスは、ネットワークライフサイクル全体にわたって最大限に投資を保護し、ネットワーク運用の最適化、移行のサポート、IT 能力の強化を実現します。詳細については、www.cisco.com/jp/go/services を参照してください。

Cisco Capital

目的達成に役立つ柔軟な支払いソリューション

Cisco Capital により、目標を達成するための適切なテクノロジーを簡単に取得し、ビジネス変革を実現し、競争力を維持できます。総所有コスト(TCO)の削減、資金の節約、成長の促進に役立ちます。100 か国あまりの国々では、ハードウェア、ソフトウェア、サービス、およびサードパーティの補助機器を購入するのに、シスコの柔軟な支払いソリューションを利用して、簡単かつ計画的に支払うことができます。詳細はこちらをご覧ください。

詳細情報

詳細については、営業担当者にお問い合わせください。


文書の変更履歴

表 5.                    文書の変更履歴

新規トピックまたは改訂されたトピック

説明箇所

日付

機能と利点を更新

4 ページ

2022 年 1 月

 

 

 

Learn more