Compatibility Matrix for Cisco Unified Communications Manager and IM and Presence Service, Release 10.x

Revision History

Table 1. Software Compatibility Matrix Revision History

Date

Changes

December 2, 2016

Restructured information about supported upgrade paths. Supported upgrade paths are now listed according to whether the currently installed software is running on a physical server or on a virtual server. The new tables also list the supported upgrade or migration method available for each path. See the following topics:

April 12, 2018

Applied the following updates:

  • Minor edits to clarify supported upgrade paths.

  • Pointed Cisco Unified Communications Manager compatibility to the CSR Matrix.

April 20, 2018

Removed AOL as supported integration as AOL has removed support for AOL Instant Messenger.

Information About Releases

Notes About Engineering Specials (ESs), Service Updates (SUs), And Windows Service Release (SR) Upgrades

If you run a Linux or Windows Engineering Special (ES), a Service Update (SU), or a Windows Service Release (SR) for any version listed in the “Direct upgrade” tables, you can also upgrade to the target version for that section.

If you install an ES, it may contain fixes that are not included in newer releases. For example, a fix in the latest 10.5(1)es, 10.5(1.32xx-x), may not be included in 10.5(2x) because the fix was not available prior to the release of 10.5(2x). In this example, a later ES on the 10.5(2x) branch may be required to retain the same fixes.

Restricted and Unrestricted

Cisco Unified Communications Manager and Cisco Unified Communications Manager IM and Presence Service are available in both US Export Restricted and US Export Unrestricted (UNRST). The Restricted version contains full encryption capabilities. The Unrestricted version contains fewer encryption capabilities.

The US Export Restricted release has always been available from Cisco. A sample file name for US Export Restricted would be UCSInstall_UCOS_#.#.#.#####-#.sgn.iso.

The US Export Unrestricted UNRST release complies with import /export restrictions to various countries and is available in limited markets. A sample file name for US Export Unrestricted would be UCSInstall_UCOS_UNRST_#.#.#.#####-#.sgn.iso.

UNRST releases support fewer encryption capabilities and are classified as US export unrestricted. UNRST releases are intended for customers for which US Export and/or Foreign Import Encryption Regulations apply.


Note

Once installed, UNRST releases can never be converted or upgraded to releases which support full encryption capabilities


Long-Life Releases

Long-Life Releases are the final planned releases on a major train and will be the last releases to go End-of-Support on a major train. Customers planning to remain on one version of code for an extended period of time should select a Long-Life Release for their deployment.


Note

"Major" releases are differentiated by the first digit of the release number; 9.x, 10.x are examples of "major" releases.


Upgrade and Migration Paths for Cisco Unified Communications Manager and IM and Presence Service Release 10.x

The tables in the following sections list the supported upgrade and migration paths for Cisco Unified Communications Manager and IM and Presence Service Release 10.x. Engineering Special (ES) and Service Updates (SU) within each path are also supported, unless otherwise indicated. Use the tables in the following sections to determine whether you can upgrade or migrate from your currently installed version, and which of the upgrade methods are available to you:

  • direct upgrades using either the Unified CM OS Admin interface or the Cisco Prime Collaboration Deployment (PCD) Upgrade task

  • migrations using the PCD Migration task


Note

Cisco Unified Communications Manager and IM and Presence Service support an export unrestricted (XU) version, in addition to the export restricted (K9) version, If your currently installed version is export unrestricted, you cannot upgrade to an export restricted release.


For more information, see:

Upgrade and Migration Paths for Cisco Unified Communications Manager and IM and Presence Service Release 10.0(x)

Use the tables below to determine whether you can upgrade or migrate from your currently installed version of Cisco Unified Communications Manager and IM and Presence Service. The supported path and the method that you can use to perform the upgrade or migration depend on whether your current version is installed directly on server hardware or on a virtual machine:

If you are performing a refresh upgrade, refer also to COP Files Required for Upgrades to Release 10.0(x)


Note

Unless otherwise indicated, the release categories in these tables include subsequent SU releases. For example, in the From column, Release 9.1(2) includes upgrades from Release 9.1(2)SU2.


Installations on Cisco Media Convergence Server (MCS) 7800 Series Hardware

You cannot install or run Cisco Unified Communications Manager and the IM and Presence Service directly on server hardware; you must run these applications on virtual machines. The tables below list the supported migration paths for deployments that are currently running on MCS 7800 hardware. All of the supported migration paths listed below are physical-to-virtual (P2V) migrations.


Note

The tables below list the upgrade paths supported for MCS 7800 Series servers, with the following exceptions:

  • MCS 7816-C1 for Business Edition 3000 (BE3000)

  • MCS 7828 for Business Edition 5000 (BE5000)

PCD migrations are not supported for BE3000 and BE5000 deployments. We recommend a fresh installation for upgrades from these products.


Table 2. Cisco Unified Communications Manager Releases Installed on MCS 7800 Series Hardware

From

To

Supported Method

6.1(5)

10.0(x)

PCD Migration

7.1(3) and 7.1(5)

8.0(x)

9.x

8.5(1)

8.6(1) and 8.6(2)

9.0(1)

9.1(1) and 9.1(2)

Table 3. Cisco Unified Presence and IM and Presence Releases Installed on MCS 7800 Series Hardware

From

To

Supported Method

CUP 8.5(4)

10.0(x)

PCD Migration

CUP 8.6(3), 8.6(4), and 8.6(5)

IM and Presence 9.0(1)

IM and Presence 9.1(1)

Installations on Virtual Machines

The tables below list the supported upgrade and migration paths for deployments that are currently running on virtual machines. All of the supported upgrade and migration paths listed below are virtual-to-virtual (V2V).

Table 4. Cisco Cisco Unified Communications Manager Releases Installed on Virtual Machines

From

To

Supported Method

8.02 and 8.0.3

10.0(x)

Unified CM OS Admin

PCD Migration

8.5.1

Unified CM OS Admin

PCD Migration

8.6.1

Unified CM OS Admin

PCD Migration or PCD Upgrade

8.6.2

Unified CM OS Admin

PCD Migration or PCD Upgrade

9.0.1

Unified CM OS Admin

PCD Migration or PCD Upgrade

9.1(1) and 9.1(2)

Unified CM OS Admin

PCD Migration or PCD Upgrade

10.0(x)

Unified CM OS Admin

PCD Migration or PCD Upgrade

Table 5. Cisco Unified Presence and IM and Presence Releases Installed on Virtual Machines

From

To

Supported Method

CUP 8.5(4)

10.0(x)

PCD Migration

Unified CM OS Admin

CUP 8.6(3), 8.6(4), and 8.6(5)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 9.0(1)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 9.1(1)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 10.0(x)

PCD Migration or PCD Upgrade

Unified CM OS Admin

COP Files Required for Upgrades to Release 10.0(x)

Upgrade COP files are required only for refresh upgrades that you perform using the Unified CM OS Admin interface or the Prime Collaboration Deployment (PCD) upgrade task. You can use PCD to perform a bulk installation of the COP files before you begin the upgrade.

The tables below lists the upgrade paths that require COP files.

Table 6. Required COP Files for Upgrades to Cisco Unified Communications Manager Release 10.0(x)
From To Upgrade Type

8.0(x) to 8.5(x)

10.0(x)

Refresh upgrade

Required COP files:

  • ciscocm.refresh_upgrade_<latest_version>.cop.sgn

  • ciscocm.version3-keys.cop.sgn

Optional COP files:

  • ciscocm.vmware-disk-size-reallocation-<latest_version>.cop.sgn)

  • ciscocm.free_common_space_v<latest_version>.cop.sgn

8.6(x) to 9.x

10.0(x)

Standard upgrade; no COP files required

Table 7. Required COP Files for Upgrades to IM and Presence Service Release 10.0(x)
From To Upgrade Type

8.5(4)

10.0(x)

Refresh upgrade

Required COP files:

  • cisco.com.cup.refresh_upgrade_v<latest_version>.cop

  • ciscocm.version3-keys.cop.sgn

8.6(3) to 9.x

10.0(x)

Standard upgrade; no refresh COP file required

If you are upgrading from one export unrestricted version to another unrestricted version , you must install the following COP file before you begin the upgrade: ciscocm.cup.unrst_upgrade_10_0_1_v1.2.cop.sgn

Upgrade and Migration Paths for Cisco Unified Communications Manager and IM and Presence Service Release 10.5(x)

Use the tables below to determine whether you can upgrade or migrate from your currently installed version of Cisco Unified Communications Manager and IM and Presence Service. The supported path and the method that you can use to perform the upgrade or migration depend on whether your current version is installed directly on server hardware or on a virtual machine:

If you are performing a refresh upgrade, refer also to COP Files Required for Upgrades and Migrations to Release 10.5(x)


Note

Unless otherwise indicated, the release categories in these tables include subsequent SU releases. For example, in the From column, Release 9.1(2) includes upgrades from Release 9.1(2)SU2.


Installations on Cisco Media Convergence Server (MCS) 7800 Series Hardware, Release 10.5(x)

You cannot install or run Cisco Unified Communications Manager and the IM and Presence Service directly on server hardware; you must run these applications on virtual machines. The tables below list the supported migration paths for deployments that are currently running on MCS 7800 hardware. All of the supported migration paths listed below are physical-to-virtual (P2V) migrations. Engineering Special (ES) and Service Updates (SU) within each path are supported, unless otherwise indicated.


Note

The tables below list the upgrade paths supported for MCS 7800 Series servers, with the following exceptions:

  • MCS 7816-C1 for Business Edition 3000 (BE3000)

  • MCS 7828 for Business Edition 5000 (BE5000)

PCD migrations are not supported for BE3000 and BE5000 deployments. We recommend a fresh installation for upgrades from these products.


Table 8. Cisco Unified Communications Manager Releases Installed on MCS 7800 Series Hardware

From

To

Supported Method

6.1(5)

10.5(x)

PCD Migration

7.1(3) and 7.1(5)

8.0(x)

9.x

8.5(1)

8.6(1) and 8.6(2)

9.0(1)

9.1(1) and 9.1(2)

Exception: 9.1(2)SU4; see below for more information

Exceptions

9.1(2)SU4

10.5(2) or higher SU

Note 
Upgrades or migrations to 10.5(1) not supported.

PCD Migration

Table 9. Cisco Unified Presence and IM and Presence Releases Installed on MCS 7800 Series Hardware

From

To

Supported Method

CUP 8.5(4)

10.5(x)

PCD Migration

CUP 8.6(3), 8.6(4), and 8.6(5)

IM and Presence 9.0(1)

IM and Presence 9.1(1)

Installations on Virtual Machines 10.5x

The tables below list the supported upgrade and migration paths for deployments that are currently running on virtual machines. All of the supported upgrade and migration paths listed below are virtual-to-virtual (V2V). Engineering Special (ES) and Service Updates (SU) within each path are supported, unless otherwise indicated.

Table 10. Cisco Cisco Unified Communications Manager Releases Installed on Virtual Machines

From

To

Supported Method

8.02 and 8.0.3

10.5(x)

Unified CM OS Admin

PCD Migration

8.5.1

Unified CM OS Admin

PCD Migration

8.6.1

Unified CM OS Admin

PCD Migration or PCD Upgrade

8.6.2

Unified CM OS Admin

PCD Migration or PCD Upgrade

9.0.1

Unified CM OS Admin

PCD Migration or PCD Upgrade

9.1(1) and 9.1(2)

Exceptions:9.1(2)SU4; see Exceptions below

Unified CM OS Admin

PCD Migration or PCD Upgrade

10.0(1)

Unified CM OS Admin

PCD Migration or PCD Upgrade

10.5(x)

Unified CM OS Admin

PCD Migration or PCD Upgrade

Exceptions

9.1(2)SU4

10.5(2) or higher SU

Note 

Upgrades or migrations to 10.5(1) not supported.

Unified CM OS Admin

PCD Migration or PCD Upgrade

Table 11. Cisco Unified Presence and IM and Presence Releases Installed on Virtual Machines

From

To

Supported Method

CUP 8.5(4)

10.5(x)

PCD Migration

Unified CM OS Admin

CUP 8.6(3), 8.6(4), and 8.6(5)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 9.0(1)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 9.1(1)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 10.0(1)

PCD Migration or PCD Upgrade

Unified CM OS Admin

IM and Presence 10.5(x)

PCD Migration or PCD Upgrade

Unified CM OS Admin

COP Files Required for Upgrades and Migrations to Release 10.5(x)

The tables below lists the upgrade paths that require COP files. You must install COP files on each node before you begin an upgrade using the Cisco Unified OS Admin interface or the Prime Collaboration Deployment (PCD) tool. You can use PCD to perform a bulk installation of the COP files before you begin the upgrade.

Table 12. Required COP Files for Upgrades and Migrations to Cisco Unified Communications Manager Release 10.5(x)
From To Upgrade Type

8.0(x) through 8.5(x)

10.5(x)

Refresh upgrade

Required COP files:

  • ciscocm.refresh_upgrade_<latest_version>.cop.sgn

  • ciscocm.version3-keys.cop.sgn

Optional COP files:

  • ciscocm.vmware-disk-size-reallocation-<latest_version>.cop.sgn)

  • ciscocm.free_common_space_v<latest_version>.cop.sgn

8.6(x) to 9.x

10.5(x)

Refresh upgrade

Required COP files:

  • ciscocm.version3-keys.cop.sgn

Optional COP files:

  • ciscocm.vmware-disk-size-reallocation-<latest_version>.cop.sgn)

  • ciscocm.free_common_space_v<latest_version>.cop.sgn

10.0(x)

10.5(x)

Standard upgrade; no COP files required

10.5(x)

10.5(x)

Standard upgrade; no COP files required

Table 13. Required COP Files for Upgrades to IM and Presence Service Release 10.5(x)
From To Upgrade Type

Cisco Unified Presence 8.5(4)

10.5(x)

Refresh upgrade

Required COP files:

  • cisco.com.cup.refresh_upgrade_v<latest_version>.cop

  • ciscocm.version3-keys.cop.sgn

8.6(3) to 9.x

10.5(x)

Refresh upgrade

Required COP files:

  • ciscocm.version3-keys.cop.sgn

10.0(x)

10.5(x)

Standard upgrade; no refresh COP file required

If you are upgrading from one export unrestricted version to another unrestricted version , you must install the following COP file before you begin the upgrade: ciscocm.cup.unrst_upgrade_10_0_1_v1.2.cop.sgn

10.5(x)

10.5(x)

Standard upgrade; no refresh COP file required

If you are upgrading from one export unrestricted version to another unrestricted version , you must install the following COP file before you begin the upgrade: ciscocm.cup.unrst_upgrade_10_0_1_v1.2.cop.sgn

Compatibility Information for Cisco Unified Communications Manager

Cisco Unified IP Phones


Note

Phone models that are End of Software Maintenance will continue to be supported on the latest Unified Communications Manager releases. However, they will not take advantage of any new Unified Communications Manager or firmware features associated with that release.

For more information on End of Sale phone models, reference the model's End of Sale announcement for information on level of firmware and hardware support.


For a list of phones that have been tested with this release, see the CSR Compatibility Matrix at http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/uc_system/unified/communications/system/Compatibility/CSR-Compatibility-Matrix.html.

For information about the Cisco Unified Communications Manager Device Package compatibility to support the phones, see http://www.cisco.com/c/en/us/td/docs/voice_ip_comm/cucm/compat/matrix/CMDP_BK_CCBDA741_00_cucm-device-package-compatibility-matrix.html.

Compatibility Information for IM & Presence Service

Hardware Compatibility

In Release 10.0(1) and later, Cisco supports only virtualized deployments of IM and Presence Service on Cisco Unified Computing System servers, or on a Cisco-approved third-party server configuration. In Release 10.0(1) and later, Cisco does not support deployments of IM and Presence Service on Cisco Media Convergence Server servers.

For more information about the deployment of IM and Presence Service in a virtualized environment, see http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/virtualization-cisco-ucm-im-presence.html.

For more information about the VMware that IM and Presence Service supports, see http://www.cisco.com/c/dam/en/us/td/docs/voice_ip_comm/uc_system/virtualization/collaboration-virtualization-hardware.html.

Software Compatibility

The following table shows the supported integrations with various software.

Table 14. Software Compatibility for IM and Presence Service 10.x

Software

Version

Cisco Unified Communications Manager

IM and Presence Service and Cisco Unified Communications Manager software versions must match. For example, IM and Presence Service Release 10.5(2) is supported only with Cisco Unified Communications Manager Release 10.5(2). Similarly, IM and Presence Service Release 10.0(1) is supported only with Cisco Unified Communications Manager Release 10.0(1), and so on.

Cisco Jabber1

Cisco Jabber for Windows

Cisco Jabber for Mac

Cisco Jabber IM for BlackBerry

Cisco Jabber IM for iPhone

Cisco Jabber IM for Android

Cisco Jabber for iPad

Cisco Jabber Web SDK

Cisco Expressway

Cisco Expressway Release 8.1 or greater

Cisco Agent Desktop

With Cisco Unified Contact Center Enterprise (Unified CCE):
  • For IM and Presence Service 10.0(1): Cisco Agent Desktop 10.0(1) and 10.0(1a)

  • For IM and Presence Service 10.5(x): Cisco Agent Desktop 10.0(1a)

With Cisco Unified Contact Center Express (Unified CCX):
  • Cisco Agent Desktop 9.0(2)SU2, 10.0(1), 10.5(1), 10.6(1)

Microsoft Remote Call Control (RCC)

OCS 2007 R2

Lync 2010

Lync 2013

Microsoft Exchange Calendaring

Exchange 20032 (NTLMv1 only)

Exchange 2007 (NTLMv1 only)

Exchange 2010 (NTLMv1 only)

Exchange 2013 (NTLMv1 only)

External Database Servers (Persistent Group Chat3, IM Compliance, Managed File Transfer)

Oracle database, versions 9i, 10g, or 11g

PostgreSQL database, versions 8.3.x through 9.1.1

Compliance Servers

Cisco supports third-party compliance servers. For more information, contact your Cisco Representative.

Cisco AJAX XMPP Libraries (CAXL)

CAXL 2.0.1, 2.1.1, 8.5, 8.6

See the Cisco Developer Network at http://developer.cisco.com for details around CAXL interfaces.
1 For version compatibility for all Cisco Jabber clients, see the appropriate Cisco Jabber client documentation.
2 IM and Presence Service Release 10.0(1) only.
3 Persistent chat is only available on Cisco Unified Communications Manager IM and Presence Service 10.0 and later. Persistent chat is only available for Cisco Jabber for Windows.

Supported Integrations

Interdomain Federation

The following table shows the interdomain federations that are supported in IM and Presence Service Release 10.x.


Note

If you have Cisco Expressway deployed, you should configure XMPP federation on Cisco Expressway and not on IM and Presence Service.


Table 15. Interdomain Federation Support

Federated Enterprise

IM and Presence Service Release 10.x

Protocol

TCP/TLS

Cisco Unified Presence 7.x

No1

Cisco Unified Presence 8.0

No1

Cisco Unified Presence 8.5

No1

Cisco Unified Presence 8.6

Yes

XMPP

TCP and TLS

IM and Presence Service 9.0(1)

Yes

XMPP

TCP and TLS

IM and Presence Service 9.1(1)

Yes

XMPP

TCP and TLS

IM and Presence Service 10.0(1)

Yes

XMPP

TCP and TLS

IM and Presence Service 10.5(1)

Yes

XMPP

TCP and TLS

IM and Presence Service 10.5(2)

Yes

XMPP

TCP and TLS

Webex Messenger 7.x

Yes

XMPP

TCP and TLS

Jabber XCP (XMPP federation)

Yes

XMPP

TCP and TLS

IBM Sametime 8.2

Yes

XMPP

TCP and TLS

IBM Sametime 8.5

Yes

XMPP

TCP and TLS

GoogleTalk2

Yes

XMPP

TCP

Microsoft LCS 2005

No

Microsoft OCS 2007

Yes

SIP3

TLS

Microsoft OCS 2007 R2

Yes

SIP3

TLS

Microsoft Lync 2010 (Direct Federation)

Yes

SIP3

TLS

Microsoft Lync 2010 (Business to Business)

Yes

SIP3

TLS

Microsoft Lync 2013 (Direct Federation)

Yes

SIP3

TLS

Microsoft Lync 2013 (Business to Business)

Yes

SIP3

TLS

Skype for Business (Direct Federation)

No

Skype for Business (Business to Business)

No

1 Not supported due to End of Software maintenance. See End-of-Life and End-of-Safe Notices

2 Be aware that Google are planning to discontinue support for XMPP federation. Refer to Google for more information.

3 Only SIP federation to Microsoft clients is supported.

Support for Cisco Adaptive Security Appliance (ASA)

IM and Presence Service Release 10.x supports Cisco ASA Version 9.0.4-1.

Support for Group Chat

The XMPP protocol supports group chat over federation, assuming that the federated enterprise also supports group chat.

Intradomain Federation

The following table shows the intradomain federations that are supported in IM and Presence Service Release 10.x.

Table 16. Intradomain Federation Support

Federated Enterprise

IM and Presence Service Release 10.x

Protocol

TCP/TLS

Chat + Calling via Expressway Gateway1

Microsoft LCS 2005

No

No

Microsoft OCS 2007

No

No

Microsoft OCS 2007 R2

Yes

SIP

TCP or TLS

No

Microsoft Lync 2010

Yes

SIP

TLS only

Yes

Microsoft Lync 2013

Yes

SIP

TLS only

Yes

Skype for Business

No

No

1Minimum Expressway-C version for chat + calling is Expressway X8.8.

Interclustering

The following table shows the intercluster configurations that are supported in IM and Presence Service Release 10.x.


Note

These intercluster configurations also support interdomain and intradomain federation.


Table 17. Intercluster Peering Support

Intercluster with

IM and Presence Service Release 10.x

Cisco Unified Presence 8.6

Yes

IM and Presence Service 9.0(1)

Yes

IM and Presence Service 9.1(1)

Yes

IM and Presence Service 10.0(1)

Yes

IM and Presence Service 10.5(1)

Yes

IM and Presence Service 10.5(2)

Yes

Supported Interfaces

The following interfaces are supported with this release of IM and Presence Service:

  • SIP/SIMPLE
  • REST
  • SOAP
  • XMPP
  • Cisco AJAX XMPP Library (CAXL)