|
Command or Action |
Purpose |
|
enable
Example:
Device> enable
|
Enables privileged EXEC mode.
-
Enter your password if prompted.
|
|
configure terminal
Example:
Device# configure terminal
|
Enters global configuration mode. |
|
router bgp autonomous-system-number
Example:
Device(config)# router bgp 65000
|
Enters router configuration mode for the specified routing process. |
|
neighbor {ip-address | ipv6-address[%] | peer-group-name} remote-as autonomous-system-number [alternate-as autonomous-system-number ...]
Example:
Device(config-router)# neighbor FE80::1234:BFF:FE0E:A471% remote-as 64600
|
Adds the link-local IPv6 address of the neighbor in the specified remote autonomous system to the IPv6 multiprotocol BGP neighbor table of the local device.
-
The optional % keyword is the IPv6 link-local address identifier. This keyword needs to be added whenever a link-local IPv6 address is used outside the context of its interface.
|
|
neighbor {ip-address | ipv6-address[%] | peer-group-name} update-source interface-type interface-number
Example:
Device(config-router)# neighbor FE80::1234:BFF:FE0E:A471% update-source fastethernet0
|
Specifies the link-local address over which the peering is to occur.
-
The optional % keyword is the IPv6 link-local address identifier. This keyword needs to be added whenever a link-local IPv6 address is used outside the context of its interface.
-
If there are multiple connections to the neighbor and you do not specify the neighbor interface by using the interface-type and interface-number arguments in the neighbor update-source command, a TCP connection cannot be established with the neighbor using link-local addresses.
|
|
address-family ipv6 [vrf vrf-name] [unicast | multicast | vpnv6]
Example:
Device(config-router)# address-family ipv6
|
Specifies the IPv6 address family, and enters address family configuration mode.
-
The unicast keyword specifies the IPv6 unicast address family. By default, the device is placed in configuration mode for the IPv6 unicast address family if the unicast keyword is not specified with the address-family ipv6 command.
-
The multicast keyword specifies IPv6 multicast address prefixes.
|
|
neighbor {ip-address | peer-group-name | ipv6-address %} activate
Example:
Device(config-router-af)# neighbor FE80::1234:BFF:FE0E:A471% activate
|
Enables the neighbor to exchange prefixes for the IPv6 address family with the local device using the specified link-local addresses.
-
The optional % keyword is the IPv6 link-local address identifier. This keyword needs to be added whenever a link-local IPv6 address is used outside the context of its interface.
|
|
neighbor {ip-address | peer-group-name | ipv6-address[%]} route-map map-name {in | out}
Example:
Device(config-router-af)# neighbor FE80::1234:BFF:FE0E:A471% route-map nh6 out
|
Applies a route map to incoming or outgoing routes.
-
The optional % keyword is the IPv6 link-local address identifier. This keyword needs to be added whenever a link-local IPv6 address is used outside the context of its interface.
|
|
exit
Example:
Device(config-router-af)# exit
|
Exits address family configuration mode, and returns the device to router configuration mode. |
|
exit
Example:
Device(config-router)# exit
|
Exits router configuration mode, and returns the device to global configuration mode. |
|
route-map map-tag [permit | deny] [sequence-number]
Example:
Device(config)# route-map nh6 permit 10
|
Defines a route map and enters route-map configuration mode. |
|
match ipv6 address {prefix-list prefix-list-name | access-list-name}
Example:
Device(config-route-map)# match ipv6 address prefix-list cisco
|
Distributes any routes that have a destination IPv6 network number address permitted by a prefix list, or performs policy routing on packets. |
|
set ipv6 next-hop ipv6-address [link-local-address] [peer-address]
Example:
Device(config-route-map)# set ipv6 next-hop 2001:DB8::1
|
Overrides the next hop advertised to the peer for IPv6 packets that pass a match clause of a route map for policy routing.
-
The ipv6-address argument specifies the IPv6 global address of the next hop. It need not be an adjacent device.
-
The link-local-address argument specifies the IPv6 link-local address of the next hop. It must be an adjacent device. If you do not specify this optional argument, the link-local address of the interface specified with the interface-type argument (in the neighbor update-source command in Step 5) is included as the next-hop in the BGP updates. Therefore, only one route map that sets the global IPv6 next-hop address in BGP updates is required for multiple BGP peers that use link-local addresses.
-
The route map sets the IPv6 next-hop addresses (global and link-local) in BGP updates. If the route map is not configured, the next-hop address in the BGP updates defaults to the unspecified IPv6 address (::), which is rejected by the peer.
|