Cisco Remote PHY System Bring Up

Finding Feature Information

Your software release may not support all the features that are documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. The Feature Information Table at the end of this document provides information about the documented features and lists the releases in which each feature is supported.

Use Cisco Feature Navigator to find information about the platform support and Cisco software image support. To access Cisco Feature Navigator, go to the link http://tools.cisco.com/ITDIT/CFN/. An account at the http://www.cisco.com/ site is not required.

Hardware Compatibility Matrix for Cisco Remote PHY Device


Note

Unless otherwise specified, the hardware components introduced in a given Cisco Remote PHY Device Software Release are supported in all subsequent releases.


Table 1. Hardware Compatibility Matrix for the Cisco Remote PHY Device

Cisco HFC Platform

Remote PHY Device

Cisco GS7000 Super High Output Node

Cisco 1x2 / Compact Shelf RPD Software 2.1 and Later Releases

Cisco Remote PHY Device 1x2

  • PID—RPD-1X2=

Cisco 1x2 / Compact Shelf RPD Software 2.1a and Later Releases

Cisco Remote PHY Device 1x2

  • PID—RPD-1X2-PKEY=

Cisco GS7000 Super High Output Intelligent Node (iNode)

Cisco 1x2 / Compact Shelf RPD Software 4.1 and Later Releases

Cisco Intelligent Remote PHY Device 1x2

  • PID—iRPD-1X2=

  • PID—iRPD-1X2-PKEY=


Note

The -PKEY suffix in the PID indicates units that enable the SCTE-55-2 Out-of-Band protocol support.


Information about RPD Bring Up

Remote PHY device bring up process is prerequisite to the operation of the remote PHY system, just like the cable modem bring up in a DOCSIS system.

How to Bring Up RPD

This section describes how to bring up RPD on Cisco cBR-8.

Configuring DHCP Server

To configure DHCP server, follow the steps below:

Procedure


Step 1

Add option for CCAP-Core. Fill in the name, DHCP type, and vendor option string as shown in the figure below.

Step 2

Define option. Fill in the option number and name as shown in the figure below.

Step 3

Define suboption. Fill in the name, type and repeat of suboption 61 as shown in the figure below..

Step 4

Add the option into policy as shown in the figure below. Replace the IP address 120.102.15.1 in the figure to the DPIC port IP address.


Configuring PTP

To configure PTP, use the following example as reference:

On cBR-8 router:


interface Loopback1588
  ip address 159.159.159.4 255.255.255.255
interface TenGigabitEthernet5/1/3   /* connect to ASR903 */
  ip address 192.104.10.4 255.255.255.0

ip route 10.90.3.93 255.255.255.255 192.104.10.93   /* route to ASR903 loopback ip */

ptp clock ordinary domain 0
  servo tracking-type R-DTI
  clock-port slave-from-903 slave
    delay-req interval -4
    sync interval -5
    sync one-step
    transport ipv4 unicast interface Lo1588 negotiation
    clock source 10.90.3.93   /* ASR903 loopback ip */

ptp r-dti 1
  ptp-domain 0   /* same domain number with ptp server */
  clock-port 1
    ethernet 1   /* default value is same index with clock-port index, for RPD, ethernet 1=vbh0, ethernet 2=vbh1 */
    clock-source 10.90.3.93 gateway 93.3.10.2   /* clock-source is ASR093 loopback ip, gateway is ASR903 BDI ID for node */

On ASR903 router as PTP master:


ptp clock ordinary domain 0
 clock-port Master-to-all-cBR8 master
  sync interval -5
  sync one-step
  transport ipv4 unicast interface Lo1588 negotiation

interface Loopback1588
 ip address 10.90.3.93 255.255.255.255

interface GigabitEthernet0/3/5
 no ip address
 negotiation auto
 cdp enable
 service instance 31 ethernet   /* 31 is vlan id */
  encapsulation dot1q 31
  rewrite ingress tag pop 1 symmetric
  bridge-domain 31
 service instance 32 ethernet
  encapsulation dot1q 32
  rewrite ingress tag pop 1 symmetric
  bridge-domain 32
interface BDI31   /* for cBR, SUP PIC */
 ip address 192.104.10.93 255.255.255.0
 no shut
interface BDI32   /* For RPD */
 ip address 93.3.10.2 255.255.255.0 
 no shut 

ip route 159.159.159.4 255.255.255.255 192.104.10.48   /* route to cbr-8 loopback ip */

Configuring cBR-8

To configure the cBR-8 to bring up the RPD, use the following example as reference:


/* D-PIC TenGiga interface config */
interface TenGigabitEthernet0/1/0
  ip address 93.3.10.1 255.255.255.0
  ip helper-address 20.1.0.33

/* Downstream/Upstream controller profile */
cable downstream controller-profile 101
rf-chan 0 95
  type DOCSIS
  frequency 381000000
  rf-output NORMAL
  qam-profile 1
  docsis-channel-id 1

cable upstream controller 201
  us-channel 0 channel-width 1600000 1600000
  us-channel 0 docsis-mode atdma
  us-channel 0 minislot-size 4
  us-channel 0 modulation-profile 221
  no us-channel 1 shutdown
  
/* RPD configuration */
cable rpd node1
  identifier 0004.9f03.0061
  core-interface Te0/1/0
    rpd-ds 0 downstream-cable 0/0/0 profile 101
    rpd-us 0 upstream-cable 0/0/0 profile 201
  r-dti 1
  rpd-event profile 0

interface Cable0/0/0
  load-interval 30
  downstream Downstream-Cable 0/0/0 rf-channel 0-23
  upstream 0 Upstream-Cable 0/0/0 us-channel 0
  upstream 1 Upstream-Cable 0/0/0 us-channel 1
  upstream 2 Upstream-Cable 0/0/0 us-channel 2
  upstream 3 Upstream-Cable 0/0/0 us-channel 3
  cable upstream bonding-group 1
    upstream 0
    upstream 1
    upstream 2
    upstream 3
    attributes 80000001
    cable bundle 1
  cable ip-init ipv6
interface Wideband-Cable0/0/0:0
  cable bundle 1
  cable rf-channels channel-list 0-7 bandwidth-percent 10
interface Wideband-Cable0/0/0:1
  cable bundle 1
  cable rf-channels channel-list 8-15 bandwidth-percent 10
cable fiber-node 200
  downstream Downstream-Cable 0/0/0
  upstream Upstream-Cable 0/0/0