Guest

IBM Networking

Enterprise Data Center Networking Sample Configurations

Table Of Contents

Product Bulletin No. 1549

Overview

SNASw/DLSw+ Sample Configuration

CIP/CPA Sample Configuration

DLUR TN3270 Server Sample Configuration

TN3270 Server/SNASw Sample Configuration

Remote SNASw Router Sample Configuration

Remote DLSw+ Router Sample Configuration


Product Bulletin No. 1549


Enterprise Data Center Networking Sample Configurations

Overview

This bulletin provides sample configurations for the following enterprise data center networking solutions:

SNA Switching Services (SNASw) used with Data-Link Switching Plus (DLSw+)

Channel Interface Processor (CIP) and Channel Port Adapter (CPA)

Dependent Logical Unit Requester (DLUR) with Cisco TN3270 Server

TN3270 Server with SNASw

Remote SNASw router

Remote DLSw+ router

SNASw/DLSw+ Sample Configuration

In the following sample configuration, which ties SNASw to DLSw+ using the virtual data-link control (VDLC) port, SNASw uses Enterprise Extender transport for communication to the upstream host:

!
source-bridge ring-group 100
dlsw local-peer peer-id 10.2.10.1 promiscuous
!
interface Loopback0
 ip address 10.2.10.1 255.255.255.252
!
interface Ethernet0/1
 ip address 10.2.12.1 255.255.255.0
 no ip mroute-cache
!
interface FastEthernet1/0
 ip address 10.2.1.1 255.255.255.0
 no ip mroute-cache
 duplex auto
 speed auto
!
snasw cpname NETA.RWSNASR1
snasw port HPRLO0 hpr-ip Loopback0 vnname NETA.SSCPVN
snasw port VDLCPORT vdlc 100 mac 4000.0001.0001 conntype nohpr
snasw link MVSALINK port HPRLO0 ip-dest 10.2.8.1
!
router ospf 1
 log-adjacency-changes
 network 10.2.0.0 0.0.255.255 area 1
!

CIP/CPA Sample Configuration

The following sample configuration is for a Cisco 7500 Series CIP using Cisco MultiPath Channel (CMPC):

!
*** some statements omitted***
!
microcode CIP flash slot1:cip28-6.bin
microcode reload
!
source-bridge ring-group 1001
!
interface Channel6/0
 description CPMC read interfaces to sysplex hosts
 no ip address
 ip directed-broadcast
 load-interval 30
 no keepalive
 cmpc CA02 E0 TGMVS001 READ
 cmpc CA02 E2 TGMVS062 READ
 cmpc CA02 E4 TGMVS069 READ
 cmpc CA02 E6 TGMVS154 READ
!
interface Channel6/1
 description CMPC write interfaces to sysplex hosts
 no ip address
 ip directed-broadcast
 ip ospf network point-to-multipoint
 load-interval 30
 no keepalive
 cmpc D900 10 TGMVS001 WRITE
 cmpc D900 12 TGMVS062 WRITE
 cmpc D900 14 TGMVS069 WRITE
 cmpc D900 16 TGMVS154 WRITE
!
interface Channel6/2
 description TN3270 Server Port
 ip address 10.1.2.21 255.255.255.248
 ip ospf network point-to-multipoint
 ip igmp join-group 224.0.1.2
 no keepalive
 max-llc2-sessions 2000
 lan TokenRing 0
  source-bridge 100 1 1001
  adapter 0 4000.7507.7507
  adapter 1 4000.7507.3270
 tn3270-server
  maximum-lus 200
  unbind-action keep
  dlur USIBMNM.C7507TN USIBMNM.N07N
   lsap token-adapter 1
    link DLURPIPE rmac 4000.7507.7507
   pu TESTPU11 05D70571 10.1.2.170
   pu TESTPU12 05D70572 10.1.2.171
   pu TESTPU13 05D70573 10.1.2.172
   pu TESTPU14 05D70574 10.1.2.173
   pu TESTPU15 05D70575 10.1.2.174
 tg TGMVS001 ip 10.1.2.17 10.1.2.21 broadcast
 tg TGMVS062 ip 10.1.2.18 10.1.2.21 broadcast
 tg TGMVS069 ip 10.1.2.19 10.1.2.21 broadcast
 tg TGMVS154 ip 10.1.2.20 10.1.2.21 broadcast
!
!
router eigrp 1
 redistribute ospf 7514 route-map stopem
 network 10.1.2.144 0.0.0.15
 network 211.1.1.0
 network 211.1.2.0
 default-metric 16000 1 255 1 1500
 distribute-list 1 out Fddi5/0
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7514
 router-id 10.1.2.82
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 redistribute eigrp 1 subnets route-map sendem
 network 10.1.2.0 0.0.0.255 area 1.1.1.1
 maximum-paths 3
!
ip kerberos source-interface any
ip classless
ip route 0.0.0.0 0.0.0.0 211.1.1.1
!
access-list 1 permit 10.1.2.96 0.0.0.15
access-list 1 permit 10.1.2.112 0.0.0.15
access-list 1 permit 10.1.2.128 0.0.0.15
access-list 10 permit any
access-list 20 deny   0.0.0.0
access-list 20 permit any
access-list 111 permit tcp any any eq telnet
access-list 112 permit tcp any any eq www
access-list 113 permit tcp any any eq ftp
access-list 114 permit ip any any
access-list 121 permit udp any any range 16384 32768
access-list 131 permit udp any any dscp af11
access-list 132 permit udp any any dscp af12
access-list 132 permit tcp any any eq ftp
route-map stopem deny 10
 match tag 1
!
route-map stopem permit 11
 match tag 0
!
route-map sendem permit 10
 match ip address 10
 set tag 1
!

The following sample configuration is for a Cisco 7200 Series CPA using Common Link Access for Workstations (CLAW):

!
*** some statement omitted ***
!
version 12.2
!
microcode ecpa disk0:xcpa28-6.bin
microcode reload
ip subnet-zero
!
interface Channel3/0
 description CLAW interfaces to sysplex hosts
 ip address 10.1.2.65 255.255.255.248
 no ip redirects
 ip directed-broadcast
 ip pim dense-mode
 no ip route-cache cef
 ip ospf network point-to-multipoint
 ip igmp join-group 224.0.1.2
 no ip mroute-cache
 load-interval 30
 no keepalive
 service-policy input SETDSCP
 claw D102 A0 10.1.2.66 MVS001B C7507A PACKED PACKED broadcast
 claw D102 A2 10.1.2.67 MVS069B C7507B PACKED PACKED broadcast
 claw D102 A4 10.1.2.68 MVS154B C7507C PACKED PACKED broadcast
 claw D102 A6 10.1.2.69 MVS062B C7507D PACKED PACKED broadcast
 ip rsvp bandwidth 1 1
 ip rsvp udp-multicasts 224.0.0.14
!
router eigrp 1
 redistribute ospf 1 route-map stopem
 network 10.1.2.144 0.0.0.15
 network 211.1.2.0
 default-metric 16000 1 255 1 1500
 no auto-summary
 no eigrp log-neighbor-changes
!
router ospf 1
 router-id 10.1.2.89
 log-adjacency-changes
 auto-cost reference-bandwidth 1000
 redistribute eigrp 1 subnets route-map sendem
 network 10.1.2.0 0.0.0.255 area 1.1.1.1
 neighbor 10.1.2.82 cost 2
 neighbor 10.1.2.81 cost 1
 maximum-paths 3
!
ip classless
!
access-list 10 permit any
access-list 111 permit tcp any any eq telnet
access-list 112 permit tcp any any eq www
access-list 113 permit tcp any any eq ftp
access-list 114 permit ip any any
access-list 121 permit udp any any range 16384 32768
access-list 131 permit udp any any dscp af11
access-list 132 permit udp any any dscp af12
access-list 132 permit tcp any any eq ftp
access-list 198 permit tcp any any
access-list 199 permit tcp any any eq 8008
access-list 199 permit tcp any any range 8000 8008
route-map stopem deny 10
 match tag 1
!
route-map stopem permit 11
 match tag 0
!
route-map sendem permit 10
 match ip address 10
 set tag 1
!

DLUR TN3270 Server Sample Configuration

The following sample configuration illustrates DLUR used with TN3270 Server:

*** some statements omitted***
!
microcode CIP flash slot1:cip28-6.bin
microcode reload
!
source-bridge ring-group 1001
!
interface Channel6/0
 description CPMC read interfaces to sysplex hosts
 no ip address
 ip directed-broadcast
 load-interval 30
 no keepalive
 cmpc CA02 E0 TGMVS001 READ
 cmpc CA02 E2 TGMVS062 READ
 cmpc CA02 E4 TGMVS069 READ
 cmpc CA02 E6 TGMVS154 READ
!
interface Channel6/1
 description CMPC write interfaces to sysplex hosts
 no ip address
 ip directed-broadcast
 ip ospf network point-to-multipoint
 load-interval 30
 no keepalive
 cmpc D900 10 TGMVS001 WRITE
 cmpc D900 12 TGMVS062 WRITE
 cmpc D900 14 TGMVS069 WRITE
 cmpc D900 16 TGMVS154 WRITE
!
interface Channel6/2
 description TN3270 Server Port
 ip address 10.1.2.21 255.255.255.248
 ip ospf network point-to-multipoint
 ip igmp join-group 224.0.1.2
 no keepalive
 max-llc2-sessions 2000
 lan TokenRing 0
  source-bridge 100 1 1001
  adapter 0 4000.7507.7507
  adapter 1 4000.7507.3270
 tn3270-server
  maximum-lus 200
  unbind-action keep
  dlur USIBMNM.C7507TN USIBMNM.N07N
   lsap token-adapter 1
    link DLURPIPE rmac 4000.7507.7507
   pu TESTPU11 05D70571 10.1.2.170
   pu TESTPU12 05D70572 10.1.2.171
   pu TESTPU13 05D70573 10.1.2.172
   pu TESTPU14 05D70574 10.1.2.173
   pu TESTPU15 05D70575 10.1.2.174
 tg TGMVS001 ip 10.1.2.17 10.1.2.21 broadcast
 tg TGMVS062 ip 10.1.2.18 10.1.2.21 broadcast
 tg TGMVS069 ip 10.1.2.19 10.1.2.21 broadcast
 tg TGMVS154 ip 10.1.2.20 10.1.2.21 broadcast
!

TN3270 Server/SNASw Sample Configuration

The following sample configuration shows how the Channel Port Adapter (CPA) can be used to implement TN3270 Server, connecting to a virtual Token Ring interface configured as a SNASw port:

!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname cabernet
!
boot system flash disk0:c7200-a3js-mz.121-5.T5.bin
boot system flash
logging buffered 32000 debugging
logging rate-limit console 10 except errors
enable password cisco
!
microcode ecpa disk0:xcpa28-2.bin
microcode reload
ip subnet-zero
!
no ip finger
!
call rsvp-sync
cns event-service server
!
source-bridge ring-group 100
!
interface Loopback0
 ip address 10.2.10.13 255.255.255.252
!
interface FastEthernet0/0
 ip address 172.26.65.49 255.255.240.0
 no ip proxy-arp
 no ip mroute-cache
 duplex half
!
interface Channel1/0
 ip address 10.2.90.1 255.255.255.0
 no keepalive
 lan TokenRing 0
  source-bridge 200 1 100
  adapter 1 4000.7200.0001
   name tnadap
 tn3270-server
  pu RWP98001 08198001 10.2.98.1	token-adapter 1  08 rmac 4000.7200.0002
!
interface FastEthernet2/0
 ip address 10.2.1.4 255.255.255.0
 duplex half
!
interface Virtual-TokenRing0
 mac-address 4000.7200.0002
 no ip address
 ring-speed 16
 source-bridge 300 2 100
!
snasw cpname NETA hostname
snasw port HPRLO0 hpr-ip Loopback0 vnname NETA.SSCPVN nostart
snasw port TNPORT Virtual-TokenRing0 conntype nohpr
snasw link MVSALINK port HPRLO0 ip-dest 10.2.8.1 nostart
!
router ospf 1
 log-adjacency-changes
 redistribute static subnets
 network 10.2.0.0 0.0.255.255 area 1
!

Remote SNASw Router Sample Configuration

The following sample configuration uses SNASw and Enterprise Extender to transport SNA traffic natively over High Performance Routing (HPR)/IP:

!
version 12.1
!
interface Loopback0
 ip address 10.2.10.5 255.255.255.252
!
interface FastEthernet0/0
 ip address 172.26.65.55 255.255.240.0
 no ip proxy-arp
 no ip route-cache
 no ip mroute-cache
 duplex auto
 speed auto
!
interface FastEthernet1/0
 mac-address 4000.0000.0002
 ip address 10.2.13.1 255.255.255.0
 duplex half
!
interface Serial2/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
!
interface Serial2/0.100 point-to-point
 ip address 10.2.11.2 255.255.255.252
 frame-relay interface-dlci 100
!
snasw cpname NETA hostname
snasw port HPRLO0 hpr-ip Loopback0 vnname NETA.SSCPVN
snasw port ETHER FastEthernet1/0 conntype nohpr
snasw link MVSALINK port HPRLO0 ip-dest 10.2.8.1
!
router ospf 1
 log-adjacency-changes
 network 10.2.0.0 0.0.255.255 area 1
!

Remote DLSw+ Router Sample Configuration

This sample configuration shows a remote router with two upstream peers. It designates one peer as the preferred router by setting a lower cost. For increased availability, the configuration uses Ethernet redundancy, which allows another remote router to provide backup SNA service in the event that the primary router fails:

!
version 12.2

!
source-bridge ring-group 400
dlsw local-peer peer-id 10.2.10.21
dlsw timer explorer-wait-time 3
dlsw remote-peer 0 tcp 10.2.10.17 cost 2
dlsw remote-peer 0 tcp 10.2.10.13 cost 4
!
!
interface Loopback0
 ip address 10.2.10.21 255.255.255.252
!
interface FastEthernet0/0
 mac-address 4000.7777.0001
 ip address 10.3.3.1 255.255.255.0
 no keepalive
 duplex half
 standby ip 10.3.3.3
 dlsw transparent redundancy-enable 9999.9999.9999
!
interface FastEthernet2/0
 ip address 10.2.11.6 255.255.255.252
 duplex half
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 1
!