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CHAPTER 1

Overview of Cisco Unified
Communications Integration for Microsoft Office
Communicator

Revised: January 29, 2010

Cisco UC Integration for Microsoft Office Communicator, page 1-1
Installation Prerequisites, page 1-3

Installing Cisco UC Integration for Microsoft Office Communicator with Other Microsoft Office
Communicator Tabs, page 1-3

Cisco UC Integration for Microsoft Office Communicator

The Cisco UC Integration for Microsoft Office Communicator adds a conversation pane to
Microsoft Office Communicator.

Users can perform the following tasks from the conversation pane:

Place and receive phone calls.
Start and participate in conference calls.

Transfer your callsto other contacts, or depending on your configuration, to amobile device or other
remote device.

Forward your calls to your voicemail service, another contact, or another number.
Park your call, then retrieve the call from another device.

Call your voicemail service.

Display your conversation history.

(Optional) Save your conversation history in Microsoft Outlook.

Set options for the conversation pane.

Switch phone modes.

(Optional) Usethe click-to-call featureto place calls from within Mozilla Firefox and the following
Microsoft applications: Excel, Internet Explorer, Outlook, PowerPoint, Sharepoint, and Word.

(Optional) Use the click-to-call feature to place calls to numbers in your clipboard.
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M Cisco UC Integration for Microsoft Office Communicator

Cisco UC Integration for Microsoft Office Communicator integrates closely with Microsoft Office
Communicator. Cisco UC Integration for Microsoft Office Communicator updates the availability status
of users automatically. Users can send instant messages through Microsoft Office Communicator to
contacts with whom they are currently having a conversation through the conversation pane.

Cisco UC Integration for Microsoft Office Communicator interacts with servers and applications as
shown in Figure 1-1:

Figure 1-1 Cisco UC Integration for Microsoft Office Communicator Interactions with Network
Servers
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Cisco UC Integration for Microsoft Office Communicator provides window management, client
security, third-party integration, and client servicesframework (CSF) integration. The CSF provides call
control services, user authentication, message waiting indicators, media, firewall traversal, and so on.

When you install Cisco UC Integration for Microsoft Office Communicator, the installation application
installs all the required components.
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Installation Prerequisites

Installation Prerequisites

Before you install Cisco UC Integration for Microsoft Office Communicator, check that your system
meets all the necessary prerequisites. Ensure that you have the correct versions of all the required
software, as listed in the release notes at the following URL.:

http://www.cisco.com/en/US/products/ps10317/prod_release notes list.html

Installing Cisco UC Integration for Microsoft Office
Communicator with Other Microsoft Office Communicator Tabs

Cisco UC Integration for Microsoft Office Communicator isimplemented as atab that is added to the
Microsoft Office Communicator window. Microsoft Office Communicator can be configured with
multiple tabs.

» Definition of Microsoft Office Communicator Tabs, page 1-3
» Precedence of the TabURL Registry Key Entry, page 1-3
» Updating the Microsoft Office Communicator Tabs XML File, page 1-3

Definition of Microsoft Office Communicator Tabs

The Microsoft Office Communicator tabs are defined in an XML file which can be located in the local
file system, or on aremote server. You can define the tabs in only one XML file. One of the following
registry key entries specifies the location of this XML file;

- HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Communicator\TabURL
- HKEY_CURRENT_USER\Software\Policies\Microsoft\Communicator\TabURL

If you performed a default installation, and did not specify values for the TabURL key before the
installation, the XML fileisin the default installation folder, as follows:

C:\Program Files\Cisco Systems\Cisco UC Integration TM for Microsoft Office
Communicator\cisco-moc-tab-config.xml

Precedence of the TabURL Registry Key Entry

Microsoft Office Communicator can read only one TabURL registry key. The
HKEY_LOCAL_MACHINE entry takes precedence over the HKEY_CURRENT_USER entry.

Updating the Microsoft Office Communicator Tabs XML File

If the XML fileinyour configuration of Microsoft Office Communicator is on aremote server, you must
update the XML file before you install Cisco UC Integration for Microsoft Office Communicator.

Add the following <tab> element within the <tabdata> element in the XML file:

<tab attr="CUCIMOC">

<image>file:///<installation_ folder>\Resources\CUCIMOCTab.PNG</image>
<name>Cisco Softphone</names>

<tooltip>Cisco Softphone</tooltips>
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<contenturls>file:///<installation folder>\MocTab\CUCIMOCTab.html</contenturl>
<useridstrue</userid>

<contactids>false</contactids>

<accessibilitysboth</accessibility>

</tab>

For more information about how to edit the XML file, see the Microsoft Office Communicator 2007

Deployment Guide at the following URL:

http://www.microsoft.com/downl oads/detail s.aspx?Familyl D=F1D1A947-6EFF-4AC4-8878-FOA 7789
4AC99& displaylang=en
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CHAPTER 2

Configuring Servers for Cisco Unified
Communications Integration for Microsoft Office
Communicator

Revised: January 29, 2010

« How to Configure Active Directory Server and OCS Server, page 2-1
« Dial Plan Options for Cisco UC Integration for Microsoft Office Communicator, page 2-5
- How to Configure Cisco Unified Communications Manager Server, page 2-8

- Verifying the Configuration of Active Directory, OCS, and Cisco Unified
Communications Manager Servers, page 2-15

How to Configure Active Directory Server and OCS Server

When you configure your servers for Cisco UC Integration for Microsoft Office Communicator, you
must ensure that the user I1Ds, devices, and directory numbers match in the following servers:

- Active Directory server
- Office Communications Server (OCS)
» Cisco Unified Communications Manager server
You must also configure your users so that each user has the following:

« A phone number that can be correctly dialed within the context of your Cisco Unified
Communications Manager configuration.

« All phone numbers for the user are in E.164 format.

For more information about the importance of the use of the E.164 format to the deployment of
Cisco UC Integration for Microsoft Office Communicator, read the following topics:

- E.164 Formatting, page 2-2
» Phone Numbers for Active Directory Users Must Use E.164 Formatting, page 2-2

To configure the Active Directory server and the OCS server for Cisco UC Integration for Microsoft
Office Communicator, you must perform the following tasks:

« Enabling Usersfor OCS, page 2-2
» Updating OCS Address Book Manually, page 2-3
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B How to Configure Active Directory Server and OCS Server

- Verifying OCS Address Book Synchronization, page 2-4

E.164 Formatting

The E.164 standard defines an international numbering plan for public phone systems. In the E.164
standard, each number contains a country code, an area code, and a subscriber number. Each phone user
has a globally unique number. In Cisco UC Integration for Microsoft Office Communicator, phone
numbers in E.164 format must begin with a plus character (“+").

Phone Numbers for Active Directory Users Must Use E.164 Formatting

Tip

You must define phone numbersin E.164 format for each user in your Active Directory. This ensuresthe
following:

+ When Microsoft Office Communicator downloads the OCS address book, each user in the OCS
address book is assigned a number in the correct format.

» Each user has a phone number that can be correctly dialed within the context of your Cisco Unified
Communications Manager configuration.

The Microsoft Office Communicator Automation API reads contacts and their associated phone
numbers from Active Directory, and passes this data to the Cisco UC Integration for Microsoft Office
Communicator.

Define phone numbersin E.164 format for each user in your Active Directory. If you do not do this, you
must configure a set of phone number normalization rules on the OCS server, so that a phone number
that can be correctly dialed is available in the OCS address book. Configuring phone number
normalization rules can be an error-prone task, especially for international and enterprise dial plans. If
you choose not to define phone numbers in E.164 format, see Appendix A, “Normalization Rules for
OCs'.

What to Do Next
» Enabling Usersfor OCS, page 2-2

Enabling Users for OCS

Step 1
Step 2
Step 3
Step 4

Procedure

Start the Active Directory Users and Computers administrative tool.
Expand the domain that contains your users.
Open the organizational unit (OU) that contains your users.
Check the following details for all users that you want to enable for OCS:
» All users have valid email addresses.
« All users are assigned to a group.

« All the phone numbers for each user are in E.164 format, and can be correctly dialed within the
context of your Cisco Unified Communications Manager configuration.
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Step5  Right-click the users, then select Enable users for Communications Server.

Active Directory uses the User logon name field and the domain name to form a SIP email addressin
the Office Communications Server Address column. This address is used to sign usersin to
Microsoft Office Communicator, and enables users to send instant messages.

Related Topics
- Configuration of Telephony Options for Users, page 2-3

» Phone Numbers for Active Directory Users Must Use E.164 Formatting, page 2-2

What to Do Next
» Updating OCS Address Book Manually, page 2-3

Configuration of Telephony Options for Users

We strongly recommend that you do not select the following telephony options for your users:
- Enable Remote call control
- Enable Enterprise Voice

If you select either of these options, voice traffic is allowed from both Cisco UC Integration for
Microsoft Office Communicator and Microsoft Office Communicator. This can result in the following
problems:

- A confusing user experience, as users can place and receive calls from a mixture of user interface
elements in both applications.

« Inconsistent voice traffic. That is, calls from Cisco UC Integration for Microsoft Office
Communicator might give a different audio experience to Microsoft Office Communicator.

- A mixed configuration is more difficult to manage, as administrators must track traffic from two
sources. You might want to monitor voice usage in your network and if you use both applications,
you must configure your monitoring tools to track traffic from both applications.

Related Topics
- Enabling Users for OCS, page 2-2

Updating OCS Address Book Manually

To ensure that the OCS address book has the latest information from the Active Directory server, you
must update the OCS address book manually. For information about how to perform this task, see the
following URL :

http://technet.microsoft.com/en-us/library/bb936631.aspx

What to Do Next
- Verifying OCS Address Book Synchronization, page 2-4
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Verifying OCS Address Book Synchronization

You must verify that the users are enabled for OCS, that the OCS address book is synchronized with the
Active Directory server, and that the OCS address book is configured and operational.

To resolve problems associated with synchronization of the OCS address book, see Troubleshooting
Cisco Unified Communications Integration for Microsoft Office Communicator, page 5-1.
Alternatively, see the relevant Microsoft documentation.

Procedure

Stepl  Useone of the user accountsto sign in to Microsoft Office Communicator.
This step signs the user in to OCS.

Step2  Verify that the following message is not displayed in the notifications area in Microsoft Office
Communicator after the user signsin:

Cannot Synchronize Address Book
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Dial Plan Options for Cisco UC Integration for Microsoft Office
Communicator

The following table summarizes the dial plan options available when you deploy Cisco UC Integration
for Microsoft Office Communicator:

Phone Numbers in

Phone Numbers in Cisco Unified
Option |Active Directory Communications Manager Comments
1 E.164 number format |E.164 number format Requires Cisco Unified
Communications Manager Release
7.0 or later.
2 E.164 number format | Private numbering plan Requires you to do the following:
- Configure application dialing
rules and directory lookup
dialing rules on Cisco Unified
Communications Manager.
3 Private numbering plan |Private numbering plan Requires you to do the following:

» Configure normalization ruleson
ocCs.

« Configure application dialing
rules and directory lookup
dialing rules on Cisco Unified
Communications Manager.

This chapter deals with options 1 and 2. Appendix A, “Normalization Rules for OCS” deals with
option 3.

Note  If you choose option 3, you must configure aset of phone number normalization rules on the OCS server.
Configuring OCS normalization rules can be an error-prone task, especially for international and
enterprise dial plans. For more information about this topic, see Appendix A, “Normalization Rules for
OCs'.

Dialing Rules Required for Cisco UC Integration for Microsoft Office
Communicator

If your Cisco Unified Communications Manager uses a private numbering plan, you must configure the
following types of dialing rules in Cisco Unified Communications Manager:

- Application Dialing Rules, page 2-6
- Directory Lookup Dialing Rules, page 2-7
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For detailed conceptual and task-based information on dialing rules, see the Cisco Unified
Communications Manager Administration online help or the Cisco Unified Communications Manager
Administration Guide and the Cisco Unified Communications Manager System Guide:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_maintenance _guides_list.html

Note  If your Cisco Unified Communications Manager uses dialing rules, you must ensure that
Cisco UC Integration for Microsoft Office Communicator and Cisco Unified Client Services Framework
(CSF) can access these dialing rules.

Related Topics
« How to Make Cisco Unified Communications Manager Dialing Rules Accessible, page 2-12

Application Dialing Rules

Application dialing rules modify the dial string on outbound calls to conform to the route plan on the
Cisco Unified Communications Manager. For Cisco UC Integration for Microsoft Office
Communicator, application dialing rules map numbersin the OCS address book to a number format that
can be correctly dialed within the context of your Cisco Unified Communications Manager
configuration. That is, you must define application dialing rules to map E.164 numbers to the private
numbering plan.

Example Application Dialing Rule for Contacts with North American Numbers

The following table illustrates the application dialing rule that you need to use to resolve E.164-format
numbers to a Cisco Unified Communications Manager private numbering plan that uses six-digit
numbers beginning with 8.

1 2 3 |4 |5 |6 |7 |8 |9 |10 |11 |12
Number for contact in OCS addressbook (+ (1L (4 |0 (8 |5 |5 5 |0 |1 0 |0
in E.164 format Number begins with +1408555
Number of digitsis 12

Operations performed by application + ‘1 ‘4 ‘O ‘8 ‘5 ‘5 5 ‘O ‘1 ‘0 ‘0

dialing rule Number of digits to removeis7
Prefix with 8
Dialed number 850100

Example of Application Dialing Rule for Contacts with Spanish Numbers

The following table illustrates the application dialing rule that you need to use to resolve E.164-format
numbers to a Cisco Unified Communications Manager private numbering plan that uses nine-digit
numbers beginning with 9.

1 2 (3 |4 |5 |6 |7 |8 |9 |10 |11 |12

Number for contact in OCS addressbook (+ |3 (4 |9 |8 |5 |5 |5 |0 |1 |9 |9
in E.164 format

Number
begins with
+34

Number of digitsis 12
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1 12 3 |4 |5 6 |7 (8 |9 |10 |11 |12

Operations performed by application + 3 4 |9 8 |5 |5 |5 |0 (1 |9 |9
dialing rule

Number of
digitsto
removeis 3

No prefix required
Dialed number 985550199

Directory Lookup Dialing Rules

Directory lookup dialing rules transform caller identification numbers into numbers that can be looked
up in the directory. For example, if the Cisco Unified Communications Manager reports a call from
85550100, that must be transformed into the E.164 format +14085550100 as stored in LDAP to identify
the caller as a contact. If numbers in the LDAP are not in E.164 format, but the enterprise routable
number is stored in LDARP, then the directory lookup dialing rules need to map incoming numbers to the
enterprise routable numbers.

For Cisco UC Integration for Microsoft Office Communicator, directory lookup dialing rules map
private numbering plan numbersto the number format used in Active Directory. That is, you must define
directory lookup dialing rules to transform private numbering plan numbers to E.164-format numbers.

Example of Directory Lookup Dialing Rule for Contacts with North American Numbers

Thefollowing tableillustrates the directory lookup dialing rule that you need to use to resolve a number
from a Cisco Unified Communications Manager private numbering plan that uses six-digit numbers
beginning with 81 to an E.164-format number.

1 ‘2 ‘3 \4 \5 ‘6 7 s 10 11 [12
Private numbering plan number from 8 (1 |0 |11 9 |9
Cisco Unified Communications M anager

©

Number
begins
with 81

Number of digitsis 6

Operations performed by directory + ‘1 ‘4 0 ‘8 ‘5 ‘5 ‘5 ‘O ‘1 ‘9 ‘9
lookup dialing rule

Prefix with
+1408555

Digitsto removeis 2
Resulting E.164-format number +14085550199
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Example of Directory Lookup Dialing Rule for Contacts with Spanish Numbers

Thefollowing tableillustrates the directory lookup dialing rule that you need to use to resolve a number
from a Cisco Unified Communications Manager private numbering plan that uses nine-digit numbers
beginning with 98 to an E.164-format number.

1 2 3 4[5 6 [7 8 [9 |10 11 |12
Private numbering plan number from 9 |18 |5 |5 5 |0 |1 |0 |O
Cisco Unified Communications Manager Number
begins
with 98
Number of digitsis9
Operations performed by directory + ‘3 ‘4 9 ‘8 ‘5 ‘5 ‘5 ‘O ‘1 ‘O ‘0
lookup dialing rule Prefix with
+34
Digitsto removeisO
Resulting E.164-format number +34985550100

How to Configure Cisco Unified Communications Manager

Server

Before you configure the Cisco Unified Communications Manager server, read the following topics:
« Prerequisites for Configuring Cisco Unified Communications Manager, page 2-8
- Cisco Unified Communications Manager Client Services Framework Device Type, page 2-9

To configure the Cisco Unified Communications Manager server for Cisco UC Integration for Microsoft
Office Communicator, you must perform the following tasks:

« Enabling LDAP Synchronization, page 2-9

- Enabling LDAP Authentication, page 2-10

» Creating Devices and Directory Numbers for Users, page 2-10

« How to Make Cisco Unified Communications Manager Dialing Rules Accessible, page 2-12

Prerequisites for Configuring Cisco Unified Communications Manager

You must have a properly working Cisco Unified Communications configuration with the following
servers:

» Cisco Unified Communications Manager server

For information about Cisco Unified Communications Manager servers, see the documentation at
the following URL:

http://www.cisco.com/en/US/products/sw/voicesw/psb56/tsd_products_support_general _informati
on.html

» Cisco Trivial File Transfer Protocol (TFTP) server
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For information about Cisco TFTP servers, seethe Cisco Unified Communications Manager System
Guide.

» Cisco CTIManager server

For information about Cisco CTIManager servers, seethe Cisco Unified Communications Manager
System Guide.

» Cisco Unified Communications Manager | P Phone (CCMCIP) server

Cisco Unified Communications Manager Client Services Framework Device

Type

The Cisco UC Integration for Microsoft Office Communicator requires a new Cisco Unified
Communications Manager device type called Client Services Framework. Depending on which release
of Cisco Unified Communications Manager isinstalled in your Cisco Unified Communications system,
you might need to patch Cisco Unified Communications Manager with a Cisco Options Package (COP)
file.

You must run the COP file if your Cisco Unified Communications Manager does not have the Client
Services Framework device type. You run the COP file on the Cisco Unified Communications M anager
publisher server. After you apply the COP file, you must restart the Cisco Unified

Communications Manager publisher server, and all other servers.

For information about which releases of Cisco Unified Communications Manager require you to run the
COPfiletoinstall the Client Services Framework device type, see the release notes at the following URL:

http://www.cisco.com/en/US/products/ps10317/prod_release notes_list.html

What to Do Next
- Enabling LDAP Synchronization, page 2-9

Enabling LDAP Synchronization

Step 1
Step 2
Step 3

This allows Cisco Unified Communications Manager to integrate with Active Directory and build the
Cisco Unified Communications Manager user database from the same data source where Windows users
and Microsoft Office Communicator users are defined.

If you synchronize the Cisco Unified Communications Manager with Active Directory, the

Cisco UC Integration for Microsoft Office Communicator user IDswill be the same as the Windows and
Microsoft Office Communicator user IDs. If you synchronize the Cisco Unified

Communications Manager with Active Directory, you must also enable L DAP authentication. For more
information about how to enable L DAP authentication, see Enabling LDAP Authentication, page 2-10.

If you do not synchronize, you must manually map your Cisco Unified Communications Manager user IDs
with Windows and Microsoft Office Communicator user IDs. If you choose not to synchronize, see
Appendix A, “Normalization Rules for OCS".

Procedure
Select System > LDAP > LDAP System in Cisco Unified Communications Manager Administration.

Select Enable Synchronizing from LDAP Server.
Select Microsoft Active Directory from the LDAP Server Type list box.
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Step 4

Step 5
Step 6
Step 7
Step 8
Step 9
Step 10

Select the LDAP attribute that you want to use as the User ID in Cisco Unified Communications Manager
from the LDAP Attribute for User ID list box.

Select Save.

Select System > LDAP > LDAP Directory.

Select Add New.

Enter datain the LDAP Directory window as required.
Select Save.

Select Perform Full Sync Now.

For information about how to synchronize with LDAP, see the LDAP directory integration
documentation at the following URLs:

Release 7.x: http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/7x/directry.html

Release 6.x: http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/6x/directry.html

What to Do Next
- Enabling LDAP Authentication, page 2-10

Enabling LDAP Authentication

Step 1

Step 2
Step 3

If you enable LDAP authentication in Cisco Unified Communications Manager, the Active Directory
provides authentication services to Cisco Unified Communications Manager by proxy. For example,
Cisco Unified Communi cations Manager can forward authentication requests from the

Cisco UC Integration for Microsoft Office Communicator to Active Directory, and Active Directory
responds to the request.

Procedure

Select System > L DAP > L DAP Authentication in Cisco Unified Communications M anager
Administration.

Select Use LDAP Authentication for End Users.
Select Save.

What to Do Next
» Creating Devices and Directory Numbers for Users, page 2-10

Creating Devices and Directory Numbers for Users

Step 1
Step 2

Procedure

Select Device > Phone in Cisco Unified Communications Manager Administration.
Select Add New.
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Step 3
Step 4

Step 5
Step 6
Step 7

Step 8

Step 9

Step 10
Step 11
Step 12
Step 13
Step 14

How to Configure Cisco Unified Communications Manager Server

Select Client Services Framework from the Phone Type list box, then select Next.

Enter information for the phone in the Phone Configuration window, as follows:

Field Description

Device Name Enter a name to identify the Cisco Unified Client Services Framework
device. The name can contain 1 to 15 characters, including al phanumeric
characters, periods, hyphens, and underscores. The device name does not
need to relate to the user 1D of the user.

Device Pool Select the device pool to which you want the phone assigned. The device
pool defines sets of common characteristics for devices, such as region,
date/time group, softkey template, and Multilevel Precedence and
Preemption (MLPP) information.

Phone Button Template Select the appropriate phone button template. The phone button template
determines the configuration of buttons on a phone and identifies which
feature (line, speed dial, and so on) is used for each button.

Allow Control of Device |Select this option if you want Cisco UC Integration for Microsoft Office
from CTI Communicator to be able to control the desk phone of the user with the
Computer Telephony Integration (CTI) server.

Ensure that the user is added to the Standard CT| Enabled user group.

Device Security Profile Select the security profile you require for the phone.

If you select Client Services Framework- Standard SIP Secure Profile, do
the following:

a. Enter certification and authentication information in the Certification
Authority Proxy Function (CAPF) Information section.

b. Select Generate String.
c. Email the contents of the Authentication String field to the user.

SIP Profile Select the default SIP profile or a specific profile that was previously
created. SIP profiles provide specific SIP information for the phone such
as registration and keepalive timers, media ports, and do not disturb
control.

Enter any other required information, then select Save.
Select Reset on the Phone Configuration window to reset the phone.

Select the Add a new DN link in the Association Information section on the Phone Configuration

window.

Enter information for the directory number on the Directory Number Configuration window.
Select Save.

Select Associate End User s on the Directory Number Configuration window.

Search for the user in the Find and List Users window, select the user, then select Add Selected.
Select Save.

Select User Management > End User in Cisco Unified Communications Manager Administration.

Search for the user in the Find and List Users window, then select the user.
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Step 15

Verify that the deviceislisted for the user in the Controlled Devices list box in the Device Associations
group.

Related Topics
- Adding a User to the Standard CT| Enabled User Group, page 2-12

» Cisco Unified Communications Manager Client Services Framework Device Type, page 2-9

Adding a User to the Standard CTI Enabled User Group

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

If you want Cisco UC Integration for Microsoft Office Communicator to be able to control the desk
phone of the user, you must select the Allow Control of Device from CTI option when you create the
device for the user. You must also ensure that the user is added to the Standard CT| Enabled user group.

Procedure

Select User Management > End User in Cisco Unified Communications Manager Administration.

Select the user that you want to add.

Select Add to User Group in the Permissions Information group in the End User Configuration window.
Search for “ Standard CTI1” in the Find and List User Groups window.

Select the Standard CTI Enabled user group.

Select Add Selected.

Select Save in the End User Configuration window.

How to Make Cisco Unified Communications Manager Dialing Rules

Accessible

A

Note

If your Cisco Unified Communications Manager uses dialing rules, you must ensure that
Cisco UC Integration for Microsoft Office Communicator and CSF can access these dialing rules.

You must run a COP file to generate copies of the dialing rulesin XML format, which
Cisco UC Integration for Microsoft Office Communicator and CSF can access.

You must run a COP file to generate copies of the dialing rulesin XML format, which

Cisco UC Integration for Microsoft Office Communicator and CSF can access. You can get the COPfile
from the Administration Toolkit. To accessthe Administration Toolkit, navigateto Cisco UC Integration
for Microsoft Office Communicator from the Download Software page at the following URL:

http://tools.cisco.com/support/downl oads/go/Redirect.x ?mdfid=278875240

- Every timeyou update the dialing rulesin your Cisco Unified Communications Manager, you must
run the COP file again, to ensure that Cisco UC Integration for Microsoft Office Communicator and
CSF can access the updated dialing rules.
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» You must run the COP file on each Cisco Unified Communications Manager that runsa TFTP
server.

To make the Cisco Unified Communications Manager dialing rules accessible by Cisco UC Integration
for Microsoft Office Communicator and CSF, you must perform the following tasks:

- Verifying That Dialing Rules Are Configured on Cisco Unified Communications Manager,
page 2-13

- Generating Copies of the Dialing Rules, page 2-13
- Verifying That Copies of the Dialing Rules Were Generated, page 2-14
» Restarting the TFTP Service, page 2-14

» Ensuring That Cisco UC Integration for Microsoft Office Communicator Clients Are Restarted,
page 2-14

Verifying That Dialing Rules Are Configured on Cisco Unified Communications Manager

Step 1

Step 2
Step 3
Step 4

Step 5
Step 6

Procedure

Select Call Routing > Dial Rules> Application Dial Rulesin Cisco Unified Operating System
Administration.

Search for the dialing rulesin the Find and List Application Dial Rules window.
Verify that application dialing rules are found.

Select Call Routing > Dial Rules > Directory Lookup Dial Rulesin Cisco Unified Operating System
Administration.

Search for the dialing rules in the Directory Lookup Dial Rule Find and List window.
Verify that directory lookup rules are found.

If there are no application dialing rules or directory lookup dialing rules on your Cisco Unified
Communications Manager, you do not need to make dialing rules accessible by Cisco UC Integration for
Microsoft Office Communicator.

What to Do Next
- Generating Copies of the Dialing Rules, page 2-13

Generating Copies of the Dialing Rules

Step 1

You must run a COPfile to generate copies of thedialing rulesin XML format. You can get the COP file
from the Administration Toolkit. To accessthe Administration Toolkit, navigate to Cisco UC Integration
for Microsoft Office Communicator from the Download Software page at the following URL:

http://tools.cisco.com/support/downl oads/go/Redirect.x ?mdfid=278875240

Procedure

Select Software Upgrades > Install/Upgrade in Cisco Unified Operating System Administration.
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Step2  Specify the location of the COP file in the Software Installation/Upgrade window.
Step3  Select Next.

Step4  Select the appropriate file from the Available Software list box.

Step5  Select Next.

Step6  Select Install.

What to Do Next
« Verifying That Copies of the Dialing Rules Were Generated, page 2-14

Verifying That Copies of the Dialing Rules Were Generated

Procedure

Stepl  Select Software Upgrades> TFTP File Management in Cisco Unified Operating System
Administration.

Step2  Search for adirectory that begins with CUPC in the TFTP File Management window.
Step3  Verify that the following files are found:

« AppDiaRules.xml

« DirLookupDialRules.xml

What to Do Next
» Restarting the TFTP Service, page 2-14

Restarting the TFTP Service

After you verify the generation of the copies of the dialing rules, restart the TFTP service. You must
restart the TFTP service on every server on which you ran the COP file.

For information about how to restart TFTP services, see Cisco Unified Serviceability Administration
Guide at the following URL.:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/prod_maintenance guides_list.html

What to Do Next

» Ensuring That Cisco UC Integration for Microsoft Office Communicator Clients Are Restarted,
page 2-14

Ensuring That Cisco UC Integration for Microsoft Office Communicator Clients Are Restarted
Procedure

stepl  Select B in the Microsoft Office Communicator title bar.
Step2  Select Tools > Stop Conver sation Pane.
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Step 3
Step 4
Step 5
Step 6

Verifying the Configuration of Active Directory, OCS, and Cisco Unified Communications Manager Servers

Start the Task Manager.

End the cucsf.exe process.

Select B in the Microsoft Office Communicator title bar.
Select Tools > Start Conver sation Pane.

The Cisco UC Integration for Microsoft Office Communicator client and the cucsf.exe process are
automatically restarted.

Verifying the Configuration of Active Directory, OCS, and
Cisco Unified Communications Manager Servers

Use auser account to sign in to the User Options pages of a user. Check that the devices associated with
the user are the correct devices.
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« About Client Computer Configuration, page 3-1
« Location of CSF Configuration Data, page 3-2
- Value Names for CSF Client Integration, page 3-2

» Configuring Microsoft Office Communicator to Use HTTPS to Access Custom Availability
Statuses, page 3-8

» Enabling LDAP Over SSL, page 3-7

« Configuring Microsoft Office Communicator to Use HTTPS to Access Custom Availability
Statuses, page 3-8

» Configuration of Policies for Microsoft Office Applications, page 3-9
« About the CSF Cache and LDAP Searches, page 3-10

About Client Computer Configuration

Before you install Cisco UC Integration for Microsoft Office Communicator, you must perform some
configuration on the computers of your users. You specify the CSF client settings, Microsoft Office
Communicator settings, and Microsoft Office settings that you want the client computers to use.

Then you must deploy the policy changes to the CSF client and Microsoft Office Communicator to the
computersinyour Cisco Unified Communications system. To do this, you can use software management
system, for example, Active Directory Group Policy, Altiris, Microsoft System Management Server
(SMS), and so on.

You must configure the Client Services Framework (CSF) on the computers of your users so that the CSF
can function as the phone device for that user, to specify where CSF can connect to, and to specify the
LDAP parameters. For more information about the configuring CSF on client computers, read this
chapter.
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Location of CSF Configuration Data

You specify the configuration for CSF in the following registry key:
HKEY_CURRENT_USER\Software\Cisco Systems, Inc.\Client Services Framework\AdminData

If you use Active Directory Group Policy to configure Cisco UC Integration for Microsoft Office
Communicator, then CSF configuration data is specified in the following registry key:

HKEY_CURRENT_USER\Software\Policies\Cisco Systems, Inc.\Client Services

Framework\AdminData

Note » |f CSF configuration data is present in both of these registry keys, the policies configuration data

takes precedence.

« CSF reads only HKEY_CURRENT_USER keys. CSF does not read HKEY _LOCAL_MACHINE

keys.

Value Names for CSF Client Integration

Table 3-1 lists the name-value pairs that you must use to specify the servers, voice message service
configuration, and security certificate location.

Table 3-1 Server and Voice Message Service Value Names
Value Names Description
TftpServerl, TftpServer2, |Enter the IP address of the primary TFTP server in your

TftpServer3

Cisco Unified Communications system, and any other TFTP servers.

CtiServerl, CtiServer2

Enter the | P address of the primary CTIManager server in your
Cisco Unified Communications system, and the secondary CTIM anager
server, if present.

CcmcipServerValidation

Enter the type of certificate validation for CSF to use with HTTPS to
signinto Cisco Unified Communications Manager toretrieve the device
list. Enter one of the following values:

e 0: CSF accepts all certificates.

« 1: CSF accepts certificates that are defined in the keystore and
self-signed certificates. A keystoreisafilethat storesauthentication
and encryption keys. The keystore islocated in
<location-of-jre>/lib/security. The default location of the JRE is
C:\Program Files\Common Files\Cisco Systems\Client Services
Framework.

« 2: CSF only accepts certificates that are defined in the keystore.

Note  CSF uses this certificate to verify the Cisco Unified
Communications Manager server. When the certificate is
accepted, CSF must use the credentials of the user to signin to
Cisco Unified Communications Manager.
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Table 3-1 Server and Voice Message Service Value Names

Value Names

Description

CcmcipServerl,
CcmcipServer2

Enter the IP address of the primary CCMCIP server in your
Cisco Unified Communications system, and the secondary CCMCIP
server, if present.

Voicemail PilotNumber

Enter the number of the voice message service in your
Cisco Unified Communications system. Thisvalue only relates to when
users use the desk phone to access their voice message.

SECURITY _CertificateDire
ctory

Specify the location of the directory where the security certificates are
stored. For example, you might store LDAP or CCMCIP certificatesin
this location.

Use this setting to specify alocation for the certificates where the
certificates will not be overwritten if you reinstall Cisco UC Integration
for Microsoft Office Communicator.

If you do not specify a value for this setting, the certificates are stored
in the following locations:

+ Windows XP: <drive>:\Documents and
Settings\<user name>\A pplication Data\Cisco\Unified
Communications\Client Services Framework\certificates

+ Windows Vista:
<drive>:\Users\<user name>\A ppData\Roaming\Cisco\Unified
Communications\Client Services Framework\certificates
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Table 3-2 lists the name-value pairs that you must use to specify the LDAP configuration.

Table 3-2

LDAP Value Names

Value Names

Description

LDAP_Server_1

Enter the protocol name, followed by the fully-qualified domain name
(FQDN) of your LDAP server. For example:

Idap://Idap.example.com

If you want to use a port number other than the default 389, add a colon
to the value, followed by the port number. For example:

|dap://Idap.example.com:19389

If you want to use LDAP over SSL, this IP address must begin with
Idaps://. For example:

|daps://Idap.example.com

If you want to use a port number other than the default 636, add a colon
to the value, followed by the port number. For example:

Idaps://Idap.example.com: 19636

For more information about how to enable LDAP over SSL, see
Enabling LDAP Over SSL, page 3-7.

LDAP_SearchBaseDN_1,
LDAP_SearchBaseDN_2,
LDAP_SearchBaseDN_3,
LDAP_SearchBaseDN_4,
LDAP_SearchBaseDN_5

Specify the primary distinguished name for the location in the LDAP
directory from which searches begin. For example, specify a
distinguished name similar to the following:

OU=Sales,DC=example,DC=com
Specify any further search bases also.

LDAP_MaxCacheSize

Specify the maximum number of LDAP directory recordstoretaininthe
cache of the user.

LDAP_ResultSetMaxSize

Specify the maximum number of records to return when the user
searches the LDAP directory. That is, when the user searches for
contacts in Microsoft Office Communicator.

LDAP_UserLogonDomain

Enter the name of the domain that contains the LDAP account of the
user.

LDAP_enableWildcardMat
chesForPhoneNumberSearc
hes

Set to true if you want to enable wildcard searches for phone numbers
in the LDAP.

Note  If you set this key to true, the speed of searches of the LDAP

might be affected.

LDAP_AttributeName_pri
maryPhoneNumberForSear
ches

Specify the phone number field that you use to resolve most of your
LDAP queries.

CSF searches thisfield first. If a match is not found, CSF searches the
remaining phone number fields. The default valueisthe value you set for
the LDAP_AttributeName_businessPhone key.
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Table 3-3 lists the values you must enter for LDAP attribute key names to enable CSF searches to map
to the appropriate fields of the Active Directory.

Table 3-3

Values to Enter to Map CSF Searches to Active Directory

For This Value Name...

Enter the Following Active Directory Field...

LDAP_AttributeName_objectclassKey

objectclass

LDAP_AttributeName_objectclassValue

person

LDAP_AttributeName_userL ogonName

userPrincipalName

LDAP_AttributeName_displayName displayName
LDAP_AttributeName _commonName cn
LDAP_AttributeName_firstName givenName
LDAP_AttributeName_|lastName sn
LDAP_AttributeName_email mail
LDAP_AttributeName_uri mMsRTCSIP-PrimaryUserAddress
LDAP_AttributeName_photoUri photoUri
LDAP_AttributeName_businessPhone telephoneNumber
LDAP_AttributeName_homePhone homePhone
LDAP_AttributeName_mobilePhone mobile
LDAP_AttributeName_otherPhone otherTelephone
LDAP_AttributeName_title title
LDAP_AttributeName_companyName company
LDAP_AttributeName _userAccountName  |SAMAccountName

~

Note Do not use any other Active Directory field for

this key name.

POLICY_CREDENTIALS IsLdapSynchron
izedWithCucm

Specify whether CSF uses the Cisco Unified
Communications Manager user ID and password to
authenticate with LDAP. Set to trueif the

Cisco Unified Communications Manager user ID and
password have been synchronized with LDAP. This
means that users do not need to enter a separate LDAP
user ID and password in the options dialog box of
Cisco UC Integration for Microsoft Office
Communicator.

Related Topics

- Configuration of Policies for Microsoft Office Applications, page 3-9

« Using an Active Directory Group Policy Administrative Template to Configure CSF Clients,

page 3-6
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Using an Active Directory Group Policy Administrative Template to Configure CSF Clients

Step 1

Step 2
Step 3
Step 4

Step 5

Note

Step 6
Step 7
Step 8

Note

A Group Policy administrative template is provided with Cisco UC Integration for Microsoft Office
Communicator. You can use this template to define the CSF registry settings on a system, or for groups
of users. The template file is CUCIMOC.adm.

Procedure

Execute the following command to start the Group Policy application:
gpedit.msc

Expand the User Configuration node.

Right-click Administrative Templates, then select Add/Remove Templates.

Add thefile CUCIMOC.adm to thelist of current policy templatesin the Add/Remove Templates dial og
box, then select Close.

Open the Cisco Unified Communications Integration for Microsoft Office Communicator folder in the
right pane.

In Windows Vista, this folder isin the Administrative Templates > Classic Administrative Templates
folder. In Windows XP, this folder is in the Administrative Templates folder.

Open the folder for the settings whose value you want to specify.
Double-click the setting whose value you want to specify.

Enter the value you require, then select OK.

Every time that you start the Group Policy application after you set the registry settings, the settings
under the Cisco Unified Communications Integration for Microsoft Office Communicator folder are not
automatically displayed. Each timeyou start the Group Policy application, you must uncheck Only show
policy settings that can be fully managed in the Filtering dialog box to display the settings.

Related Topics
» Configuration of Policies for Microsoft Office Applications, page 3-9

Installing Security Certificates on Client Computers

Step 1
Step 2

Procedure

Put the certificate file into a folder where you store your security certificates.

Use the SECURITY _CertificateDirectory registry key value name to specify the folder where the
certificates are stored.
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Enabling LDAP Over SSL

Related Topics

« Vaue Names for CSF Client Integration, page 3-2

Enabling LDAP Over SSL

- Creating a Certificate on the Active Directory Server, page 3-7
« Installing the Certificate on the Client Computer, page 3-7
» Configuring CSF, page 3-8

Creating a Certificate on the Active Directory Server

Step 1
Step 2

Before You Begin
Ensure that the LDAP server is configured to support LDAP over SSL (LDAPS).

Procedure

Sign in to the Active Directory server.
Execute the following command:
certutil -ca.cert cucimoc.crt

This command generates a file called cucimoc.crt. You must install this certificate on each client
computer.

What to Do Next
» Installing the Certificate on the Client Computer, page 3-7

Installing the Certificate on the Client Computer

Before you install the certificate on the client computer, ensure that neither of the following processes
are running:

» CSF, that is, the cucsf.exe process.
- Cisco UC Integration for Microsoft Office Communicator, that is, the cucimoc.exe process.

For information about how to install the LDAP security certificate, see Installing Security Certificates
on Client Computers, page 3-6.

What to Do Next
» Configuring CSF, page 3-8
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Configuring CSF

Procedure

Stepl  Set the value for the LDAP_Server_1 value name to set the URL of the LDAP server. For example, set
the value of LDAP_Server_1 to the following:

Idaps://Idap.example.com
The only change from using standard LDAP is that you specify the protocol as |daps instead of Idap.

Use the FQDN of the LDAP server as specified in the certificate. You cannot use the I P address of the
LDAP server, or the server name alone. Ensure that the FQDN is reachable. If the FQDN cannot be
reached using DNS, add an appropriate entry to your hosts file.

If your LDAP server does not use the default port for LDAPS, specify the port with the URL. For
example, enter a value such as the following:

Idaps://Idap.example.com:19636
Step2  Restart Cisco UC Integration for Microsoft Office Communicator.

Step3  To verify that you are connected to LDAPS, select the Menu button in the Microsoft Office
Communicator title bar, then select Tools > Server Status.

Read the server protocol information in the Server Status tab. The protocol is displayed as |dap. Read
the server port field to verify that you are connected to LDAPS.

Related Topics
« Value Names for CSF Client Integration, page 3-2

Configuring Microsoft Office Communicator to Use HTTPS to
Access Custom Availability Statuses

Cisco UC Integration for Microsoft Office Communicator includes custom availability statuses such as
“On the Phone”. These statuses are stored in a custom availability statusfile,
cisco-presence-states-config.xml.

To enable Microsoft Office Communicator to access the custom availability statusfile, the security mode
of Microsoft Office Communicator must be set to high.

That is, you must set the value of the following Microsoft Office Communicator registry key to 1:
[HKEY_CURRENT_USER\Software\Policies\Microsoft\Communi cator]" Enabl eS| PHighSecurityM od

€

For information about how to apply this policy setting to Microsoft Office Communicator, see the
following URL :

http://www.microsoft.com/downl oads/detail s.aspx?Familyl D=dd3cae08-3153-4c6a-a314-daa79d61624
8&displaylang=en
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Configuration of Policies for Microsoft Office Applications

» Microsoft Office Communicator Policies, page 3-9
» Microsoft Office Phone Policy, page 3-9

Microsoft Office Communicator Policies

We strongly recommend that you configure Microsoft Office Communicator policies to alow only IM
and availability status traffic on all Cisco UC Integration for Microsoft Office Communicator user
groups.

If you do not do this, voice traffic is allowed from both Cisco UC Integration for Microsoft Office
Communicator and Microsoft Office Communicator. This can result in the following problems:

» A confusing user experience, as users can place and receive calls from a mixture of user interface
elements in both applications.

« Inconsistent voice traffic. That is, calls from Cisco UC Integration for Microsoft Office
Communicator might give a different audio experience to Microsoft Office Communicator.

- A mixed configuration is more difficult to manage, as administrators must track traffic from two
sources. You might want to monitor voice usage in your network and if you use both applications,
you must configure your monitoring tools to track traffic from both applications.

We strongly recommend that you configure the Microsoft Office Communicator policies as shown in the

following table:
Policy Set Value To...
TelephonyMode 5= 1M and Presence Only

DisableAV Conferencing 1

For information about how to apply these policy settings to Microsoft Office Communicator, see the
following URL:

http://www.microsoft.com/downl oads/detail s.aspx?Familyl D=dd3cae08-3153-4c6a-a314-daa79d61624
8&displaylang=en

You can also find the policy administrative template file Communicator.adm on that web site.
Alternatively, you can apply the following keys to set the policies manually:

[HKEY _CURRENT_USER\Software\Policies\Microsoft\Communicator] " TelephonyM ode" =dword:00
000005

[HKEY_CURRENT_USER\Software\Policies\Microsoft\Communicator] " DisableAV Conferencing'=d
word:00000001

Related Topics
« Vaue Names for CSF Client Integration, page 3-2

Microsoft Office Phone Policy
We strongly recommend that you configure a Microsoft Office policy to disable the Call menu that

appears when you select a contact in a Microsoft Office application. This Call menu only appearsif you
have the correct smart tag switched on in the relevant Microsoft Office application.
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B About the CSF Cache and LDAP Searches

Note

Cisco UC Integration for Microsoft Office Communicator provides an Additional Actions menu that
enables you to call contacts that you select in your Microsoft Office applications. If you do not disable
the Call menu, this can result in a confusing user experience, as users might think that they can perform
similar actions from a mixture of user interface elements.

To disable the Call menu in Microsoft Office, set the value of the Phone policy to zero (0).
Alternatively, you can apply the key to set the policy manually.

[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Common\PersonaM enu] " Phone"=dword:
00000000

In the registry keys, the values 11.0 and 12.0 refer to the different versions of Microsoft Office; 11.0
refers to Microsoft Office 2003 and 12.0 refers to Microsoft Office 2007.

About the CSF Cache and LDAP Searches

CSF maintains a cache of LDAP contacts. When you place a call, receive acall, or missacall, the
contacts for the calls are added to your CSF cache. Any contact that isin your conversation history is
automatically placed in your cache. All the data for the contactsin your contact list in Microsoft Office
Communicator is also cached.

If acontact for acall already exists in the cache, CSF does not search LDAP. If a contact does not exist
in the cache, CSF searches LDAP. LDAP searches are only performed when you place acall to, or receive
acall from a contact who is not in your conversation history or your Microsoft Office Communicator
contact list.

All contacts in the CSF cache have already had the directory lookup dialing rules applied to all of their
numbers. When Cisco UC Integration for Microsoft Office Communicator displays numbersfor contacts
that are in the CSF cache, the numbers have already had the directory lookup dialing rules applied to
them.

The CSF cacheisadisk cache. The contents of the cache are not copied to alocal file system. When the
cucsf.exe process is restarted, the contents of the CSF cache are refreshed.

« Incoming Calls, page 3-10

- Outgoing Calls to Contacts Who Are Enabled for OCS, page 3-11

» Outgoing Calls to Contacts Who Are Not Enabled for OCS, page 3-11
» Outgoing Callsto Microsoft Outlook Contacts, page 3-12

Incoming Calls

When a user receives a call, the following events occur:

1. When Cisco Unified Communications Manager detects the incoming call, it sends the following
data to CSF:

- Thedirectory number from which the call originates.

» TheAlerting Name of the directory number that is specified in the Directory Number Configuration
screen, if the field is not blank.

2. CSF sends the directory number and alerting name to Cisco UC Integration for Microsoft Office
Communicator.
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About the CSF Cache and LDAP Searches Il

Cisco UC Integration for Microsoft Office Communicator displays the directory number and
alerting name in a notification window and, if the call is answered, in the conversation window.

If the directory number is not in the CSF cache, CSF applies any directory lookup dialing rules to
the directory number. This occurs while CSF transmits the data to Cisco UC Integration for
Microsoft Office Communicator.

If the directory number is not in the CSF cache, CSF searches LDAP for the number that is returned
after the directory number is processed by the directory lookup dialing rules.

LDAP sends the LDAP data for any matches back to CSF, including data such as other phone
numbers, and a URI of a photo of the caller.

CSF updates the data for the contact and sends the updated data to Cisco UC Integration for
Microsoft Office Communicator.

Cisco UC Integration for Microsoft Office Communicator updates the conversation window. For
example, at this point a photo of the caller might be displayed as the photoURI field from LDAP is
passed to Cisco UC Integration for Microsoft Office Communicator by CSF.

Outgoing Calls to Contacts Who Are Enabled for OCS

When a user places a call to a contact who is enabled for OCS, the following events occur:

1.

Cisco UC Integration for Microsoft Office Communicator sends the number for the contact to be
called to CSF, and asks CSF to place a call to that number.

If the contact is not in the CSF cache, CSF searches LDAP for details of the party to be called.
LDAP sends data back to CSF.

CSF sends data about the contact back to Cisco UC Integration for Microsoft Office Communicator.
If the contact has several numbers, Cisco UC Integration for Microsoft Office Communicator
displays awindow from which the user selects the number to call. If the contact has only one
number, Cisco UC Integration for Microsoft Office Communicator places the call.

CSF applies any directory lookup dialing rules to the number to be called.

CSF searches LDAP for the number that is returned after the directory lookup dialing rules are
applied.

CSF applies the application dialing rules and sends the number to Cisco Unified
Communications Manager.

Cisco Unified Communications Manager places the call.

Outgoing Calls to Contacts Who Are Not Enabled for OCS

When a user places a call to a contact who is not enabled for OCS, the following events occur:

1.

Cisco UC Integration for Microsoft Office Communicator sends the display name for the contact to
CSF.

If the contact is not in the CSF cache, CSF searches L DAP for the contact associated with the display
name. The operator for this search is contains rather than equals.

If the LDAP search returns more than one contact, Cisco UC Integration for Microsoft Office
Communicator displays awindow from which the user selects the number to call. If the contact has
only one number, Cisco UC Integration for Microsoft Office Communicator places the call.
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B About the CSF Cache and LDAP Searches

CSF applies any directory lookup dialing rules to the number to be called.

CSF searches LDAP for the number that is returned after the directory lookup dialing rules are
applied.

CSF applies the application dialing rules and sends the number to Cisco Unified
Communications Manager.

Cisco Unified Communications Manager places the call.

Outgoing Calls to Microsoft Outlook Contacts

When a user places a call to a Microsoft Outlook contact, the following events occur:

1.

The user drags a contact from the Microsoft Office Communicator to the Cisco UC Integration for
Microsoft Office Communicator conversation pane.

Cisco UC Integration for Microsoft Office Communicator searches the Microsoft Outlook contacts
for a user that matches the display name. If a contact is found, then the contact is added to the CSF
cache.

CSF applies any directory lookup dialing rules to the phone numbers of the contact.

CSF searches LDAP for the number that is returned after the directory lookup dialing rules are
applied.

CSF applies the application dialing rules and sends the number to Cisco Unified
Communications Manager.

Cisco Unified Communications Manager places the call.
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» Cisco UC Integration for Microsoft Office Communicator Deployment, page 4-1
« Information to Provide to Users After Installation, page 4-2

Cisco UC Integration for Microsoft Office Communicator
Deployment

The Cisco UC Integration for Microsoft Office Communicator installation application installs the
following components:;

» User interface for Cisco UC Integration for Microsoft Office Communicator.
» The client-related components of the client services framework (CSF).
» Click-to-call functionality, which you can choose whether to install.

You can deploy the Cisco UC Integration for Microsoft Office Communicator installation application in
any of the following ways:

« UseAdctive Directory Group Policy. You can use group policy to deploy administrator configuration
settings.

» Use a software management system, for example, Altiris, Microsoft System Management Server
(SMS), and so on.

» Use aself-extracting executable with a batch script. You can use the batch script to deploy
administrator configuration settings.

- Useastandalone installation. You deploy the administrator configuration settings, but usersinstall
Cisco UC Integration for Microsoft Office Communicator.

The installation application contains the following:

« Anexecutablefile. Thisincludes a.NET 3.5 SP1 installer stub. Users can run the executable file on
their own computers. The .NET installer stub runs automatically as part the Cisco UC Integration
for Microsoft Office Communicator installation.
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W information to Provide to Users After Installation

- A Microsoft Installer (MSI) file. This file assumes that .NET 3.5 SP1 is already installed. You can
use a software management system to push the M Sl file to the computers of your users.

MSI requires that Microsoft Visual Studio 2005 Tools for Office Second Edition Runtime (x86) is
installed on the computer of the administrator. .

Upgrading Cisco UC Integration for Microsoft Office Communicator

To upgrade Cisco UC Integration for Microsoft Office Communicator, you do not need to uninstall
Cisco UC Integration for Microsoft Office Communicator. When you install a newer version, the
installation application uninstalls the previous version of Cisco UC Integration for Microsoft Office
Communicator, then installs the new version.

Information to Provide to Users After Installation

When your installation of Cisco UC Integration for Microsoft Office Communicator is complete, you
can provide the information in the following table to your users:

Provide...

Explanation

Sign-in information.

If you set the POLICY_CREDENTIALS_IsLdapSynchronizedWithCucm key
value name to false, your users must enter their LDAP username and password
after they sign in for the first time. Ask your users to do the following:

1. Select ‘3.2} in the conversation pane.

2. Enter auser ID and password in the LDAP Credentials area on the options
dialog box.

3. Select OK.

Instructions for using the application.

Provide users with information about how to access the online help, as follows
1. Select B in the Microsoft Office Communicator title bar.
2. Select Tools > Help on Conversation Pane.

You can also provide users with the User Guide for Cisco UC Integration for
Microsoft Office Communicator, which contains the same information as the
online help.

Internal company support for the
application.

Provide your users with the names of people to contact for assistance if they
encounter problems with the application.
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« Moving a Device to Another Cluster, page 5-1

« Viewing Logs, page 5-2

- How to Resolve General Problems with the Integration, page 5-2
» How to Resolve Synchronization Problems, page 5-5

- How to Resolve Availability Status Problems, page 5-6

« How to Resolve Click to Call Problems, page 5-8

» How to Resolve Instant Message Window Problems, page 5-10

Moving a Device to Another Cluster

Step 1

If you configure security in your Cisco Unified Communications system, you use Certificate Trust List
(CTL) files. The CTL file contains certificates for all of the serversin your
Cisco Unified Communications system with which CSF might need to communicate securely.

When adevice connectsto aserver in your Cisco Unified Communications system, the server isverified
against this list. CSF does not allow secure connections to servers that are not explicitly listed in the
CTL.

If adeviceis moved from one cluster to another, you must update the CTL file for the device list of
serversin the new cluster.

Delete the contents of the appropriate folder from the following table;

Operating System Folder

Windows XP <drive>:\Documents and Settings\<username>\Application
Data\Cisco\Unified Communications\Client Services
Framework\Security\sec

Windows Vista <drive>:\Users\< username>\A ppData\Roaming\Cisco\Unified
Communications\Client Services Framework\Security\sec
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M Viewing Logs

Step2  Delete the contents of the appropriate folder from the following table:

Operating System

Folder

Windows XP <drive>:\Documents and Settings\< username>\Application
Data\Cisco\Unified Communications\Client Services Framework\Config
Windows Vista <drive>:\Users\< username>\A ppData\Roaming\Cisco\Unified

Communications\Client Services Framework\Config

Step3  Update the device settings for the user to point to the new cluster. For example, update the references to
the Cisco Unified Communications Manager |P Phone (CCMCIP) server, Trivial File Transfer Protocol
(TFTP) server, and Computer Telephony Integration (CTI) servers.

Viewing Logs

To obtain logs for Cisco UC Integration for Microsoft Office Communicator from a user, ask the user to
create a problem report and send the report to you. Users can also change the logging level for

Cisco UC Integration for Microsoft Office Communicator. For information about how to create a
problem report, or how to change the logging level, see the online help or the User Guide for

Cisco Unified Communications Integration for Microsoft Office Communicator.

Alternatively, you can view the log files in the following locations:

Operating System

Log File Location

Windows XP <drive>:\Documents and Settings\<username>\Local
Settings\A pplication Data\Cisco\Unified
Communications\Cucimoc\L ogs

Windows Vista <drive>:\Users\<username>\A ppData\L ocal\Cisco\Unified

Communications\Cucimoc\L ogs

How to Resolve General Problems with the Integration

» Users See “Application Deployment Canceled” Error Message, page 5-3

» Users Cannot Seethe Cisco UC Integration for Microsoft Office Communicator Conversation Pane,

page 5-3

» Users Cannot See the Cisco UC Integration for Microsoft Office Communicator Menu ltems,

page 5-3

- Cisco Unified IP Phone 7931G Users Cannot Control Desk Phone from Cisco UC Integration for
Microsoft Office Communicator, page 5-4

» Audio Devices Are Selected Incorrectly, page 5-4

» Conversation Pane Takes a Long Time to Connect, page 5-4

« Incorrect Caller Name Displayed for Shared Lines, page 5-5

« Userswith More Than One Directory Number Not Added to Conference Call, page 5-5
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Users See “Application Deployment Canceled” Error Message

Problem Users see the following error message in a pane at the bottom of the Microsoft Office
Communicator window, when they try to start Cisco UC Integration for Microsoft Office Communicator
for the first time:

“Application Deployment Canceled. The application deployment was canceled.”

The Cisco UC Integration for Microsoft Office Communicator conversation pane is implemented as an
XBAP (XAML browser application). XBAPs are hosted in browsers or in user interface controlsin
browsers. Cisco UC Integration for Microsoft Office Communicator uses a browser control in
Microsoft Office Communicator to display the conversation pane.

When the .NET runtime environment |oads an XBAP application for the first time, it displays a progress
dialog with a Cancel button in the browser or browser control. While the XBAP isloading, this Cancel
button has focus. If a user accidentally presses the space, Esc, Return, or Enter keys, the Cancel button
is selected, and deployment of the XBAP is canceled.

If this occurs, the Application Deployment Canceled message is displayed, with a Retry button.

Solution Ask the user to select the Retry button, and to wait until the Connecting to conversation pane
message is displayed before pressing the space, Esc, Return, or Enter keys again.

Users Cannot See the Cisco UC Integration for Microsoft Office Communicator
Conversation Pane

Problem The user cannot see the conversation pane, even though the processes
Cisco.Uc.Clients.Moc.UCClient.exe and cucsf.exe are running.

The user might have grabbed the horizontal line at the top of the conversation pane, then dragged the
horizontal line below the conversation pane.

Solution Restart Microsoft Office Communicator to restore the conversation pane.

Users Cannot See the Cisco UC Integration for Microsoft Office Communicator

Menu Items

Problem When users select B in the Microsoft Office Communicator title bar, then select Tools, the
following menu items are missing:

» Help on Conversation Pane

» Select Device for Conversation Pane
» Create Problem Report

- Connection Statistics

- Server Status

- About Conversation Pane

= Sign Out of Conversation Pane

- Start Conversation Pane

» Stop Conversation Pane
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This problem occurs if the computer has no network connection.

Solution Close Microsoft Office Communicator, connect to a network, then restart Microsoft Office
Communicator.

Cisco Unified IP Phone 7931G Users Cannot Control Desk Phone from
Cisco UC Integration for Microsoft Office Communicator

Problem Users who have a Cisco Unified IP Phone 7931G cannot use their desk phone from
Cisco UC Integration for Microsoft Office Communicator.

Solution Set the value of the Outbound Call Rollover to field to No Rollover in Cisco Unified
Communications Manager, as follows:

Stepl  Select Device > Phonein Cisco Unified Communications Manager Administration.
Step2  Search for the Cisco Unified | P Phone 7931G phone of the user in the Find and List Phones window.
Step3  Select the Cisco Unified IP Phone 7931G phone.

Step4  Select No Rollover from the Outbound Call Rollover list box in the Protocol Specific Information
section.

Step5  Select Save.

Audio Devices Are Selected Incorrectly

Problem Users might experience audio device selection issues. For example, audio might be played on
the computer speakers, but the headset microphone is the active microphone, rather than the microphone
on the computer.

Solution Cisco UC Integration for Microsoft Office Communicator does not support the Default option
in the Microsoft Office Communicator Set Up Audio and Video feature. Ensure that users select the
Custom option when they configure the audio devices for Cisco UC Integration for Microsoft Office
Communicator. To do this, the user must select B in the Microsoft Office Communicator title bar, then
select Tools > Setup Audio and Video. For more information, see User Guide for Cisco Unified
Communications Integration for Microsoft Office Communicator.

Conversation Pane Takes a Long Time to Connect

Problem When a user starts Microsoft Office Communicator, the “Connecting to conversation pane”
message is displayed, but the application does not connect to the conversation pane within five minutes.

Solution Host Intrusion Protection Software (HIPS) software might unexpectedly terminate the
cucimoc.exe process. Start the Task Manager, then check if the cucimoc.exe process is running. If the
process is not running, check if there is HIPS software running on your computer. Disabling HIPS
software might help to resolve this problem.

The exact cause of the process termination is not clear. Please report such incidents to Cisco support to
help to determine the root cause of the problem and to help identify a solution.
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Incorrect Caller Name Displayed for Shared Lines

Problem When users are configured in Cisco Unified Communications Manager to share aline, the
incorrect caller name might be displayed in notification windows or in the active conversations window.

Solution Thisisexpected behavior. In Cisco Unified Communications Manager, caller names are sent to
the phones when the phones are initially configured. However, Cisco UC Integration for Microsoft
Office Communicator must search for the caller name in Active Directory.

If lines are shared, when Cisco UC Integration for Microsoft Office Communicator performs a search
based on the phone number, the caller name in the first set of results returned that is the closest match
to the Cisco Unified Communications Manager caller name is displayed. When shared lines are not
configured, thereisusually only one matchin Active Directory for the phone number and the caller name
associated with this number is displayed.

Users with More Than One Directory Number Not Added to Conference Call

Problem When a user tries to add a participant to a conference call, the participant is not added to the
conference call but remainsin anormal phone call with the user who tried to add them to the conference.

Solution Thisissuetypically occurswhen participantsin a conference call have shared lines configured.
The issue occurs in the following circumstances:

« A participant in the conference call has more than one directory number configured in Cisco Unified
Communications Manager.

« One of the directory numbers of that participant is missing from Active Directory.

» Thereisanother participant who also has more than one directory number. This participant has the
same directory number configured in the Active Directory that the first participant is missing from
Active Directory.

Either of these participants might not be added to the conference call, but remain in a one-to-one call
with the host of the conference call.

If a user has more than one directory number configured, then the corresponding Active Directory
registry value must be set also. To resolve thisissue, ensure that all users who have more than one
directory number have all of their numbers configured in Active Directory. The field in the Active
Directory to which you need to add the numbers is defined in the following registry key value name:

HKEY _CURRENT_USER\Software\Cisco Systems, Inc.\Client Services
Framework\AdminData\LDAP_AttributeName_otherPhone

How to Resolve Synchronization Problems

» Users See “Cannot Synchronize...” Error Message, page 5-5
» Users See “Cannot Synchronize... Communicator 2007” Error Message, page 5-6

Users See “Cannot Synchronize...” Error Message

Problem Microsoft Office Communicator users see the following error message:
“Cannot synchronize with the corporate address book because the file could not be found.”
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Solution Install a security certificate for the default web site in Internet Information Services (11S). For
more information about this issue, see the following URLS:

 http://support.microsoft.com/kb/939530
 http://support.microsoft.com/kb/299875

Users See “Cannot Synchronize... Communicator 2007 Error Message

Problem Microsoft Office Communicator users see the following error message:

“You cannot synchronize the corporate address book when you use Communicator 2007 to log on to
Communications Server 2007.

Cannot synchronize with the corporate address book. This may be because the proxy server setting in
your web browser does not allow access to the address book. I the problem persists, contact your system
administrator.”

Solution Set the correct permissionsin I1S. For more information about this issue, see the following
URL:

http://support.microsoft.com/kb/953113

Solution Ensure that the password for the RTCComponentService user account has not expired. If the
password has expired, reset the password, and check Password Never Expires.

Solution Ensurethat the security certificates are configured properly. For more information on thistopic,
see the following URL.:

http://www.windowsecurity.com/arti cles/Client-Certificate-A uthentication-11S6.html

Related Topics
» Users See “Application Deployment Canceled” Error Message, page 5-3

How to Resolve Availability Status Problems

« “Inactive” and “Away” Availability Statuses and Custom Availability Statuses, page 5-6
e “Onthe Phone” Availability Status Not Available in Some Locales, page 5-7
» Availability Status Incorrect for Previously-Called Contacts, page 5-8

“Inactive” and “Away” Availability Statuses and Custom Availability Statuses

_ 'nstallation Guide for Cisco Unified Communications Integration for Microsoft Office Communicator Release 7.1

Problem Users might observe some unusual availability statuses.

Solution Microsoft Office Communicator provides the availability information in Cisco UC Integration
for Microsoft Office Communicator. In particular circumstances, Cisco UC Integration for Microsoft
Office Communicator provides custom phone availability statusinformation which can result in unusual
availability statuses.
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The following table lists the circumstances that result in these unusual availability statuses:

Initial Availability Status Event Availability Status Is Updated To...

Inactive Call starts  |Inactive On the Phone

Away Call starts  |Availability status is not updated.

Inactive On the Phone All callsend |Inactive, followed by the availability status

before the call started. For example, the status
might be Inactive Available.

Away, and Cisco UC Integration for |All callsend |Inactive, followed by the availability status

Microsoft Office Communicator before the call started. For example, the status
automatically set the status to On the might be Inactive Available.
Phone

“On the Phone” Availability Status Not Available in Some Locales

Step 1

Step 2
Step 3

Step 4

Problem Users cannot see the custom availability status “On the Phone” when they select the presence
button in Microsoft Office Communicator. Other users see the availability status of this user as“Busy”.
This problem occurs on computers that use the following Microsoft locales:

Language Locale ID
Chinese (Taiwan) 1028
Spanish - Spain (Traditional Sort) 1034

This problem occurs on computers on which Microsoft Office Communicator was installed using a
standalone installer for each language. In this case, the locale ID is not stored in the system registry, so
Microsoft Office Communicator uses the locale ID of the computer.

Users who share the same OCS server cannot use a mixture of the locale I1Ds above and the following
locale IDs:

Language Locale ID
Chinese (Default Chinese-Simplified) 2052
Spanish - Modern Sort (Default Spanish) 3082

Solution You can change the locale I Ds of the custom availability status file as follows:

Search the uc-client log files on the computer for the following string:

CurrentCulture LCID

Thelocale ID that the computer is using isin brackets ([]) after the string.

L ocate the cisco-presence-states-config.xml file in the installation folder, then open the file.

If the current locale ID identified in Step 1 is 1028, change the value of the LCID attribute of the
<activity> element in cisco-presence-states-config.xml from 2052 to 1028.

If the current locale ID is 1034, change the value of the LCID attribute from 3082 to 1034.
Ask the user to sign out of Microsoft Office Communicator, then sign in again.
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Bl How to Resolve Click to Call Problems

Related Topics
« Viewing Logs, page 5-2

Availability Status Incorrect for Previously-Called Contacts

Problem If you have previously called a contact, their availability status appears as “Unknown” in the
conversation history window and Select Contacts dialog box.

Solution This problem occurs because the contact has been cached. If your system does not use E.164
number formatting, enable wildcard searches.

For more information about how to enable wildcard searches, see Value Names for CSF Client
Integration, page 3-2.

How to Resolve Click to Call Problems

» Users Cannot See “Call” or “Call with Edit” in Microsoft Excel 2003 or Word 2003, page 5-8
» Users Cannot See “Call” or “Call with Edit” in Microsoft Word 2003 or Word 2007, page 5-9

« Users Cannot See “Call” or “Call with Edit” in Microsoft Excel, Outlook, PowerPoint, or Word,
page 5-9
» Users Cannot See “Additional Actions” Menu in Microsoft Outlook Contacts, page 5-10

Users Cannot See “Call” or “Call with Edit” in Microsoft Excel 2003 or
Word 2003

Problem After you perform a complete installation of Cisco UC Integration for Microsoft Office
Communicator, the“ Call” and “ Call with Edit” menu items for the click-to-call feature do not appear in
Microsoft Excel 2003 or Word 2003.

Solution The DLL file mscoree.dll has been disabled. To enable mscoree.dll, perform the following
steps:

Stepl  Select Help > About Microsoft <application> in the application where the problem occurs.
Step2  Select Disabled Items.

Step3  Select mscoree.dll.

Step4  Select Enable.

Step5  Close the application, then open the application again.
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How to Resolve Click to Call Problems

Users Cannot See “Call” or “Call with Edit” in Microsoft Word 2003 or
Word 2007

Problem The “Call” and “Call with Edit” menu items for the click-to-call feature do not appear, or

several instances appear in Word 2003 or Word 2007. The menu items appear correctly in Excel 2003 or
Excel 2007.

Solution Replace your normal template file as follows:

Step1  Close Word.
Step2  Delete the Word normal template file as indicated in the following table:
Version Filename File Location
Word 2003 |Normal.dot <drive>:\Documents and Settings\<username>\Application
Data\Microsoft\Templates
Word 2007 |Normal.dotm |<drive>:\Documents and Settings\<username>\Application
Data\Microsoft\Templates
Step3  Open Word.

The normal template file is recreated automatically.

Related Topics
- Viewing Logs, page 5-2

Users Cannot See “Call” or “Call with Edit” in Microsoft Excel, Outlook,
PowerPoint, or Word

Problem The“Call” and “Call with Edit” menu items for the click-to-call feature do not appear in
Microsoft Excel, Outlook, PowerPoint, or Word. This problem can occur in either 2003 or 2007 versions
of these applications.

Solution Set the value of LoadBehavior to 3 in the appropriate registry key as shown in the following
table, then restart the application.

Application |Architecture |Registry Key

Excel 2003 |32-bit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Excel\Add

or 2007 ins\CiscoClickToCall.Connect

64-bit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\O

ffice\Excel\Addins\CiscoClickToCall.Connect

Outlook 32-bit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Outl ook\A

2003 or ddins\CiscoClickToCall Contacts.Connect

2007 64-bit HKEY LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\O
ffice\Outl ook\Addins\CiscoClickToCall Contacts.Connect
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M How to Resolve Instant Message Window Problems

Application |Architecture |Registry Key
PowerPoint |32-bit HKEY _LOCAL_MACHINE\SOFTWARE\Microsoft\Office\PowerPoin
2003 t\Addins\CiscoClickToCall.Connect

64-bit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\O

ffice\PowerPoint\A ddins\CiscoClickToCall.Connect

Word 2003 |32-bit HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addi
or 2007 ns\CiscoClickToCall.Connect

64-bit HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\O

ffice\Word\Addins\CiscoClickToCall.Connect

Users Cannot See “Additional Actions” Menu in Microsoft Outlook Contacts

Step 1
Step 2
Step 3

Step 4

Problem When users right-click on a contact in the Microsoft Outlook Contacts folder, the Additional
Actions menu is not displayed.

Solution Restart Outlook as follows:

Procedure

Close Outlook.
Start the Task Manager.

End the Outlook process.
The name of the Outlook processis OUTLOOK.EXE or OUTLOOK* 32.EXE.
Restart Outlook.

How to Resolve Instant Message Window Problems

« Instant Message Window Closes When You Try to Call a Contact Who Has No Number in LDAP,

page 5-10

« Instant Message Window Displayed When Users Select the Place a Call Menu Item, page 5-11

Instant Message Window Closes When You Try to Call a Contact Who Has No
Number in LDAP

Problem The instant message window closes automatically when you do the following:

1. Open instant message window with a contact who has no number in LDAP.

2. Do not type any text in the window.

3. Right-click the contact, then select Place a Call.

Solution Thisis expected behavior.
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Instant Message Window Displayed When Users Select the Place a Call Menu
ltem

Problem When usersright-click on acontact in the Microsoft Office Communicator Contact List, Instant
Message Window, or Search Box, then select Place a Call, an instant message window is displayed
briefly.

Solution Thisis expected behavior.
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Note

APPENDIX‘ \

Normalization Rules for OCS

Revised: January 29, 2010

If you do not define phone numbers in E.164 format for each user in your Active Directory, you must
perform other actions to ensure that the numbers in your Active Directory are processed into the Office
Communications Server (OCS) address book in aform that Cisco Unified Communications Manager
dialing rules can process to dial a number.

If all the numbersin your Active Directory arein E.164 format, you do not need to configure OCS
normalization rules. Thisis the easiest way to deploy Cisco UC Integration for Microsoft Office
Communicator.

If the numbersin your Active Directory are not in E.164 format, then you must configure OCS
normalization rulesto ensure that Microsoft Office Communicator downloads E.164-formatted numbers
from OCS.

Thisis necessary because OCS requires E.164-formatted numbers, unless you configure normalization
rules. For information about this topic, see the following URL.:

http://technet.microsoft.com/en-us/library/bb964002.aspx

Configuring OCS normalization rules can be an error-prone task, especially for international and
enterprise dial plans.

Related Topics
- Dial Plan Options for Cisco UC Integration for Microsoft Office Communicator, page 2-5

- Dialing Rules Required for Cisco UC Integration for Microsoft Office Communicator, page 2-5
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APPENDIX B

Enabling Display of Photos in Notification
Windows, the Active Conversations Window,
and Contact Cards

Revised: January 29, 2010
« Adding the Active Directory Schema Snap-In, page B-1

- Creating the photoUri Attribute, page B-2

» Setting a Default Value for the photoUri Attribute Using ADSI Edit, page B-2
» Configuring IS to Display Photos, page B-4

» Verifying the User Object, page B-4

Adding the Active Directory Schema Snap-In

Procedure

Stepl  Execute the following command:
regsvr 32 schmmgmt.dil
Step2  Execute the following command to start Microsoft Management Console:
mmc
Step3  In Microsoft Management Console, select File > Add/Remove Snap-in.
Step4  Select Active Directory Schema, then select Add.

Step5  Select Close on the Add Standalone Snap-in dialog box, then select OK on the Add/Remove Snap-in
dialog box.

What to Do Next
« Creating the photoUri Attribute, page B-2
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M Creating the photoUri Attribute

Creating the photoUri Attribute

Step 1
Step 2
Step 3

Step 4
Step 5

Step 6
Step 7

Procedure

Start the Active Directory Schema administrative tool.
Right-click the Attribute container, then select New > Attribute from the pop-up menu.

To create the photoUri attribute, complete the fields on the properties dialog box as follows:

Field Description

Description Enter “photoUri”.

Common Name Enter “photoUri”.

X500 OID Enter the object ID.

Syntax Enter “ Case Insensitive String”.

Allow thisattributeto be |Select this option.
shown in advanced view

Attribute is active Select this option.

Attribute is copied when |Select this option.
duplicating a user

Select OK.

Open the Classes container in the Active Directory Schema administrative tool, right-click user, then
select Properties from the pop-up menu.

Select Attributes, then select Add.
Select photoUri from the list on the Select Schema Object dialog box, then select OK.

What to Do Next
» Setting a Default Value for the photoUri Attribute Using ADSI Edit, page B-2

Setting a Default Value for the photoUri Attribute Using ADSI

Edit

Step 1

Step 2

Before You Begin
If you cannot run the ADSI Edit application, you must enable the ADSI Edit application before you
perform this procedure.

Procedure
Execute the following command to start the Active Directory Service Interface (ADSI) editor:

adsiedit.msc
Open the organizational unit (OU) you require, right-click the user you require, then select Properties.
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Step 3
Step 4

Note

Step 5
Step 6

Setting a Default Value for the photoUri Attribute Using ADSI Edit

Select the photoUri attribute, then select Edit.

Enter the URL for the photo for the user in the Value field. For example, enter a URL similar to the
following:

http://www.example.com/photos/mweinstein.jpg

If you plan to use a script to populate the default value, enter a space character in the Value field. You
cannot run a script if there is no default value.

Select OK.

After you configure 1S to display photos, you can verify that you can view the photo by accessing the
URL you entered.

Related Topics
- Enabling the ADSI Edit Application, page B-3

» Configuring 11S to Display Photos, page B-4

Enabling the ADSI Edit Application

Step 1

Step 2

Step 3

If you cannot run the ADSI Edit application, you must perform the following procedure.

Procedure

Execute the following command:

regsvr 32 adsiedit.dll

Execute the following command to start the ADSI editor:
adsiedit.msc

If the application still does not start, obtain the adsiedit.dll file, then run the command in Step 1 from
the folder where the adsiedit.dll file is located.

Related Topics
» Setting a Default Value for the photoUri Attribute Using ADSI Edit, page B-2

What to Do Next
» Configuring IS to Display Photos, page B-4
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M Configuring 1S to Display Photos

Configuring IS to Display Photos

Procedure

Stepl  Start Internet Information Services Manager.

Step2  Select the computer name in the left pane, then select Web Sites.

Step3  Right-click Default Web Site, then select New > Virtual Directory.

Step4  Follow theinstructionsin the wizard to create the virtual directory, and enter the local folder where the
photos are located. You can now access the photos from the URL structured as follows:

http://<domain-name>/<virtual -directory>/<photo-filename>

For example, you can access a photo with a URL similar to the following:

http://www.example.com/photos/mweinstein.jpg

What to Do Next
» Verifying the User Object, page B-4

Verifying the User Object

Procedure

Stepl  Execute the following command:

Idp

Step2  Select Connection > Connect, then select OK.

Step3  Select Connection > Bind, enter your username and password, then select OK.
Step4  Select View > Tree, select the BaseDN, then select OK.

Step5  Open the BaseDN node, then double-click on the user you require.

Step6  Verify that the photo information is present for the user.
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"Application Deployment Canceled” error message 5-3

"Away" availability status and custom availability
statuses  5-6

"Cannot synchronize..." error message 5-5

"Cannot synchronize... Communicator 2007" error
message  5-6

"Inactive" availability status and custom availability
statuses 5-6

"On the Phone" availability status not available 3-8, 5-7
"Unknown" availability status 5-8

INDEX
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7931G users cannot control desk phone  5-4

A

Active Directory server, configuring 2-1
address book, OCS
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administrative template, using to configure CSF
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availability statusissues
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"On the Phone" not available 3-8, 5-7
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C

caller name, incorrect with shared lines  5-5
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prerequisites 2-8
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devices
creating for users  2-10
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how to make accessible 2-12
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Manager 2-13

dial plan options 2-5
directory lookup dialing rules. See dialing rules
directory numbers, creating for users  2-10
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Host Intrusion Protection Software (HIPS) software 5-4

illustration, interaction with network servers 1-2
installation
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integration 3-5
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over SSL  3-4,3-7
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Lightweight Directory Access Protocol. See LDAP
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M
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