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1 Overview

The Cisco Unified Videoconferencing Manager IBM Lotus Notes Plug-in is a separately deployed plug-in
that can work in a Cisco Unified Videoconferencing Manager deployment or in a standalone Desktop
Server deployment without Cisco Unified Videoconferencing Manager.

In a Cisco Unified Videoconferencing Manager deployment, the IBM Lotus Notes Plug-in allows users to
schedule, modify, cancel and manage Resource Manager meetings using the IBM Lotus Notes interface.

In a standalone Desktop Server deployment, the Cisco IBM Lotus Notes Plug-in allows users to send out
meeting invitations using the IBM Lotus Notes interface.



2 Prerequisites

System Requirements

Lotus Domino Server

e Supported versions: 7.0 and 8.0

e Running DIIOP HTTP services

e Configured as a Web SSO server with Ltpa token

e Administrator and Designer interfaces must be available
Each user should have a dedicated e-mail account for receiving meeting messages including meeting accept and decline messages.
For Cisco Unified Videoconferencing Manager deployments

¢ A dedicated Cisco Unified Videoconferencing Manager server which the IBM Lotus Notes Plug-in can connect to.

e This Cisco Unified Videoconferencing Manager server should be configured to work with IBM Domino server LDAP
Directory service.

e Assign at least one virtual room to each user.
For Desktop Server deployments
e A dedicated Desktop Server server which the IBM Lotus Notes Plug-in can connect to.

3 How to Verify that the DIIOP Service is Running

Procedure

Step1 Open the Lotus Domino Server command window.
Step2 Enter “show task”.
Step3  Verify that the “DIIOP Server” entry is present.

Step4 If the “DIIOP Server” entry is not present, contact your Domino Server administrator to run the service.

4 How to Install the Cisco Unified Videoconferencing IBM Lotus Notes
Plug-in
e Creating NSF Objects via the Domino Designer Interface, page 2

¢ Configuring a Template via the Domino Administrator Interface, page 3

¢ Configuring Forms and Script Libraries via the Domino Designer Interface, page 3

Creating NSF Objects via the Domino Designer Interface

Procedure

Step1 Open the Domino Designer interface to connect to the target Domino server.

Step2 Log in using the LocalDomainAdmins account.



Step 3

Step 4

Step 5

Step 6

Open the setup.nsf file locally and sign the following agents:

Create IVConfig.nsf—Contains the Cisco IBM Lotus Notes Plug-in configuration screen.

Create mail8_IV.ntf—New template file for scheduling meetings using the Cisco IBM Lotus Notes Plug-in.

Locally create IVConfig.nsf as follows:

Select the Create IVConfig.nsf agent and click Run.

Select the IVConfig.dxl file provided on the Cisco Utilities and Documentation CD-ROM supplied with the
product.

The agent completes the operation and IVConfig.nsf is created remotely.

Remotely create mail8_IV.ntf as follows:

Select the Create mail8_IV.ntf agent and click Run.

Select the IVAgentLib.dxl file provided on the Cisco Utilities and Documentation CD-ROM supplied with the
product.

The agent completes the operation and mail8_IV.ntf is created remotely.

Close the Domino Designer interface

Configuring a Template via the Domino Administrator Interface

Procedure

Step1 Open the Domino Administrator interface to connect to the target Domino server.
Step2 Select File.

Step3 Select the Properties window of mail8_IV.ntf template.

Step4 Select Database file is master template.

Step5 Select StdMail7_IV in the Template Name field.

Step6 Close the Properties window.

Step7 Save your changes.

Step8 Close the Domino Administrator interface.

Configuring Forms and Script Libraries via the Domino Designer Interface

Procedure

Step1 Open the Domino Designer interface to connect to the target Domino server.

Step2 Log in using the LocalDomainAdmins account.

Step3  Go to File > Database > Open.

Step4 Select the remote Domino server that has the Cisco IBM Lotus Notes Plug-in installed from the Server list.
Step5 Select and open the Mail (R8) IV Addon database from the Database list.

Step6 Enter code into the _Calendar Entry Form as follows:

Go to Top Menu > View > Go to > Forms for the Mail (R8) IV Addon database to display all forms in this database.
Double-click _Calender Entry.

Locate the Body field.

Right-click above the Body field and select Insert Resource.



Step 7
Step 8

Step 9

Step 10

e Select - Current database - from the Database list.
e Select Subform from the Resource Type list.
e Select IVSubForm from the Available resources list.
e (Click OK.
Save and close the _Calendar Entry Form.
Enter code into the ($Calendar) View as follows:
e Go to Top Menu > View > Go to > Views for the Mail (R8) IV Addon database to display all views in this database.
e Double-click ($Calendar).
e Verify that the View > Action Pane option is selected.
e Right-click Unfilter in the Action pane.
e Select Create Action.
e Enter Cisco Settings in the Name field.
e Select Hide action if formula is true in the second tab of the Action window.
¢ (lick Formula Window.
e Paste the following code in the Edit Formula window:
@If (@TextToNumber (@Version) < 174;@True;@False) | @Environment ("OEMClient") = "1" |
@IsNotMember ("Notes_Video_conf_sched group"; @UserNamesList)
e Close the Action window.
e Add the following code in the (Action): Click window:

@If (@ClientType = "Notes";@Command ([Compose];"IVClientConfig") : @Return(0);"")

Enter code into the _Calendar Entry Form as follows:
¢ Go to Top Menu > View > Go to > Forms for the Mail (R8) IV Addon database to display all forms in this database.
e Double-click _Calender Entry.
e Verify that the View > Programmer’s Pane option is selected.
e Select (Global) Appointment > (Options) in the Objects tab.
e Add the following line to the code:

Use "IVShareLib"

e Select Appointment (Form) > Queryopen in the Objects tab.
e Locate CSCalendarEntry and replace with IVCSWrapper.
e Save and close the form.

Enter code into the CSUIViewClass Script Library as follows:

¢ Go to Top Menu > View > Go to > Script Libraries for the Mail (R8) IV Addon database to display all script
libraries in this database.

e Double-click CSUIViewClass.
e Select CSUIViewClass > (Options) in the Objects tab.
e Add the following line to the code:

Use "IVShareLib"

e Select CSUIViewClass > InitEventObject in the Objects tab.
e Locate CSEventNotes and replace with IVCalendarWrapper.

e Save and close the script library.



B How to Configure the Cisco Unified Videoconferencing IBM Lotus Notes
Plug-in
e Using a New Template, page 5

e Configuring Domino Web SSO, page 5

e Assigning an Execution Control List, page 6

Using a New Template

Procedure

Step1 Create a user group called Notes_Video_conf_sched_group.
Any user that you assign to this group can see the user interface of the Cisco IBM Lotus Notes Plug-in.
Step2 Use the Domino server console command to change the mail file template for all affected users.
For example, assume user John’s mail file is John.nsf.
Send the following command from the Domino server console to convert the John.nsf template to mail8.ntf:
For Windows:

>> load convert mail\ John.nsf * mail8_IV.ntf

For Linux

>> load convert mail/ John.nsf * mail8_IV.ntf

Step3 To change all the mail files in mail directory, send the following command:
For Windows:

>> load convert mail\*.nsf * mail8_IV.ntf

For Linux:

>> load convert mail/ *.nsf * mail8_IV.ntf

Configuring Domino Web SSO

The Web SSO configuration described here is RS compatible.

Procedure

Step1 Open the Domino Administrator interface to connect to the target Domino server.

Step2 Click Configuration.

Step3 Select Server > Current Server Document.

Step4 Click Create Web and select SSO Configuration.

Step5 Enter the Cisco Unified Videoconferencing Manager server DNS domain in the DNS Domain field.
For example, “mycompany.com”.

Step6 Verify that the Domino server with the Cisco IBM Lotus Notes Plug-in installed is configured in the Domino Server
Names field.

For example, “Domino3/Test”.

Step7 Click Keys and select Create Domino SSO Key to generate a new key.



Step 8

Step 9

Step 10
Step 11
Step 12
Step 13
Step 14
Step 15

Step 16

Save your changes and close the Web SSO Configuration window.
Select Server > Current Server Document.

Click Internet Protocols.

Click Domino Web Engine.

Click Edit.

Select Multiple Servers (SSO) in the Session authorization option.
Select LtpaToken in the Set Web SSO Configuration option.

Click Basics and verify that the Load Internet configurations from Server\Internet Sites documents field is set to
Disabled.

Click Save & Close to save your changes.

Assigning an Execution Control List

Assign an Execution Control List (ECL) to users so that they can execute the Cisco IBM Lotus Notes Plug-in client-side module.

Create a new policy which allows users to run the Cisco IBM Lotus Notes Plug-in, and then assign this policy to user group
Notes_Video_conf_sched_group.

Procedure

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7
Step 8
Step 9
Step 10
Step 11
Step 12
Step 13

Step 14
Step 15
Step 16
Step 17
Step 18
Step 19

Open the Domino Administrator interface to connect to the target Domino server.
Click Configuration.
Select Policies > Create to create a new policy.
Enter a name for the new policy in the Basics tab such as “IV_POLICY”.
Click New next to the Security field to create new security settings.
Enter a name for the new security setting in the Basics tab such as “IV_SECURITY”.
Click Execution Control List.
Set Update Mode to Replace.
Click New next to Admin ECL.
Select Allow user to modify.
Select Workstation security.
Select a workstation security setting for the domain admin user from the When signed by list, such as admin/Test.
Select the following access options:
e Access to file system
e Access to current database
e Access to environment variables
e Access to external programs
e Ability to read other databases
e Ability to modify other databases
Select Java applet security under Allow user to modify.
Select all the Allow options.
Click OK to save your changes and close the Execution Control List window.
Click the People & Groups tab and select Groups.
Right-click Notes_Video_conf_sched_group and select Assign Policy.
Select IV_POLICY for this user group.



Step20 Click OK to save your changes.

6 Configuring the Domino Server

Procedure
Step1 Select File > Database > Open in the Lotus Notes interface.
Step2 Select the remote Domino server that has the Cisco IBM Lotus Notes Plug-in installed from the Server list.
Step3 Select and open the ivconfig database from the Database list.
Step4 Configure the Cisco Unified Videoconferencing Manager or Desktop Server servers that end users can connect to for
meeting scheduling in the Add Server section, as follows:
e Set the type of server URL that you want to add in the Server Type field.
e Enter a name for the server that you want to add in the Server Name field.
e Enter the server URL in the Server URL field.
For Cisco Unified Videoconferencing Manager use the format http://SERVER_URL:PORT_NUMBER
For Cisco Unified Videoconferencing Desktop use the format http://SERVER_URL:PORT_NUMBER/cuvm
e Click Add to List.
Step5 (Optional) Click Remove from List to remove any defined server from the Select List section.
Step6 (Optional) Click Check Server Status to verify that the server is reachable.
The server status is displayed in the Status field.
A server must be reachable for the Cisco IBM Lotus Notes Plug-in to function properly.
Step7 (Optional) Click Generate Ltpa token in the Advanced section to verify that a secure communication mechanism has

been properly configured between the Lotus Domino server and the Cisco Unified Videoconferencing Manager server
working in Single Sign-on (SSO) mode.

If a new Ltpa token is displayed in the Status field, secure communication has been properly configured.

7 How to Uninstall the Cisco Unified Videoconferencing IBM Lotus Notes
Plug-in

e Reverting to the Default Mail Template, page 7

e Removing the ivconfig Database, page 8

e Removing the mail8_iv Template, page 8

Reverting to the Default Mail Template

Procedure

Step 1

Use Domino server console command to change mail file template for all affected users.

For example, assume user John’s mail file is John.nsf.

Send the following command from the Domino server console to convert the John.nsf template to mail8.ntf:
For Windows:

>> load convert mail\ John.nsf * mail8.ntf



For Linux

>> load convert mail/ John.nsf * mail8.ntf

Step2 To change all the mail files in mail directory, send the following command:
For Windows:

>> load convert mail\*.nsf * mail8.ntf

For Linux:

>> load convert mail/ *.nsf * mail8.ntf

Removing the ivconfig Database

Procedure

Step1 Open the Domino Administrator interface to connect to the target Domino server.
Step2 Click File.

Step3 Right-click ivconfig and select Delete Database.

Step4 Select Also delete replicas of this database on all other servers.

Step5 Click OK to delete this database.

Removing the mail8_iv Template

Procedure

Step1 Open the Domino Administrator interface to connect to the target Domino server.
Step2 Click File.

Step3 Right-click Mail (R8) IV Addon and select Delete Database.

Step4 Select Also delete replicas of this database on all other servers.

Step5 Click OK to delete this template.



8 Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional information, see the
monthly What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed and set content to be
delivered directly to your desktop using a reader application. The RSS feeds are a free service and Cisco currently supports
RSS Version 2.0.
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trademarks; Changing the Way We Work, Live, Play, and Learn and Cisco Store are service marks; and Access Registrar, Aironet, AsyncOS, Bringing the Meeting To You,
Catalyst, CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, CCVP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS, Cisco Press, Cisco Systems,
Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Collaboration Without Limitation, EtherFast, EtherSwitch, Event Center, Fast Step, Follow Me Browsing,
FormShare, GigaDrive, HomeLink, Internet Quotient, I0S, iPhone, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, iQuick Study, IronPort, the IronPort logo,
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are registered trademarks of Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries.

All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the word partner does not imply a partnership relationship
between Cisco and any other company. (0807R)

Any Internet Protocol (IP) addresses used in this document are not intended to be actual addresses. Any examples, command display output, and figures included in the
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