[an error occurred while processing this directive]

Support

Default Configuration Templates

 Feedback

Table Of Contents

Default Configuration Templates

Templates for Use with Cisco AccessPath-LS3 Systems

Cisco 3640 (3640-LS3-default)

Templates for Use with Cisco AccessPath-TS3 Systems

Cisco 3640 (3640-default)

Cisco 7206 without Catalyst 5002 (7206-Entry-default)

Cisco 7206 with Catalyst 5002 (7206-default)

Cisco AS5300 (AS5300-default-channelized)

Cisco AS5300 (AS5300-default-pri)

Catalyst 5002 (CAT5002-default)

Templates for Use with Cisco System Controllers

Cisco 3640 (SC3640-default)

Cisco AS5800 (AS5800-default)


Default Configuration Templates


This appendix provides the default configuration templates that are included with
Cisco Access Manager (CAM):

Templates for Use with Cisco AccessPath-LS3 Systems

Templates for Use with Cisco AccessPath-TS3 Systems

Templates for Use with Cisco System Controllers

These CAM templates are text files that contain Cisco IOS command-line interface (CLI) commands and template variables. CAM creates configuration files to download to the shelves in your system by substituting data for the template variables based on your entries during the following procedures:

Create Container or Modify Container—See Chapter 4, "Configuring Containers."

Create Shelf or Modify Shelf—See Chapter 5, "Configuring Shelves."

You can also create custom configuration templates for your specific needs—See Chapter 8, "Using Tools."


Note   The configuration variables that CAM modifies based on your input are in uppercase and are preceded by a pound sign (#). In addition, these variables are printed in bold in this appendix.


If you need additional information on Cisco IOS commands to help you use the templates, refer to the following documents:

Cisco AccessPath-LS3 Integrated Access System Software Configuration

Cisco AccessPath-TS3 Integrated Access System Software Configuration Guide

Cisco 3640 System Controller Installation and Configuration Guide

Cisco IOS Configuration Fundamentals Configuration Guide

The following table lists the CAM standard configuration templates for each system:

System
Template
Supports

Cisco AccessPath-LS3

Cisco 3640 (3640-LS3-default)

Cisco 3640 (Console Management Shelf)

Cisco AccessPath-TS3

Cisco 3640 (3640-default)

Cisco 3640 (Console Management Shelf)

Cisco 7206 without Catalyst 5002 (7206-Entry-default)

Cisco 7206 using two Switch Blade cards for switching

Cisco 7206 with Catalyst 5002 (7206-default)

Cisco 7206 using a Catalyst 5002 for its primary switching path

Cisco AS5300 (AS5300-default-channelized)

Cisco AS5300s using channelized T1 or E1

Cisco AS5300 (AS5300-default-pri)

Cisco AS5300s using PRI

Catalyst 5002 (CAT5002-default)

Catalyst 5002

Cisco System Controller

Cisco 3640 (SC3640-default)

Cisco 3640 (System Controller)

 

Cisco AS5800 (AS5800-default)

Cisco AS5800


Templates for Use with Cisco AccessPath-LS3 Systems

Cisco 3640 (3640-LS3-default)

!
no service finger 
service timestamps debug datetime msec localtime show-timezone 
service timestamps log datetime msec localtime show-timezone 
service password-encryption 
no service udp-small-servers 
no service tcp-small-servers 
! 
hostname #SHELF_HOST_NAME
! 
#IF_BOOT_SYSTEM_FLASH
aaa new-model 
aaa authentication login CONSOLE none 
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
! uncomment the following line to use modem on AUX port
! aaa authentication ppp ADMIN if-needed #STACK_AUTHEN_PPP_ADMIN_TYPE 
local
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
#STACK_ENABLE_PASSWORD
enable secret #STACK_SECRET_PASSWORD
! 
ip routing
username #APM_USER password #APM_PASSWORD
!
ip subnet-zero 
no ip source-route 
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
! 
interface Loopback 1 
description "MGMT Network and Async129" 
ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface Ethernet1/0
 description "To Failover switch" 
 ip address #IP_1 #NETMASK_1
 no ip directed-broadcast
 no shutdown 
!  
interface FastEthernet2/0
 description "offload address"
 ip address #IP_2 #NETMASK_2
 no ip directed-broadcast
 no shutdown 
!  
interface Async 129 
 description "OSS Modem Incoming Call" 
 ip unnumbered Loopback1 
 encapsulation ppp 
 async dynamic address 
 async mode interactive 
 peer default ip address #IP_3
 no cdp enable
 no fair-queue 
 ppp authentication chap callin ADMIN 
! 
router eigrp #STACK_EIGRP_AS_NUM
#EIGRP_NETWORK
! 
ip classless 
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging IP
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
! 
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS #SHELF_HOST_NAME
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
! 
line con 0 
 session-timeout 45 
 exec-timeout 45 0 
 login authentication CONSOLE 
 transport preferred none 
line 1 16 
 session-timeout 60 
 no exec 
 login authentication ADMIN 
 modem InOut
 transport input all 
 flowcontrol hardware
line aux 0
 exec-timeout 15 0 
 autoselect during-login 
 autoselect ppp 
 login authentication ADMIN 
 modem InOut 
 transport preferred none 
 transport input none 
 flowcontrol hardware 
 speed 115200
line vty 0 63
 session-timeout 45
 exec-timeout 45
 transport preferred none 
 login authentication ADMIN
! 
#STACK_NTP_SERVER_ADDR
#IF_NO_NTP ntp source Loopback1
end 

Templates for Use with Cisco AccessPath-TS3 Systems

Cisco 3640 (3640-default)

! 
no service finger 
service timestamps debug datetime msec localtime show-timezone 
service timestamps log datetime msec localtime show-timezone 
service password-encryption 
no service udp-small-servers 
no service tcp-small-servers 
! 
hostname #SHELF_HOST_NAME
! 
#IF_BOOT_SYSTEM_FLASH
aaa new-model 
aaa authentication login CONSOLE none 
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
! uncomment the following line to use modem on AUX port
! aaa authentication ppp ADMIN if-needed #STACK_AUTHEN_PPP_ADMIN_TYPE 
local
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
#STACK_ENABLE_PASSWORD
enable secret #STACK_SECRET_PASSWORD
! 
ip routing
username #APM_USER password #APM_PASSWORD
!
ip subnet-zero 
no ip source-route 
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
! 
interface Loopback 1 
description "MGMT Network and Async129" 
ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface Ethernet1/0
 description "To Failover switch" 
 ip address #IP_1 #NETMASK_1
 no ip directed-broadcast
 no shutdown 
!  
interface Ethernet1/1
 description "To Primary switch" 
 ip address #IP_2 #NETMASK_2
 no ip directed-broadcast
 no shutdown 
!  
interface Async 129 
 description "OSS Modem Incoming Call" 
 ip unnumbered Loopback1 
 encapsulation ppp 
 async dynamic address 
 async mode interactive 
 peer default ip address #IP_3
 no cdp enable
 no fair-queue 
 ppp authentication chap callin ADMIN 
! 
router eigrp #STACK_EIGRP_AS_NUM
#EIGRP_NETWORK
! 
ip classless 
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging IP
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
! 
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS #SHELF_HOST_NAME
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
! 
line con 0 
 session-timeout 45 
 exec-timeout 45 0 
 login authentication CONSOLE 
 transport preferred none 
line 1 32 
 session-timeout 60 
 no exec 
 login authentication ADMIN 
 modem InOut
 transport input all 
 flowcontrol hardware
line aux 0
 exec-timeout 15 0 
 autoselect during-login 
 autoselect ppp 
 login authentication ADMIN 
 modem InOut 
 transport preferred none 
 transport input none 
 flowcontrol hardware 
 speed 115200
line vty 0 63
 session-timeout 45
 exec-timeout 45
 transport preferred none 
 login authentication ADMIN
! 
#STACK_NTP_SERVER_ADDR
#IF_NO_NTP ntp source Loopback1
end 

Cisco 7206 without Catalyst 5002 (7206-Entry-default)


Note   This configuration is used with Cisco AccessPath-TS3 systems that use the Switch Blade as their primary switching path.


!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #SHELF_HOST_NAME
!
#IF_BOOT_SYSTEM_FLASH
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
#STACK_ENABLE_PASSWORD
enable secret #STACK_SECRET_PASSWORD
!
ip routing
username #APM_USER password #APM_PASSWORD
!
ip subnet-zero
no ip source-route
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
!
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
clock calendar-valid
!
interface Loopback1
 description "Management (SNMP & AAA) pseudo interface"
 ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface FastEthernet0/0
 description "To Eth switch FastE3/0"
 ip address #IP_2 #NETMASK_2
 full-duplex
 media-type MII
 no shutdown
 no ip directed-broadcast
 ip route-cache
 no keepalive
 no fair-queue
!
interface FastEthernet 3/0
 description "To FastE0/0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface FastEthernet 3/1
 description "To CMS01 E1/1"
 no ip address
 bridge-group 1
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 3/2
 description "To AS01 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/3
 description "To AS02 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/4
 description "To AS03 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/5
 description "To AS04 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/6
 description "To AS05 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/7
 description "To AS06 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/8
 description "To AS07 FastE0"
 no ip address
 bridge-group 1
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 3/9
 no ip address
 bridge-group 1
 default keepalive
!
interface Ethernet 3/10
 no ip address
 bridge-group 1
!
interface Ethernet 3/11
 no ip address
 bridge-group 1
 default keepalive
!
interface Ethernet 3/12
 no ip address
 bridge-group 1
 default keepalive
!
interface Ethernet 3/13
 no ip address
 bridge-group 1
 default keepalive
!
interface FastEthernet 5/0
 no ip address
 bridge-group 2
 default keepalive
 full-duplex
 no shutdown
!
interface FastEthernet 5/1
 no ip address
 bridge-group 2
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 5/2
 description "To AS01 E0"
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/3
 description "To AS02 E0"
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/4
 description "To AS03 E0"
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/5
 description "To AS04 E0"
 no ip address
 bridge-group 2
 default keepalive
 no shutdown
!
interface Ethernet 5/6
 description "To AS05 E0"
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/7
 description "To AS06 E0"
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/8
 description "To AS07 E0"

 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/9
 no ip address
 bridge-group 2
 default keepalive
!
interface Ethernet 5/10
 no ip address
 bridge-group 2
 default keepalive
!
interface Ethernet 5/11
 no ip address
 bridge-group 2
 default keepalive
!
interface Ethernet 5/12
 no ip address
 bridge-group 2
 default keepalive
!
interface Ethernet 5/13
 description "To CMS01 E1/0"
 no ip address
 bridge-group 2
 default keepalive
 no shutdown
!
router eigrp #STACK_EIGRP_AS_NUM
redistribute connected
passive-interface Loopback1
#EIGRP_NETWORK
no auto-summary
!

bridge irb
bridge 1 protocol ieee
bridge 1 priority 1
bridge 2 protocol ieee
bridge 2 priority 1
bridge 2 route ip
!

interface BVI 2
 description "Bridge-group Virtual Interface for bridge 2"
 ip address #IP_1 #NETMASK_1
 no ip directed-broadcast
!

ip classless
ip route 0.0.0.0 0.0.0.0 #SHELF_DEFAULT_ROUTE_IP
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging IP
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
!
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS #SHELF_HOST_NAME
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
!
line con 0
session-timeout 30
exec-timeout 15 0
logout-warning 60
login authentication CONSOLE
transport preferred none
line aux 0
line vty 0 4
session-timeout 45
exec-timeout 45 0
login authentication ADMIN
transport preferred none
!
#STACK_NTP_SERVER_ADDR
end

Cisco 7206 with Catalyst 5002 (7206-default)

! Document Number ENG-17217
! Revision 2.5
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #SHELF_HOST_NAME
!
#IF_BOOT_SYSTEM_FLASH
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
#STACK_ENABLE_PASSWORD
enable secret #STACK_SECRET_PASSWORD
!
ip routing
username #APM_USER password #APM_PASSWORD
!
ip subnet-zero
no ip source-route
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
clock calendar-valid
!
interface Loopback1
 description "Management (SNMP & AAA) pseudo interface"
 ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface FastEthernet0/0
 description "To Failover path Switch"
 ip address #IP_1 #NETMASK_1
 full-duplex
 media-type MII
 no shutdown
 bandwidth 10000
 delay 100
 no ip directed-broadcast
 ip route-cache
 no keepalive
 no fair-queue
!
interface FastEthernet1/0
 description "To Stack via SW01"
 ip address #IP_2 #NETMASK_2
 no ip directed-broadcast
 ip route-cache
 default keepalive
 full-duplex
 no shutdown
!
interface FastEthernet 5/0
 description "To FastE0/0"
 no ip address
 bridge-group 2
 default keepalive
 full-duplex
 no shutdown
!
interface FastEthernet 5/1
! description "Reserved for link to RS02 Eswitch FastE5/1" ! RS01
! description "To RS01 Eswitch FastE5/1" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 full-duplex
 no shutdown
!
interface Ethernet 5/2
! description "To AS01 E0" ! RS01
! description "To AS12 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/3
! description "To AS02 E0" ! RS01
! description "To AS13 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/4
! description "To AS03 E0" ! RS01
! description "To AS14 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/5
! description "To AS04 E0" ! RS01
! description "To AS15 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/6
! description "To AS05 E0" ! RS01
! description "To AS16 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/7
! description "To AS06 E0" ! RS01
! description "To AS17 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/8
! description "To AS07 E0" ! RS01
! description "To AS12 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/9
! description "To AS08 E0" ! RS01
! description "To AS19 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/10
! description "To AS09 E0" ! RS01
! description "To AS20 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 no shutdown
!
interface Ethernet 5/11
! description "To AS10 E0" ! RS01
! description "To AS21 E0" ! RS02
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/12
! description "To AS11 E0" ! RS01
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
interface Ethernet 5/13
! description "To CMS01 E1/0" ! RS01
 no ip address
 bridge-group 2
 default keepalive
 half-duplex
 no shutdown
!
router eigrp #STACK_EIGRP_AS_NUM
 redistribute connected
 passive-interface Loopback1
 #EIGRP_NETWORK
 no auto-summary
!
bridge irb
bridge 2 protocol ieee
! RS01 has priority 1, RS02 has priority 2
bridge 2 priority #7206_BRIDGE_IRB_PRIORITY
!
ip classless
ip route 0.0.0.0 0.0.0.0 #SHELF_DEFAULT_ROUTE_IP
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging IP
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
!
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS #SHELF_HOST_NAME
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
!
line con 0
 session-timeout 30
 exec-timeout 15 0
 logout-warning 60
 login authentication CONSOLE
 transport preferred none
line aux 0
line vty 0 4
 session-timeout 45
 exec-timeout 45 0
 login authentication ADMIN
 transport preferred none
!
#STACK_NTP_SERVER_ADDR
end

Cisco AS5300 (AS5300-default-channelized)

! Document Number ENG-17219
! Revision 2.8
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #SHELF_HOST_NAME
!
#IF_BOOT_SYSTEM_FLASH
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
aaa authentication login USERS #STACK_AUTHEN_LOGIN_USERS_TYPE 
aaa authentication ppp USERS&TUNNELS if-needed 
#STACK_AUTHEN_PPP_USERS_TUNNELS_TYPE
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE if-authenticated
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
enable secret #STACK_SECRET_PASSWORD
#STACK_ENABLE_PASSWORD
!
ip routing
username #APM_USER password #APM_PASSWORD
!
! username #STACKSTATE_SGBP_GROUPNAME password #STACK_SGBP_PASSWORD
ip subnet-zero
no ip source-route
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
!
#STACK_DNS_SERVERS
#STACK_NBNS_SERVERS
#SHELF_VPDN_ENABLED vpdn enable
#SHELF_VPDN_ENABLED vpdn source-ip #SHELF_LOOPB0_IP
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
!
controller #STACK_CONTROLLER_TYPE 0
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source line primary
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 cas-group 1 timeslots 1-#TIME_SLOTS type #SHELF_SIGNALLING_TYPE
#IF_E1_R2_CUSTOM cas-custom 1 
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults 
 no shutdown
!
controller #STACK_CONTROLLER_TYPE 1
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source line secondary
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 cas-group 1 timeslots 1-#TIME_SLOTS type #SHELF_SIGNALLING_TYPE
#IF_E1_R2_CUSTOM cas-custom 1 
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults 
 no shutdown
!
controller #STACK_CONTROLLER_TYPE 2
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source internal
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 cas-group 1 timeslots 1-#TIME_SLOTS type #SHELF_SIGNALLING_TYPE
#IF_E1_R2_CUSTOM cas-custom 1 
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults 
 no shutdown
!
controller #STACK_CONTROLLER_TYPE 3
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source internal
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 cas-group 1 timeslots 1-#TIME_SLOTS type #SHELF_SIGNALLING_TYPE
#IF_E1_R2_CUSTOM cas-custom 1 
#IF_E1_R2_CUSTOM country #E1_R2_COUNTRY use-defaults 
 no shutdown
!
interface Loopback0
 description "L2F tunnel NAS pseudo interface"
 ip address #SHELF_LOOPB0_IP #SHELF_LOOPB0_NETMASK
!
interface Loopback1
 description "Management (SNMP & AAA) NAS pseudo interface"
 ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface Ethernet0
 description "To Failover path via Switch port on 7206"
 ip address #IP_1 #NETMASK_1
 #IP_SUMMARY_ADDR
 no shutdown
 no ip directed-broadcast
 ip route-cache
 no lat enabled
 no mop enabled
 delay 101
 default keepalive
 no fair-queue
!
interface FastEthernet0
 description "To Primary path via SW01"
 ip address #IP_2 #NETMASK_2
 #IP_SUMMARY_ADDR
 no shutdown  
 duplex auto
 speed auto
#IF_ENTRY_STACK speed 10
#IF_ENTRY_STACK duplex full
 no ip directed-broadcast
 ip route-cache 
 no lat enabled 
 no mop enabled 
 default keepalive 
 no fair-queue 
!
interface Group-Async1
 description "Async Incoming Call"
 ip unnumbered Loopback0
 encapsulation ppp
 async dynamic address
!if token card, IF_TOKEN_CARD=interactive, otherwise =dedicated
 async mode #STACK_EXEC_ALLOWED
 no snmp trap link-status
 peer default ip address pool  #SHELF_HOST_NAME
 ip tcp header-compression passive
 default keepalive 
 no fair-queue
 no cdp enable
 ppp authentication chap callin USERS&TUNNELS
 ppp chap hostname #STACK_EXTERNAL_HOSTNAME
! T1 = 96, E1 = 120
 group-range 1 #HALF_MODEMS
 group-range 1 #INSTALLED_MODEMS
!
router eigrp #STACK_EIGRP_AS_NUM
 redistribute connected
 passive-interface Loopback0
 passive-interface Loopback1
 #EIGRP_NETWORK
 no auto-summary
!
ip local pool #SHELF_HOST_NAME #SHELF_LOCAL_POOL_BEGIN_IP 
#SHELF_LOCAL_POOL_END_IP
ip classless
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging ip
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
!
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS public
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
!
line con 0
 session-timeout 30
 exec-timeout 15 0
 logout-warning 60
 transport preferred none
 login authentication CONSOLE
line aux 0
line vty 0 4
 session-timeout 45
 exec-timeout 45 0
 login authentication ADMIN
 transport preferred none
line 1 #HALF_MODEMS
#IF_GROUP_ASYNC_EXEC autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
 login authentication USERS
 modem InOut
 transport preferred none
 autohangup
line 1 #INSTALLED_MODEMS
#IF_GROUP_ASYNC_EXEC autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
 login authentication USERS
 modem InOut
 transport preferred none
 autohangup
!
#STACK_NTP_SERVER_ADDR
end

Cisco AS5300 (AS5300-default-pri)

! Document Number ENG-17220
! Revision 2.7
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
!
no service finger
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #SHELF_HOST_NAME
!
#IF_BOOT_SYSTEM_FLASH
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
aaa authentication login USERS #STACK_AUTHEN_LOGIN_USERS_TYPE 
aaa authentication ppp USERS&TUNNELS if-needed 
#STACK_AUTHEN_PPP_USERS_TUNNELS_TYPE
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE if-authenticated
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
enable secret #STACK_SECRET_PASSWORD
#STACK_ENABLE_PASSWORD
!
ip routing
username #APM_USER password #APM_PASSWORD
!
username #STACKSTATE_SGBP_GROUPNAME password #STACK_SGBP_PASSWORD
ip subnet-zero
no ip source-route
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
!
#IF_MMP no sgbp group #STACKSTATE_SGBP_GROUPNAME
!
#IF_MMP sgbp group #STACKSTATE_SGBP_GROUPNAME
#IF_MMP sgbp seed-bid default
#IF_MMP sgbp source-ip #SHELF_LOOPB0_IP
! sgbp members will be built at run time. 
! There is one per peer NAS, fully meshed.
! Example: sgbp member Nas02 4.2.1.2
#SGBP_MEMBER
#STACK_DNS_SERVERS
#STACK_NBNS_SERVERS
#SHELF_VPDN_ENABLED vpdn enable
#SHELF_VPDN_ENABLED vpdn source-ip #SHELF_LOOPB0_IP
isdn switch-type #SHELF_ISDN_SWITCH_TYPE
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
!
controller #STACK_CONTROLLER_TYPE 0
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source line primary
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 pri-group timeslots 1-#TIME_SLOTS
 no shutdown
!
controller #STACK_CONTROLLER_TYPE 1
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source line secondary
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 pri-group timeslots 1-#TIME_SLOTS
 no shutdown
!
controller #STACK_CONTROLLER_TYPE 2
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source internal
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 pri-group timeslots 1-#TIME_SLOTS
 no shutdown
!
controller #STACK_CONTROLLER_TYPE 3
 framing #SHELF_FRAMING
#IF_FRAMING_ESF fdl ansi
 clock source internal
 linecode #SHELF_LINECODE
! if T1, no of isdn channel=24, E1=31
 pri-group timeslots 1-#TIME_SLOTS
 no shutdown
!
interface Loopback0
 description "L2F tunnel NAS pseudo interface"
 ip address #SHELF_LOOPB0_IP #SHELF_LOOPB0_NETMASK
!
interface Loopback1
 description "Management (SNMP & AAA) NAS pseudo interface"
 ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface Ethernet0
 description "To Failover path via Switch port on 7206"
 ip address #IP_1 #NETMASK_1
 #IP_SUMMARY_ADDR
 no shutdown
 no ip directed-broadcast
 ip route-cache
 no lat enabled
 no mop enabled
 delay 101
 default keepalive
 no fair-queue
!
interface FastEthernet0
 description "To Primary Switch path"
 ip address #IP_2 #NETMASK_2
 #IP_SUMMARY_ADDR
 no shutdown  
 duplex auto
 speed auto
#IF_ENTRY_STACK speed 10
#IF_ENTRY_STACK duplex full
 no ip directed-broadcast
 ip route-cache 
 no lat enabled 
 no mop enabled 
 default keepalive 
 no fair-queue 
!
! if North American isdn d channel=23, European=15
interface Serial0:#PRI_D_CHANNEL
 description "PRI D channel"
 ip unnumbered Loopback0
 encapsulation ppp
 isdn incoming-voice modem
 peer default ip address pool #SHELF_HOST_NAME
 dialer rotary-group 1
 no fair-queue
 no cdp enable
 no keepalive
 no shutdown
 dialer-group 1
!
interface Serial1:#PRI_D_CHANNEL
 description "PRI D channel"
 ip unnumbered Loopback0
 encapsulation ppp
 isdn incoming-voice modem
 peer default ip address pool #SHELF_HOST_NAME
 dialer rotary-group 1
 no fair-queue
 no cdp enable
 no keepalive
 no shutdown
 dialer-group 1
!
interface Serial2:#PRI_D_CHANNEL
 description "PRI D channel"
 ip unnumbered Loopback0
 encapsulation ppp
 isdn incoming-voice modem
 peer default ip address pool #SHELF_HOST_NAME
 dialer rotary-group 1
 no fair-queue
 no cdp enable
 no keepalive
 no shutdown
 dialer-group 1
!
interface Serial3:#PRI_D_CHANNEL
 description "PRI D channel"
 ip unnumbered Loopback0
 encapsulation ppp
 isdn incoming-voice modem
 peer default ip address pool #SHELF_HOST_NAME
 dialer rotary-group 1
 no fair-queue
 no cdp enable
 no keepalive
 no shutdown
 dialer-group 1
!
! Delete the entire Group-Async1 if no modems are installed in stack
!
interface Group-Async1
 description "Async Incoming Call"
 ip unnumbered Loopback0
 encapsulation ppp
 async dynamic address
!if token card, IF_TOKEN_CARD=interactive, otherwise =dedicated
 async mode #STACK_EXEC_ALLOWED
 no snmp trap link-status
 peer default ip address pool #SHELF_HOST_NAME
 ip tcp header-compression passive
 default keepalive 
 no fair-queue
 no cdp enable
 ppp authentication chap callin USERS&TUNNELS
 ppp chap hostname #STACK_EXTERNAL_HOSTNAME
! T1 = 96, E1 = 120
group-range 1 #HALF_MODEMS
group-range 1 #INSTALLED_MODEMS
! T1 = 48, E1 = 60
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 peer default ip address pool #SHELF_HOST_NAME
#IF_MMP ppp multilink
 ppp authentication chap callin USERS&TUNNELS 
 ppp chap hostname #STACK_EXTERNAL_HOSTNAME
 dialer-group 1
 dialer in-band
 no keepalive
 no cdp enable
!
router eigrp #STACK_EIGRP_AS_NUM
 redistribute connected
 passive-interface Loopback0
 passive-interface Loopback1
 passive-interface Serial0:#PRI_D_CHANNEL
 passive-interface Serial1:#PRI_D_CHANNEL
 passive-interface Serial2:#PRI_D_CHANNEL
 passive-interface Serial3:#PRI_D_CHANNEL
 #EIGRP_NETWORK
 no auto-summary
!
ip local pool #SHELF_HOST_NAME #SHELF_LOCAL_POOL_BEGIN_IP 
#SHELF_LOCAL_POOL_END_IP
ip classless
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging ip
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
!
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS public
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
!
line con 0
 session-timeout 30
 exec-timeout 15 0
 logout-warning 60
 transport preferred none
 login authentication CONSOLE
line aux 0
line vty 0 4
 session-timeout 45
 exec-timeout 45 0
 transport preferred none
 login authentication ADMIN
line 1 #HALF_MODEMS
#IF_GROUP_ASYNC_EXEC autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
 login authentication USERS
 modem InOut
 transport preferred none
 autohangup
line 1 #INSTALLED_MODEMS
#IF_GROUP_ASYNC_EXEC autoselect during-login
#IF_GROUP_ASYNC_EXEC autoselect ppp
 login authentication USERS
 modem InOut
 transport preferred none
 autohangup
!
#STACK_NTP_SERVER_ADDR
end

Catalyst 5002 (CAT5002-default)

! Document Number ENG-17221
! Revision 2.5
! Copyright 1997 Cisco Systems, Inc. -- Company Confidential
!
set prompt #SHELF_HOST_NAME>
set length 24 default
set logout 20
! Security: Use either enablepass or tacacs+
! set enablepass
! set authentication enable tacacs
! set authentication enable tacacs
! set tacacs server
! set tacacs key
!
#system
set system baud  9600
set system modem disable
set system name  #STACKSTATE_SGBP_GROUPNAME 
set system location #STACK_SNMP_LOCATION
set system contact #STACK_SNMP_CONTACT
!
#snmp
set snmp community read-only      #STACK_SNMP_READ 
set snmp community read-write     #STACK_SNMP_WRITE 
set snmp community read-write-all #STACK_SNMP_RW_ALL
set snmp rmon disable
set snmp trap enable module
set snmp trap enable chassis
set snmp trap disable bridge
set snmp trap disable repeater
set snmp trap enable vtp
set snmp trap enable auth
set snmp trap #STACK_TRAP_SERVERS #STACK_SNMP_READ
!
#vtp
set vtp domain #STACKSTATE_SGBP_GROUPNAME mode server
set vlan 1 name default type ethernet mtu 1500 said 100001 state active
!
#ip
set interface sc0 1 #IP_1 #NETMASK_1 #SHELF_NET_BROADCAST_IP
set interface sl0 0.0.0.0 0.0.0.0
set arp agingtime 1200
set ip redirect   enable
set ip unreachable   enable
set ip fragmentation enable
set ip route 0.0.0.0         #IP_2 1
set ip alias default         0.0.0.0
!
#Command alias
!
#switch port analyzer
set span 1 2/24  both
set span disable
!
#bridge
set bridge ipx snaptoether   8023raw
set bridge ipx 8022toether   8023
set bridge ipx 8023rawtofddi snap
!
#vlan  
set vlan 1    1/1-2
set vlan 1    2/1-24
!
#syslog
set logging console enable
set logging server enable
! use logging ip for the logging server address, for example:
! set logging server 192.168.10.1
#STACK_LOG_SERVER_ADDR
set logging level cdp 2 default
set logging level cgmp 2 default
set logging level disl 5 default
set logging level dvlan 2 default
set logging level earl 2 default
set logging level fddi 2 default
set logging level ip 2 default
set logging level pruning 2 default
set logging level snmp 2 default
set logging level spantree 2 default
set logging level sys 5 default
set logging level tac 2 default
set logging level tcp 2 default
set logging level telnet 2 default
set logging level tftp 2 default
set logging level vtp 2 default
set logging level vmps 2 default
!
#ntp
set ntp broadcastclient disable
set ntp broadcastdelay 3000
set ntp client enable
#STACK_NTP_SERVER_ADDR
set timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME set summertime enable #STACK_SUMMER_TIME
!
#cam
set cam agingtime 1    300
!
#cdp
set cdp enable   1/1-2
set cdp enable   2/1-24
!
#trunks
set trunk 1/1 auto 1-1000
set trunk 1/2 auto 1-1000
!
#spantree
#vlan 1
set spantree enable         1 
set spantree fwddelay 15    1
set spantree hello    2     1
set spantree maxage   20    1
set spantree priority 32    1
!
#trunk 
set spantree portfast 1/1-2 enable
set spantree portfast 2/1-24 enable
!
#module 1
set module name    1
set port enable    1/1-2     
set port level     1/1-2  high
set port duplex    1/1-2  full
set port trap      1/1-2  enable
set port name      1/1  RS01
set port name      1/2  RS02
!
#module 2
set module name    2
set module enable  2
set port enable    2/1-24
set port speed     2/1     10
set port speed     2/2-24  100
set port level     2/1-24  normal
set port duplex    2/1     half
set port duplex    2/2-24  full
set port trap      2/1-24  enable
set port name      2/1   CMS01
set port name      2/2   AS01
set port name      2/3   AS02
set port name      2/4   AS03
set port name      2/5   AS04
set port name      2/6   AS05
set port name      2/7   AS06
set port name      2/8   AS07
set port name      2/9   AS08
set port name      2/10  AS09
set port name      2/11  AS10
set port name      2/12  AS11
set port name      2/13  AS12
set port name      2/14  AS13
set port name      2/15  AS14
set port name      2/16  AS15
set port name      2/17  AS16
set port name      2/18  AS17
set port name      2/19  AS18
set port name      2/20  AS19
set port name      2/21  AS20
set port name      2/22  AS21

Templates for Use with Cisco System Controllers

Cisco 3640 (SC3640-default)


Note   This configuration is used with Cisco System Controllers.


! 
no service finger 
service timestamps debug datetime msec localtime show-timezone 
service timestamps log datetime msec localtime show-timezone 
service password-encryption 
no service udp-small-servers 
no service tcp-small-servers 
! 
hostname #SHELF_HOST_NAME
! 
#IF_BOOT_SYSTEM_FLASH
aaa new-model 
aaa authentication login CONSOLE none 
aaa authentication login ADMIN #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
! uncomment the following line to use modem on AUX port
! aaa authentication ppp ADMIN if-needed #STACK_AUTHEN_PPP_ADMIN_TYPE 
local
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE
aaa accounting network start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec start-stop #STACK_ACCOUNT_NETWORK_TYPE
#STACK_ENABLE_PASSWORD
enable secret #STACK_SECRET_PASSWORD
! 
ip routing
username #APM_USER password #APM_PASSWORD
!
ip subnet-zero 
no ip source-route 
#STACK_NAME_SERVERS
ip #STACK_AUTHEN_LOGIN_ADMIN_TYPE source-interface Loopback1
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
! 
interface Loopback 1 
description "MGMT Network and Async129" 
ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NETMASK
!
interface Ethernet1/0
 description "To Failover switch" 
 ip address #IP_1 #NETMASK_1
 no ip directed-broadcast
 no shutdown 
!  
interface Ethernet1/1
 description "To Primary switch" 
 ip address #IP_2 #NETMASK_2
 no ip directed-broadcast
 no shutdown 
!  
interface Async 129 
 description "OSS Modem Incoming Call" 
 ip unnumbered Loopback1 
 encapsulation ppp 
 async dynamic address 
 async mode interactive 
 peer default ip address #IP_3
 no cdp enable
 no fair-queue 
 ppp authentication chap callin ADMIN 
! 
router eigrp #STACK_EIGRP_AS_NUM
#EIGRP_NETWORK
! 
ip classless 
! ip http server
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
! logging source uses logging IP
#STACK_LOG_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVERS
! 
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVERS #SHELF_HOST_NAME
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
! 
line con 0 
 session-timeout 45 
 exec-timeout 45 0 
 login authentication CONSOLE 
 transport preferred none 
line 1 32 
 session-timeout 60 
 no exec 
 login authentication ADMIN 
 modem InOut
 transport input all 
 flowcontrol hardware
line aux 0
 exec-timeout 15 0 
 autoselect during-login 
 autoselect ppp 
 login authentication ADMIN 
 modem InOut 
 transport preferred none 
 transport input none 
 flowcontrol hardware 
 speed 115200
line vty 0 63
 session-timeout 45
 exec-timeout 45
 transport preferred none 
 login authentication ADMIN
! 
#STACK_NTP_SERVER_ADDR
#IF_NO_NTP ntp source Loopback1
end 

Cisco AS5800 (AS5800-default)

!
version 11.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname #SHELF_HOST_NAME
!
#IF_BOOT_SYSTEM_FLASH
aaa new-model
aaa authentication login CONSOLE none
aaa authentication login admin #STACK_AUTHEN_LOGIN_ADMIN_TYPE local
aaa authentication login users #STACK_AUTHEN_LOGIN_USERS 
! uncomment the following line to use modem on AUX port
! aaa authentication ppp admin if-needed #STACK_AUTHEN_PPP_admin_TYPE 
local
aaa authentication ppp users if-needed #STACK_AAA_AUTHEN_PPP_USERS
aaa authorization network #STACK_AUTHOR_NETWORK_TYPE
aaa accounting network default start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting connection default start-stop #STACK_ACCOUNT_NETWORK_TYPE
aaa accounting exec default start-stop #STACK_ACCOUNT_NETWORK_TYPE
#STACK_ENABLE_PASSWORD
enable secret #STACK_SECRET_PASSWORD
!
username #APM_USER password #APM_PASSWORD
!
shelf-id #SHELF_ROUTER_NUMBER Router-shelf
shelf-id #SHELF_DIAL_NUMBER Dial-shelf
!
#REQUIRE_SC_POLLING syscon address #SC_IP_1 #SC_PASSWORD
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
ip rcmd rcp-enable
ip rcmd remote-host #SC_HOST_NAME #SC_IP_1 #SC_HOST_NAME enable
ip radius source-interface Loopback1
!put a dummby isdn switch-type, the real one is in interface serial 
section
isdn switch-type primary-5ess
#STACK_NAME_SERVERS
#STACK_DNS_SERVERS
#STACK_NBNS_SERVERS
#SHELF_VPDN_ENABLED vpdn enable
#SHELF_VPDN_ENABLED vpdn source-ip #SHELF_LOOPB1_IP
clock timezone #STACK_TIME_ZONE
#IF_SUMMER_TIME clock summer-time #STACK_SUMMER_TIME
clock calendar-valid
!
#IF_SHELF_SLOT_PORT_RANGE_DEFINED modem-pool Default
 #IF_SHELF_SLOT_PORT_RANGE_DEFINED pool-range #SHELF_SLOT_PORT_RANGE
! modem country #SHELF_MODEM_COUNTRY
!
#SHELF_CONTROLLER_TYPE_SHELF_SLOT_PORTS
!
interface Loopback0
 description "NAS pseudo interface"
 ip address #SHELF_LOOPB0_IP #SHELF_LOOPB0_NET_MASK
!
interface Loopback1
 description "Management (SNMP & AAA) pseudo interface"
 ip address #SHELF_LOOPB1_IP #SHELF_LOOPB1_NET_MASK
!
! Only one interface used to connect to SC3640 
interface #ROUTER_MEDIA_TYPE 
#SHELF_ROUTER_NUMBER/#SHELF_ROUTER_SLOT/#SHELF_ROUTER_PORT
 ip address #ROUTER_IP #ROUTER_NETMASK
 no ip mroute-cache
 no shutdown
!
#SHELF_INT_SERIAL_SHELF_SLOT_PORT_RANGE
!
interface Group-Async0
 no ip address
 no group-range
!
interface Group-Async1
 ip unnumbered Loopback0
 encapsulation ppp
 no ip route-cache
 no ip mroute-cache
 no logging event link-status
 no snmp trap link-status
 async default routing
 async mode #STACK_EXEC_ALLOWED
 peer default ip address pool default
 ip tcp header-compression passive
 default keepalive
 no cdp enable
 ppp authentication chap callin users
 ppp chap hostname #STACK_EXTERNAL_HOSTNAME
 #IF_SHELF_SLOT_PORT_RANGE_DEFINED group-range 
#SHELF_SLOT_PORT_GROUP_RANGE
!
interface Dialer1
 ip unnumbered Loopback0
 encapsulation ppp
 peer default ip address pool default
 ppp authentication chap callin users
 ppp multilink
 ppp chap hostname #STACK_EXTERNAL_HOSTNAME
 dialer-group 1
 dialer in-band
 no keepalive
 no cdp enable
 no fair-queue
!
#IP_LOCAL_POOL_DEFAULT_RANGES
#IF_EIGRP_ROUTER eigrp #STACK_EIGRP_AS_NUM
#IF_EIGRP #EIGRP_NETWORK
#IF_EIGRP redistribute connected
#IF_EIGRP passive-interface Loopback0
#IF_EIGRP passive-interface Loopback1
#IF_EIGRP no auto-summary
ip classless
ip route 0.0.0.0 0.0.0.0 #NITRO_DEFAULT_ROUTE_IP
#IF_LOGGING logging trap #STACK_LOGGING_LEVEL
#IF_LOGGING logging facility #STACK_LOGGING_FACILITY
#STACK_LOGGING_SERVER_ADDR
no access-list 10
access-list 10 permit #STACK_TRAP_SERVER
access-list 10 permit #SC_IP_1
!
snmp-server community #STACK_SNMP_READ RO
snmp-server community #STACK_SNMP_WRITE RW 10   
snmp-server trap-source Loopback1
snmp-server host #STACK_TRAP_SERVER public
snmp-server location #STACK_SNMP_LOCATION
snmp-server contact #STACK_SNMP_CONTACT
snmp-server system-shutdown
dialer-list 1 protocol ip permit
#STACK_RADIUS_SERVERADDR
#STACK_TACACS_SERVERADDR
#AAA_RADIUS_TYPE-server key #STACK_RADIUS_SERVERKEY
#AAA_TACACS_TYPE-server key #STACK_TACACS_SERVERKEY
!
line con 0
 session-timeout 30
 exec-timeout 15 0
 logout-warning 60
 transport preferred none
 login authentication CONSOLE
line aux 0
line vty 0 4
 session-timeout 45
 exec-timeout 45 0
 transport preferred none
 login authentication admin
#SHELF_LINE_SHELF_SLOT_LINE
!
#STACK_NTP_SERVER_ADDR
!
end


[an error occurred while processing this directive]