Release 15.1SY Supervisor Engine 2T Software Configuration Guide
Unidirectional Ethernet (UDE) and unidirectional link routing (UDLR)
Downloads: This chapterpdf (PDF - 230.0KB) The complete bookPDF (PDF - 13.63MB) | The complete bookePub (ePub - 2.65MB) | The complete bookMobi (Mobi - 3.48MB) | Feedback

Table of Contents

Unidirectional Ethernet (UDE) and UnidirectionalLink Routing (UDLR)

Prerequisites for UDE and UDLR

Restrictions for UDE and UDLR

UDE Restrictions

UDLR Back-Channel Tunnel Restrictions

Information About UDE and UDLR

UDE and UDLR Overview

Information about UDE

UDE Overview

Hardware-Based UDE

Software-Based UDE

Information about UDLR

Default Settings for UDE and UDLR

How to Configure UDE and UDLR

Configuring UDE

Configuring Hardware-Based UDE

Configuring Software-Based UDE

Configuring UDLR

Configuring a Receive-Only Tunnel Interface for a UDE Send-Only Port

Configuring a Send-Only Tunnel Interface for a UDE Receive-Only Port

Unidirectional Ethernet (UDE) and Unidirectional Link Routing (UDLR)


Note • For complete syntax and usage information for the commands used in this chapter, see these publications:

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

  • Cisco IOS Release 15.1SY supports only Ethernet interfaces. Cisco IOS Release 15.1SY does not support any WAN features or commands.
  • Cisco IOS Release 15.1SY supports unidirectional Ethernet (UDE) and unidirectional link routing (UDLR) only on the WS-X6704-10GE 4-port 10-Gigabit Ethernet switching module.


 


Tip For additional information about Cisco Catalyst 6500 Series Switches (including configuration examples and troubleshooting information), see the documents listed on this page:

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

Participate in the Technical Documentation Ideas forum


 

Prerequisites for UDE and UDLR

None.

Restrictions for UDE and UDLR

UDE Restrictions

  • STP cannot prevent Layer 2 loops in topologies that include unidirectional links.
  • Send-only ports always transition to the STP forwarding state, because send-only ports never receive BPDUs.
  • Receive-only ports cannot send BPDUs.
  • Unidirectional ports do not support any features or protocols that require negotiation with the port at the other end of the link, including these:

Speed and duplex mode autonegotiation

Link negotiation

IEEE 802.3Z flow control

Dynamic trunking protocol (DTP)

You must manually configure the parameters that are typically controlled by Layer 2 protocols.

  • A topology that includes unidirectional links only supports the VLAN Trunking Protocol (VTP) when the VTP server can send VTP frames to all switches in the VTP domain.
  • Disable VTP pruning on switches that have send-only ports, because VTP pruning depends on a bidirectional exchange of information.
  • Unidirectional EtherChannels cannot support PAgP or LACP. To create a unidirectional EtherChannel, you must configure the EtherChannel “on” mode.
  • You can configure software-based UDE on the physical ports in an EtherChannel. You cannot configure software-based UDE on any nonphysical interfaces (for example, port-channel interfaces).
  • When you implement hardware-based UDE on a port or configure software-based UDE on a port, UDLD is automatically disabled on the port.
  • CDP sends CDP frames from send-only ports and receives CDP frames from receive-only ports, which means that the switch on the send-only side of a unidirectional link never receives CDP information.
  • SPAN does not restrict configuration of unidirectional ports as sources or destinations.

Send-only ports can be SPAN destinations.

Receive-only ports can be SPAN sources.

  • Unidirectional ports do not support IEEE 802.1X port-based authentication.
  • IGMP snooping does not support topologies where there are unidirectional links between the switch and the hosts that are receiving multicast traffic.
  • Configure UDLR with UDE to support communication over unidirectional links between IGMP snooping on the switch and a multicast router.
  • Unidirectional links do not support ARP.

UDLR Back-Channel Tunnel Restrictions

  • The PFC does not provide hardware support for UDLR back-channel tunnels. UDLR back-channel tunnels are supported in software.
  • Configure a UDLR back-channel tunnel for each unidirectional link.
  • On UDE send-only interfaces, configure the UDLR back-channel tunnel interface to receive.
  • On UDE receive-only interfaces, configure the UDLR back-channel tunnel interface to send.
  • You must configure IPv4 addresses on UDLR back-channel tunnel interfaces.
  • You must configure source and destination IPv4 addresses on UDLR back-channel tunnel interfaces.
  • The UDLR back-channel tunnel default mode is GRE.
  • UDLR back-channel tunnels do not support IPv6 or MPLS.

Information About UDE and UDLR

UDE and UDLR Overview

Routing protocols support unidirectional links only if the unidirectional links emulate bidirectional links because routing protocols expect to send and receive traffic through the same interface.

Unidirectional links are advantageous because when you transmit mostly unacknowledged unidirectional high-volume traffic (for example, a video broadcast stream) over a high-capacity full-duplex bidirectional link, you use both the link from the source to the receiver and the equally high-capacity reverse-direction link, called the “back channel,” that carries the few acknowledgements from the receiver back to the source.

UDE and UDLR support use of a high-capacity unidirectional link for the high-volume traffic without consuming a similar high-capacity link for the back channel. UDE provides a high-capacity unidirectional link. UDLR provides the back channel through a tunnel that is configured over a regular-capacity link, and also provides bidirectional link emulation by transparently making the back channel appear to be on the same interface as the high-capacity unidirectional link.

UDE Overview

You can implement UDE with hardware or in software. Hardware-based UDE and software-based UDE both use only one strand of fiber instead of the two strands of fiber required by bidirectional traffic.

The supported unidirectional transceiver (WDM-XENPAK-REC) provides receive-only UDE. You can configure software-based UDE as either transmit-only or receive-only. You do not need to configure software-based UDE on ports where you implement hardware-based UDE.

Hardware-Based UDE

You can create a unidirectional link by using a unidirectional transceiver. Unidirectional transceivers are less expensive than bidirectional transceivers. The supported unidirectional transceiver is WDM-XENPAK-REC.

Software-Based UDE

You can create a unidirectional link by configuring ports equipped with bidirectional transceivers to unidirectionally transmit or receive traffic. You can use software-based UDE when there is no appropriate unidirectional transceiver available. For example, with no supported transmit-only transceivers, you must configure transmit-only links with software-based UDE.

Information about UDLR

UDLR provides a unidirectional tunnel as the back channel of a unidirectional high-capacity link, and transparently emulates a single bidirectional link for unicast and multicast traffic.

UDLR intercepts packets that need to be sent on receive-only interfaces and sends them on UDLR back-channel tunnels. When routers receive these packets over UDLR back-channel tunnels, UDLR makes the packets appear as if received on send-only interfaces.

UDLR back-channel tunnels support these IPv4 features:

  • Address Resolution Protocol (ARP)
  • Next Hop Resolution Protocol (NHRP)
  • Emulation of a bidirectional link for all IPv4 traffic (as opposed to only broadcast and multicast control traffic)
  • IPv4 GRE multipoint at a receive-only tunnels

Note UDLR back-channel tunnels do not support IPv6 or MPLS.


Default Settings for UDE and UDLR

None.

How to Configure UDE and UDLR


Note This caveat is open in releases that support UDLR: Neighboring ISIS routers are not seen through a UDLR topology. (CSCee56596)


Configuring Hardware-Based UDE

Install a unidirectional transceiver to implement hardware-based UDE. Hardware-based UDE requires no software configuration procedures.

To verify hardware-based UDE on a port, perform this task:

 

Command
Purpose

Router# show interfaces [{ gigabitethernet | tengigabitethernet } slot/interface }] status

Verifies the configuration.

This example shows how to verify the configuration of Gigabit Ethernet port 1/1:

Router# show interfaces gigabitethernet 1/1 status
 
Port Name Status Vlan Duplex Speed Type
Gi1/1 notconnect 1 full 1000 WDM-RXONLY

Configuring Software-Based UDE

To configure software-based UDE on a port, perform this task:

 

Command
Purpose

Step 1

Router(config)# interface {{ gigabitethernet | tengigabitethernet } slot/interface }

Selects the interface to configure.

Step 2

Router(config-if)# unidirectional { send-only | receive-only }

Configures software-based UDE.

Step 3

Router(config-if)# end

Exits configuration mode.

This example shows how to configure 10-Gigabit Ethernet port 1/1 as a UDE send-only port:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/1
Router(config-if)# unidirectional send-only
Router(config-if)# end
 
Warning!
 
Enable port unidirectional mode will automatically disable port udld. You must manually ensure that the unidirectional link does not create a spanning tree loop in the network.
 
Enable l3 port unidirectional mode will automatically disable ip routing on the port. You must manually configure static ip route and arp entry in order to route ip traffic.
 

This example shows how to configure 10-Gigabit Ethernet port 1/2 as a UDE receive-only port:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/2
Router(config-if)# unidirectional receive-only
Router(config-if)# end
 
Warning!
 
Enable port unidirectional mode will automatically disable port udld. You must manually ensure that the unidirectional link does not create a spanning tree loop in the network.
 
Enable l3 port unidirectional mode will automatically disable ip routing on the port. You must manually configure static ip route and arp entry in order to route ip traffic.
 

This example shows how to verify the configuration:

Router> show interface tengigabitethernet 1/1 unidirectional
Unidirectional configuration mode: send only
CDP neighbour unidirectional configuration mode: receive only
 

This example shows how to disable UDE on 10-Gigabit Ethernet interface 1/1:

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface tengigabitethernet 1/1
Router(config-if)# no unidirectional
Router(config-if)# end
 

This example shows the result of entering the show interface command for a port that does not support unidirectional Ethernet:

Router# show interface gigabitethernet 6/1 unidirectional
Unidirectional Ethernet is not supported on GigabitEthernet6/1

Configuring a Receive-Only Tunnel Interface for a UDE Send-Only Port

To configure a receive-only tunnel interface for a UDE send-only port, perform this task:

 

Command
Purpose

Step 1

Router(config)# interface tunnel number

Selects the tunnel interface.

Step 2

Router(config-if)# tunnel udlr receive-only ude_send_only_port

Associates the tunnel receive-only interface with the UDE send-only port.

Step 3

Router(config-if)# ip address ipv4_address

Configures the tunnel IPv4 address.

Step 4

Router(config-if)# tunnel source { ipv4_address | type number }

Configures the tunnel source.

Step 5

Router(config-if)# tunnel destination { hostname | ipv4_address }

Configures the tunnel destination.

Configuring a Send-Only Tunnel Interface for a UDE Receive-Only Port

To configure a send-only tunnel interface for a UDE receive-only port, perform this task:

 

Command
Purpose

Step 1

Router(config)# interface tunnel number

Selects the tunnel interface.

Step 2

Router(config-if)# tunnel udlr send-only ude_receive_only_port

Associates the tunnel send-only interface with the UDE receive-only port.

Step 3

Router(config-if)# ip address ipv4_address

Configures the tunnel IPv4 address.

Step 4

Router(config-if)# tunnel source { ipv4_address | type number }

Configures the tunnel source.

Step 5

Router(config-if)# tunnel destination { hostname | ipv4_address }

Configures the tunnel destination.

Step 6

Router(config-if)# tunnel udlr address-resolution

Enables ARP and NHRP.

In the following UDE and UDLR sample configuration:

  • On Router A:

Open Shortest Path First (OSPF) and PIM are configured.

10-Gigabit Ethernet port 1/1 is a send-only UDE port.

The UDLR back-channel tunnel is configured as receive only and is associated with 10-Gigabit Ethernet port 1/1.

  • On Router B:

OSPF and PIM are configured.

10-Gigabit Ethernet port 1/2 is a receive-only UDE port.

The UDLR back-channel tunnel is configured as send-only and is associated with 10-Gigabit Ethernet port 1/2.

ARP and NHRP are enabled.

Router A Configuration

ip multicast-routing
!
! tengigabitethernet 1/1 is send-only
!
interface tengigabitethernet 1/1
unidirectional send-only
ip address 10.1.0.1 255.255.0.0
ip pim sparse-dense-mode
!
! Configure tunnel as receive-only UDLR tunnel.
!
interface tunnel 0
tunnel source 11.0.0.1
tunnel destination 11.0.0.2
tunnel udlr receive-only tengigabitethernet 1/1
!
! Configure OSPF.
!
router ospf <pid>
network 10.0.0.0 0.255.255.255 area 0

Router B Configuration

ip multicast-routing
!
! tengigabitethernet 1/2 is receive-only
!
interface tengigabitethernet 1/2
unidirectional receive-only
ip address 10.1.0.2 255.255.0.0
ip pim sparse-dense-mode
!
! Configure tunnel as send-only UDLR tunnel.
!
interface tunnel 0
tunnel source 11.0.0.2
tunnel destination 11.0.0.1
tunnel udlr send-only tengigabitethernet 1/2
tunnel udlr address-resolution
!
! Configure OSPF.
!
router ospf <pid>
network 10.0.0.0 0.255.255.255 area 0


Tip For additional information about Cisco Catalyst 6500 Series Switches (including configuration examples and troubleshooting information), see the documents listed on this page:

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

Participate in the Technical Documentation Ideas forum