Release 15.1SY Supervisor Engine 2T Software Configuration Guide
Layer 2 over Multipoint GRE (L2omGRE)
Downloads: This chapterpdf (PDF - 149.0KB) The complete bookPDF (PDF - 14.35MB) | Feedback

Table of Contents

Layer 2 over Multipoint GRE (L2omGRE)

Prerequisites for L2omGRE

Restrictions for L2omGRE

Information About L2omGRE

Default Settings for L2omGRE

How to Configure L2omGRE

Configuring a Loopback Interface

Configuring an mGRE Tunnel Interface

Configuring a VLAN Interface

L2omGRE Configuration Examples

Verifying the L2omGRE Configuration

Layer 2 over Multipoint GRE (L2omGRE)


Note • For complete syntax and usage information for the commands used in this chapter, see these publications:

http://www.cisco.com/en/US/products/ps11846/prod_command_reference_list.html

  • Cisco IOS Release 15.1SY supports only Ethernet interfaces. Cisco IOS Release 15.1SY does not support any WAN features or commands.


 


Tip For additional information about Cisco Catalyst 6500 Series Switches (including configuration examples and troubleshooting information), see the documents listed on this page:

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

Participate in the Technical Documentation Ideas forum


 

Prerequisites for L2omGRE

None.

Restrictions for L2omGRE

  • The L2omGRE feature is supported in VSS mode.
  • The VLAN interface used to support L2omGRE cannot also be configured to support any Layer 3 features.
  • You can configure QoS to police (rate limit) Layer 2 traffic that is flooded in a VLAN because it is addressed to a currently unlearned MAC-Layer destination address (see match l2 miss in the “Traffic Classification” section).

Information About L2omGRE

The L2omGRE feature provides Layer 2 connectivity between multiple separate network sites by extending the topology of a Layer 2 broadcast domain through an mGRE tunnel (see Figure 43-1).

Figure 43-1 L2omGRE Topology

 

The L2omGRE feature associates a VLAN interface with an mGRE tunnel interface. mGRE tunnel interfaces configured to support the L2omGRE feature function like Layer 2 LAN ports to provide Layer 2 switching (bridging) for traffic of all types in the VLAN, so that the tunnel only carries traffic addressed to devices accessible through the mGRE tunnel (see the “Information about Layer 2 Ethernet Switching” section). The switch will learn MAC addresses that are accessible through mGRE tunnels and the show mac address-table command displays the learned addresses.

The PFC and any DFCs support bridging and mGRE tunnel encapsulation and decapsulation in hardware.

Each tunnel can carry multiple L2omGRE-connected VLANs. The tunnel encapsulation includes the VLAN ID. When the tunneled traffic is decapsulated, the VLAN ID in the tunneled traffic is used to select the correct VLAN for the traffic.

Default Settings for L2omGRE

None.

How to Configure L2omGRE

Configuring a Loopback Interface

To configure a loopback inteface to support L2omGRE, perform this task:

 

Command or Action
Purpose

Step 1

Router> enable

Enables privileged EXEC mode. Enter your password if prompted.

Step 2

Router# configure terminal

Enters global configuration mode.

Step 3

Router(config)# interface loopback number

Creates the loopback interface and enters interface configuration mode.

Step 4

Router(config-if)# ip address address mask

Configures an IP address on the interface.

Note Tunnel interfaces on other switches refer to this IP address on this switch.

Step 5

Router(config-if)# end

Returns to global configuration mode.

Configuring an mGRE Tunnel Interface

To configure an mGRE tunnel inteface, perform this task:

 

Command or Action
Purpose

Step 1

Router(config)# interface tunnel number

Creates a tunnel interface and enters interface configuration mode.

Note VLAN interfaces on this switch refer to this tunnel number.

Step 2

Router(config-if)# ip address address mask

Configures an IP address on the interface.

Step 3

Router(config-if)# ip nhrp map tunnel_address loopback_address

Configures the IP-to-nonbroadcast multiaccess (NBMA) address mapping to the loopback interface IP addresses configured on the other switches with L2omGRE tunnel interfaces.

  • Enter the tunnel_address loopback_address values configured on the other L2omGRE switches.
  • Repeat this command for each of the other L2omGRE switches.

Step 4

Router(config-if)# ip nhrp network-id ID

Enables the Next Hop Resolution Protocol (NHRP) for the mGRE tunnels. Use the same ID value on all of the L2omGRE tunnel interfaces.

Step 5

Router(config-if)# tunnel source loopback number

Associates this tunnel interface with the loopback interface .

Step 6

Router(config-if)# tunnel mode gre multipoint

Configures multipoint GRE as the tunnel mode.

Step 7

Router(config-if)# end

Returns to global configuration mode.

Configuring a VLAN Interface

To configure a VLAN interface to support L2omGRE, perform this task:

 

Command or Action
Purpose

Step 1

Router(config)# interface vlan number

Creates the VLAN interface and enters interface configuration mode.

Step 2

Router(config-if)# no ip address

Ensures that no IP address is configured on the interface.

Step 3

Router(config-if)# platform xconnect l2gre tunnel number

Associates the VLAN interface with an L2omGRE tunnel interface.

Step 4

Router(config-if)# end

Returns to global configuration mode.

L2omGRE Configuration Examples

The L2omGRE configuration commands must be coordinated as follows:

  • The ip nhrp map commands on each switch point to the tunnel and loopback IP addresses on each of the other switches.
  • On each switch, the tunnel source loopback command points to the loopback interface configured on that switch.
  • On each switch, the platform xconnect l2gre tunnel command points to the L2omGRE tunnel interface on that switch.

Enter the show platform l2transport gre summary command to display information about the L2omGRE configuration on a switch.

 

Switch One
Switch Two
Switch Three

 

interface loopback 1
ip address 10.1.1.1 255.255.255.255
interface tunnel 10
ip address 10.10.10.1 255.255.255.0
no ip redirects
ip nhrp map 10.20.20.2 10.2.2.2
ip nhrp map 10.30.30.3 10.3.3.3
ip nhrp network-id 10
tunnel source loopback 1
tunnel mode gre multipoint
interface vlan 10
no ip address
platform xconnect l2gre tunnel 10

 

interface loopback 1
ip address 10.2.2.2 255.255.255.255
interface tunnel 10
ip address 10.20.20.2 255.255.255.0
no ip redirects
ip nhrp map 10.10.10.1 10.1.1.1
ip nhrp map 10.30.30.3 10.3.3.3
ip nhrp network-id 10
tunnel source loopback 1
tunnel mode gre multipoint
interface vlan 10
no ip address
platform xconnect l2gre tunnel 10

 

interface loopback 1
ip address 10.3.3.3 255.255.255.255
interface tunnel 10
ip address 10.30.30.3 255.255.255.0
no ip redirects
ip nhrp map 10.10.10.1 10.1.1.1
ip nhrp map 10.20.20.2 10.2.2.2
ip nhrp network-id 10
tunnel source loopback1
tunnel mode gre multipoint
interface vlan 10
no ip address
platform xconnect l2gre tunnel 10

Verifying the L2omGRE Configuration

Enter the show platform l2transport gre command to display information about L2omGRE, including traffic statistics.


Tip For additional information about Cisco Catalyst 6500 Series Switches (including configuration examples and troubleshooting information), see the documents listed on this page:

http://www.cisco.com/en/US/products/hw/switches/ps708/tsd_products_support_series_home.html

Participate in the Technical Documentation Ideas forum