Catalyst 6500 Release 12.2SX Software Configuration Guide
mLACP for Server Access
Downloads: This chapterpdf (PDF - 508.0KB) The complete bookPDF (PDF - 21.37MB) | Feedback

Configuring mLACP for Server Access

Table Of Contents

Configuring mLACP for Server Access

Understanding mLACP for Server Access

Overview of mLACP for Server Access

Understanding mLACP Operation

mLACP for Server Access Feature Components

mLACP System ID

mLACP Port Identifier

Port-Channel ID

Failure Protection Scenarios

mLACP Failover

Overview

Dynamic Port Priority

Revertive and Nonrevertive Modes

Peer Monitoring with Interchassis Redundancy Manager

mLACP for Server Access Guidelines and Restrictions

Configuring mLACP for Server Access

Summary of mLACP PoA Configuration Values

Configuring mLACP Global Options

Configuring the Interchassis Communication Channel

Configuring the ICC Port

Configuring ICCP Routing

Configuring Interchassis Redundancy Groups

Configuring an Interchassis Redundancy Group

Configuring an mLACP Port-Channel Interface

Configuring the mLACP Member Port

Forcing a PoA Failover

Troubleshooting mLACP

Verifying an Active PoA

show lacp multi-chassis group

show lacp multi-chassis port-channel

show etherchannel summary

show etherchannel channel_id port-channel

show lacp internal

show lacp neighbor

Verifying a Standby PoA

show lacp multi-chassis group

show lacp multi-chassis portchannel

show etherchannel summary

show etherchannel channel_id port-channel

show lacp internal

show lacp neighbor


Configuring mLACP for Server Access


This chapter describes how to configure the multichassis LACP (mLACP) for server access feature. Release 12.2(33)SXJ and later releases support the mLACP for server access feature. This chapter includes these sections:

Understanding mLACP for Server Access

mLACP for Server Access Guidelines and Restrictions

Configuring mLACP for Server Access


NoteFor information about Etherchannels, see Chapter 19 "Configuring EtherChannels."

For information about the IEEE 802.3ad link aggregation control protocol (LACP), see the "Understanding IEEE 802.3ad LACP EtherChannel Configuration" section.


Understanding mLACP for Server Access

These sections describe mLACP for server access:

Overview of mLACP for Server Access

Understanding mLACP Operation

Failure Protection Scenarios

mLACP Failover

Overview of mLACP for Server Access

The mLACP for server access feature supports single redundant Layer 2 LACP links from a pair of Catalyst 6500 switches to a server. Figure 20-1 illustrates switches connected to a server.

Figure 20-1 mLACP for Server Access Topology

In the mLACP for server access topology, the server is a dual-homed device connected through two Layer 2 links. On the server, the links attach to ports that are configured as members of a Layer 2 LACP EtherChannel. The links function in active-standby redundancy mode, with only one link active at any time, which prevents Layer 2 loops and imposes no Spanning Tree Protocol (STP) requirements.

Each link connects to a switch that functions as a point-of-attachment (PoA). On the switches, the links attach to ports that are configured as members of a Layer 2 Multichassis EtherChannel (MCEC). An MCEC uses the Interchassis Communication Protocol (ICCP) over the interchassis communication channel (ICC) to synchronize states between the PoAs.


NoteA switch configured as a PoA cannot form mLACP peer relationships with more than one other switch.

The switch-to-server connection is a connection between an mLACP port-channel interface on the PoAs and an LACP port-channel interface on the server.


Understanding mLACP Operation

These sections describe mLACP operation:

mLACP for Server Access Feature Components

mLACP System ID

mLACP Port Identifier

Port-Channel ID

mLACP for Server Access Feature Components

This table describes the feature components that must be configured compatibly on the PoAs.

Active PoA (Switch A)
Standby PoA (Switch B)
 

Component:

Interchassis communication channel (ICC)

Definition:

A link that connects the PoAs to carry only ICCP traffic.

Note:

The ICC supports only Interchassis Communication Protocol (ICCP) traffic.

On switch A, the ip address interface command configures an IP address on the switch A end of the ICC link.

On switch B, the ip address interface command configures an IP address on the switch B end of the ICC link.

 

Component:

mLACP Redundancy Group

Definition:

Two PoAs that form a virtual LACP peer.

Note:

One mLACP redundancy group can support multiple mLACP port-channel interfaces.

An mLACP redundancy group has the same mLACP interchassis group ID on both PoAs.

The mLACP interchassis group ID configured on port-channel interfaces configures them as members of the mLACP redundancy group.

On switch A, the member ip redundancy group command points to the ICC-link IP address on switch B.

On switch B, the member ip redundancy group command points to the ICC-link IP address on switch A.

On switch A, the mlacp system-priority redundancy group command configures the switch A mLACP system priority value used on this PoA in this redundancy group as part of the mLACP system ID value.

On switch B, the mlacp system-priority redundancy group command configures the switch B mLACP system priority value used on this PoA in this redundancy group as part of the mLACP system ID value.

On switch A, the mlacp system-mac redundancy group command configures the switch A mLACP system priority value used on this PoA in this redundancy group as part of the mLACP system ID value.

On switch B, the mlacp system-mac redundancy group command configures the switch B mLACP system priority value used on this PoA in this redundancy group as part of the mLACP system ID value.

On switch A, the mlacp node-id redundancy group command configures the switch A mLACP port number value used on this PoA in this redundancy group as part of the mLACP port identifier value.

On switch B, the mlacp node-id redundancy group command configures the switch B mLACP port number value used on this PoA in this redundancy group as part of the mLACP port identifier value.

On switch A, the backbone interface redundancy group command configures mLACP link-status monitoring on the switch A physical ports that carry server traffic to and from the network.

On switch B, the backbone interface redundancy group command configures mLACP link-status monitoring on the switch B physical ports that carry server traffic to and from the network.

 

Component:

Port-channel interfaces

Definition:

Port-channel interface commands that configure DHD connection links.

Note:

Each port-channel interface supports one Layer 2 link to a server.

Port-channel interfaces must be configured with matching interface port-channel port-channel interface command ID values on both PoAs.

Use the mLACP interchassis group ID as the mlacp interchassis group port-channel interface command ID value on both PoAs.

On switch A, the mlacp lag-priority port-channel interface command configures the switch A mLACP port priority value used on this PoA in this redundancy group as part of the mLACP port identifier value.

On switch B, the mlacp lag-priority port-channel interface command configures the switch B mLACP port priority value used on this PoA in this redundancy group as part of the mLACP port identifier value.

 

Component:

Port interfaces

Definition:

Interface commands that configure Layer 2 DHD connection links as members of the mLACP port-channel interfaces.

Note:

The channel-group interface command configured with the mLACP port-channel ID value makes the port a member of an mLACP port-channel interface.


mLACP System ID

In each mLACP redundancy group, the PoA with the lowest mLACP system ID value is the link selection PoA. The link selection PoA controls selection of the link that will be active. Comparisons of mLACP system IDs are numeric comparisons of the unsigned integer values of the mLACP system ID values.

mLACP uses the two-byte mLACP system priority value as the most significant two octets and the configured mLACP system MAC address value as the least significant octets of the 8-byte mLACP system ID value.


Note The mLACP for server access feature does not support DHD control of active link selection. Configure the LACP instance on the DHD to have a numerically higher LACP system ID value than the PoA mLACP system ID values.


mLACP System Priority

The mlacp system-priority redundancy group command sets the mLACP system priority value. A lower value contributes to selection of the PoA as the link selection PoA.

mLACP System MAC Address

The mlacp system-mac redundancy group command sets the mLACP system MAC address. A lower value contributes to selection of the PoA as the link selection PoA.


Note The mLACP system MAC value is only used in the LACP PDUs sent between the PoAs and DHD.


mLACP Port Identifier

In each redundancy group, for each port-channel interface in the redundancy group, the link selection PoA selects the link with the lowest mLACP port identifier value to be active. Comparisons of mLACP port identifiers are numeric comparisons of the unsigned integer values of the mLACP port identifier values.

mLACP uses the two-byte mLACP port priority value as the most significant two octets and the configured mLACP port number as the least significant two octets of the four-byte mLACP port identifier value.

mLACP Port Priority

The mlacp lag-priority port-channel interface command configures the mLACP port priority value. A lower value contributes to selection of a link to be active.

mLACP Port Number

The mlacp node-id redundancy group command configures the mLACP port number. A lower value contributes to selection of a link to be active.

Port-Channel ID

You create the port-channel ID with the port-channel id_number command and associate physical ports to it with the channel-group id_number interface configuration mode command. The port-channel ID on the two PoAs in an mLACP redundancy group must match. The port-channel ID on the DHD can be different from the value configured on the PoAs.

Failure Protection Scenarios

The mLACP for server access feature provides network resiliency by protecting against port, link, and PoA failures. These failures can be categorized into five types. Figure 20-2 shows the failure points in a network, denoted by the letters A through E.

A—Failure of the port on the server

B—Failure of the server-connection link

C—Failure of the server-connection port on the active PoA

D—Failure of the active PoA

E—Failure of the backbone interfaces

Figure 20-2 mLACP for Server Access Protected Failure Points

When any of these faults occur, mLACP triggers a switchover from the active PoA to the standby PoA.

mLACP Failover

These sections describe mLACP failover:

Overview

Dynamic Port Priority

Revertive and Nonrevertive Modes

Peer Monitoring with Interchassis Redundancy Manager

Overview

mLACP forces failover in these situations:

If the active PoA loses communication with the server (failure points A, B, or C) or if all backbone interfaces on the active PoA fail (failure point E), mLACP fails over to the link on the standby PoA. (PoA failover does not occur.)

If ICRM notifies the standby PoA that the active PoA has failed, the standby PoA becomes active.


Note The DHD does not participate in failover determination.


Dynamic Port Priority

The default failover method uses dynamic port priority changes on the local member links to force the LACP selection logic to move the required standby link to the SELECTED and Collecting_Distributing state. This state change occurs when the LACP actor port priority values for all affected member links on the currently active PoA are changed to a higher numeric value than the standby PoA's port priority (which gives the standby PoA ports a higher claim to bundle links). Changing the actor port priority triggers the transmission of an mLACP Port Config Type-Length-Value (TLV) message to all peers in the redundancy group. These messages also serve as notification to the standby PoA that the currently active PoA is attempting to relinquish its role. The LACP then transitions the standby link to the SELECTED state and moves all the currently active links to STANDBY.

Dynamic port priority changes are not automatically written back to the running configuration or to the NVRAM configuration. If you want the system to use the current priorities when the it reloads, configure the mlacp lag-priority command and save the configuration.

Revertive and Nonrevertive Modes

The mLACP feature uses the dynamic port priority functionality for both revertive mode and nonrevertive mode. The default operation is revertive, which is the default in single chassis LACP. Nonrevertive mode can be enabled on a per port-channel basis by using the lacp failover non-revertive command in interface configuration mode, which is supported only for mLACP.

Nonrevertive mode limits failover and possible traffic loss. Dynamic port priority changes are utilized to ensure that the newly activated PoA remains active after the failed PoA recovers.

Revertive mode operation forces the configured primary PoA to return to active state after it recovers from a failure. Dynamic port priority changes are uses when necessary to allow the recovering PoA to resume its active role.

Peer Monitoring with Interchassis Redundancy Manager

The interchassis redundancy manager (ICRM) can monitor a peer with these methods:

Routewatch (RW)—This method is the default.

Bidirectional Forwarding Detection (BFD)—You must configure the redundancy group with the monitor peer bfd command.


Note For stateful switchover (SSO) deployments with redundant supervisor engines, configure BFD monitoring and a static route for the ICCP connection to prevent both PoAs from being active after an SSO failover. Routewatch does not support SSO.


There is a monitoring adjacency for each peer (designated by a member IP address) in each redundancy group. If there are two peers with the same IP address, the adjacency is shared regardless of the monitoring mode. For example, if redundancy groups 1 and 2 have a peer relationship with member IP address 10.10.10.10, there is only one adjacency to 10.10.10.10, which is shared in both redundancy groups. Redundancy groups can use different monitoring methods.


Note BFD is completely dependent on routewatch; there must be a route to the peer for ICRM to initiate BFD monitoring. BFD implies routewatch. Sometimes the status of the adjacency might seem misleading but is accurately representing the state. Also, if the route to the peer PoA is not through the directly connected (back-to-back) link between the systems, BFD can give misleading results.


This is an example of output from the show redundancy interface command:

Router# show redundancy interface 
 
   
Redundancy Group 1 (0x1)
  Applications connected: mLACP
  Monitor mode: Route-watch
  member ip: 201.0.0.1 `mlacp-201', CONNECTED
    Route-watch for 201.0.0.1 is UP
    mLACP state: CONNECTED
 
   
ICRM fast-failure detection neighbor table
  IP Address       Status Type Next-hop IP      Interface
  ==========       ====== ==== ===========      =========
  201.0.0.1        UP     RW   
 
   

Table 20-1 explains the adjacency status displayed by the show redundancy interchassis command.

Table 20-1 Status Information from the show redundancy interchassis command 

Adjacency Type
Adjacency Status
Meaning

RW

DOWN

Routewatch or BFD is configured, but there is no route for the given IP address.

RW

UP

Routewatch or BFD is configured. Routewatch is up, which indicates that there is a valid route to the peer. If BFD is configured and the adjacency status is UP, BFD is probably not configured on the interface of the route's adjacency.

BFD

DOWN

BFD is configured. A route exists and the route's adjacency is to an interface that has BFD enabled. BFD is started but the peer is down. The DOWN status can be because the peer is not present or BFD is not configured on the peer's interface.

BFD

UP

BFD is configured and operational.

Note If the adjacency type is BFD, routewatch is UP regardless of the BFD status.


mLACP for Server Access Guidelines and Restrictions

When configuring mLACP for Server Access, follow these guidelines and restrictions:

PFC3A mode does not support the mLACP for server access feature.

VSS mode does not support the mLACP for server access feature.

No more than 100 VLANs can be active on a switch configured as a PoA.

Switches configured with the mLACP for server access feature cannot support the Wireless Services Module (WiSM; WS-SVC-WISM-1-K9) or Wireless Services Module 2 (WiSM2; WS-SVC-WISM2-K9). Do not install WiSM modules in switches configured with the mLACP for server access feature. Do not configure the mLACP for server access feature in switches where any WiSM modules are installed. (CSCtn90999)

The mLACP for server access feature supports the following:

Pairs of Catalyst 6500 switches with Supervisor Engine 720 or with Supervisor Engine 720-10GE configured as points of attachment (PoAs).


Note A switch configured as a PoA cannot form an mLACP peer relationship with more than one other switch.


Servers with fully compliant IEEE 802.3ad LACP support, configured as dual-homed devices (DHDs).


Note The CLI does not enforce this restriction, but servers that support IEEE 802.3ad LACP are the only tested and supported DHDs.


One Layer 2 access link from each PoA to each DHD.


Note The CLI does not enforce this restriction, but one Layer 2 access link from each PoA to each DHD is the only tested and supported configuration.


mLACP Layer 2 port-channel interfaces on a pair of switches with one Layer 2 access port per mLACP port-channel interface on each PoA.


Note The CLI does not enforce this restriction, but one Layer 2 access port per mLACP port-channel interface on each PoA is the only tested and supported configuration.


The mLACP for server access feature has an mLACP extended mode.

The mLACP extended mode is disabled by default.

A reload is required to enable the mLACP extended mode after you enter the port-channel mode mlacp-extended command.

When the mLACP extended mode is not enabled, the switch supports 128 PaGP, LACP, or mLACP port-channel interfaces, numbered between 1 and 256. These port channel interfaces support QoS and ACLs.

When the mLACP extended mode is enabled, the switch supports the following:

—128 PaGP, LACP, or mLACP port-channel interfaces, numbered 1 through 256.
    These port-channel interfaces support QoS and ACLs.

—An additional 128 mLACP port-channel interfaces, numbered 257 through 512.
    These port-channel interfaces do not support QoS and ACLs.

Configure PoA network access so that each PoA can fully support all of the server traffic. Do not include one PoA in the network access path of the other PoA.

Ensure that there is no server traffic on any links between the PoAs.

Configure the Interchassis Communication Channel (ICC) as a point-to-point connection between the PoAs.

Configure the ICC so that it carries only ICCP traffic.


Note Traffic volume on the ICC will be relatively low.


mLACP operation is only supported when the ICC is functioning correctly. If possible, configure the ICC as a redundant connection. For example, you can configure the ICC as a two-link EtherChannel if there is available port-channel capacity.

mLACP does not support half-duplex links.

mLACP does not support multiple neighbors.

Converting a port channel to mLACP can cause a service disruption.

The DHD system priority must be lower (higher numerically) than the PoA system priority.

Configuring mLACP for Server Access

These sections describe how to configure mLACP for server access:

Summary of mLACP PoA Configuration Values

Configuring mLACP Global Options

Configuring the Interchassis Communication Channel

Configuring Interchassis Redundancy Groups

Forcing a PoA Failover

Troubleshooting mLACP

Verifying an Active PoA

Verifying a Standby PoA

Summary of mLACP PoA Configuration Values

Table 20-2 provides a list of the values that need to be coordinated on the PoA switches.

Table 20-2 Coordinated mLACP Configuration Values  

Active PoA (Switch A)
Standby PoA (Switch B)
interface type slot/port 
  description connected to switch B 
  ip address 10.0.0.1 255.255.255.255 
interface type slot/port 
  description connected to switch A 
  ip address 10.0.0.2 255.255.255.255 
interface loopback 0 
  description Supports routing to switch B 
  ip address 100.0.0.1 255.255.255.255 
interface loopback 0 
  description Supports routing to switch A 
  ip address 200.0.0.1 255.255.255.255 
mpls ldp router-id loopback 0 force 
mpls ldp router-id loopback 0 force 
redundancy 
  interchassis group 10 
    member ip 10.0.0.2 
    mlacp system-mac 0001.0001.0001 
    mlacp node-id 1 
redundancy 
  interchassis group 10 
    member ip 10.0.0.1 
    mlacp system-priority 2 
    mlacp system-mac 0002.0002.0002 
    mlacp node-id 2 
interface port-channel 50 
  mlacp interchassis group 10 
interface port-channel 50 
  mlacp interchassis group 10 
  mlacp lag-priority 2 
interface type slot/port 
  description connected to DHD 
  channel-group 50 mode passive 
interface type slot/port 
  description connected to DHD 
  channel-group 50 mode passive 


Note This summary section does not list all of the commands required to configure the mLACP for server access feature. See the following sections for complete configuration procedures.


Configuring mLACP Global Options

To configure mLACP global options, perform this task:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config)# port-channel mode mlacp-extended

(Optional) Enables the mLACP extended mode, which supports configuration of an additional 128 mLACP port-channel interfaces.

Note A reload is required to enable the mLACP extended mode after you enter the port-channel mode mlacp-extended command.

Step 4 

Router(config)# errdisable recovery cause mlacp-minlink

Enables automatic recovery from a failover state of the port channel.

Step 5 

Router(config)# end

Returns to privileged EXEC mode.

Configuring the Interchassis Communication Channel

These sections describe how to configure the Interchassis Communication Channel (ICC):

Configuring the ICC Port

Configuring ICCP Routing

Configuring the ICC Port

To configure the ICC port, perform this task:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config-if)# interface type1  slot/port

Selects the ICC port.

Step 4 

Router(config-if)# description peer_description

Describes the ICC port that connects to the other PoA.

Step 5 

Router(config-if)# ip address ip_address mask

Configures an IP address on the ICC port.

Note This address is used as the member IP address on the other PoA.

Step 6 

Router(config-if)# mpls ip

Enables MPLS on the interface.

Step 7 

Router(config-if)# bfd interval 600 min_rx 600 multiplier 6

Configures BFD to support Interchassis Redundancy Manager (ICRM) traffic.

Step 8 

Router(config-if)# shutdown

Disables the interface.

Step 9 

Router(config-if)# no shutdown

Enables the interface.

Step 10 

Router(config-if)# exit

Exits interface configuration mode.

Step 11 

Router(config)# end

Returns to privileged EXEC mode.

1 type = fastethernet, gigabitethernet, or tengigabitethernet

This example shows how to configure the port that connects to the other PoA switch:

Router> enable 
Router# configure terminal 
Router(config-if)# interface fastethernet 1/1 
Router(config-if)# description Connected to switch B 
Router(config-if)# ip address 10.0.0.1 255.255.255.255 
Router(config-if)# bfd interval 600 min_rx 600 multiplier 6 
Router(config-if)# shutdown 
Router(config-if)# no shutdown 
Router(config-if)# exit 
Router(config)# end 

Configuring ICCP Routing

To configure ICCP routing, perform this task:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config)# ip route ip_address mask icc_port

Configures a static route that points to the IP address of the loopback interface on the other PoA through the ICC port.

Step 4 

Router(config)# interface loopback_interface

Configures a loopback interface to support ICCP routing. (You can use an existing loopback interface.)

Step 5 

Router(config-if)# description loopback_description

Describes the loopback interface.

Step 6 

Router(config-if)# ip address ip_address mask

Configures an IP address on the ICC port.

Step 7 

Router(config-if)# exit

Exits interface configuration mode.

Step 8 

Router(config)# mpls ldp router-id loopback_interface force

Configures MPLS LDP to use the loopback interface created in Step 4.

Step 9 

Router(config)# end

Returns to privileged EXEC mode.

This example shows how to configure the port that connects to the other PoA switch:

Router> enable 
Router# configure terminal 
Router(config)# ip route 200.0.0.2 255.255.255.255 fastethernet 1/1 
Router(config-if)# interface loopback 0 
Router(config-if)# description Supports routing to switch B 
Router(config-if)# ip address 100.0.0.1 255.255.255.255 
Router(config-if)# exit 
Router(config)# mpls ldp router-id 0 force 
Router(config)# end 

Configuring Interchassis Redundancy Groups

These sections describe how to configure interchassis redundancy groups:

Configuring an Interchassis Redundancy Group

Configuring an mLACP Port-Channel Interface

Configuring the mLACP Member Port

Configuring an Interchassis Redundancy Group

To configure an interchassis redundancy group, perform this task:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config)# redundancy

Enters redundancy configuration mode.

Step 4 

Router(config-red)# interchassis group group_id

Creates an interchassis group and enters interchassis redundancy mode.

Note Use the same interchassis group ID on the other PoA for the other link in the redundancy group.

Step 5 

Router(config-r-ic)# member ip ip_address

Configures the IP address of the mLACP peer member group. Use the IP address configured on ICC port on the other PoA ("Configuring the Interchassis Communication Channel," Step 5).

Step 6 

Router(config-r-ic)# mlacp system-mac {0001.0001.0001 | 0002.0002.0002}

Defines the mLACP system MAC address value that is part of the mLACP system ID value that selects the PoA that selects the active link.

Configure the active PoA with 0001.0001.0001.

Configure the standby PoA with 0002.0002.0002.

Step 7 

Router(config-r-ic)# mlacp system-priority {1 | 2}

Defines the mLACP system priority value that is part of the mLACP system ID value that selects the PoA that selects the active link.

Configure the active PoA with priority 1.

Configure the standby PoA with priority 2.

Step 8 

Router(config-r-ic)# mlacp node-id {1 | 2}

Defines the mLACP port number value used as part of the mLACP port identifier value that is used to select the active link.

Configure node ID 1 on the PoA that will have the active link.

Configure node ID 2 on the PoA that will have the standby link.

Step 9 

Router(config-r-ic)# backbone interface type slot/port

Configures mLACP link-status monitoring on the physical ports that carry server traffic to and from the network.

Note Enter a backbone interface command for each port that carries server traffic between the PoA and the network.

Step 10 

Router(config-r-ic)# monitor peer bfd

Configures the BFD option to monitor the state of the peer. The default option is route-watch.

This example shows how to configure an interchassis redundancy group that configures a switch as the active PoA:

Router> enable 
Router# configure terminal 
Router(config)# redundancy 
Router(config-red)# interchassis group 10 
Router(config-r-ic)# member ip 10.0.0.2 
Router(config-r-ic)# mlacp node-id 1 
Router(config-r-ic)# mlacp system-mac 0001.0001.0001 
Router(config-r-ic)# mlacp system-priority 1 
Router(config-r-ic)# monitor peer bfd 

Configuring an mLACP Port-Channel Interface

To configure an mLACP port-channel interface, perform this task:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config)# interface port-channel port_channel_id

Configures the port channel and enters interface configuration mode.

The port_channel_id value can be from 1 through 256.

In mLACP extended mode, the value can be from 1 through 512.

You can configure 128 PaGP, LACP, or mLACP port-channel interfaces, numbered 1 through 256. These port channel interfaces support QoS and ACLs.

You can configure an additional 128 mLACP port-channel interfaces, numbered 257 through 512. These port channel interfaces do not support QoS and ACLs.

You must configure the same port-channel ID on the other PoA for the port-channel interface of other link in the mLACP redundancy group.

Step 4 

Router(config-if)# switchport

Configures the port-channel interface for Layer 2 switching.

Step 5 

Router(config-if)# switchport access

Configures the port-channel interface as an access port.

Step 6 

Router(config-if)# no shutdown

Enables the interface.

Step 7 

Router(config-if)# mlacp interchassis group group_id

Associates the port-channel interface with the mLACP redundancy group. Use the group_id configured in "Configuring Interchassis Redundancy Groups" section, Step 4.

Step 8 

Router(config-r-ic)# mlacp node-id {1|2}

Defines the the mLACP port number value used as part of the mLACP port identifier value that is used to select the active link.

Configure the PoA with the active link with priority 1.

Configure the PoA with the standby link with priority 2.

Step 9 

Router(config-if)# lacp max-bundle 1

Sets maximum number of active member ports.

Note The CLI does not enforce 1 as the only value, but it is the only tested and supported value.

Step 10 

Router(config-if)# port-channel min-links 1

Sets the minimum number of member ports.

Note

The CLI does not enforce 1 as the only value, but it is the only tested and supported value.

The other link in the EtherChannel is on the other PoA.

Step 11 

Router(config-if)# lacp failover non-revertive

(Optional) Sets the mLACP switchover to nonrevertive. The revertive mode is the default, with a 180-second delay.

Note Although present in the CLI, the lacp failover brute-force command is not supported.

This example shows how to configure an mLACP port-channel interface:

Router> enable 
Router# configure terminal 
Router(config)# interface port-channel 50 
Router(config-if)# switchport 
Router(config-if)# switchport access 
Router(config-if)# no shutdown 
Router(config-if)# mlacp lag-priority 1 
Router(config-if)# mlacp interchassis group 10 
Router(config-if)# lacp max-bundle 1 
Router(config-if)# port-channel min-links 1 

Configuring the mLACP Member Port

To configure the mLACP member port, perform this task:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# configure terminal

Enters global configuration mode.

Step 3 

Router(config-if)# interface type1  slot/port

Selects a LAN port to configure.

Step 4 

Router(config-if)# no ip address

Ensures that there is no IP address assigned to the LAN port.

Step 5 

Router(config-if)# switchport

Configures the LAN port for Layer 2 switching.

Step 6 

Router(config-if)# switchport mode access

Configures the LAN port as an access port.

Step 7 

Router(config-if)# switchport access vlan vlan_id

Configures the LAN port as a member of a VLAN.

Step 8 

Router(config-if)# channel-protocol lacp

Enables the LACP EtherChannel protocol.

Step 9 

Router(config-if)# channel-group port_channel_id mode {active | passive}

Configures the LAN port as a member of an mLACP port-channel interface and specifies the mode. Use the port_channel_id value configured on the appropriate mLACP port-channel interface.

Step 10 

Router(config-if)# mlacp lag-priority {1|2}

Defines the the mLACP port priority value used as part of the mLACP port identifier value that is used to select the active link.

Configure the active link with priority 1.

Configure the standby link with priority 2.

Step 11 

Router(config-if)# shutdown

Disables the interface.

Step 12 

Router(config-if)# no shutdown

Enables the interface.

1 type = fastethernet, gigabitethernet, or tengigabitethernet

This example shows how to configure an mLACP member port as the active link:

Router> enable 
Router# configure terminal 
Router(config-if)# interface gigabitethernet 1/1 
Router(config-if)# no ip address 
Router(config-if)# switchport 
Router(config-if)# switchport mode access 
Router(config-if)# switchport access vlan 10 
Router(config-if)# channel-protocol lacp 
Router(config-if)# channel-group 10 mode passive 
Router(config-if)# mlacp lag-priority 1 
Router(config-if)# no shutdown 

Forcing a PoA Failover

The mlacp lag-priority command also can be used to force a PoA failover in the following two ways:

Set the active PoA's LAG priority to a value greater than the LAG priority on the standby PoA. This setting results in the quickest failover because it requires the fewest LACP link state transitions on the standby links before they turn active.

Set the standby PoA's LAG priority to a value numerically less than the LAG priority on the active PoA. This setting results in a slightly longer failover time because standby links have to signal OUT_OF_SYNC to the DHD before the links can be brought up and go active.

In some cases, the operational priority and the configured priority might differ when using dynamic port priority management to force failovers. In this case, the configured version is not changed unless the port channel is operating in nonrevertive mode. Enter the show lacp multichassis port-channel command to view the current operational priorities. Use the show running-config command to display the configured priority values.

Troubleshooting mLACP

Use these debug commands to troubleshoot mLACP:

 
Command or Action
Purpose

Step 1 

Router> enable

Enables privileged EXEC mode (enter your password if prompted).

Step 2 

Router# debug redundancy interchassis {all | application | error | event | monitor}

Enables debugging of the interchassis redundancy manager.

Step 3 

Router# debug mpls ldp iccp

Enables debugging of the InterChassis Control Protocol (ICCP).

Step 4 

Router# debug lacp [all | event | fsm | misc | multi-chassis [all | database | lacp-mgr | redundancy-group | user-interface] | packet]

Enables debugging of LACP activity.

Verifying an Active PoA

The following show commands can be used to display statistics and configuration parameters to verify the operation of the mLACP feature on an active PoA:

show lacp multi-chassis group

show lacp multi-chassis port-channel

show etherchannel summary

show etherchannel channel_id port-channel

show lacp internal

show lacp neighbor

show lacp multi-chassis group

Use the show lacp multi-chassis group command to display the LACP parameters, local configuration, status of the backbone uplink, peer information, node ID, channel, state, priority active, and inactive links.

DC35-5# show lacp multi-chassis group 100 
Interchassis Redundancy Group 10
 
   
        Operational LACP Parameters:
                RG State:     Synchronized
                System-Id:    1.0001.0001.0001
                ICCP Version: 0
        Backbone Uplink Status: Connected
        Local Configuration:
                Node-id:   1
                System-Id: 1.0001.0001.0001
 
   
        Peer Information:
                State:        Up
                Node-id:      2
                System-Id:    2.0002.0002.0002
                ICCP Version: 0
 
   
State Flags: Active            - A
             Standby           - S
             Down              - D
             AdminDown         - AD
             Standby Reverting - SR
             Unknown           - U
          
mLACP Channel-groups
Channel    State      Priority     Active Links   Inactive Links
 Group   Local/Peer  Local/Peer     Local/Peer      Local/Peer
   50       A/S         1/2            1/1             0/0

show lacp multi-chassis port-channel

Use the show lacp multi-chassis port-channel command to display the interface port-channel value channel group, LAG state, priority, inactive links peer configuration, and standby links.

DC35-5# show lacp multi-chassis port-channel1 
Interface Port-channel50
        Local Configuration:
                Address: 00d0.d32e.d23f
                Channel Group: 50
                State: Active
                LAG State: Up
                Priority: 1
                Inactive Links: 0
                Total Active Links: 1   
                           Bundled: 1   
                          Selected: 1   
                           Standby: 0   
                        Unselected: 0   
 
   
        Peer Configuration:
                Interface: Port-channel50
                Address: 0002.fcbd.cee5
                Channel Group: 50
                State: Standby
                LAG State: Up
                Priority: 2
                Inactive Links: 0
                Total Active Links: 1   
                           Bundled: 0   
                          Selected: 0   
                           Standby: 1   
                        Unselected: 0 

show etherchannel summary

Use the show etherchannel summary command to display the status and identity of the mLACP member links.

DC35-5# show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
 
   
        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port
 
   
        w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators:           1
 
   
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
50     Po50(SU)        LACP      Fa1/44(P) 

show etherchannel channel_id port-channel

Use the show etherchannel channel_id port-channel command to display the status and identity of the EtherChannel and and port channel.

DC35-5# show etherchannel 50 port-channel 
Port-channels in the group: 
                ----------------------
 
   
Port-channel: Po50    (Primary Aggregator)
 
   
------------
 
   
Age of the Port-channel   = 0d:01h:15m:10s
Logical slot/port   = 14/5          Number of ports = 1
HotStandBy port = null 
Port state          = Port-channel Ag-Inuse 
Protocol            =   LACP
Fast-switchover     = disabled
 
   
 
   
Load share deferral = disabled   
 
   
Ports in the Port-channel: 
 
   
Index   Load      Port          EC state       No of bits
------+------+------------+------------------+-----------
 0      FF         Fa1/44   mLACP-active  8
 
   
Time since last port bundled:    0d:00h:14m:18s    Fa1/44
Time since last port Un-bundled: 0d:00h:14m:20s    Fa1/44
 
   
Last applied Hash Distribution Algorithm: Adaptive

show lacp internal

Use the show lacp internal command to display the device, port, and member-link information.

DC35-5# show lacp internal 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
 
   
Channel group 50
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Fa1/44    SA      bndl-act   1             0x32      0x32    0x912D      0x3D  
 
   
Peer (DC35-6) mLACP member links

show lacp neighbor

Use the show lacp neighbor command to display the neighbor device, port, and member-link information.

DC35-5# show lacp neighbor 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
 
   
Channel group 50 neighbors
 
   
Partner's information:
 
   
          Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Fa1/44    SA      bndl-act   32768         0x0       0xAC     0x62D       0x3D

Verifying a Standby PoA

The following show commands can be used to display statistics and configuration parameters to verify the operation of the mLACP feature on a standby PoA:

show lacp multi-chassis group

show lacp multi-chassis portchannel

show etherchannel summary

show lacp internal

show lacp multi-chassis group

Use the show lacp multi-chassis group command to display the LACP parameters, local configuration, status of the backbone uplink, peer information, node ID, channel, state, priority active, and inactive links.

DC35-6# show lacp multi-chassis group 
Interchassis Redundancy Group 10
 
   
        Operational LACP Parameters:
                RG State:     Synchronized
                System-Id:    1.0001.0001.0001
                ICCP Version: 0
        Backbone Uplink Status: Connected
        Local Configuration:
                Node-id:   2
                System-Id: 2.0002.0002.0002
 
   
        Peer Information:
                State:        Up
                Node-id:      1
                System-Id:    1.0001.0001.0001
                ICCP Version: 0
 
   
State Flags: Active            - A
             Standby           - S
             Down              - D
             AdminDown         - AD
             Standby Reverting - SR
             Unknown           - U
          
mLACP Channel-groups
Channel    State      Priority     Active Links   Inactive Links
 Group   Local/Peer  Local/Peer     Local/Peer      Local/Peer
   50       S/A         2/1            1/1             0/0

show lacp multi-chassis portchannel

Use the show lacp multi-chassis portchannel command to display the interface port-channel value channel group, LAG state, priority, inactive links peer configuration, and standby links.

DC35-6# show lacp multi-chassis port-channel 
Interface Port-channel50
        Local Configuration:
                Address: 0002.fcbd.cee5
                Channel Group: 50
                State: Standby
                LAG State: Up
                Priority: 2
                Inactive Links: 0
                Total Active Links: 1   
                           Bundled: 0   
                          Selected: 0   
                           Standby: 1   
                        Unselected: 0   
 
   
        Peer Configuration:
                Interface: Port-channel50
                Address: 00d0.d32e.d23f
                Channel Group: 50
                State: Active
                LAG State: Up
                Priority: 1
                Inactive Links: 0
                Total Active Links: 1   
                           Bundled: 1   
                          Selected: 1   
                           Standby: 0   
                        Unselected: 0 

show etherchannel summary

Use the show etherchannel summary command to display the status and identity of the mLACP member links.

DC35-6# show etherchannel summary 
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
 
   
        M - not in use, no aggregation due to minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        d - default port
 
   
        w - waiting to be aggregated
Number of channel-groups in use: 1
Number of aggregators:           1
 
   
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
50     Po50(SU)        LACP      Fa3/44(P)

show etherchannel channel_id port-channel

Use the show etherchannel channel_id port-channel command to display the status and identity of the EtherChannel and port channel.

DC35-6# show etherchannel 50 port-channel 
                Port-channels in the group: 
                ----------------------
 
   
Port-channel: Po50    (Primary Aggregator)
 
   
------------
 
   
Age of the Port-channel   = 0d:01h:17m:40s
Logical slot/port   = 14/5          Number of ports = 1
HotStandBy port = null 
Port state          = Port-channel Ag-Inuse 
Protocol            =   LACP
Fast-switchover     = disabled
 
   
 
   
Load share deferral = disabled   
 
   
Ports in the Port-channel: 
 
   
Index   Load      Port          EC state       No of bits
------+------+------------+------------------+-----------
 0      FF         Fa3/44   mLACP-stdby  8
 
   
Time since last port bundled:    0d:00h:16m:59s    Fa3/44
Time since last port Un-bundled: 0d:00h:17m:00s    Fa3/44
 
   
Last applied Hash Distribution Algorithm: Adaptive

show lacp internal

Use the show lacp internal command to display the device, port, and member-link information.

DC35-6# show lacp internal 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
 
   
Channel group 50
                            LACP port     Admin     Oper    Port        Port
Port      Flags   State     Priority      Key       Key     Number      State
Fa3/44    SA      bndl-sby   2             0x32      0x32    0xA32D      0x5   
 
   
Peer (DC35-5^C^C) mLACP member links

show lacp neighbor

Use the show lacp neighbor command to display the neighbor device, port, and member-link information.

DC35-6# show lacp neighbor 
Flags:  S - Device is requesting Slow LACPDUs 
        F - Device is requesting Fast LACPDUs
        A - Device is in Active mode       P - Device is in Passive mode     
 
   
Channel group 50 neighbors
 
   
Partner's information:
 
   
          Partner Partner   LACP Partner  Partner   Partner  Partner     Partner
Port      Flags   State     Port Priority Admin Key Oper Key Port Number Port State
Fa3/44    FA      bndl-sby   32768         0x0       0xAC     0x32D       0xF