Cisco Nexus 7000 Series NX-OS MPLS Configuration Guide
Configuring MPLS LDP IGP Synchronization
Downloads: This chapterpdf (PDF - 345.0KB) The complete bookPDF (PDF - 13.45MB) | Feedback

Table of Contents

Configuring MPLS LDP IGP Synchronization

Information About MPLS LDP IGP Synchronization

MPLS LDP IGP Synchronization Process

MPLS LDP IGP Synchronization Delay Timer

MPLS LDP IGP Synchronization and IGP Nonstop Forwarding

MPLS LDP IGP Synchronization Compatibility with LDP Graceful Restart

Licensing Requirements for MPLS LDP IGP Synchronization

Prerequisites for MPLS LDP IGP Synchronization

Guidelines and Limitations for MPLS LDP IGP Synchronization

Default Settings for MPLS LDP IGP Synchronization

Configuring MPLS LDP IGP Synchronization

Configuring MPLS LDP IGP Synchronization for OSPF Interfaces

Configuring MPLS LDP IGP Synchronization for IS-IS Interfaces

Prerequisites

Configuring the MPLS LDP IGP Synchronization Delay Timer

Disabling MPLS LDP IGP Synchronization for Selected OSPF or IS-IS Interfaces

Verifying the MPLS LDP IGP Synchronization

Configuration Examples for MPLS LDP IGP Synchronization

Additional References for MPLS LDP IGP Synchronization

Related Documents

MIBs

Feature History for MPLS LDP IGP Synchronization

Information About MPLS LDP IGP Synchronization

The MPLS LDP IGP synchronization feature ensures that LDP is fully established before the IGP path is used for switching.

If IGP adjacency starts before LDP adjacency when an interface comes up, traffic flows over the interface, but LDP labels are not available. The VPN overlay traffic is dropped until LDP labels are available. To reduce VPN traffic drops when an interface comes up, you can synchronize IGP with LDP.

This section includes the following topics:

MPLS LDP IGP Synchronization Process

Packet loss can occur because the IGP and LDP actions are not synchronized. Packet loss can occur in the following situations:

  • When an IGP adjacency is established, the router begins forwarding packets using the new adjacency before the LDP label exchange completes between the peers on that link.
  • If an LDP session closes, the router continues to forward traffic using the link that is associated with the LDP peer rather than an alternate pathway with a fully synchronized LDP session.

The MPLS LDP IGP synchronization feature does the following:

  • Enables you to synchronize LDP and IGP to minimize MPLS packet loss.
  • Allows you to globally enable LDP IGP synchronization on each interface that is associated with an IGP Open Shortest Path First (OSPF) or Intermediate System-to-System (IS-IS) process.
  • Prevents MPLS packet loss due to synchronization conflicts.

After you enable LDP IGP synchronization for all interfaces that belong to an OSPF or IS-IS process, you can disable it for specific interfaces on which you do not want it to be enabled.

When an IGP adjacency is established on an interface but LDP IGP synchronization is not yet achieved or is lost, IGP advertises the maximum metric on that interface. When at least one LDP session over the interface is converged, IGP advertises the normal metric for the interface.

MPLS LDP IGP Synchronization Delay Timer

MPLS LDP IGP synchronization enables you to configure a delay time for MPLS LDP and IGP synchronization on an interface-by-interface basis. Typically, when LDP IGP synchronization is configured, LDP notifies IGP as soon as LDP is converged. When you configure the delay time, this notification is delayed.

When LDP is fully established and synchronized, LDP checks the delay timer as follows:

  • If you configured a delay time, LDP starts the timer. When the timer expires, LDP checks that synchronization is still valid and notifies the OSPF or IS-IS process.
  • If you did not configure a delay time, if synchronization is disabled or down, or if an interface was removed from an IGP process, LDP stops the timer and immediately notifies the OSPF or IS-IS process.

If you configure a new delay time while a timer is running, LDP saves the new delay time but does not reconfigure the running timer.

MPLS LDP IGP Synchronization and IGP Nonstop Forwarding

MPLS LDP IGP synchronization does not take effect while IGP is undergoing a graceful restart. IGP completes the graceful restart regardless of whether LDP is up. After the NSF startup is complete, MPLS LDP IGP synchronization is in effect, and future network events that cause an LDP or IGP session flap will trigger normal LDP IGP synchronization behavior.

MPLS LDP IGP Synchronization Compatibility with LDP Graceful Restart

LDP graceful restart protects traffic when an LDP session is lost. If an interface that supports a graceful-restart-enabled LDP session fails, MPLS LDP IGP synchronization is still achieved on the interface while it is protected by a graceful restart. MPLS LDP IGP synchronization is eventually lost under the following circumstances:

  • If LDP fails to restart before the LDP graceful restart reconnect timer expires
  • If an LDP session restarts through other interfaces but the LDP session on the protected interface fails to recover when the LDP graceful restart recovery timer expires

Licensing Requirements for MPLS LDP IGP Synchronization

 

Product
License Requirement

Cisco NX-OS

MPLS LDP IGP synchronization requires an MPLS license. For a complete explanation of the Cisco NX-OS licensing scheme and how to obtain and apply licenses, see the Cisco NX-OS Licensing Guide .

Prerequisites for MPLS LDP IGP Synchronization

MPLS LDP IGP synchronization has the following prerequisites:

  • You must enable MPLS LDP on the interfaces.
  • You must enable OSPF and IS-IS on the device using the feature ospf and feature isis commands.

Guidelines and Limitations for MPLS LDP IGP Synchronization

MPLS LDP IGP synchronization has the following configuration guidelines and limitations:

  • This feature is supported only on interfaces that are running OSPF or IS-IS processes. Other IGPs are not supported.
  • This feature is not supported on MPLS traffic-engineering tunnel interfaces.
  • When MPLS LDP IGP synchronization is configured for an interface, LDP assumes that peers are reachable over the interface unless proven otherwise (for example, if LDP discovers a neighbor over the interface by receiving a hello message and finds out that the neighbor is not reachable).

Default Settings for MPLS LDP IGP Synchronization

Table 1-1 lists the default settings for MPLS LDP IGP synchronization parameters.

 

Table 1-1 Default MPLS LDP IGP Synchronization Parameters

Parameters
Default

MPLS LDP IGP synchronization

Disabled

MPLS LDP IGP synchronization delay timer

0 seconds

Configuring MPLS LDP IGP Synchronization

This section includes the following topics:

Configuring MPLS LDP IGP Synchronization for OSPF Interfaces

You can configure MPLS LDP IGP synchronization for all interfaces that run OSPF processes.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that MPLS LDP is enabled on the OSPF interfaces.

SUMMARY STEPS

1. configure terminal

2. router ospf process-name

3. mpls ldp sync

4. (Optional) show mpls ldp igp sync

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

router ospf process-name

 

Example:

switch(config)# router ospf p1
switch(config-router)#

Enables an OSPF routing process and enters router configuration mode.

You can enter up to 20 alphanumeric characters for the process-name argument.

Step 3

mpls ldp sync

 

Example:

switch(config-router)# mpls ldp sync

Enables MPLS LDP IGP synchronization for all OSPF interfaces.

Step 4

show mpls ldp igp sync

 

Example:

switch(config-router)# show mpls ldp igp sync

(Optional) Displays the status of MPLS LDP IGP synchronization on all interfaces.

Step 5

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuring MPLS LDP IGP Synchronization for IS-IS Interfaces

You can configure MPLS LDP IGP synchronization for all interfaces that run IS-IS processes.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that MPLS LDP is enabled on the IS-IS interfaces.

SUMMARY STEPS

1. configure terminal

2. router isis process-name

3. mpls ldp sync

4. (Optional) show mpls ldp igp sync

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

router isis process-name

 

Example:

switch(config)# router isis p1
switch(config-router)#

Enables an IS-IS routing process and enters router configuration mode.

You can enter up to 20 alphanumeric characters for the process-name argument.

Step 3

mpls ldp sync

 

Example:

switch(config-router)# mpls ldp sync

Enables MPLS LDP IGP synchronization for all IS-IS interfaces.

Step 4

show mpls ldp igp sync

 

Example:

switch(config-router)# show mpls ldp igp sync

(Optional) Displays the status of MPLS LDP IGP synchronization on all interfaces.

Step 5

copy running-config startup-config

 

Example:

switch(config-router)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Configuring the MPLS LDP IGP Synchronization Delay Timer

You can configure a delay time for MPLS LDP IGP synchronization on an interface-by-interface basis. Typically, when LDP IGP synchronization is configured, LDP notifies IGP as soon as LDP is converged. When the delay timer is configured, this notification is delayed.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that MPLS LDP is enabled on the interfaces.

SUMMARY STEPS

1. configure terminal

2. interface ethernet slot/port

3. mpls ldp igp sync delay seconds

4. (Optional) show mpls ldp igp sync interface ethernet slot / port

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface ethernet slot/port

 

Example:

switch(config)# interface ethernet 7/1
switch(config-if)#

Specifies the interface on which you are configuring the MPLS LDP IGP synchronization delay timer and enters interface configuration mode.

Step 3

mpls ldp igp sync delay seconds

 

Example:

switch(config-if)# mpls ldp igp sync delay 30

Configures a delay time for MPLS LDP IGP synchronization on the specified interface.

The range for the seconds argument is from 5 to 60 seconds.

command sets the delay time to 0 seconds but leaves MPLS LDP IGP synchronization enabled.

Step 4

show mpls ldp igp sync interface ethernet slot/port

 

Example:

switch(config-if)# show mpls ldp igp sync interface ethernet 7/1

(Optional) Displays the delay time configuration and running status for MPLS LDP IGP synchronization on the specified interface.

Step 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Disabling MPLS LDP IGP Synchronization for Selected OSPF or IS-IS Interfaces

You can disable LDP IGP synchronization for specific OSPF or IS-IS interfaces after they were configured with the MPLS LDP IGP synchronization feature.

Prerequisites

Ensure that you are in the correct VDC (or use the switchto vdc command).

Ensure that MPLS LDP is enabled on the interfaces.

SUMMARY STEPS

1. configure terminal

2. interface ethernet slot/port

3. no mpls ldp igp sync [delay]

4. (Optional) show mpls ldp igp sync interface ethernet slot / port

5. (Optional) copy running-config startup-config

DETAILED STEPS

Command
Purpose

Step 1

configure terminal

 

Example:

switch# configure terminal

switch(config)#

Enters global configuration mode.

Step 2

interface ethernet slot/port

 

Example:

switch(config)# interface ethernet 7/1
switch(config-if)#

Specifies the interface on which you are disabling MPLS LDP IGP synchronization and enters interface configuration mode.

Step 3

no mpls ldp igp sync [delay]

 

Example:

switch(config-if)# no mpls ldp igp sync

Disables MPLS LDP IGP synchronization for the specified interface.

command sets the delay time to 0 seconds but leaves MPLS LDP IGP synchronization enabled.

Step 4

show mpls ldp igp sync interface ethernet slot/port

 

Example:

switch(config-if)# show mpls ldp igp sync interface ethernet 7/1

(Optional) Displays the status of MPLS LDP IGP synchronization on the specified interface.

Step 5

copy running-config startup-config

 

Example:

switch(config-if)# copy running-config startup-config

(Optional) Copies the running configuration to the startup configuration.

Verifying the MPLS LDP IGP Synchronization

To display the MPLS LDP IGP synchronization, perform one of the following tasks:

 

Command
Purpose

show ip ospf mpls ldp interface [ethernet slot / port ]

Displays the status of MPLS LDP IGP synchronization on the OSPF interfaces.

show mpls ldp igp sync [interface ethernet slot / port ]

Displays the status of MPLS LDP IGP synchronization.

For detailed information about the fields in the output from these commands, see the Cisco Nexus 7000 Series NX-OS MPLS Command Reference .

Configuration Examples for MPLS LDP IGP Synchronization

The following example shows how to configure MPLS LDP IGP synchronization for OSPF interfaces and verify the results:

switch# configure terminal
switch(config)# router ospf 1
switch(config-router)# mpls ldp sync
switch(config-router)# show mpls ldp igp sync
Ethernet2/1:
LDP configured; LDP-IGP Synchronization enabled.
Sync status: sync not achieved; peer not reachable.
Sync delay time: 0 seconds (0 seconds left)
IGP enabled: isis-p1[gen:1]
Ethernet2/6:
LDP configured; LDP-IGP Synchronization enabled.
Sync status: sync not achieved; peer reachable.
Sync delay time: 0 seconds (0 seconds left)
IGP enabled: isis-p1[gen:1]
 

The following example shows how to configure a delay time for MPLS LDP IGP synchronization on a specific interface:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# mpls ldp igp sync delay 10
switch(config-if)# show mpls ldp igp sync interface ethernet 2/1
Ethernet2/1:
LDP configured; LDP-IGP Synchronization enabled.
Sync status: sync achieved; peer reachable.
Sync delay time: 10 seconds (0 seconds left)
IGP enabled: isis-p1[gen:1]
 

The following example shows how to disable MPLS LDP IGP synchronization on a specific interface after it was enabled using the MPLS LDP IGP synchronization feature:

switch# configure terminal
switch(config)# interface ethernet 2/1
switch(config-if)# no mpls ldp igp sync
switch(config-if)# show mpls ldp igp sync interface ethernet 2/1
Ethernet2/1:
LDP configured; LDP-IGP Synchronization not enabled.

Additional References for MPLS LDP IGP Synchronization

For additional information related to implementing MPLS LDP IGP synchronization, see the following sections:

Related Documents

Related Topic
Document Title

CLI commands

Cisco Nexus 7000 Series NX-OS MPLS Command Reference

MIBs

MIB
MIBs Link

MPLS-LDP-STD-MIB

To locate and download MIBs, go to the following URL:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Feature History for MPLS LDP IGP Synchronization

Table 1-2 lists the release history for this feature.

 

Table 1-2 Feature History for MPLS LDP IGP Synchronization

Feature Name
Releases
Feature Information

MPLS LDP IGP synchronization

5.2(1)

This feature was introduced.